О движке

Общая информация по движку

Навигация: Общая информация >

Общая информация по движку

DataLife Engine v.17.1 - это многопользовательский новостной движок, обладающий большими функциональными возможностями. Движок предназначен, в первую очередь, для создания новостных блогов и сайтов с большим информационным контекстом. Однако он имеет большое количество настроек, которые позволяют использовать его практически для любых целей. Движок может быть интегрирован практически в любой существующий дизайн и не имеет никаких ограничений по созданию шаблонов для него. Еще одной ключевой особенностью DataLife Engine - является низкая нагрузка на системные ресурсы. Даже при очень большой аудитории сайта нагрузка на сервер будет минимальной и вы не будете испытывать каких-либо проблем с отображением информации. Движок оптимизирован под поисковые системы, что приведет на ваш сайт дополнительных клиентов. Использование продвинутой технологии AJAX позволит вам сэкономить вам ваш трафик и трафик посетителей, а также снижает нагрузку на сервер.


Общие Возможности

Навигация: Общая информация >

Общие Возможности

DataLife Engine обладает следующими возможностями:

Общие возможности:

·Использует для хранения данных MySQL

·Минимальная нагрузка на базу данных

·Использование продвинутой технологии AJAX

·Вывод новостей, статей, да и вообще всего что угодно

·Поддержка ЧПУ (человеко-понятный URL) позволяет использовать тему статьи или любой другой текст в URL браузера, благодаря этому индексация сайта в поисковых системах будет более качественной (необходим modrewrite)

·Возможность отключения ЧПУ

·Общая статистика сайта

·Поддержка дополнительных полей (возможность использовать не только краткую и полную новость на сайте, но и имеется возможность для создания любого количества дополнительных полей различных видов для ввода информации)

·Возможность написания статей, содержащих несколько страниц

·Флуд контроль

·Автоматический фильтр слов в комментариях

·Поддержка категорий

·Возможность установки любого количества вложенных категорий

·Каждой категории можно назначить отдельный шаблон

·Автоматическое обрезание длинных слов в комментариях

·Рейтинг новостей

·Календарь

·Поиск по статьям включая дополнительные поля (подсветка найденного текста)

·Обзор непрочитанных новостей с момента последнего посещения сайта

·Возможность просмотра сколько раз была прочитана новость

·Возможность добавления статей в раздел "Избранное"

·Отсылка писем пользователям через форму на сайте

·Вывод страницы используя сжатие gzip

·Поддержка персональных сообщений между пользователями

·Поддержка нескольких языков

·Вывод популярных статей в отдельном блоке

·Возможность создания статистический страниц непосредственно через админпанель

·Возможность выбора между упрощенной регистрацией и расширенной, при выборе расширенной регистрации пользователь будет зарегистрирован только после активации аккаунта. Активация высылается по почте.

·Возможность загрузки и прикрепления файлов к новостям

·Встроенные средства защиты от несанкционированного скачивания файлов (antileech)

·RSS Импорт новостей

·RSS Информеры

·Мультиязычная поддержка новостей на сайте

·Поддержка Облака Тегов

·Автоматическая поддержка смартфонов

Возможности для посетителей сайта:

·Регистрация на сайте

·Добавление комментариев

·Изменение и удаление пользователями своих собственных комментариев

·Возможность добавления новостей со стороны посетителей

·Модерирование новостей

·Статистика по конкретному пользователю (включая рейтинг и профиль)

·Вывод различной информации для зарегистрированных посетителей и нет

·Возможность загрузки фотографии в профиле пользователя

·Возможность восстановления забытого пароля

·Возможность редактирования новости непосредственно на сайте

·Смена скинов на сайте по своему усмотрению

·Ведение закладок для новостей, и быстрый доступ к ним.

·Массовая загрузка картинок на сервер

·Просмотр и добавление видео на сайт

·Персонализация вывода рекламы для определенных групп

·Возможность загрузки большого количества картинок и файлов в один клик

·Система жалоб "в один клик", на ошибки, новости, комментарии, персональные сообщения

Возможности админцентра:

·Добавление, редактирование и удаление новостей

·Полностью настраиваемая админпанель для различных групп пользователей

·Возможность использования двух редакторов (BBCODES или WYSIWYG)

·Антивирус проверяющий состояние файлов на предмет возможного взлома

·Редактирование пользователей

·Имеется возможность использовать смайлы и HTML код

·Неограниченное создание групп пользователей с тонкой настройкой различных прав доступа

·Возможность выставления бана для посетителей

·Средства для создания и редактирования шаблонов непосредственно в админцентре

·Возможность корректировки времени

·Возможность изменения даты публикации

·Автоматическая публикация статьи при наступлении установленного времени

·Возможность отключения календаря и архивов (для экономии ресурсов)

·Возможность фиксации новостей (будут всегда наверху, независимо от даты)

·Отключение регистрации посетителей

·Автоматическая временная приостановка регистрации при достижении максимального количества зарегистрированных пользователей

·Автоматическое уменьшение загруженных картинок с сохранением пропорций до указанных размеров

·Автоматическое удаление пользователей которые не посещали сайт заданное время

·Наложение водяных знаков на картинки

·Возможность загрузки картинок для каждой конкретной новости (при удалении новости, картинки тоже будут удаляться)

·Удобный менеджер загруженных картинок

·Оптимизацию, ремонт, создание резервной копии и восстановление базы данных можно осуществлять непосредственно из скрипта

·Поиск пользователей по IP адресам

·Удобное управление рекламными материалами.

·Быстрый поиск и замена в базе данных

·Публикация "правил" на сайте

·Создание карты сайта для Google

·Создание фильтров для автоподстановки слов и значений

И много других полезных функций...


Список изменений

Навигация: Общая информация >

Список изменений

Список изменений в версии 17.1:

qДля дополнительных полей с типом список добавлена возможность выбора нескольких значений из списка. Вы можете в настройках данного дополнительного поля установить можно ли для него выбирать одновременно нескольких значений или нужно выбрать только одно из списка. Также вы можете указать разделитель при выводе значений данного поля на сайте. Дополнительно вы можете назначить для данного поля является ли оно обязательным к заполнению или может быть оставлено пустым.

qДобавлена возможность включать в карту сайта Sitemap также и ссылки на изображения, загруженные к публикациям. Данная опция может включаться либо отключаться непосредственно при создании карты в админпанели. При включении данной опции все изображения, которые были загружены к публикации будут также добавлены в карту согласно стандартам поисковой системы Google https://developers.google.com/search/docs/crawling-indexing/sitemaps/image-sitemaps?hl=ru. А если опция отключена, то карта будет создаваться без ссылок на изображения. Включение изображений в карту увеличивает время, необходимое для создания карты и требует дополнительных запросов к базе данных, поэтому вы сами решаете есть ли необходимость включать данную опцию или нет. При этом включение изображений в карту существенно улучшает индексацию изображений на вашем сайте.

qДобавлена новая система уведомлений пользователей на сайте о успешном выполнении или наоборот о ошибке выполнения запрошенных ими действий на сайте. Ранее информация выводилась на странице в всплывающем окне DLEAlert, которое пользователю нужно было также дополнительно закрыть, нажав на кнопку “Ок” или на закрытие окна. Новая система выполнена в формате пуш уведомлений, которые всплывают в углу браузера и по прошествии времени автоматически закрываются, не требуя от посетителя сайта никаких действий. Разработчики дополнительных шаблонов, модулей и плагинов могут также использовать новые встроенные функции для вызова пуш уведомлений. Пуш о успешном выполнении вызывается функцией DLEPush.info (message, title), пуш о предупреждении вызывается функцией DLEPush.warning (message, title), пуш уведомления о возникновении ошибки вызывается функцией DLEPush.error (message, title). Разные типы уведомлений обладают специальным сигнализирующим оформлением.

qВ настройки скрипта в панели управления DataLife Engine, в разделе управления изображениями добавлена возможность включать принудительное добавление уникального префикса для загружаемых изображений. При включении данной опции к имени всех загружаемых изображений будет добавлен уникальный префикс. Данное нововведение будет полезно, для тех, кто часто изменяет загруженное изображение на другое, во избежание браузерного кеширования, чтобы пользователи сразу видели изменённое изображение на сайте. В случае если данная настройка отключена, то будет сохранено оригинальное имя изображения и только если такой файл уже существует на сервере, то к нему будет применён уникальный префикс. Сам же префикс больше не привязан непосредственно к времени загрузки как ранее, и является уникальным и сгенерированным случайным образом.

qДобавлена возможность сортировки заданных внешних хранилищ в том порядке вывода, в котором это необходимо. Для этого вы можете путём простого переноса в нужное место задать нужный вам порядок сортировки в панели управления в разделе управления хранилищами. Тем самым наиболее часто используемые вы можете разместить выше при необходимости.

qДобавлена возможность установить настройки режима быстрого редактирования публикаций на сайте. Теперь вы можете выбрать для быстрого редактирования нужно ли редактировать только уже ранее заполненные поля публикации или же выводить все поля для редактирования, в том числе и не заполненные ранее. При выборе режима редактирования только заполненных полей, быстрое редактирование на сайте, как и ранее будет выводить только заполненные ранее при добавлении поля. В случае если выбран режим всех полей, то независимо от того пустое поле или нет, было оно ранее заполнено или нет, при быстром редактировании вы можете редактировать и краткое и полное описание и все дополнительные поля для публикаций.

qДобавлено полное сохранение имени файла загружаемого на сервер с использованием DataLife Engine и предназначенное для скачивания. При загрузке файла на сервер, его имя будет сохранено так, как оно было изначально, и соответственно при скачивании оно будет сохранено на компьютер с тем же именем. Например, если в имени использовались кириллические символы (мой файл.txt), то они также останутся при скачивании без транслитерации: мой файл.txt, тоже самое касается и других языков.

qДля системы плагинов в панели управления DataLife Engine добавлена возможность выполнить все необходимые действия с плагином непосредственно при редактировании самого плагина. Например, на странице редактирования плагина вы можете, не покидая страницу проверить обновления или обновить, скачать его или удалить. Ранее на страницы редактирования плагина можно было только отредактировать его. В общей сложности добавлено пять новых опций.

qДля системы плагинов в панели управления DataLife Engine добавлен вывод ссылки на редактирование плагина в меню опций плагина, тем самым вы можете открывать редактирование плагинов в новых вкладках браузера, что полезно при одновременном редактировании разных плагинов в панели управления.

qДобавлена возможность менять имя автора комментария при редактировании комментариев на сайте и в админпанели, в случае если комментарий был оставлен незарегистрированным пользователем. Теперь в случае, если пользователь написал в поле имени какой-либо недопустимый текст, администратор может его отредактировать, не удаляя сам комментарий на сайте.

qДобавлено автоматическое динамическое изменение содержимого тегов [add-favorites] текст [/add-favorites] и [del-favorites] текст [/del-favorites] при добавлении или удалении публикации в закладки на сайте. При этом не важно, где в шаблоне расположены эти теги и какого их содержимое. Содержимое будет обновляться автоматически при осуществлении AJAX действия, без необходимости перезагрузки страницы и пользователь автоматически будет видеть, что публикация была либо добавлена в закладки, либо удалена из них.

qПри выводе кнопки “Пожаловаться” в комментариях на сайте добавлена проверка, является ли пользователем автором данного комментария и если является, то кнопка жалобы для этого комментария у него не выводится, т.к. пользователи не могут жаловаться на собственные комментарии.

qДобавлена поддержка нового глобального тега {lang text="LANG_PARAMETER"}, который предназначен для вывода информации из языкового файла website.tpl, который в данный момент используется, где LANG_PARAMETER это значение параметра, который необходимо вывести. Например, тег {lang text="attach_images"} выведет надпись “Прикрепить изображения” из языкового пакета, в случае использования русского языка и если используется английский язык, то “Attach Images”. Данный тег будет полезен при разработке дополнительных модулей и плагинов, когда вы можете разместить дополнительные языковые данные непосредственно в языковой пакет и автоматически выводить нужные вам фразы при смене языка пользователем на сайте, выводя значения в шаблоне в виде тега, а не прямого написания фразы.

qДля шаблонов вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl) добавлена поддержка нового тега {edit-date=формат даты} который выводит дату редактирования публикации в заданном в теге формате. Тем самым вы можете задавать свой собственный формат для даты редактирования, или выводить не только дату целиком, но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {edit-date=d} выведет день месяца, а тег {edit-date=F} выведет название месяца, а тег {edit-date=d-m-Y H:i} выведет полную дату и время.

qДля шаблона вывода всплывающей карточки пользователя (profile_popup.tpl) добавлена поддержка нового тега {usertitle} который выводит логин пользователя в нужном вам месте. Ранее логин пользователя выводился только в заголовке карточки, теперь вы можете вывести его дополнительно в нужном вам месте в шаблоне.

qДля дополнительных полей с типом “Дата и время” добавлена поддержка нового тега [xfvalue_X format="Формат"], где X это имя дополнительного поля, а “Формат” это формат вывода заданной в поле даты и времени. Тем самым в разных местах шаблона, вы можете выводить данное дополнительное поле в разных форматах даты и времени, а не только в том формате, которое указано для поля по умолчанию в настройках поля. Например тег [xfvalue_test format="j F Y H:i"] выведет дату и время указанное в поле в формате времени j F Y H:i.

qДля шаблонов вывода профиля пользователя (userinfo.tpl и profile_popup.tpl) добавлена поддержка новых шаблонных тегов: [banned] текст [/banned] выводят текст заключённый в них если пользователь в данный момент забанен на сайте, [not-banned] текст [not-banned] выводят текст заключённый в них если пользователь не забанен на сайте, {ban-description} выводит причину по которой пользователь забанен, {ban-date} выводит дату до которой пользователь был забанен на сайте. Тем самым при помощи новых тегов вы можете выводить информацию для других посетителей сайта при посещении профиля пользователя, о том, что данный пользователь был забанен и по какой причине он был забанен.

qДобавлена возможность указать в настройках скрипта в админпанели, какой именно провайдер будет использован для уведомлений поисковых систем с использованием протокола IndexNow. Выбор провайдера не влияет на то какие поисковые системы будут уведомлены, они автоматически синхронизуют данные, но выбор влияет на то, какой из провайдеров быстрее отвечает и ближе доступен к вашему сайту по расположению. Тем самым каждый может выбрать оптимального провайдера для своего сайта.

qВ настройки скрипта добавлена возможность включения специально адаптированного редактора для мобильных устройств при написании комментариев на сайте. При включении данной опции, будет отображён специальный облегчённый редактор с минимумом набора кнопок в нем. Данный редактор не перегружает информацией мобильный экран, а также в нем упрощена загрузка и управление изображениями.

qДобавлена автоматическая поддержка всех поддерживаемых сервером часовых поясов, которые вы можете установить для сайта по умолчанию или пользователь сможет выбрать в своём профиле. А также в случае, если на сервере обновляются часовые пояса, то DataLife Engine автоматически будет их также использовать. Тем самым добавлено более 300 новых регионов для выбора часового пояса, и обновляться они будут автоматически в случае появления новых. Для удобства выбора часового пояса добавлен поиск по часовым поясам при выборе.

qДобавлена система поиска по настройкам скрипта в админпанели. Теперь вы можете более быстро найти нужную настройку, начав набирать ее название. Также для удобства визуального отображения текст в найденной настройке подсвечивается.

qДобавлен редактор с подсветкой исходного кода, для раздела управления шаблонами E-mail сообщений, а также улучшена визуальная составляющая данного раздела. Тем самым редактировать шаблоны для E-Mail сообщений стало более удобней.

qДобавлено автоматические перестроение облака тегов при перестроении публикаций в админпанели. Данное нововведение будет полезно, если при ручной самостоятельной работе с базой данных были некорректно обновлены связи между таблицами. Например, в случае добавления публикаций минуя DLE.

qДобавлено автоматическое перенаправление пользователя на главную страницу сразу после регистрации на сайте. Тем самым уменьшается количество кликов пользователем на сайте при его регистрации на сайте и уменьшается количество шагов, которые необходимо сделать посетителю сайта.

qДобавлена поддержка IPv6 адресов для настройки “Список IP для которых разрешена авторизация в админпанели скрипта” в настройках админпанели. Тем самым если администратор сайта имеет IPv6 адрес вместо не IPv4 адреса, то для доступа к сайту он может ограничить доступ для необходимых ему IPv6 адресов.

qУлучшена система визуального отображения выбранных категорий при добавлении и редактировании публикаций в панели управления.

qДля редактора TinyMCE возвращена возможность устанавливать размеры изображения непосредственно при редактировании свойств данного изображения.

qВнесены изменения в работу кнопки отметки пользователя спамером. Теперь данная кнопка не появляется у комментариев пользователей, которые находятся в защищенной от этого группе пользователей.

qСортировка внешних хранилищ, при выборе их во время загрузки файлов если это разрешено, приведена к такому же отображению, как и в разделе управления внешними хранилищами.

qПереработана и улучшена система определения цвета наложения водяных знаков на изображения. Теперь DataLife Engine лучше и качественнее определяет цветовые участки, на которые будет наложен водяной знак, что позволяет более точно определить какой водяной знак (темный или светлый) необходимо наложить в данном случае.

qУлучшена система предварительной проверки e-mail адреса при регистрации пользователя на сайте и изменении адреса в профиле.

qПри редактировании значений дополнительных полей пользователей в панели управления, добавлено использование прав именно редактируемого пользователя, а не с использование прав того, кто редактирует. Например, если пользователю запрещено добавлять ссылки в дополнительных полях, то при редактировании пользователя администратором, данный запрет также будет использоваться и сохраняться.

qДобавлена возможность использовать HTML код в дополнительных полях профилей пользователей, в случае если для данных полей не включён безопасный режим. Ранее допускалось использование только BB тегов.

qДобавлена возможность использования дополнительных полей с типом “Дата и Время” в главном шаблоне main.tpl при просмотре полных публикаций. Ранее данный тип полей не был доступен в полном объёме вывода согласно настройкам поля.

qДобавлен автоматический сброс кеша файла пользовательских стилей adminpanel.css, расположенного в шаблоне, при очистке кеша в админпанели.

qДля тегов [ifxfvalue ….] … [/ifxfvalue], предназначенного для проверки значений дополнительных полей, добавлена проверка по списку значений, если дополнительное поле имеет включённую опцию “Использовать как перекрестные ссылки”. Например, если поле имеет несколько значений, то проверка будет происходить не по полю целиком, а каждое значение в поле по отдельности. Аналогичное поведение проверки добавлено и для тегов [if ….] … [/if] для данных типов дополнительных полей.

qДобавлена поддержка PHP линейки 8.3.xx

qВизуальный редактор TinyMCE обновлён до актуальной линейки. Улучшена скорость его рендеринга.

qПри использовании редактора TinyMCE в случае, если изображение загружается не через менеджер файлов, а через окно вставки изображений в редакторе, добавлено сохранение написанного описания изображения в случае если создаются при этом уменьшенные копии.

qВ связи с тем что поисковые системы прекратили поддержку предварительных уведомлений от сайтов об изменении карты сайта sitemap.xml https://developers.google.com/search/blog/2023/06/sitemaps-lastmod-ping?hl=ru, данная функция уведомлений также была исключена из DataLife Engine. Теперь все происходит автоматически со стороны поисковых систем, вам достаточно просто добавить адрес в панели вебмастера поисковой системы и поисковые системы будут автоматически проверять и переиндексировать данный сайт.

qУлучшена система отображения загруженных изображений и файлов в окне загрузки файлов. Префикс файлов для удобства скрывается из имени загруженных файлов для более удобной ориентации по файлам. Также сам префикс более корректно определяется в имени и избегается случайное удаление части имени в ряде определенных случаев.

qИсправлена проблема, при которой невозможно было добавлять ответы на комментарии при включённой защите от спама reCAPTCHA v3.

qИсправлена проблема, при которой некоторые дополнительные поля могли принимать некорректные значения при перестроении публикаций в панели управления.

qИсправлена проблема, при которой могли в некоторых случаях некорректно обрабатываться шаблоны комментариев если комментарий был оставлен не зарегистрированным пользователем.

qИсправлена проблема, при которой не загружался список внешних хранилищ при загрузке изображений, если несколько разных сайтов объединялись в единую базу пользователей.

qИсправлена проблема, при которой некорректно очищался кеш при одобрении комментария, находящегося на модерации.

qИсправлена проблема, при которой пользователь с логином “noname”, не мог выставлять оценки для публикаций и комментариев.

qИсправлена проблема, при которой при перестроении публикаций в админпанели, в индекс поиска публикаций на основе дополнительных полей попадали публикации, не опубликованные на сайте.

qИсправлена проблема, при которой некоторые часовые пояса пользователь не мог выбрать в своём профиле.

qИсправлена проблема, при которой могла некорректно отображаться дата публикации “Вчера” и “Сегодня” в случае, если произошла смена дня относительно серверного времени согласно часовому поясу, который выбрал пользователь для себя в профиле на сайте.

qИсправлена проблема, при которой при просмотре полных новостей мог не работать непосредственный переход к нужному комментарию в блоке комментариев выводимых тегом {customcomments …..} если таковой присутствует на странице.

qИсправлена проблема, при которой не очищался кеш для страниц полных новостей в случае редактирования публикации в админпанели, в случае если включён третий тип ЧПУ в настройках скрипта.

Список изменений относительно версии 16.1:

qДобавлена возможность для пользователей сайта самостоятельно удалять свой аккаунт на сайте, в случае если они этого желают. Данное разрешение включается в настройках групп пользователей. И может быть выбрано из нескольких вариантов. Вы можете разрешить пользователям полностью самостоятельно принимать решение об удалении аккаунта, либо можете разрешить только отправку запроса администрации сайта на удаление аккаунта, либо вообще запретить самостоятельное удаление. Администраторская группа всегда защищена от самостоятельного удаления в целях безопасности от кражи аккаунта. Администратора может удалить только другой администратор. В случае если пользователю разрешено самостоятельное удаление, то он сам может удалить свой аккаунт и все свои данные с сайта в своём профиле подтвердив данное решение дополнительным вводом своего пароля от аккаунта. В случае если включена отправка запроса администрации, то в разделе управления пользователями для администраторов сайта будет показан список пользователей, которые запросили удаление данных и аккаунта с сайта, и администратору необходимо будет принять решение о удалении данного аккаунта или об отклонении данного запроса. После удаления аккаунта администратором, пользователь получить соответствующее уведомление, что его запрос на удаление выполнен.

qДля шаблона вывода профиля пользователя (userinfo.tpl), добавлена поддержка новых тегов: [delete] Текст [/delete] которые выводят текст заключённый в них в виде ссылки на удаление собственного профиля на сайте пользователем, в случае если это ему разрешено настройками групп пользователей.

qДобавлен новый раздел “Хранилища” в панели управления DataLife Engine. В данном разделе вы можете добавлять различные системы внешних хранилищ, на которые в дальнейшем будут загружаться файлы с использованием DataLife Engine. Тем самым на сайт может использовать не одно определенное внешние хранилище для файлов, а разные. Причём для разных нужд могут использоваться разные хранилища. В данном разделе вы можете добавлять хранилища, отключать их, назначать какое-либо хранилище, хранилищем по умолчанию и т.д.

qВ настройки скрипта в админпанели добавлена возможность указывать в какие хранилища загружать те или иные файлы. Вы можете настроить разные хранилища для изображений к публикациям, комментариям, статических страниц, аватаров пользователей и т.д. Для всех случаев вы можете задать или хранилище по умолчанию, либо любое другое хранилище, созданное в разделе управления хранилищами.

qВ настройки групп пользователей добавлена возможность разрешать или запрещать пользователям выбирать хранилище непосредственно перед самой загрузкой файлов и изображений. В случае если данная возможность разрешена пользователю, то он сможет выбрать перед загрузкой файлов, в какое хранилище их необходимо разместить. Тем самым разные файлы по желанию могут быть размещены по разным хранилищам. А в случае, если это запрещено, то загрузка будет согласно всем настройкам по умолчанию.

qДля дополнительный полей с типами “Загружаемое изображение”, “Загружаемая галерея изображений”, “Загружаемый аудиоплейлист”, “Загружаемый видеоплейлист”, и “Загружаемый файл” добавлена возможность указания в настройках данных полей в какое хранилище необходимо загружать файлы. Тем самым вы можете загружать разные дополнительные поля в разные хранилища, которые указаны в разделе управления хранилищами.

qДля дополнительных полей профилей пользователей добавлена возможность назначения опции “безопасный режим поля”, при данном типе поля полностью отключается возможность использования BB тегов или HTML тегов. А также данные поля можно будет безопасно использовать при выводе их в атрибутах HTML тегов шаблона.

qПри выводе списка последних комментариев на сайте, добавлен автоматический переход к выбранному комментарию при клике на заголовок новости к которому от относится. При этом автоматически ищется страница, на которой он находится, если, например комментарий находится на второй странице у новости, то пользователь автоматически попадёт на вторую страницу, а также браузер будет автоматически прокручен к данному комментарию. Тем самым пользователь будет видеть его сразу визуально. Для того чтобы добавить автоматический поиск при формировании пользовательских ссылок в шаблоне, вам необходимо добавить к ссылкам атрибут: onclick="findCommentsPage(this, '{id}', '{news-id}'); return false;"

qДобавлена автоматическая маркировка загружаемых пользователем аватаров уникальным значением имени файла аватара. Тем самым при каждой загрузке пользователем аватара для своего аккаунта, его имя будет автоматически меняться, и новый аватар будет виден сразу после загрузки, без использования кэша из браузера. Тем самым больше не требуется очистка кэша браузера при смене аватара пользователем на сайте.

qДобавлена возможность быстрого прикрепления изображений к комментариям, при быстром редактировании комментариев на сайте. В случае если в шаблоне добавления комментария используются теги для вывода быстрой формы загрузки и прикрепления изображений к комментарию, то при редактировании также будет автоматически добавляться форма быстрой загрузки изображений к комментарию.

qДобавлена возможность быстрого прикрепления изображений к комментариям, при ответах на комментарии. В случае если в шаблоне добавления комментария используются теги для вывода быстрой формы загрузки и прикрепления изображений к комментарию, то при ответах на комментарии будет также автоматически добавляться форма быстрой загрузки изображений к комментарию. Тем самым возможности при добавлении нового комментария и при добавлении ответа на комментарий будут идентичны.

qДля пользовательского вывода публикаций с использованием тега {custom …} добавлена возможность пользовательского назначения периода, на который необходимо кешировать блок в параметре cache. Вы можете указывать период в минутах, часах или днях. Для указания времени кеширования используются значения с суффиксами “m”, “h” и “d”. Например, если вы укажите {custom cache="30m" ….} то блок будет принудительно закеширован на 30 минут, если вы укажите {custom cache="2h" ….}, то блок будет кеширован на 2 часа, если указать {custom cache="1d" ….} то блок будет кеширован на один день. Если указать просто {custom cache="yes" ….} то как и ранее будет включён автоматический контроль кеша и он будет обновляться по мере обновления информации. Указание времени принудительного кеширования позволит сэкономить ресурсы сервера если блок нет необходимости обновлять сразу, например, при добавлении новых публикаций или комментариев.

qДля пользовательского вывода комментариев с использованием тега {customcomments …} добавлена возможность пользовательского указания периода, на который необходимо кешировать блок в параметре cache. Вы можете указывать период в минутах, часах или днях. Для указания времени кеширования используются значения с суффиксами “m”, “h” и “d”. Например, если вы укажите {customcomments cache="30m" ….} то блок с комментариями будет принудительно кеширован на 30 минут, если вы укажите {customcomments cache="2h" ….}, то блок с комментариями будет кеширован на 2 часа, если указать {customcomments cache="1d" ….} то блок с комментариями будет кеширован на один день. Если указать просто {customcomments cache="yes" ….} то как и ранее будет включён автоматический контроль кеша и он будет обновляться по мере обновления информации. Указание времени принудительного кеширования позволит сэкономить ресурсы сервера если блок нет необходимости обновлять сразу если меняется информация на сайте.

qДля панели управления DataLife Engine добавлена полная поддержка языков, использующих способ написания текста справа налево. Для этого в языковые пакеты добавлена директива “direction” в которой указывается тип написания текста для данного языка ‘ltr’ либо ‘rtl’. При этом в случае, если используется тип написания справа налево, то DataLife Engine подключит для панели управления специально подготовленный и адаптированный для этого файл CSS со стилями панели управления, который будет корректно зеркально отображать всю панель управления. Тем самым пользователи могут использовать необходимое для данного языка оформление панели.

qДля визуальных редакторов WISYWIG добавлена поддержка языков, использующих написание текста справа налево. Для этого также используется значение директивы “direction”, которая устанавливается в языковых пакетах, при создании перевода на нужный язык. Указав написание справа налево “rtl” в директиве, редакторы автоматически будут использовать данный режим написания текста.

qДля всех обычных текстовых полей, которые DataLife Engine генерирует в панели управления и на сайте добавлена автоматическая поддержка языков, использующих написание справа налево. Переключение происходит автоматически, как только пользователь начинает писать текст на данном языке. Тем самым улучшена и облегчена интеграция и создание сайтов на данных языках.

qВ разделе управления группами пользователей добавлена возможность включать или отключать разрешение на использование модуля “Заголовки, описания, метатеги”. Тем самым вы можете разрешать другим группам пользователей использовать данный раздел, а не только для групп администраторов.

qВ разделе управления группами пользователей добавлена возможность включать или отключать разрешение на использование модуля “Перекрестные ссылки”. Тем самым вы можете разрешать другим группам пользователей использовать данный раздел, а не только для групп администраторов.

qВ разделе управления группами пользователей добавлена возможность включать или отключать разрешение на использование модуля “Редиректы”. Тем самым вы можете разрешать другим группам пользователей использовать данный раздел, а не только для групп администраторов.

qДля модуля “Редиректы” в панели управления, добавлена возможность отключать или включать редиректы. Тем самым при необходимости вы можете временно выключить или включить нужный вам редирект без необходимости их удаления и повторного добавления.

qДля модуля “Перекрестные ссылки” в панели управления, добавлена возможность отключать или включать ключевые слова Тем самым при необходимости вы можете временно выключить или включить замену нужных вам слов без необходимости их удаления и повторного добавления.

qДля модуля “Заголовки, описания, метатеги” в панели управления, добавлена возможность отключать или включать заданные правила. Тем самым при необходимости вы можете временно выключить или включить указанные правила для данных страниц без необходимости их удаления и повторного добавления.

qВ админпанели в разделе редактирования публикаций, добавлено визуальное отображение количества найденных публикаций при использовании расширенного поиска по различным параметрам.

qВ настройки скрипта добавлена возможность указать сколько найденных публикаций показывать в результатах быстрого поиска на сайте. Ранее всегда отображалось только пять найденных результатов, теперь вы можете указать своё необходимое вам значение в настройках.

qВнесены изменения в логику работы быстрого поиска. Теперь результаты поиска, в случае если они не входят в окно по высоте не загораживают непосредственно само поле поиска.

qДля суммарного рейтинга публикаций пользователя добавлено использование нового тега {ratingscore} в шаблонах вывода профиля пользователя и быстрой карточки пользователя (userinfo.tpl и profile_popup.tpl). Данный тег выводит число усреднённого рейтинга всех публикаций пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д. Данный тег позволяет задать, например, собственное оформление звезд рейтинга с частичным заполнением, а не только 2 или 4 заполненных звезды.

qДля суммарного рейтинга комментариев пользователя добавлено использование нового тега {commentsratingscore} в шаблонах вывода профиля пользователя и быстрой карточки пользователя (userinfo.tpl и profile_popup.tpl). Данный тег выводит число усредненного рейтинга всех комментариев пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д. Данный тег позволяет задать, например, собственное оформление звезд рейтинга с частичным заполнением, а не только 2 или 4 заполненных звезды.

qВнесены изменения в работу тега [active] … [/active] для шаблона меню категорий. Теперь данный тег выводит текст, заключённый в них и для родительских категорий, в случае если категория, в которую зашёл посетитель сайта является вложенной субкатегорией данных родительских категорий. Ранее данный тег выводил текст только для одной категории, непосредственно в той в которой находился посетитель. Тем самым вы можете посвечивать в том числе и активные родительские категории.

qДобавлена корректная система подсчёта хеша загружаемых файлов непосредственно по содержанию, в случае их загрузки на внешние хранилища.

qДобавлена поддержка подсчёта цифровой контрольной подписи загружаемых на внешние хранилища файлов, в случае если файл поступает на внешнее хранилища, минуя сервер где установлен DataLife Engine, например если файл загружается с внешнего сайта по URL, а не с компьютера.

qВнесены изменения в логику работы поиска по сайту. Теперь данные на сервер передаются при помощи GET запросов, а не POST. Тем самым посетители сайта при использовании навигации по страницам результатов поиска смогут использовать кнопку “Назад” в браузере, а также перегружать страницу без предупреждений от браузера, а также вы можете оставлять ссылки на результаты поиска и определенные страницы результатов на других сайтах и делится этими страницами.

qДля визуального редактора TinyMCE добавлена возможность при написании комментариев вставлять изображения из буфера обмена и путём переноса картинки в редактор и автоматически их загружать на сервер, в случае если для загрузки комментариев включена и используется упрощённая форма загрузки комментариев. То есть вы можете использовать как упрощённую форму и вставлять в текст редактора, так и автоматически загружать в поле самого текста в редакторе.

qДля визуального редактора TinyMCE добавлена возможность вставки раскрывающихся списков (Accordion), а также возможность управления ими. Данные списки вставляются с использованием HTML5 тегов “details” и “summary”.

qПри просмотре загруженных файлов онлайн на сайте, добавлена возможность просмотра файлов и при включённой настройке блокирования скачивания файлов при обращении с других сайтов. Ранее просмотр становился недоступен т.к. обращение к просмотру сайтов происходили с внешних сервисов Google и Microsoft.

qУлучшена система загрузки файлов на сервер с внешних сайтов. Добавлена возможность загружать файлы в случае, если URL содержит не простые прямые ссылки на файл, а с использованием различных параметров в ссылках.

qУлучшен выбор родительских категорий при создании и редактировании категорий. В случае наличия большого количества категорий их можно найти при помощи быстрого поиска по списку категорий.

qУлучшена система выхода и разлогинивания пользователя на сайте. В случае если пользователь выходит с сайта, то производится полная очистка всех данных с браузера, в том числе и тех что были установлены сторонними плагинами и скриптами на сайте.

qВнесены изменения в логику обработки тегов [if field = "значение"] текст [/if], теперь они выполняются раньше чем происходит подключение и обработка тегов {custom ….} и {include file=”….”}. Тем самым вы можете использовать данные теги внутри этих конструкций, не создавая избыточной нагрузки на сервер и выполняя их только если выполняются условия той конструкции, в которой они находятся.

qПосле загрузки видео или аудио файлов на сервер, ссылка на вставку плеера теперь выбирается по умолчанию при выборе вставки. Тем самым вставка медиафайлов осуществляется быстрее при написании публикаций.

qОбновлена инструкция по созданию приложения на сервисе Google для использования авторизации на сайте при помощи Google аккаунтов.

qПереработана система поиска похожих новостей при редактировании публикаций в панели управления. Теперь система данного поиска учитывает какой режим поиска включён в настройках скрипта: “Простой” или “Полнотекстовый”.

qУвеличена скорость работы поиска похожих новостей в разделе редактирования публикаций при использовании полнотекстового режима поиска на больших базах данных с большим объёмом контента.

qОптимизирована работа с кэшем в панели управления, что в некоторых случаях позволяет более реже очищать кэш некоторых данных при выполнении ряда действий. Тем самым снижается нагрузка на сервер и увеличивается производительность работы сайта.

qУлучшена производительность сайта, в случае выполнения каких-либо автоматических программ по крону. Кеш теперь очищается более точно и только в случае необходимости если какие-либо данные в базе данных были изменены. Тем самым снижается нагрузка на сервер.

qУлучшена система формирования контрольной подписи, необходимой для выполнения различных действий, для пользователей, которые не авторизованы на сайте. Данная подпись больше не зависит от IP пользователей, тем самым им не будет отказано в выполнении действия на сайте, в случае если неожиданно изменился IP адрес между выполнениями действий.

qОбновлён визуальный редактор TinyMCE до актуальной версии. Было исправлены различные небольшие ошибки в работе редактора.

qИсправлена проблема, при которой некорректно обрабатывался тег {THEME} при использовании его в шаблоне вывода результатов быстрого поиска по сайту.

qИсправлена проблема, при которой не обновлялась информация об облаке тегов и перекрёстных ссылках в случае если публикация автоматически снималась с сайта по крону, в случае если истекал установленный срок ее публикации на сайте.

qИсправлена проблема, при которой в некоторых случаях могло некорректно отображаться название кнопки для загрузки видео файлов для дополнительных полей с типом “Загружаемый видео плейлист”.

qИсправлена проблема с некорректным отображением раздела редактирования дополнительных полей публикаций и пользователей в панели управления DataLife Engine.

qИсправлена проблема, при которой вложенные комментарии отображались на один уровень меньше, чем указано в настройке: “Максимальный уровень вложенности комментариев” в панели управления скриптом.

qИсправлена проблема, при которой при отключении комментариев на сайте, переставала корректно работать пользовательская сортировка публикаций по просмотрам на сайте.

Список изменений относительно версии 16.0:

qДобавлена поддержка двухфакторной авторизации с использованием одноразовых паролей из приложения Google Authenticator или любых других приложений, поддерживающих одноразовые OTP пароли. Пользователь может сам выбрать в своём профиле, какую двухфакторную авторизацию он хочет использовать. Он может выбрать использование приложений, либо одноразовый пароль будет отправляться по E-Mail. Для использования могут быть использованы любые приложения, поддерживающие OTP верификацию, включая встроенные средства операционных систем смартфонов, а не только Google Authenticator.

qДобавлена поддержка нового типа капчи на сайте Cloudflare Turnstile Sites. Данный тип капчи обеспечивает наиболее качественную защиту от спам ботов, а также работает максимально комфортно для посетителей сайта, которым не потребуется делать выбор надоедливых картинок, или написания текста. Все максимально просто, автоматически и быстро.

qДобавлена возможность ограничивать количество скачиваний для загруженных на сайт файлов. Для этого в настройках групп пользователей, вы можете для данной группы указать сколько файлов в день им разрешено скачивать. При этом ведётся учёт скачиваний именно уникальных файлов, а не просто попыток скачиваний. Например, вы разрешили скачивать пять файлов в день, посетитель скачал пять файлов, и ему будет запрещено скачивать какие-либо другие файлы после этого, но если при скачивании какой то файл был повреждён или случайно удалён, то эти файлы, которые он уже скачивал, он также может скачать без проблем повторно. Если вы не хотите устанавливать лимит на скачивание, то данное ограничение можно также отключить.

qДобавлен новый тип дополнительных полей для публикаций: “Загружаемый видео плейлист”. В данном поле вы можете быстро загружать видео файлы, которые будут выводится на сайте в виде готового видео плеера со списком загруженных файлов для их воспроизведения. Тем самым вы можете быстро и удобно организовывать публикацию видео на своём сайте. В свойствах поля вы можете задать максимальное количество загружаемых файлов, а также максимальный размер файла допустимый к загрузке.

qДобавлен новый тип дополнительных полей для публикаций: “Загружаемый аудио плейлист”. В данном поле вы можете быстро загружать аудио файлы, которые будут выводится на сайте в виде готового аудио плеера со списком загруженных файлов для их воспроизведения. Тем самым вы можете быстро и удобно организовывать публикацию аудио файлов на своём сайте. В свойствах поля вы можете задать максимальное количество загружаемых файлов, а также максимальный размер файла допустимый к загрузке.

qДля системы быстрого поиска на сайте добавлена поддержка полнотекстового поиска. Теперь быстрый поиск на сайте в зависимости от того, что включено в настройках также будет использовать либо полнотекстовый, либо простой поиск. Тем самым результаты при быстром поиске не будут отличаться от результатов от раздела полного поиска на сайте, если был включён полнотекстовый режим поиска на сайте.

qДля быстрого поиска на сайте добавлена поддержка системы шаблонов. Теперь для вывода результатов поиска используется новый файл шаблона fastsearchresult.tpl в котором вы можете использовать все без исключения теги, которые поддерживает шаблон вывода кратких новостей. Тем самым вы можете выводить и дополнительные поля, и оформлять результаты так, как вам хочется без каких-либо ограничений.

qПри редактировании комментариев на сайте, в случае если осуществляется вывод загруженных изображений с использованием тега {images} в комментариях, добавлен вывод списка загруженных изображений для быстрого удаления изображений из редактируемого комментария.

qДобавлен вывод загруженных изображений для комментариев в админпанели в разделе редактирования комментариев. Тем самым вы можете сразу видеть изображения, если в шаблоне для них используется отдельный тег вывода и их нет в тексте комментария. А также вы можете быстро удалить при необходимости загруженные изображения в один клик.

qВ настройки скрипта добавлена возможность указывать свойства RSS потоков, которые используются на сайте. Данные свойства используются для определения какие теги допустимы в потоке, их стандарты и прочее. Вы можете указать свойства для всех трех потоков, используемых на сайте. Данные свойства необходимы различным сервисам использующие данные потоки в своей работе, тем самым в случае, если у какого-то сервиса изменились требования к RSS потокам, вы можете самостоятельно указать в настройках нужные параметры без необходимости ждать обновлений DataLife Engine или самому править файлы скрипта. Также вы можете использовать потоки вообще для каких-то других собственных сервисов, и задавать необходимые параметры самостоятельно.

qВ настройки скрипта в админпанели добавлена возможность скрывать поле краткого описания при добавлении и редактировании публикаций. Вы можете отключить данное поле, если не пользуетесь им при написании публикаций, чтобы оно вам не мешало. Данное нововведение будет полезно тем, кто использует, например только дополнительные поля со своими свойствами.

qВ настройки скрипта в админпанели добавлена возможность скрывать поле полного описания при добавлении и редактировании публикаций. Вы можете отключить данное поле, если не пользуетесь им при написании публикаций, чтобы оно вам не мешало. Данное нововведение будет полезно тем, кто использует, например только дополнительные поля со своими свойствами.

qДля шаблона добавления новостей (addnews.tpl) добавлена поддержка новых тегов: [allow-shortstory] текст [/allow-shortstory] которые выводят текст заключённый в них в случае, если в настройках скрипта включена поддержка поля краткого описания, и скрывают текст в случае данное поле отключено. Также добавлены теги: [allow-fullstory] текст [/allow-fullstory] которые выводят текст заключённый в них в случае, если в настройках скрипта включена поддержка поля полного описания, и скрывают текст в случае данное поле отключено.

qДобавлена возможность сортировки публикаций по дате их редактирования. Порядок сортировки может быть выполнен в настройках скрипта в панели управления, на сайте самим пользователем если это разрешено, а также в настройках каждой категории отдельно.

qДобавлена возможность сохранять резервные копии базы данных на внешнее хранилище. Для этого в настройках скрипта вы можете включить настройку “Сохранять резервные копии на внешнее хранилище”. При включении данной опции резервная копия будет автоматически переноситься на внешнее хранилище.

qДобавлена возможность автоматически конвертировать загружаемые изображения в один выбранный формат в настройках скрипта формат. Вместо настройки автоматического конвертирования загружаемых изображений в формат WebP, вы можете выбрать один из четырех форматов: PNG, JPG, WEBP, AVIF. Либо вы можете вообще отключить автоматическое конвертирование в другой формат и изображение будет оставаться в том формате, в котором оно изначально.

qДобавлена возможность использовать для отложенной загрузки изображений не только средства jаvascript, но и нативную поддержку браузером. Теперь в настройках скрипта вы можете выбрать тип отложенной загрузки: Отключена, включена с использованием jаvascript и включена с использованием нативной поддержкой браузером. Нативная поддержка браузером работает точнее и быстрее, не требует загрузки на страницу дополнительных скриптов, но при этом поддерживается только современными браузерами. Не все посетители вашего сайта могут иметь такие браузеры. В случае использования пользователем старого браузера, изображение он будет видеть в любом случае, однако отложенная загрузка для него не будет работать.

qДля тегов вывода изображений и встроенных фреймов (img и iframe) добавлена возможность добавлять атрибут loading="lazy" при добавлении публикаций. Для добавления нативной отложенной загрузки изображений и фреймов, браузерами, которые поддерживают данный атрибут.

qДобавлена поддержка новых глобальных тегов: [category-description] текст [/category-description], которые выводят текст заключённый в них если просматриваемая категория имеет заданное описание категории. А также добавлена поддержка тегов: [not-category-description] текст [/not-category-description], которые выводя текст заключённый в них, если категория не имеет описания. Данные теги будут полезны при оформлении различных блоков шаблона для случаев, когда описание задано, и для случаев, когда описание отсутствует.

qДля пользователей, находящихся в группе “Главные редакторы”, добавлена возможность менять автора публикаций. Ранее такая возможность была только у администраторов сайта.

qДля системы плагинов добавлена возможность указывать несколько плагинов, которые обязательны присутствовать в системе для работы устанавливаемого плагина. Для назначения нескольких плагинов, их имена перечисляются через запятую. Ранее можно было указать только один обязательный плагин.

qДобавлено автоматическое переключение на тёмную тему в панели управления DataLife Engine (в случае если включено автоматическое включение ночного режима) в зависимости от установленной темы операционной системы. Теперь переключение будет не только по времени, но и в случае, если тема операционной системы была переключена на тёмную, то также будет произведено переключение и в панели управления.

qДля шаблона вывода RSS добавлена поддержка нового тега {full-story limit="X"} который выводит текст полной новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов. Данный тег будет полезен если сайт добавляется в сервис Дзен Новости (Яндекс новости), совместно с использованием тега <yandex:full-text>.

qПри использовании сравнения с использованием тегов [if field = "значение"] текст [/if] для дополнительных полей с типом “дата” а также “дата и время” добавлена автоматическая проверка именно как значения даты. При сравнении вы можете использовать дату в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, а также использовать не только знак равенства, но и проверять больше ли дата или меньше указанного значения. Ранее данный тип полей сравнивался просто как текстовое значение.

qУлучшена система сравнения с использованием тегов [if field = "значение"] текст [/if] при использовании в сравнении значения дополнительных полей. Проводится дополнительная конвертация ранее экранированных символов в обычные символы, что упрощает сравнение.

qУпрощена система расширенной регистрации на сайте, посетителю при регистрации потребуется меньше шагов при прохождении расширенной регистрации на сайте.

qДля шаблонов вывода кратких и полных новостей, а также для шаблона главной страницы (shortstory.tpl, fullstory.tpl, main.tpl) добавлена поддержка новых тегов: [xfvalue_X video="Nr"] который выводит загруженные для дополнительного поля с типом "Видео плейлист" видео c выбранным номером по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста, [xfvalue_X video-url="Nr"] который выводит загруженные для дополнительного поля с типом "Видео плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста, [xfvalue_X video-description="Nr"] который выводит загруженные для дополнительного поля с типом "Видео плейлист" описания видео, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста. [xfgiven_X video="Nr"] текст [/xfgiven_X video="Nr"] которые выводят текст заключённый в них если видео с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер видео, [xfnotgiven_X video="Nr"] Текст [/xfnotgiven_X video="Nr"] которые выводят текст заключённый в них если видео с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер видео. Все данные теги будут полезны при использовании собственных сторонних видео плееров, для организации видео просмотра на своём сайте.

qДля шаблонов вывода кратких и полных новостей, а также для шаблона главной страницы (shortstory.tpl, fullstory.tpl, main.tpl) добавлена поддержка новых тегов: [xfvalue_X audio="Nr"] который выводит загруженные для дополнительного поля с типом "Аудио плейлист" видео по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста, [xfvalue_X audio-url="Nr"] который выводит загруженные для дополнительного поля с типом "Аудио плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста, [xfvalue_X audio-description="Nr"] который выводит загруженные для дополнительного поля с типом "Аудио плейлист" описания аудио файла, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста. [xfgiven_X audio="Nr"] текст [/xfgiven_X audio="Nr"] которые выводят текст заключённый в них если аудио с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла, [xfnotgiven_X audio="Nr"] Текст [/xfnotgiven_X audio="Nr"] которые выводят текст заключённый в них если аудио с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла. Все данные теги будут полезны при использовании собственных сторонних аудио плееров, для организации аудио просмотра на своем сайте.

qИзменено формирование мета тега заголовка (Title) страницы при показе главной страницы в случае, если установлено использование статической страницы main в качестве главной страницы. Теперь в заголовке используются только основной заголовок, указанный в настройках скрипта в панели управления.

qУлучшена система быстрого редактирования комментариев на сайте и в панели управления. В случае возникновения какой-либо ошибки, пользователю будет выведено сообщение об ошибке в всплывающем окне, при этом сохранится возможность внесения дальнейших изменений в комментарий для устранения возникших ошибок.

qУлучшена поддержка дополнительный полей, имеющих тип “Одна строка” c опцией безопасного режима. Для данных полей добавлена возможность использования URL в качестве контента, и они могут использоваться для вставки ссылок в публикациях.

qВнесены изменения, направленные на предотвращение возникновения ссылок на публикации, длина которых превышает суммарный лимит на длину URL установленными стандартами в 255 символов.

qОбновлена система показа уменьшенных копий изображений. Внешний вид стал ещё более современным, добавлена более плавная анимация, больше уровней масштабирования.

qДобавлено использование более крипто безопасных алгоритмов в различных генераторах случайных значений, используемых различными функциями идентификации пользователей.

qДля визуального редактора TinyMCE добавлена возможность установить размер текста быстро и удобно в любых величинах, а не только из списка предопределенных размеров.

qДля визуального редактора Froala добавлена возможность использования в текстах любых шрифтовых иконок, а не только FontAwesome старых версий.

qСущественно ускорена работа DLE и снижена нагрузка на сервер при формировании RSS потоков для Турбо страниц и Яндекс Дзена.ли остатки HTML сущностей в данные ссылки.

qПри написании дополнительных полей в публикации с опцией “Перекрестные ссылки”, в случае если тег был написан с использованием разного регистра букв, то и при выводе данного поля в хлебных крошках и метатегах заголовка будет использовано слово с тем же регистром букв как оно и было написано в публикации, а не маленькими буквами как было ранее. URL при этом остаётся как и ранее неизменным.

qПри написании слов для облака тегов в публикации, в случае если тег был написан с использованием разного регистра букв, то и при выводе данного тега в хлебных крошках и метатегах заголовка будет использовано слово с тем же регистром букв как оно и было написано в публикации, а не маленькими буквами как было ранее. URL при этом остаётся как и ранее неизменным.

qМинимальным требованием для работы DLE установлено наличие на сервере PHP 8.0 и выше. Ранее минимальной версией PHP являлось 7.4. Помимо этого были снижены рекомендуемые требования к версии PHP, теперь для работы всех функций DLE также достаточно иметь линейку PHP 8.0.x, а не 8.1.x

qОбновлён визуальный редактор TinyMCE до актуальной линейки.

qИсправлена проблема, при которой объединение комментариев было в одну строку, при использовании редактора BBCODES для комментариев.

qИсправлена проблема, при которой появлялись лишние строки при массовом объединении комментариев на сайте, в случае использования визуальных редакторов для комментариев.

qИсправлена проблема, при которой при изменении поисковой строки в поиске не происходил возврат на первую страницу поиска, если пользователь находится не на первой странице и использует только клавиатуру.

qИсправлена проблема, при которой некорректно работал тег {related-ids} в шаблоне полной новости, при первом показе публикации на сайте.

qИсправлена проблема, при которой не работала проверка некоторых полей в теге [if field = "значение"] текст [/if] при подключении пользовательского вывода публикаций с использованием тега {custom …}

qИсправлена проблема, при которой невозможно было добавить в некоторых случаях новые ключевые слова в облако тегов при выполнении массовых действий над новостями.

qИсправлена проблема, при которой могли в некоторых случаях не нажиматься некоторые кнопки в редакторе BBCODES при быстром редактировании публикаций на сайте.

qИсправлена проблема, при которой формировалась не валидная вёрстка в случае использования древовидной вёрстки комментариев, если при этом достигался лимит вложенности комментариев.

qИсправлена проблема, при которой могла не происходит разблокировка кнопки загрузки изображений для дополнительных полей с типом “Галерея изображений”, при переносе изображения из одной галереи в другую.

Список изменений относительно версии 15.3:

qДобавлена возможность при назначении новых ключевых слов для облака тегов в массовых действиях над публикациями, использовать в этих тегах также специальные символы, такие как кавычки и ряд других, которые поддерживаются облаком тегов.

qДля тега [mediа=…] добавлена возможность вставки коротких видео (шортсов), а также плейлистов с сервиса Youtube. Ранее была доступна вставка только обычных видеороликов.

qУлучшена система автоматической транслитерации ссылок для ЧПУ URL, чтобы при формировании ссылок не попада

qДобавлена автоматическая поддержка загрузки HiDPI (Retina) изображений и скриншотов для публикаций и статических страниц на сайте. В менеджере загрузки изображений, перед загрузкой картинки вы можете указать что изображение является изображением с высокой плотностью пикселей, например это скриншот сделанный на HiDPI (Retina) экране, и DataLife Engine при загрузке автоматически создаст две копии изображения одна для обычных экранов, вторая для экранов высокой плотности, и при просмотре сайта посетителем, в случае если у него экран высокой плотности, он будет видеть изображение высокой плотности пикселей, а если обычный экран, то обычное изображение. Тоже самое происходит и для уменьшенных копий изображений. Тем самым вы можете автоматически публиковать на своём сайте качественные скриншоты высокой чёткости. В качестве примера реализации вы можете посмотреть изображения, опубликованные в данной новости. Вставка изображений высокой чёткости поддерживается только при использовании визуальных редакторов при написании публикации.

qПоказ уменьшенных копий изображений с увеличением до оригинальных размеров был полностью переработан и переведён на использование современных JS библиотек. Также был переработан показ галереи изображений. Теперь визуальный внешний вид вы можете легко менять при помощи своих шаблонов, все элементы галереи адаптированы с использованием векторной графики, а показ изображений стал комфортен на любых устройствах, включая мобильные устройства с поддержкой жестов для комфортного просмотра увеличенных изображений.

qПереработаны запросы к базе данных при показе кратких новостей на сайте. Данные запросы были оптимизированы при работе с большими базами данных, содержащие большое количество публикаций. При навигации по страницам кратких новостей выборка из базы данных теперь осуществляется намного быстрее, и потребляет существенно меньше ресурсов сервера.

qПереработана система формирования RSS потоков вашего сайта. В связи с тем, что Яндекс и дзен разделились, теперь невозможно формировать контент в едином потоке. Поэтому DataLife Engine теперь транслирует одновременно три разных потока для разных сервисов. По адресу http://вашсайт/rss.xml транслируется RSS в общем формате для различных систем и сервисов и полностью соответствует стандартам RSS 2.0. По адресу http://вашсайт/rssturbo.xml транслируется RSS поток публикаций для Яндекс Турбо, а по адресу http://вашсайт/rssdzen.xml транслируется RSS поток публикаций для Дзена. Теперь потоки полностью независимы и не пересекаются между собой и работают отдельно. Точно также действует и разделение для категорий сайта и публикаций пользователей. Подробно все адреса для RSS потоков вы можете увидеть в документации по скрипту. Также, в связи с этим формат шаблона для RSS потоков был изменён. Для блока стандартного RSS используются новые теги [rss] ... [/rss], для блока турбо новостей используются теги [turbo] ... [/turbo], для блока дзен новостей используются теги [dzen] ... [/dzen]. После обновления вам необходимо привести свой шаблон RSS в соответствие с новым режимом работы. В качестве примера вы можете взять стандартный шаблон temlates/rss.tpl из архива дистрибутива.

qДобавлена поддержка WebDAV внешний хранилищ для загрузки и хранения изображений и файлов. Тип данного хранилища выбирается в настройках скрипта в панели управления. Там же задаются и параметры для соединения и использования данного хранилища.

qДобавлена возможность полного редактирования публикаций на сайте для пользователей, которым разрешено редактирование публикаций, но при этом запрещён доступ к административной панели управления DataLife Engine. Ранее им было доступно только быстрое редактирование, теперь же они могут полностью редактировать новости со всеми полями, включая незаполненные дополнительные поля. Для этого задействуется модуль добавления публикаций на сайте, пользователь будет редактировать новость на странице добавления, при этом заполненные поля будут уже заполненными, и он может вносить только необходимые правки либо дополнить не указанные ранее поля, в публикацию.

qВ настройки скрипта добавлена возможность устанавливать список имён доменов, для которых разрешена вставка тегов iframe. Тем самым вы можете самостоятельно указывать список безопасных доменов, с которых вы вставляете контент для своих публикаций. Также вы можете полностью отключить разрешение на вставку тегов iframe в публикациях на своём сайте.

qВ настройки скрипта в панели управления добавлена возможность включать и отключать вывод PHP ошибок, в случае если они возникают в коде. Данную опцию рекомендуется включать на время проведения технических работ, например, перед обновлением скрипта или перед установкой плагинов, чтобы в случае возникновения ошибок, увидеть их визуально. Данная настройка позволяет не менять настроек сервера для включения этой возможности, и не просматривать логи ошибок сервера, чтобы увидеть проблему.

qДобавлена система автоматического сброса кэша статических JS и CSS файлов для браузеров у всех посетителей сайта. При нажатии в панели управления DataLife Engine функции "Очистить кэш", будет сброшен специальный уникальный ID кэша, который используется скриптом при подключении статических CSS и JS файлов. В случае если вы в шаблоне подключаете стили и скрипты с использованием тега {include ...} то кэш браузера будет сброшен и у них. Тем самым при внесении, например изменений в стили шаблона, вы можете сбросив кэш, сделать так, чтобы все без исключения посетители вашего сайта сразу увидели обновлённую информацию и вёрстку, не дожидаясь пока устареет кэш в их браузерах.

qДля всех шаблонов добавлен новый глобальный тег {cache-id} который выводит текущий актуальный ID кэша, который вы можете использовать шаблонах при подключении своих статических файлов минуя такие внутренние функции DLE как {include file=....}, и их браузерный кэш будет автоматически сбрасываться при нажатии администратором сайта на кнопку "Очистить кэш" в панели управления. Например, вы можете использовать для подключения своих статических файлов конструкцию <link href="{THEME}/font/styles.min.css?v={cache-id}" rel="stylesheet" type="text/css"> для подключения статического файла стилей.

qВнешнее оформление визуального редактора TinyMCE было переработано. Отображение меню было убрано, все его функции отображаются сразу в виде кнопок, чтобы был более удобный визуальный доступ к функциям редактора, без необходимости их поиска в различных меню.

qДля визуального редактора TinyMCE добавлена возможность быстрого оформления блоков предустановленными стилями. Вы можете, например в один клик сделать оформление информационного или предупреждающего блока, выставить границы блока и т.д. Что делает оформление публикаций более простым и быстрым.

qДля визуального редактора TinyMCE добавлена возможность выбирать предустановленные классы для изображений при их вставке и редактировании, которые вы можете оформить в своём шаблоне по своему усмотрению. Тем самым вы можете быстро в один клик выставить изображениям сразу нужное вам оформление.

qПри написании комментариев и персональных сообщений на сайте с использованием визуального редактора TinyMCE добавлена возможность быстрой вставки логина пользователя со ссылкой на его профиль. Достаточно набрать символ @ после чего начать набирать логин пользователя, DataLife Engine автоматически проведёт поиск по базе данных пользователей и предложит варианты для автоматической вставки. Вставляемый контент после публикации автоматически преобразуется в ссылку на карточку пользователя, при клике на которую вы можете увидеть информацию о пользователе, написать ему сообщение и посетить его профиль.

qСервис онлайн просмотра документов на сайте был заменён на сервис от Microsoft, вместо использовавшего ранее от Google. Тем самым обеспечивается более полная совместимость при просмотре, а также была добавлена поддержка дополнительных новых форматов, доступных к онлайн просмотру. Полный список поддерживаемых форматов: "doc", "docx", "docm", "dotm", "dotx", "xlsx", "xlsb", "xls", "xlsm", "pptx", "ppsx", "ppt", "pps", "pptm", "potm", "ppam", "potx", "ppsm", "odt", "odx"

qДобавлено использование полноценных редакторов для модуля "RSS импорт новостей". В зависимости от того какой редактор был включён для публикаций в панели управления, тот и будет автоматически подключаться и использоваться при редактировании краткой публикации и при получении полной публикации.

qПри импортировании публикаций в панели управления из различных RSS источников добавлено автоматическая конвертация ссылок на изображения в случае, если в них указан путь без домена. Например, если на сайте источнике стоит ссылка "/image/file.jpg", то она автоматически будет сконвертирована на ссылку включающую домен источника "https://domain.com/image/file.jpg", тем самым изображения будут отображаться в публикациях корректно.

qДобавлена автоматическая предварительная фильтрация некорректного HTML кода при получении полной новости в модуле импортирования публикаций из различных RSS источников. После получения контента по HTML шаблону, который вы задали для RSS источника, он пройдёт предварительную фильтрацию на предмет неподдерживаемых или незакрытых тегов, будет полностью отфильтрован и только потом отобразиться в редакторе для его дальнейшей правки.

qДля файлов параметров шаблона (info.json), который находится в папке шаблонов добавлена возможность указать к какому типу относится шаблон, к светлому или тёмному. Для этого используется параметр "type": "light" для указания что шаблон является светлым и "type": "dark" для указания что шаблон является темным. При включении что шаблон является темным, все визуальные редакторы автоматически перейдут на режим работы тёмного цвета и будут иметь соответствующее тёмное оформление, без необходимости вносить правки в стили шаблона вручную.

qДля шаблонов вывода полной новости (fullstory.tpl) добавлено использование нового тега {related-ids}, который выводит список ID похожих публикаций для данной новости. Данный тег полезен при совместном использовании с тегом {custom ...}, например тег {custom id="{related-ids}"} выведет все похожие новости для данной публикации с поддержкой всех возможных шаблонных тегов в отличии от базового тега {related-news} в котором поддерживаемые теги существенно ограничены в целях обеспечения большей производительности. Тем самым вы получаете больше возможностей по оформлению публикаций на сайте.

qДля шаблона вывода персональных сообщений (pm.tpl) добавлена поддержка нового тега: {login} который выводит логин автора персонального сообщения, без какого-либо дополнительного оформления.

qДля шаблона вывода персональных сообщений (pm.tpl) добавлена поддержка нового тега: {date=формат даты} который выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком, но и её отдельные части. Формат даты задаётся согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время.

qДля шаблонов вывода профиля пользователей, комментариев, персональных сообщений (comments.tpl, pm.tpl, userinfo.tpl, profile_popup.tpl) добавлена поддержка нового тега: {lastdate=формат даты} который выводит последнего посещения сайта пользователем в заданном в теге формате. Тем самым вы можете выводить не только дату целиком, но и её отдельные части или же использовать свой формат даты, а не заданный по умолчанию. Формат даты задаётся согласно формату принятому в PHP. Например тег {lastdate=d} выведет день месяца, а тег {lastdate=F} выведет название месяца, а тег {lastdate=d-m-Y H:i} выведет полную дату и время.

qДля шаблонов вывода профиля пользователей, комментариев, персональных сообщений (comments.tpl, pm.tpl, userinfo.tpl, profile_popup.tpl) добавлена поддержка нового тега: {registration=формат даты} который выводит дату регистрации пользователя в заданном в теге формате. Тем самым вы можете выводить не только дату целиком, но и её отдельные части или же использовать свой формат даты, а не заданный по умолчанию. Формат даты задаётся согласно формату принятому в PHP. Например тег {registration=d} выведет день месяца, а тег {registration=F} выведет название месяца, а тег {registration=d-m-Y H:i} выведет полную дату и время.

qДля метатегов страниц вашего сайта добавлено автоматическое использование тега <link rel="preconnect" href="http://yourwebsite.com/" fetchpriority="high">, которое позволяет оставлять браузеру соединение открытым, а не открывать его повторно при обращении к другим страницам вашего сайта. Что позволяет немного улучшить и ускорить отзывчивость вашего сайта, особенно на медленных интернет-соединениях.

qВ настройки скрипта, в разделе настроек загрузки файлов, добавлена возможность устанавливать какие права доступа будут устанавливаться на файлы при их записи на сервер. Доступно для выбора два режима: "Публичный" и "Приватный". При использовании приватного режима, полные права доступа будут установлены только для владельца файла, от имени которого загружаются файлы на сервер. При использовании публичного режима полные права будут установлены для всех пользователей сервера. По умолчанию используется публичный режим, однако для некоторых внешний серверов, которые используют S3 протокол необходимо включить именно приватный режим. Например, сервис Cloudflare S3. Тем самым обеспечивается более обширная поддержка различный облачных сервисов для хранения данных.

qВ настройки скрипта добавлена возможность устанавливать размер пакетов при загрузке больших файлов на сервер. При загрузке больших файлов, данные файлы разбиваются на отдельные пакеты, чтобы не превышать лимиты, установленные на сервере. Вы можете указать размер пакета данных, который будет отправлен на сервер за один раз, он указывается в мегабайтах. Чем меньше пакетов отправляется, тем быстрее произойдёт загрузка на сервер. И вы можете задать свои размеры пакетов, в зависимости от конкретных настроек лимитов вашего сервера.

qДобавлена автоматическая фильтрация добавления файлов в очередь при их загрузке для публикаций. В случае если для публикации установлено ограничение на количество загружаемых изображений или других файлов, то пользователь не сможет добавить в очередь больше файлов, чем ему это разрешено. Причём фильтрация для изображений и прочих файлов происходит независимо друг от друга, и каждый лимит учитывается отдельно. Тем самым пользователь не только наглядно видит, что уже исчерпал лимит и не может добавить больше, но и на сервер не отправляются лишние данные и файлы, тем самым экономя ресурсы сервера.

qПри загрузке изображений к комментариям на сайте также добавлено автоматическое ограничение на постановку файлов в очередь, если установлен максимальный лимит на количество изображений, которые разрешено загружать для комментариев.

qДобавлено автоматическое удаление карты облака тегов из карты сайта, в случае если поддержка облака тегов отключена в настройках скрипта, либо если отсутствуют ключевые слова для облака тегов.

qДобавлено автоматическое удаление карты статических страниц из карты сайта, в случае если на сайте отсутствуют статические страницы.

qДобавлено автоматическое удаление карты категорий из карты сайта, в случае если на сайте отсутствуют категории.

qДля комментариев и персональных сообщений изменён вывод даты комментария или персонального сообщения при использовании тега {date}. При выводе даты введён более расширенный учёт того, сколько времени прошло с момента сообщения, если прошли минуты, то будет указано сколько минут прошло, если часы, то сколько прошло часов, если прошло менее недели то будет указан день недели и время, и т.д. Тем самым всегда наглядно будет видно насколько старый данный комментарий.

qДля шаблонных тегов {registration} и {lastdate} которые выводят дату регистрации и дату последнего посещения пользователя, по всему сайту, где они используются изменён вывод данной даты. При выводе даты введён более расширенный учёт того, сколько времени прошло с момента данной даты. Если прошли минуты, то будет указано сколько минут прошло, если часы, то сколько прошло часов, если прошло менее недели, то будет указан день недели и время. Тем самым всегда наглядно будет видна, например последняя активность пользователя на сайте. Например, был на сайте 20 минут назад, или вчера в 12:20 и т.д.

qПри цитировании комментариев на сайте, добавлено автоматическое добавление даты цитируемого сообщения, когда оно было оставлено. При этом если прошло немного времени, то для удобства чтения указывается сколько времени прошло с момента сообщения. Например, прошло 10 минут. Также по мере течения данного времени, эта информация автоматически на сайте обновляется.

qВ настройки панели управления Datalife Engine добавлена возможность устанавливать масштабирование панели управления. Масштабирование осуществляется всех элементов панели пропорционально, что позволит некоторым пользователям более удобно работать с панелью управления.

qВ настройки панели управления Datalife Engine добавлена возможность включать дополнительное сглаживание шрифтов, что позволяет на некоторых мониторах видеть более комфортный текст.

qВсе правила в файлах .htaccess для управления сервером Apache были переписаны таким образом, чтобы одновременно поддерживать все линейки Apache, как линейки 2.2.x так и линейки 2.4.x, даже в случае отключения некоторых модулей.

qДобавлена поддержка работы JS cкриптов DataLife Engine на некоторых типах браузеров, встроенных в телевизоры.

qДобавлена поддержка загрузки изображений и файлов для дополнительных полей публикаций методом "Drag & Drop". Для начала загрузки файлов достаточно перенести файл мышкой с компьютера в область нахождения кнопки загрузки данного поля.

qРейтинг для публикаций на сайте был переведён на использование data-xx атрибутов вместо использования id атрибутов в HTML. Тем самым вы можете использовать в одной публикации вывод рейтинга в нескольких местах одновременно, например внизу и вверху публикации, для более удобного выставления рейтинга на сайте. Автоматическое обновление также будет происходит в нескольких местах одновременно, где он был установлен.

qРейтинг для комментариев на сайте был переведён на использование data-xx атрибутов вместо использования id атрибутов в HTML. Тем самым вы можете использовать в одном комментарии вывод рейтинга в нескольких местах одновременно, например внизу и вверху комментария, для более удобного выставления рейтинга. Автоматическое обновление также будет происходит в нескольких местах одновременно, где он был установлен.

qПо настойчивым многочисленным просьбам, убран автоматический перенос на новую строку после вставки ника пользователя в поле комментария, в случаях ответов на комментарии при отключённых древовидных комментариях. А при использовании визуальных редакторов будет использоваться быстрая вставка ссылки на карточку пользователя.

qПри переключении тем и режимов работы панели управления в окне настроек панели добавлено автоматическое перестроение и обновление визуального редактора TinyMCE без необходимости перезагрузки страницы. Например, при переключении на тёмную тему редактор полностью также автоматически обновится и перейдёт на использование темной темы без перегрузки страницы.

qУлучшена система навигации в модуле управления RSS импортом публикаций в панели управления DataLife Engine.

qУлучшено визуальное оформление редакторов Froala и TinyMCE при использовании темной темы в панели управления DataLife Engine

qДобавлена новая дополнительная цветовая схема для панели управления DataLife Engine. Она нацелена на более тёплое отображение панели, при этом более контрастное восприятие контента. Надеемся, что пользователям придётся по душе новая дополнительная схема. Данная схема является дополнительной, и включается в настройках панели, все ранее существовавшие схемы также сохранились.

qОбновлены внутренние сторонние библиотеки, а также jQuery и визуальный редактор TinyMCE до актуальных версий.

qДобавлена возможность загрузки на сервер изображений в формате AVIF в случае, если используется библиотека GD2 на сервере. Данная возможность используется только если на сервере установлена версия PHP 8.1 и выше, а также имеется поддержка декодирования данных изображений со стороны сервера.

qДобавлена поддержка PHP линейки 8.2.xx

qИсправлена проблема, при которой не работала проверка по некоторым полям в шаблоне вывода кратких новостей для тега [if field = "значение"] текст [/if] из тех что описаны в документации по шаблонам.

qИсправлена проблема, при которой могли не удаляться загруженные изображения к комментариям, которые есть у новости в случае удаления непосредственно самой новости с сайта.

qИсправлены проблемы возможной некорректной работе вставки смайлов в редакторе TinyMCE, при использовании сайта на двух разных протоколах http и https одновременно.

qИсправлена проблема, при которой не работало кеширование вывода комментариев при помощи тега {customcomments ....}

qИсправлена проблема, при которой некорректно отображался визуальный редактор TinyMCE при редактировании комментариев на сайте при использовании темной темы в админпанели DataLife Engine.

qИсправлена проблема, при которой возникали проблемы при использовании загрузке изображений и файлов в Яндекс браузере.

Список изменений относительно версии 15.2:

qДобавлено автоматическое уведомление при переходе в редактирование публикации о том, что публикация уже в данный момент редактируется, в случае если она в данный момент редактируется другим пользователем. Данная возможность включается в настройках скрипта в панели управления. Данное нововведение будет особенно полезно если на сайте большое количество редакторов и модераторов, чтобы они имели возможность видеть, что этой публикацией уже занимается другой человек.

qДобавлена возможность упрощённой, быстрой и удобной загрузки изображений к комментариям. Теперь вы можете просто разместить в шаблоне добавления комментариев (addcomments.tpl) тег {image-upload}, который выведет специальное поле куда пользователь может переместить картинки для загрузки, либо выбрать их с компьютера. При этом пользователю не нужно будет ничего загружать отдельно, все будет загружено автоматически, как только пользователь нажмёт на кнопку добавить комментарий. При этом поместив файлы, при желании он может их убрать ещё до отправки комментария, либо поменять их порядок сортировки. В случае если в шаблон помещён тег для быстрой загрузки, в редакторе автоматически отключится кнопка обычной загрузки файлов, и она не будет отображаться. А в случае, если тег не размещён то загрузка и вставка изображений будет как и ранее. Вывести же все загруженные изображения в комментарии вы сможете в шаблоне вывода комментариев в любом удобном для вас месте специально предусмотренными тегами.

qДля шаблона вывода комментариев (comments.tpl) добавлена поддержка новых тегов: [images] текст [/images] которые выводят заключенный в них текст, в случае если к комментарию были загружены изображения, а также тег {images} который выведет все загруженные для комментария изображения в виде галереи изображений. Данная галерея изображений может увеличивать по клику уменьшенные копии и перелистывать изображения между собой.

qНастройки разрешения вставки в текст комментария изображений и разрешения загрузки изображений к комментариям стали полностью независимыми. Теперь вы можете запретить вставку картинок в текст комментария, но при этом разрешить загрузку картинок к комментариям и выводить загруженные изображения в строго отведённых для этого местах в шаблоне вывода комментариев при помощи тега {images}.

qПри добавлении файлов и изображений на сервер в модуле загрузки добавлена возможность предварительного просмотра добавленных для загрузки файлов. После добавления файлов, загрузка не начнётся сразу автоматически, а пользователь может посмотреть файлы, которые он добавил, если добавлены ошибочные файлы, он может их удалить из очереди на загрузку. Также добавлен выбор для пользователя как отображать список файлов, он может их смотреть в виде списка, либо в виде иконок. Выбор пользователя автоматически запоминается и на последующие загрузки.

qДобавлена возможность отсортировать порядок очерёдности загрузки изображений и файлов на сервер, непосредственно ещё до загрузки файлов и изображений на сервер. После выбора файлов и добавления их в очередь на загрузку, пользователь может поменять порядок, просто перенеся файлы из списка в нужную очерёдность.

qДобавлена возможность переименования имён загружаемых файлов, для этого после добавления файлов и до начала загрузки, достаточно дважды кликнуть на имя файла и отредактировать имя указав новое.

qДобавлена возможность загружать файлы на сервер любых размеров, независимо от настроек и ограничений серверного программного обеспечения. Зачастую на сервере установлены небольшие лимиты на максимальный размер передаваемого файла на сервер, и для загрузки больших файлов необходимо увеличивать серверные лимиты, что не всегда возможно, а также требует большего расхода памяти. Теперь DataLife Engine автоматически разбивает передаваемый файл на части и отправляет файл по частями до полной его загрузки, и уже на сервере объединяет в единый файл. Тем самым вы можете загружать файлы на сервер независимо от лимитов хостинга, и действуют только ограничения, установленные в настройках DataLife Engine, например вы можете загружать файлы весом несколько гигабайт имея лимиты хостинга всего 2 мегабайта на загрузку файлов, установив такое разрешение только в настройках DataLife Engine.

qВнесены изменения в загрузчик изображений и файлов, в случае если возникает какая-либо ошибка при загрузке. Теперь уведомление о ошибке не будет автоматически убираться с экрана, а пользователь сам может его убрать нажатием на соответствующую кнопку на уведомлении. Тем самым у пользователя будет достаточно времени, чтобы прочитать ошибку.

qПри выборе файлов на компьютере, которые пользователь будет загружать для публикаций на сервер, добавлена фильтрация файлов по расширениям файлов, которые разрешены к загрузке на сайт, и доступны для выбора будут только те файлы, расширения которых разрешены. Тем самым пользователь может выбрать сразу только то, что разрешено, а запрещённые файлы будут недоступны к выбору. Это позволит пользователю сразу избегать ошибок о том, что файл некорректен и недопустим к загрузке.

qДля дополнительных полей публикаций с типом: "Текст", "Изображение" и "Галерея изображений" добавлена поддержка новой опции: "Использовать отложенную загрузку изображений". Тем самым вы для каждого поля отдельно можете настроить, необходимо ли или нет использовать для данного контента отложенную загрузку, и для каких-то полей включать ее, а для других выключать.

qВ настройки групп пользователей добавлена возможность переносить в другую группу пользователя при наборе определенного рейтинга комментариев.

qДля модуля "Фильтр по: IP, Логину или E-Mail" в админпанели DataLife Engine добавлена система поиска, которая позволяет быстро найти нужный забанненый аккаунт. Также поиск ведётся и по причине бана, тем самым можно также быстро отсортировать забаненных пользователей.

qДля модуля "Фильтр по: IP, Логину или E-Mail" в админпанели DataLife Engine добавлена разбивка на несколько страниц в случае, если содержится большое количество адресов. Тем самым навигация и управление заблокированными пользователями становиться проще при их большом количестве.

qВизуальный редактор TinyMCE был переведён на использование актуальной линейки 6.xx и обновлён до актуальной версии. Новая линейка более быстро и надёжно работает с современными браузерами, используя их внутренние API и функции для парсинга контента.

qПри использовании на сайте визуального редактора TinyMCE в качестве основного для публикаций добавлена возможность автоматически создавать при написании публикации, таблицу содержания публикации с ссылками на заголовки. Автоматическое содержание расставляется на основе наличия в тексте заголовков (тегов H2 - H6).

qДобавлен автоматических сброс кэша браузера для визуального редактора TinyMCE в случае обновления DataLife Engine на новую версию. Тем самым браузер будет всегда автоматически загружать актуальные копии JS файлов редактора, и пользователям не придётся самим обновлять кэш браузера при обновлениях сайта до более новых версий DataLife Engine.

qДоработано и улучшено оформление редактора TinyMCE на сайте, также была произведена более тесная интеграция со сменой тем оформления админпанели с редактором.

qДобавлена возможность вставки фрагментов исходных кодов в комментариях на сайте при использовании визуального редактора.

qПереработана стилистика отображения и управления загружаемыми изображениями в дополнительных полях в админпанели и на сайте. Теперь их отображение соответствует тому, что используется в загрузчике файлов.

qДля системы шаблонов добавлена поддержка вложенного подключения файлов шаблонов с использованием тега {include file=...} с полным сохранением поддержки тегов в подключаемых вложенных шаблонах. Ранее поддерживалось только однократное вложение, после чего поддержка тегов автоматически отключалась во избежание вложенного бесконечного зацикливания. Например, ранее вы могли в main.tpl подключить шаблон {include file="header.tpl"} сохранением тегов из шаблона main.tpl, но из шаблона header.tpl не могли подключить ещё один например menu.tpl с сохранением тегов из main.tpl. Теперь это возможно. Вы можете в main.tpl подключить header.tpl из header.tpl подключит menu.tpl, а из menu.tpl подключить category.tpl и т.д. и везде будет сохраняться работоспособность шаблонных тегов родительского шаблона. Во избежания ошибок в вёрстке и бесконечного зацикливания, уровень максимальной вложенности ограничен 200 подшаблонами, что достаточно для шаблонов любой сложности.

qДля системы шаблонов добавлена возможность подключения CSS и JS файлов с использованием тега {include file=...}. При этом подключаемые таким способом файлы будут подключаться в соответствующих секциях, где и другие служебные JS и CSS файлы Datalife Engine, независимо от расположения тегов {include ...} в шаблоне. Также если в настройках скрипта будет включено сжатие CSS и JS, то данные файлы будут также объединяться и сжиматься автоматически вместе с другими файлами. Пример использования данного тега в шаблоне: {include file="{THEME}/css/styles.css"} укажет что нужно подключить данный файл к основному блоку с CSS файлами. Также вы можете подключать таким способом и внешние файлы, которые находятся на других сайтах и доменах.

qДобавлены новые глобальные теги для шаблонов: [script] код [/script] в которых вы можете разместить использовать исполняемый jаvascript код. При этом данных код будет размещён непосредственно в исполняемом блоке других JS кодов DataLife Engine, будет запущен непосредственно после загрузки других JS скриптов, которые используются при подключении. Тем самым вы можете упорядочить все JS коды в шаблоне, стандартизировать их порядок исполнения, и в будущем избегать каких-либо конфликтов.

qДля шаблона вывода полной новости (fullstory.tpl) добавлена поддержка новых тегов: [allow-comments-subscribe] текст [/allow-comments-subscribe], которые выводят текст заключённый в них, в случае если пользователю разрешено подписываться на комментарии. Тем самым вы можете сделать оформление ссылки на подписку на комментарии в нужном вам блоке и скрывать его если подписка запрещена.

qДля шаблона добавления комментария (addcomments.tpl) добавлена поддержка новых тегов: [allow-comments-subscribe] текст [/allow-comments-subscribe], которые выводят текст заключённый в них, в случае если пользователю разрешено подписываться на комментарии. Тем самым вы можете сделать оформление ссылки на подписку на комментарии в нужном вам блоке и скрывать его если подписка запрещена.

qДля шаблона добавления комментария (addcomments.tpl) добавлена поддержка нового тега {comments-subscribe} который выводит чекбокс на подписку на комментарии в форме добавления комментария. Теперь данный чекбокс не будет выводится принудительно вместе с редактором, а вы его можете разместить в шаблоне в нужном вам блоке и в нужном вам визуальном оформлении.

qДля шаблонов вывода полной новости и добавления комментария (fullstory.tpl и addcomments.tpl) добавлена поддержка новых тегов [comments-unsubscribe] текст [/comments-unsubscribe] которые выводят текст заключенный в них в виде ссылки на отписку от комментариев к данной публикации. Тем самым пользователи могут отписаться только от одной конкретной новости на сайте, ранее для этого им нужно было отписываться от всех публикаций.

qДля шаблонов профиля пользователя (userinfo.tpl) добавлена поддержка новых тегов условий сравнения значений. Например, тег [if field = "значение"] текст [/if] выведет текст заключённых в них если значения поля равно указанному значению.

qДля модуля "Редиректы" добавлена поддержка осуществления редиректа на внешние сайты. Ранее редирект осуществлялся только однократно для пользователя, потом блокировался. Теперь при посещении ссылки на вашем сайте, с которой идёт редирект на внешний сайт, такой переход будет осуществляться всегда, независимо от того сколько раз посетитель посещает данную ссылку.

qВ настройки скрипта в админпанели добавлена возможность выставить разрешение или запрет на изменение порядка сортировки категорий, назначаемых для публикации. В случае если данная настройка включена, то категории будут в том порядке, в котором их выбрал пользователь при добавлении новости (первая выбранная категория будет первой, вторая второй и т.д.), а при отключённой настройки категории будут отсортированы в том порядке, в котором они отсортированы в разделе управления категориями, независимо от того как их добавляет автор при добавлении публикации.

qДобавлена возможность использовать теги вывода дополнительных полей публикаций [xfvalue_X] в качестве параметров для тега пользовательского вывода публикаций {custom ...}, в случае его использования в общем шаблоне main.tpl. Например, вы можете использовать такие конструкции как {custom tags="[xfvalue_test]" template="test"} для вывода публикаций по определенному тегу, заданному в дополнительном поле новости.

qДобавлена возможность добавить пользователя в список игнорируемых непосредственно при просмотре его профиля на сайте. Для этого для шаблона просмотра профиля пользователя (userinfo.tpl) добавлена поддержка тегов: [ignore] текст [/ignore] которые выводят текст заключённый в них в виде ссылки на добавление пользователя в список игнорируемых.

qДля шаблона вывода карточки пользователя (profile_popup.tpl) также добавлена поддержка новых тегов [ignore] текст [/ignore] которые выводят текст заключённый в них в виде ссылки на добавление пользователя в список игнорируемых.

qРасширены возможности по игнорированию пользователей на сайте. А именно добавлен запрет на отправку e-mail писем от пользователя, если он находится у получателя в списке игнорируемых. Тем самым если один пользователь добавил в игнорируемые другого, то он не будет получать не только персональные письма, но и e-mail письма через обратную связь на сайте.

qПереработана и улучшена система подсчёта просмотров публикации. Теперь просмотры публикации учитываются только от реальных посетителей, использующих браузер для просмотра публикации. Какие-либо роботы сканирующие страницы, боты, парсеры и т.д. учитываться не будут. Тем самым счётчик просмотров публикаций станет более логичным и объективным.

qВ настройки скрипта добавлена возможность указать по истечении какого периода времени нахождения пользователя на странице с полной новостью, необходимо засчитать просмотр страницы. В случае если пользователь находился на странице меньше указанного количества времени, просмотр от него засчитан не будет. Тем самым вы можете не учитывать посетителей, которые находятся на странице явно меньше, чем необходимо для прочтения ваших публикаций.

qВнесены изменения в работу настройки "Доверительные разделы" в настройках групп, для пользователей которым разрешено редактировать любые новости. Теперь если задан список доверительных разделов, то пользователь вообще не сможет редактировать данные публикации других пользователей даже если они находятся на модерации и не опубликованы. Тем самым вы можете создать отдельных своих модераторов непосредственно на определенные разделы сайта, и у них не будет доступа к другим разделам сайта.

qДобавлено отображение количества публикаций у категории в разделе управления категориями в панели управления, в случае если подсчёт количества публикаций для категорий был включён в настройках скрипта.

qДобавлены превентивные меры защиты от случайного удаления персональных сообщений, при осуществлении массовых действий над персональными сообщениями. Теперь в случае, если выбрано удаление сообщений, то данное действие будет необходимо подтвердить.

qДобавлены новые методы оптимизации подсчёта количества публикаций в категориях, если ранее такие подсчёты уже выполнялись другими функциями DLE, в результате чего в ряде случаев снижается количество обращений в базе данных и снижение нагрузки на сервер.

qДобавлено использование настроек скрипта: "Устанавливать параметр NOREFERRER для внешних ссылок" для публикаций и комментариев также и на ссылки, которые публикуются с использованием тега шифрования ссылок [lееch=...] ... [/lееch]. Ранее передача реферала блокировалась всегда для таких ссылок, теперь в зависимости от настроек скрипта в админпанели.

qДля публикаций, которые разбиты на несколько страниц, добавлено корректное формирование метатегов для социальных сетей, которые ведут данные страницы. Теперь каждая страница будет вести именно на ту страницу, которой она соответствует. Например, если пользователь будет делится именно второй страницей, то вести ссылка будет именно на вторую страницу а не на стартовую страницу публикации.

qДля публикаций, которые разбиты на несколько страниц, добавлено корректное формирование ссылок для микроразметки Schema.org. Теперь также каждая страница будет вести именно на ту страницу, которой она соответствует.

qПереработано формирование метатегов описания и ключевых слов, для публикаций, которые разбиты на несколько страниц. Теперь описание, которое было задано в админпанели при добавлении новости, будет использовано только для первой стартовой страницы, а для последующих страниц данные метатеги будут формироваться на основе контента именно данных страниц. Тем самым метатеги разных страниц не будут дублироваться, что положительно влияет на общее SEO вашего сайта.

qВнесены изменения в систему уведомления пользователей на e-mail о новых комментариях на сайте, в случае если они подписались на получение таких уведомлений. Теперь в случае, если на сайте используются древовидные комментарии, и это ответ на какой либо комментарий, то уведомление будет получать только автор комментария на который ответили (если он на такие уведомления подписан), другие же пользователи, подписанные к этой новости на комментарии его получать не будут, а будут получать уведомления только если это новый комментарий, не являющийся ответом на другой ранее добавленный комментарий. Тем самым отправка уведомлений будет более логична, пользователи не будут получать уведомления при комментариях, в ветке дискуссий, в которых они не участвуют.

q Внесены изменения во внутренние ссылки на различные разделы находящиеся внутри главного индексного файла карты сайта Sitemap. Ссылки теперь формируются таким образом что карты по иерархии всегда выше внутренних ссылок на страницах вашего сайта. Что теоретически более положительно влияет на SEO сайта. Это внутренняя оптимизация, никаких действий по изменению каких-либо ссылок на карты в поисковых системах производить не нужно.

qПереработана и улучшена система подсветки опубликованного исходного кода на сайте. Определение языков теперь более корректно, и исключает ошибки в определении при уже выбранном типе кода. Библиотека подсветки исходного кода также была обновлена до актуальной версии.

qПереработано и улучшено использование шрифтов панели управления, тем самым была улучшена читаемость текста при использовании различных устройств. Также улучшено и оптимизировано использование панели управления с использованием смартфонов. Размеры шрифта в панели управления были переведены на относительные масштабируемые значения, и привязаны теперь к настройкам операционной системы и браузера. Тем самым если вы увеличили размеры базового шрифта в настройках браузера, это автоматически будет работать и в панели управления на вашем сайте, что удобно для пользователей с ограниченными возможностями.

qВ связи с необходимости поддержки новых функций и возможностей, а также оптимизации работы скрипта на сервере для более высокой производительности, линейка PHP 7.xx объявлена устаревшей и рекомендуется обновить серверное ПО до версии 8.1 и выше.

qИсправлена проблема, связанная с некорректной валидностью текста при вставке видео и аудио контента с использованием стандартного плеера DLE в текст публикации.

qИсправлена проблема, при которой могли не работать некоторые функции сайта если разные группы имеют разные настройки для использования каптчи Google Recaptcha v.3

qИсправлена проблема, при которой в случае загрузки иконки для категории, непосредственно при создании категории, загрузка иконки происходила на внешний сервер, если он был подключён для других функций.

qИсправлена проблема, при которой отображалась опция публично доступного файла при загрузке изображений к комментариям.

qИсправлена проблема, при которой могла не обновляться информация о загруженных изображениях в общем загрузчике изображений и файлов, в случае если изображение загружался при прямом переносе в визуальный редактор TinyMCE.

qИсправлена проблема, при которой могли возникать ошибки при обновлении с очень старых версий DataLife Engine.

qИсправлена проблема, при которой отсутствовали дополнительные поля с типом "Дата и Время" при быстром редактировании публикаций на сайте

Список изменений относительно версии 15.1:

qДобавлено формирование карты сайта, предназначенной для сервиса Google Новости, данная карта формируется автоматически при формировании карты вашего сайта в соответствующем разделе панели управления.

qПолностью переосмыслен формат создания карты сайта Sitemap для поисковых систем Google и Yandex. Теперь для разных разделов сайта будет создан отдельный файл с картой, которые в свою очередь будут объединены в единый индексный файл. Например, карта статических страниц будет находится в одном отдельном файле, ссылки на категории в другом и т.д. При этом для поисковых систем вы указываете ссылку, как и ранее только одну на ваш сайт, например, http://вашсайт.ru/sitemap.xml и в ней уже будут автоматически объединены все созданные карты вашего сайта.

qВ админпанели, в разделе управления картой сайта, добавлена возможность сохранения установленных настроек карты для их дальнейшего использования. Например, вы можете один раз настроить нужные приоритеты и сохранить их, и они будут использоваться всегда, в том числе и при автоматическом создании карты через крон сервера.

qПри формировании карты сайта добавлена возможность добавления в неё параметра вероятной частоты изменения страниц. Вы можете задать для страниц с публикациями, категориями или статических страниц не только приоритет, но и как часто ожидается изменение подобных страниц, что позволяет более оптимизированно подходить к поисковой индексации страниц вашего сайта.

qПри формировании карты сайта добавлена возможность установки количества ссылок на публикации в одном файле. Вы можете назначить сколько ссылок максимально нужно помещать в один файл и в случае, если ссылок к карте больше, то она будет разбита на большее количество файлов. Уменьшение количества ссылок снижает расход памяти на создание карты сайта. Вы можете поместить не более 40 000 ссылок в один файл, чтобы не превысить ограничения уже со стороны поисковых систем.

q При формировании карты сайта, дата последнего обновления страниц для новостей теперь задаётся в полном формате, когда было последнее обновление, включая также время и часовой пояс, а не только день последнего обновления. Что также положительно сказывается на поисковой индексации сайта и более быстрого обновления поисковыми системами.

qВ админпанели в разделе управления изображениями, добавлено использование постраничной навигации при наличии в папке большого количества изображений. Тем самым существенно ускоряется загрузка страницы управления изображениями и улучшаются возможности управления изображениями.

qДобавлена система поиска для плагинов в разделе управления плагинами в панели управления. Вы можете быстро найти нужный вам плагин по какому-либо ключевому значению. Поиск при этом ведётся по всей системе плагинов и значениям. Вы можете задать например, часть названия или описания, либо можете также задать имя или часть имени изменяемого файла или часть кода в файле, поиск будет осуществлён везде и вам будут показан список плагинов, подпадающих под поисковый запрос.

qВ настройки скрипта в админпанели, добавлена возможность, устанавливать, где использовать общую папку для изображений, в случае если используется также и внешнее хранилище. Вы можете задать отдельно нужно ли использовать общую папку с внешнего хранилища или с локального.

qВ случае если для публикации или комментария установлено ограничение на количество загружаемых изображений, то при загрузке изображений, для пользователя добавлен удобный вывод информации сколько изображений всего он может загрузить, сколько уже загрузил для публикации и какой лимит ещё остался. Тем самым пользователь понимает ещё до загрузки сколько он может ещё загружать для публикации.

qВ случае если для публикации установлено ограничение на количество загружаемых файлов, то при загрузке, для пользователя добавлен удобный вывод информации сколько файлов всего он может загрузить, сколько уже загрузил для публикации и какой лимит ещё остался. Тем самым пользователь понимает ещё до загрузки сколько он может ещё загружать для публикации.

qДля массовых действий над публикациями, в разделе редактирования публикаций, добавлена возможность назначать дополнительно новые ключевые слова для облака тегов к уже существующим. Тем самым вы можете на выбор либо полностью массово переназначить все слова, либо просто добавить новые дополнительные к уже существующим у публикаций.

qВ админпанели в разделе "Управление облаком тегов" добавлена возможность указания сортировки выводимых тегов. Вы можете сортировать вывод как по имени тега в алфавитном порядке, так и по количеству публикаций. При этом сортировку можно указать как по убыванию, так и по возрастанию. Тем самым вы можете быстро находить нужные теги для редактирования или удаления. Например, вывести сначала самые непопулярные теги или наоборот часто используемые и т.д.

qДобавлена поддержка структурированных данных schema.org для статических страниц на сайте.

qВ настройки категорий в админпанели добавлена возможность указывать для каждой категории при необходимости какой тип структурированных данных schema.org использовать при показе публикаций из данной категории. Вы можете задать как глобальные настройки, так и поменять их отдельно для нужных категорий. Например, в одних категориях могут быть новости, в других программное обеспечение или книги и т.д.

qДобавлена возможность указывать в настройках скрипта, производить или нет транслитерацию символов при формировании URL публикаций, категорий, и статических страниц. Например, при включении данной опции в настройках скрипта, при формировании URL публикации, она будет иметь вид: http://yoursite.com/id-imja-novosti.html, а при отключении будет иметь вид: http://yoursite.com/id-имя-новости.html, также по аналогии и при формировании категорий и статических страниц. Данное нововведение будет особенно полезно для SEO оптимизации сайтов на национальных языках, отличных от английского.

qДля протокола IndexNow который используется для автоматического уведомления поисковых систем добавлена поддержка уведомлений при добавлении и редактировании статических страниц на сайте.

qДобавлена возможность вставки постов из Телеграмм каналов в ваши публикации на сайте с использованием тега [mediа=....]. В данном теге указывается просто скопированная ссылка из браузера, а далее весь необходимый код DataLife Engine сформирует автоматически. Например, для вставки поста вы можете использовать: [media=https://t.me/vamtlgrm/185]

qДобавлена поддержка сервиса капчи hCaptcha (hcaptcha.com) для проверки является ли посетитель ботом или нет. Включается данный сервис в настройках скрипта в админпанели, также как и Recaptcha и действует на все разделы, где включена и требуется проверка.

qДобавлена поддержка нового глобального тега {page-count} который выводит номер страницы, на котором находится пользователь. Данный тег является глобальным, и может использоваться в любых tpl файлах шаблона. Данный тег будет особенно полезен в использовании различных рекламных кодах, например от яндекса, где можно указать дополнительным параметров номер страницы, где находится посетитель сайта, для более корректного рекламного показа на сайте.

qДобавлена поддержка отложенной загрузки изображений при выводе контента публикаций из дополнительных полей непосредственно в главном шаблоне main.tpl

qДобавлено формирование ссылок из облака тегов при формировании карты сайта. В карту сайта помимо ссылок на категории, публикации и статические страницы, теперь также будут добавляться и ссылки на все слова, существующие в облаке тегов.

qДобавлена поддержка уведомления об изменениях в карте сайта для поисковой системы Яндекс.

qВнесены изменения в уведомления поисковых систем о обновлении карты сайта. Ссылки на уведомления поисковых систем были обновлены на актуальные.

qДобавлена возможность использования символа: "|" при написании описаний к изображениям в дополнительных полях публикаций. Ранее данный символ был зарезервированным служебным символом и не мог использоваться в описании к изображениям.

qПоказ публикаций по облаку тегов стал полностью регистронезависимым, например поиск по "Новости" и "новости" будет одинаковым независимо от регистра в URL. При этом во избежание дублей в поисковых системах, DataLife Engine формирует ссылки с использованием букв только нижнего регистра, а при использовании другого регистра контроль неверных ЧПУ будет производить 301 редирект на корректный единый адрес.

qПоказ публикаций при использовании дополнительных полей с типом "перекрёстные ссылки" также стал полностью регистронезависимым, например поиск по "Новости" и "новости" будет одинаковым независимо от регистра в URL. При этом во избежание дублей в поисковых системах, DataLife Engine формирует ссылки с использованием букв только нижнего регистра, а при использовании другого регистра контроль неверных ЧПУ будет производить 301 редирект на корректный единый адрес.

qДля шаблонов вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl) добавлена поддержка новых тегов для вывода данных из дополнительных полей с типом галерея изображений: [xfgiven_X image="NR"] текст [/xfgiven_X image="NR"], где X это имя дополнительного поля, а NR это номер изображения, которые выводят текст заключённый в них если изображение с указанным номером присутствует и загружено в дополнительном поле. А также добавлена поддержка противоположных тегов: [xfnotgiven_X image="NR"] Текст [/xfnotgiven_X image="NR"], которые выводят текст заключённый в них если изображение с указанным номером отсутствует в дополнительном поле. Тем самым вы можете очень гибко организовывать формат и оформление загруженных галерей для публикаций.

qВ настройки скрипта в админпанели добавлена возможность указать значение Score при использовании reCAPTCHA v.3. Данное значение используется для проверки вероятности с которой пользователь может являться роботом, при использовании сервиса reCAPTCHA v.3. Данное поле может принимать значение от 0 до 1, где например, 0.1 означает что это скорее всего робот, а 0.9 скорее всего человек. Так на разных сайтах степень вероятности может отличаться, вы можете назначить вероятность на основе статистики Recaptcha непосредственно для вашего сайта. Рекомендуемое значение по умолчанию: 0.5.

qПереработана и улучшена проверка с использованием Recaptcha v.3 является ли посетитель ботом или нет. Уменьшено количество ложных блокировок, особенно если человек долго пишет текст или долго заполняет формы.

qПереработана и улучшена система защиты от повторной отправки данных при добавлении публикации на сайт. Были исключены срабатывания защиты при открытии большого количества вкладок, даже в интервале менее секунды, а также были устранены срабатывания защиты в случае проблем в работе PHP сессий, например если они истекли если пользователь достаточно долго пишет публикацию в браузере.

qДля статических страниц существенно увеличен лимит на имя файла шаблона, который может назначаться для использования этой страницей. Данное нововведение особенно полезно если в структуре шаблона используются вложенные папки, и теперь имя назначаемого шаблона не будет обрезаться.

qПри загрузке нового плагина на сайт в админпанели скрипта, в случае если в файле плагина отсутствует информация о том какая из секций должна быть включена или отключена (например, старые плагины, созданные на старых версиях скрипта), то данные секции будут по умолчанию включены. Ранее при добавлении таких плагинов на сайт все действия по умолчанию были выключены.

qВ настройки скрипта в админпанели, добавлена настройка указания параметров, по которым необходимо обрезать оригинальное изображение, если заданы ее максимальные размеры, и при этом указано только значение одной стороны. Вы можете выбрать "По наибольшей стороне", "По ширине" и "По высоте".

qДля модуля управления комментариями, ожидающими модерации, добавлена поддержка разбивки на несколько страниц, при наличии большого количества комментариев. Тем самым упрощается загрузка списка комментариев и их модерация при большом количестве комментариев на модерации.

qДля протокола IndexNow который используется для автоматического уведомления поисковых систем о новых публикациях, добавлено использование единой точки уведомления, которое в свою очередь уведомит все остальные поисковые системы, подключённые к данному протоколу. Использование единой точки, позволяет сократить время на уведомление всех систем, и как следствие более быстрое сохранение новости.

qДля протокола IndexNow, в случае возникновения какой-либо ошибки при уведомлении поисковых систем, вместо кода ошибки, выводится сразу текстовая расшифровка данной ошибки, которая позволяет сразу установить причину проблемы, вместо необходимости читать документацию поисковиков, на предмет того, что означает данный код ошибки.

qПри формировании файла для RSS экспорта, добавлено корректное удаление неподдерживаемого контента, в случаях, когда это необходимо. Например, описания картинок используемых в <figcaption> при экспорте в Яндкекс Новости.

qВнесены изменения в работу функции включения и отключения комментариев для каждой публикации в отдельности. В случае если отключаются комментарии для публикации, но при этом у данной публикации уже есть добавленные комментарии, то уже существующие комментарии будут продолжать отображаться на сайте (ранее они выключались и не отображались), но при этом будет запрещено добавление новых комментариев, а также ответы на существующие комментарии.

qВнесены изменения в работу автоматического уведомления поисковых систем о появлении нового контента, для более корректного распознавания ошибок пользователей скрипта, и автоматической их коррекции, которые могли допускать написание имён доменов своих сайтов в настройках скрипта с нарушением требований стандартов URL, например, используя разный регистр букв, что в свою очередь приводило к тому, что поисковые системы не принимали сайты.

qПереработано поведение динамической загрузки комментариев при показе полной новости по мере просмотра комментариев, в случае если порядок сортировки комментариев выбран по убыванию (т.е. если новые комментарии показываются первыми). Ранее комментарии некорректно подгружались, только при прокрутке наверх к началу комментариев. Теперь же они подгружаются корректно при прокрутке страницы вниз.

qОбновлена до актуальной версии библиотека Jquery UI, при использовании на сайте Jquery 3.xx. Был исправлен ряд ошибок в работе данной библиотеке.

qОбновлена типографская обработка текста. Был исправлен ряд ошибок и улучшена расстановка кавычек для текста.

qГрафический драйвер для обработки изображений был обновлён до актуальной версии, в котором была улучшена поддержка PHP 8.1 и выше.

qВизуальный редактор TinyMCE был обновлён до актуальной версии.

qВидеоплеер DLE был обновлён до актуальной версии

qИсправлена проблема, при которой при выборе любого S3 совместимого хранилища не отображались настройки: "Путь к файлам на внешнем сервере" и "HTTP адрес для внешнего хранилища".

qИсправлена проблема, при которой в некоторых случаях могла происходить некорректная обработка содержимого тега [media=...].

qИсправлена проблема, при которой при добавлении первой закладки на сайте, в профиле отображалось что добавлено уже две публикации в закладки.

qИсправлена проблема, при которой могла не работать вставка данных из некоторых сервисов с использованием тега [media=...].

qИсправлена проблема, при которой дублировались метатеги OpenGraph для статических страниц.

qИсправлена проблема, при которой при использовании редактора TinyMCE вставлялись дополнительные теги <р></р> в конец контента в случае если при редактировании исходного кода, курсор ставился в самый конец текста.

Список изменений относительно версии 15.0:

qДобавлена поддержка протокола IndexNow. Данный протокол позволяет мгновенно автоматически уведомлять поисковые системы об изменениях на сайте: появлении новых страниц, обновлении или удалении уже проиндексированных страниц. Включается поддержка данного обмена данными в настройках скрипта. После ее включения и настройки, DataLife Engine будет автоматически сообщать поисковым системам адреса страниц с вашими вновь добавленными новостями, а также при редактировании новостей, будет уведомлять о изменении контента.

qДобавлена автоматическая разметка структурированных данных Schema.org для публикаций на сайте. В настройках скрипта в админпанели вы можете задать тип ваших публикаций, и добавить ряд опций для вашего сайта, после чего для страниц просмотра полных новостей, DataLife Engine будет автоматически формировать микроразметку Schema.org в формате JSON-LD. Что улучшает индексацию вашего сайта и взаимодействие сайта с другими ресурсами.

q Микроразметка Schema.org для "Хлебных крошек (BreadСrumb)" была переведена на формат вывода JSON-LD и объединена в единое целое совместно с другой общей микроразметкой.

qМикроразметка Schema.org для "Хлебных крошек (BreadСrumb)" также была улучшена и дополнена. Теперь в неё входит полное дерево страниц, включая также и текущую страницу где находится пользователь, например, навигация по страницам и ссылка на полную новость и так далее.

qМикроразметка Schema.org для рейтинга с типом "оценка" также была переведена на формат вывода JSON-LD, и публикуется совместно с другими структурированными данными. При этом она применяется не ко всем типам публикаций, а только к тем, для которых она допустима. Тем самым поисковые системы не будут выводит уведомления о недопустимости применения к структуре данных для данного типа публикаций.

qДля навигации "Хлебные крошки (BreadСrumb)", при просмотре публикаций по ключевым словам, добавлено использование также ссылок непосредственно для просматриваемых ключевых слов, в случае перехода пользователем на следующие страницы. Тем самым он может вернуться в начало на непосредственно просматриваемое слово в самое начало, кликнув на слово в ссылке навигации.

qПереработано и улучшено автоматическое формирование метатегов страниц сайта. Добавлено автоматическое формирование метатегов: twitter:card, twitter:title, twitter:url, twitter:description для более улучшенной интеграции сайта с Твиттером, а также добавлен вывод метатегов для Open Graph и Твиттера на все страницы сайта, а не только при выводе полных новостей.

qДля системы плагинов добавлена возможность включения и отключения каждого отдельного действия в плагине. Тем самым вы можете отключить какое-либо конкретное действие, без отключения самого плагина.

qДля каждого действия плагина добавлена возможность указывать для какой версии DLE применять данное конкретное действие. Тем самым один плагин может быть разработан для нескольких версий DLE одновременно и для разных версий DLE он будет выполнять разные действия.

qВ системе управления плагинами, добавлена система подсветки для каждого назначенного действия, при редактировании плагина. Если блок подсвечивается зелёным, то это значит, что его код работает корректно, если блок отключён, то он подсвечен серым, если блок для другой версии скрипта, то подсвечивается оранжевым, а если данный блок содержит ошибку, то он подсвечен красным и дополнительно отображается текст ошибки. Тем самым если плагин содержит много разного кода, вы можете быстро ориентироваться, где находится тот или иной проблемный блок плагина.

qДля более удобной работы с системой плагинов в админпанели, была добавлена новая автоматическая система сворачивания блоков в разделе управления действий над файлами. В случае если плагин содержит редактирование нескольких файлов, то список файлов будет отображён в свёрнутом виде, а блок, в котором, например, произошла ошибка, будет автоматически подсвечен соответствующим образом. Тем самым вы можете быстро перейти в нужный блок. При переходе в блок управления конкретным файлом, в случае если в данном блоке есть ошибки в каком-либо действии, все успешные действия будут автоматически свёрнуты, а блок с ошибкой будет развернут и подсвечен соответствующим образом, тем самым вы можете быстро увидеть проблемный блок. Тем самым управление большими плагинами стало более удобным и интуитивном понятным. А если блок действий над файлом не содержит ошибок, то все блоки будут развёрнуты и вы можете быстро визуально найти нужный код. Также все блоки, как управления файлами, так и управления действиями вы можете в любой момент сворачивать и разворачивать по своему усмотрению.

qДобавлена возможность использовать в качестве внешнего хранилища для загружаемых изображений и файлов, любое внешние хранилище, совместимое с протоколом S3. Для этого в настройки скрипта добавлена возможность указания точки соединения с внешним хранилищем. Тем самым вы можете использовать множество различных сервисов, например Digital Ocean и многие другие.

qДобавлена возможность загружать публичные файлы с использованием DataLife Engine на сервер или внешнее хранилище. Разница между публичными и другими файлами, загружаемыми через DLE, состоит в том что публичные файлы загружаются в отдельную папку public_files и доступ к ним и ссылки на скачивания даются прямыми обычными ссылками, без использования тегов [attachment=....] и пользователь скачивает их напрямую с сервера с использованием браузера минуя DLE и другие скрипты. Кому разрешено загружать на сервер публичные файлы, а кому запрещено вы можете гибко настроить в настройках групп пользователей. Также пользователю при загрузке файлов доступен выбор, загрузить файл как публичный, либо загрузить файл как обычный, скачивание которого будет доступно только через DLE.

qДля дополнительных полей, имеющих тип "Изображение" или "Галерея изображений", добавлена новая опция: "Использовать изображение в разметке Open Graph". Тем самым вы можете напрямую указать из какого поля брать ссылку на изображение при формировании метатегов. Если явное указание отсутствует, то как и ранее изображение будет получено автоматически из всех полей. Если данную опцию имеют несколько полей, то изображение будет взято из первого, которое присутствует в новости и заполнено.

qДля дополнительных полей, имеющих тип "Загружаемый файл", добавлена новая опция, позволяющая установить, является ли загружаемый файл публичным или нет. Если файл публичный, то будет использоваться прямая ссылка URL на скачивание файла, а сам файл будет загружен в соответствующую папку. Если файл не публичный, то будет использоваться как обычно тег [attachment=...]

qДля общей папки загруженных изображений добавлена возможность использования уменьшенных и средних копий изображений. Для этого в папке, где находится оригинальное изображение, вы можете создать подпапки "thumbs" и/или "medium" и разместить там нужные уменьшенные копии с аналогичным названием файлов изображений.

qДля дополнительных полей публикаций добавлена новая опция "Разрешить вставку тега вывода данного поля в текст новостей". При включении данной опции у поля, тег вывода данного поля можно будет использовать не только в шаблонах, но и непосредственно в текстах публикаций, которые вы пишите в админпанели. Тем самым вы можете вставить контент данного поля, в любое место в тексте вашей публикации, а не только в определённое место в шаблоне.

q Добавлена поддержка загрузки изображений в формате AVIF. Для работы с данным форматом понадобится PHP версии не ниже 8.1 с библиотекой GD2 актуальной версии, либо Imagick собранный также с поддержкой формата AVIF.

qДобавлена поддержка загрузки изображений в формате HEIF. Для работы с данным форматом понадобится PHP версии не ниже 8.1 с библиотекой GD2 актуальной версии, либо Imagick собранный также с поддержкой формата HEIF.

qДобавлена поддержка выбора и загрузки изображений с расширением BMP для дополнительных полей с типом изображение и галерея изображений, а также при переносе таких изображений непосредственно в редактор методом Drag And Drop.

qДобавлена возможность при работе с внешними хранилищами, самостоятельно загружать на используемые хранилища файлы, и указывать данные файлы в менеджере загрузки файлов. Ранее данная возможность была только при работе с локальным хранилищем, теперь это доступно и для внешних. Данное нововведение полезно при работе с очень большими файлами, когда существуют серверные ограничения на работу вашего PHP интерпретатора.

qДля менеджера загрузки изображений и файлов к публикациям добавлен автоматический показ полного имени для загруженных изображений и файлов, при наведении курсора на имя файла в карточке. Для изображений выводится полное имя без сокращений и с префиксом если он существует, а для файлов дополнительно также отображается и их ID. Данное нововведение полезно для быстрой идентификации загруженного файла если используются длинные или одинаковые имена у файлов.

qДля менеджера загрузки изображений и файлов к публикациям добавлена возможность не вставлять, а скопировать ссылку на изображение или для вставки файла в буфер обмена браузера. Данная возможность будет полезна, когда файл нужно не вставлять, а скопировать для вставки в другое поле, например, для вставки в дополнительное поле.

qДля шаблонов вывода публикаций (shortstory.tpl и fullstory.tpl) для дополнительных полей имеющих тип "Изображение", добавлена поддержка нового тега [xfvalue_image_description_X] который выводит только описание для загруженного изображения, где "х" это имя дополнительного поля. Тем самым вы можете совместно с другими тегами, сделать полностью своё оформление загруженного изображения.

qДля шаблонов вывода публикаций (shortstory.tpl и fullstory.tpl) для дополнительных полей имеющих тип "Галерея изображений", добавлена поддержка новых тегов: [xfvalue_X image-url="Nr"] который выводит только URL выбранного изображения из галереи изображений, [xfvalue_X image-thumb-url="Nr"] который выводит только URL уменьшенной копии выбранного изображения из галереи изображений, [xfvalue_X image-description="Nr"] который выводит только описание выбранного изображения из галереи изображений. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи. Например, при использовании [xfvalue_test image-description="2"] будет выведено описание изображения номер два, загруженного в дополнительное поле с именем "test". Тем самым вы можете сделать полностью своё собственное оформление галереи изображений на своём сайте.

qДобавлена возможность вставки воспроизведения аудио файлов пользователями при написании комментариев. Включается и отключается разрешение на вставку данного контента в настройках групп, также как и для вставки видео файлов.

qДобавлена поддержка в публикациях новых HTML тегов: "svg", "path", "symbol", "use". Тем самым вы можете вставлять векторные изображения в публикации, например иконки и прочее.

qДля системы жалоб, отправляемых посетителями сайта, добавлено ограничение на текст отправляемой жалобы в 2 000 символов. Данное ограничение добавлено во избежание большого контента на странице просмотра жалоб администратором сайта. В случае если текст превышает лимит, пользователю будет выведено соответствующее уведомление и возможность уменьшить текст своей жалобы.

qДобавлены системы превентивной защиты от повторного добавления одинаковых публикаций в админпанели и на сайте. Данные системы защиты срабатывают тогда, когда пользователь либо дважды нажал на кнопку добавить публикацию в браузере, например при медленном интернет-соединении, или например, случайно подтвердил перезагрузку страницы после отправки в браузере, и тем самым одни и те же данные отправляются на сервер несколько раз, и публикации дублируются.

qДобавлены системы превентивной защиты от повторного добавления одинаковых персональных сообщений на сайте. Данные системы защиты срабатывают тогда, когда пользователь либо дважды нажал на кнопку отправить сообщение в браузере, например, при медленном интернет-соединении, или например, случайно подтвердил перезагрузку страницы после отправки в браузере, и тем самым одни и те же данные отправляются на сервер несколько раз, и сообщения дублируются.

qПереработано и улучшено отображение выделенного контента при отправке жалоб на синтаксические ошибки, отправляемые пользователями с сайта. Контент, содержащийся в тегах исходного кода или содержащий кавычки и другие HTML сущности, отображается теперь корректно, при просмотре жалобы администратором сайта.

qДобавлено автоматические скрытие ссылок на привязку аккаунта из какой-либо социальной сети в профиле пользователя, если он уже привязал данную социальную сеть к своему аккаунту в своём профиле.

qДля шаблона профиля пользователя (userinfo.tpl) добавлена поддержка следующих тегов: [attached-vk] текст [/attached-vk], [attached-odnoklassniki] текст [/attached-odnoklassniki], [attached-facebook] текст [/attached-facebook], [attached-google] текст [/attached-google], [attached-mailru] текст [/attached-mailru], [attached-yandex] текст [/attached-yandex] которые выводят текст заключенный в них в случае если аккаунт пользователя привязан к указанным социальным сетям. Данные теги полезны для оформления собственных блоков в шаблоне, для отвязки аккаунтов привязанных социальных сетей.

qДля шаблона профиля пользователя (userinfo.tpl) добавлена поддержка следующих тегов: [detach-vk] текст [/detach-vk], [detach-odnoklassniki] текст [/detach-odnoklassniki], [detach-facebook] текст [/detach-facebook], [detach-google] текст [/detach-google], [detach-mailru] текст [/detach-mailru], [detach-yandex] текст [/detach-yandex] которые выводят текст заключённый в них в виде ссылки на отвязку аккаунта от указанной социальной сети, случае если аккаунт пользователя привязан к ней. Данные теги полезны для оформления собственных ссылок в шаблоне, для отвязки аккаунтов привязанных социальных сетей.

qДобавлена поддержка вывода RSS публикаций по главному потоку сайта вашсайт.com/rss.xml в случае если для главной вашего сайта не используется вывод публикаций, а включён вывод статической страницы с именем main в настройках скрипта.

qДля редактора TinyMCE добавлена возможность использовать заголовка "Caption" для вставляемых в публикацию изображений.

qДобавлено ограничение на добавление в закладки, публикаций, находящихся в данный момент ещё на модерации.

qДобавлен автоматический контроль валидности HTML кода, при использовании вставки видео, аудио и медиа контента с использованием BB тегов, таких как [vidеo=...], [аudio=...] и [mеdia=...]. В случае если данные теги находятся в тегах HTML тегах "p", то данный тег будет заменён автоматически на тег "div", в случае если контент, формируемый BB тегами, также содержит теги "div". Так как блочные теги "div" согласно HTML стандартам не могут находится в тегах "p". Тем самым публикуемый текст будет проходить валидность, а выставленное форматирование, корректно сохраняться.

qУлучшена система наложения водяных знаков с типом "текст", при использовании библиотеки GD2 на старых версиях PHP. А также снижен расход памяти при использовании данного типа водяного знака.

qУлучшены алгоритмы типографской обработки текста и устранён ряд ошибок в ее работе.

qУлучшены алгоритмы вставки загруженных изображений и файлов в тексты публикаций при работе с редактором BBCODES. При массовой вставке только файлов без изображений теги вставляются в одну строчку с разделением пробелом, а также не вставляются теги выравнивания текста.

qВнутренняя JS функция ShowLoading, которая выводит информацию что происходит AJAX загрузка контента, получила полноценную работу как с использованием анимированных иконок, так и с использованием передачи текста сообщения. Данное нововведение будет в основном полезно для разработчиков плагинов, которые хотят передавать свой контент в данную функцию. А также вы можете указывать расположение данного всплывающего окна, для этого добавлены два дополнительных параметра для нее, указывающих смещение по оси X и по оси Y. Для смешения по оси X принимает значения "left", "right" и "center", а смещение по оси Y может принимать значения "top", "bottom", "center". Например вызов функции ShowLoading("Загрузка контента", "right", 'top'); выведет уведомление наверху справа. Новые параметры являются дополнительными и необязательными, по умолчанию уведомление выводится по центру.

qУбрана поддержка BB тегов, предназначенных для вставки флэш роликов в текст новости, в связи с неактуальностью данной устаревшей технологии и отсутствии поддержки со стороны браузеров.

qВнесены изменения в контроль минимальной длины комментария, в случае если текст меньше указанной в настройке минимальной длины комментария, но при этом в комментарий вставлен медиа контент, такой как видео, аудио или вставка из других ресурсов, если это разрешено для комментариев, то такой контент будет учтён. Тем самым пользователь может вставить, например, видео контент в комментарий, без необходимости написания дополнительного текста.

qОбновлён визуальный редактор TinyMCE до актуальной версии.

qОбновлён до актуальной версии парсер входящего текста DLE (HTML Purifier).

qДобавлена поддержка новой линейки PHP 8.1.x

qИсправлена проблема, при которой в ряде случаев после добавления или редактирования комментариев на сайте, мог не инициализироваться автоматически видео плеер, если в тексте комментария присутствовало видео.

qИсправлена проблема, при которой в случае выполнения массовых действий над статическими страницами, происходил возврат к списку новостей, а не к списку статических страниц.

qИсправлена проблема, при которой неверно вставлялись ссылки на воспроизведение загруженных аудио и видеофайлов, при использовании внешних хранилищ для загружаемых через DataLife Engine файлов.

qИсправлена проблема, при которой при выборе шаблона в разделе редактирования шаблонов в админпанели, назначенный язык для одного шаблона, назначался автоматически и другому шаблону при смене шаблона для редактирования.

qИсправлена проблема, при которой нельзя было повторно авторизоваться в админпанели если был включён таймаут неактивности в админпанели и одновременно включена авторизация по e-mail а не по логину.

qИсправлена проблема, при которой тег {%unsubscribe%} в e-mail сообщениях с сайта выводил некорректную ссылку на профиль пользователя в случае, если на сайте была отключена поддержка ЧПУ.

qИсправлена проблема, при которой могло не работать на некоторых серверах кеширование с использованием библиотеки PHP Memcache.

qИсправлена проблема, при которой не устанавливалась по умолчанию вставка средней копии изображения в некоторых случаях, если отсутствует загруженная маленькая копия изображения при этом.

qИсправлена проблема, при которой неверно формировались значения шаблонного тега {category-url} в случае если был отключен ЧПУ в настройках скрипта и новость при этом была опубликована в нескольких категориях.

Список изменений относительно версии 14.3:

qДобавлена полностью новая система управления загружаемыми на сервер файлами и изображениями. В результате чего была добавлена поддержка внешних хранилищ для загружаемых на сайт изображений и файлов. В настройках скрипта в админпанели вы можете указать, где будут сохраняться загружаемые файлы. Вы можете сохранять файлы локально, в пределах своего сервера, либо выбрать внешний FTP или SFTP сервер. А также для выбора доступны облачные сервисы, такие как Amazon S3 и Яндекс Облако. Новая система хранения и управления загружаемыми файлами построена на унифированной файловой системе Flysystem 2.0, благодаря чему вы сможете через систему плагинов, очень легко добавить поддержку своего какого либо иного внешнего хранилища, без необходимости правки множества файлов DataLife Engine. Добавив новых адаптер, DataLife Engine сможет автоматически использовать его везде для своей работы.

q Полностью переработан менеджер загрузки изображений и файлов к публикациям. Новый менеджер обеспечивает более комфортный просмотр загруженных изображений, размеры превью были увеличены, а выбор файлов для вставки более комфортным. Удалить нужный файл или изображение стало намного проще. Повторное открытие менеджера осуществляется мгновенно, т.к. он загружается на страницу один раз и сохраняет своё состояние, а все действия осуществляются с использованием AJAX технологии. Выбранные вами опции для загрузки изображений будут сохраняться до тех пор, пока вы работаете с публикацией и не будут обнуляться при каждом открытии менеджера загрузки изображений.

qДля менеджера загрузок изображений добавлена возможность предосмотра полных изображений непосредственно в менеджере загрузок.

qОбщая папка, которая использовалась в менеджере загрузок изображений к публикациям, была перемещена в отдельную папку "shared", располагающуюся в /uploads/ тем самым общие картинки теперь располагаются в отдельной папке. Также дополнительно в этой общей папке вы можете создавать свои собственные подпапки любой вложенности, и непосредственно в менеджере загрузок, переходить в эти папки и вставлять изображения в публикации. Тем самым вы можете удобно создать и расположить свою библиотеку общих изображений.

qВ админпанели в разделе управления загруженными изображениями добавлена возможность переключения каким хранилищем вы хотите управлять. Вы можете загружать по своему выбору изображения как на локальное, так и на внешнее хранилище.

qВ админпанели в разделе управления загруженными изображениями добавлена возможность создавать и удалять папки и подпапки к ним. Тем самым вы можете организовывать структуру своих изображений непосредственно в админпанели DataLife Engine, без необходимости заходить по FTP или другими средствами на ваше хранилище файлов.

qВ настройки скрипта в админпанели добавлена возможность включения и отключения загрузки изображений к публикациям на внешнее хранилище. Тем самым вы можете распределять загрузку изображений для того или иного контента по разным местам хранения. И не все сохранять изображения к публикациям на внешнее хранилище если оно включено.

qВ настройки скрипта в админпанели добавлена возможность включения и отключения загрузки изображений к комментариям на внешнее хранилище. Тем самым вы можете включить загрузку на внешнее хранилище для изображений к новостям, а для изображений к комментариям отключить. И не все сохранять изображения к комментариям на внешнее хранилище если оно включено.

qВ настройки скрипта в админпанели добавлена возможность включения и отключения загрузки изображений к статическим страницам на внешнее хранилище. Тем самым вы можете включить загрузку на внешнее хранилище для изображений к новостям, а для изображений для статических страниц отключить. И не все сохранять изображения для статических страниц на внешнее хранилище если оно включено.

qВ настройки скрипта в админпанели добавлена возможность включения и отключения загрузки файлов, предназначенных для скачивания, на внешнее хранилище. Тем самым вы можете включить загрузку на внешнее хранилище для изображений, а для других файлов отключить. И не все сохранять файлы для скачивания на внешнее хранилище если оно включено.

qВ настройки скрипта в админпанели добавлена возможность включения и отключения загрузки аватаров пользователей на внешнее хранилище. Тем самым вы можете включить загрузку на внешнее хранилище для изображений, а аватаров пользователей отключить или наоборот.

q При скачивании файлов, загруженных на сервер через DataLife Engine файлов добавлена автоматическое определение MIME типов файлов, для всех типов файлов. Что позволяет обеспечивать корректное скачивание и открытие различных файлов на разных типах устройств, и как следствие корректное реагирование устройств на поддерживаемые им типы файлов.

qДобавлена поддержка библиотеки PHP Imagick для обработки загружаемых изображений на сервер. Вы можете в настройках скрипта в админпанели выбрать, что вы хотите использовать Imagick или GD2, либо предоставить DataLife Engine автоматически выбирать. Отличий между GD2 и Imagick немного, однако Imagick позволяет производить некоторые операции над картинками быстрее и создавать более качественные уменьшенные копии, а также потребляет меньше памяти при обработке больших изображений.

qДобавлена возможность автоматического перекодирования всех загружаемых на сервер изображений в формат WebP. Включается и отключается данная возможность, в настройках скрипта в админпанели. При включении данной настройки, все изображения загружаемые на сервер, независимо от их формата и расширения, будут автоматически перекодированы в формат изображения WebP. Данный формат является прогрессивным и позволяет создавать более качественные изображения при их меньшем размере. Однако показ изображений в данном формате требует наличия у пользователей современного браузера.

qДобавлена поддержка загрузки нового формата изображений "BMP". При этом изображения в данном формате будут автоматически сконвертированы в формат JPG для более снижения размера файла и более быстрой загрузки страниц сайта.

qПри загрузке изображений на сервер, добавлена автоматическая коррекция расширения изображения, в случае если расширение загружаемого файла не соответствует его формату. Например, если картинка по своей сути является PNG картинкой, а расширение файла имеет формат .jpg, то загружаемое изображение будет автоматически переименовано в файл с корректным расширением .png, и так далее для всех других форматов.

qПри загрузке изображений на сервер, и использовании сервиса TinyPNG для обработки картинок, существенно снижено количество обращений к сервису и использования его API. Тем самым при лимитированном количестве обрабатываемых изображений, вы можете больше обрабатывать картинок на сервисе.

qДобавлена поддержка обработки изображений в формате WebP на сервисе TinyPNG. Тем самым размер данных изображений также может быть сжат до минимальных размеров, без потери качества.

qПри загрузке аватаров пользователем у себя в профиле на сайте, добавлена корректная обработка возможных ошибок, в случае если загружаемое изображение, содержит некорректный формат или содержимое. Например, если содержимое файла не является изображением, то пользователю будет просто показано уведомление что аватар содержит некорректный формат, вместо системной ошибки о некорректном действии с последующей аварийной остановкой сайта.

qВ настройки скрипта в админпанели, в опции "Область наложения водяного знака", добавлена дополнительно новая возможность указания размещения водяного знака по центру изображения.

qДобавлена возможность указывать в настройках скрипта, что будет использоваться в качестве водяного знака. Вы можете указать изображение из шаблона, как было ранее, либо указать использование собственного текста написанного в настройках скрипта. Там же в настройках вы можете указать сам текст, его размер и цвет. В данном случае будет накладываться ваш собственный текст из настроек, без необходимости создания картинок с водяным знаком.

qДобавлена возможность указывать в настройках скрипта угол поворота для водяного знака, накладываемого на изображение. Угол поворота применяется и к изображению водяного знака и к тексту если включено его отображение.

qДобавлена возможность указывать в настройках скрипта степень прозрачности для водяного знака, накладываемого на изображение. Степень прозрачности применяется и к изображению водяного знака и к тексту если включено его отображение.

qСущественно снижен расход потребляемой оперативной памяти при обработке загруженных на сервер изображений.

qДобавлена поддержка отложенных изображений, расположенных в спойлерах скрытого текста в публикациях. Теперь при включении отложенной загрузки изображений, при открытии спойлера данные изображения также будут показаны корректно.

qИзменены алгоритмы загрузки изображений на сервер. Теперь для всех загружаемых изображений на сервер, больше не будет добавляться к имени изображений временной UNIX префикс, и все имена будут сохраняться в оригинальном виде, останется только транслитерация имён, если они написаны на кириллице. Однако в случае, если на сервере уже существует изображение с данным именем, то во избежание перезаписи другой картинки, для загружаемой будет добавлен временной префикс к ее имени. Тем самым DataLife Engine будет максимально сохранять оригинальные имена у загружаемых картинок, и только в случае появления дубликатов имён, автоматически добавит необходимый префикс.

qДобавлено автоматическое удаление старого аватара пользователя с сервера, если он меняет аватар, и новый при этом имеет иной формат изображения. Тем самым экономится место на сервере.

qДобавлена возможность вывода полных данных из профиля пользователя при просмотре результатов поиска публикаций на сайте. Для вывода используются те же шаблонные теги, что и при выводе кратких и полных публикаций.

qДобавлена возможность вывода рекламных материалов, назначенных для показа между краткими новостями, при показе результатов поиска публикаций на сайте.

qДля шаблонов вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl) добавлена поддержка новых тегов: [has-category] текст [/has-category] которые выводят текст, заключённых в них, если публикация находится в какой-либо категории. А также добавлена поддержка обратных тегов: [not-has-category] текст [/not-has-category] которые выводят текст, заключённых в них, если у публикации нет никаких категорий. Тем самым вы можете гибко настраивать оформление шаблонов для публикаций, у которых есть категории, и для публикаций, у которых нет категорий.

qПри удалении публикации с сайта, а также при последующем удалении изображений, загруженных к этой публикации, добавлена автоматическая проверка используются ли удаляемое изображение в текстах у других публикаций, если используется, то данное изображение не будет удалено с сервера.

qСущественно снижена нагрузка на сервер при просмотре кратких публикаций на сайте. Теперь при просмотре кратких публикаций, независимо от раздела сайта, подсчёт общего количества страниц в разделе осуществляется только один раз, после чего информация об количестве страниц в разделе кэшируется, и при посещении других страниц, или повторных посещениях информация берётся из кэша, а не из базы данных для каждой страницы как ранее. Тем самым существенно сокращено количество запросов к базе данных MySQL.

qСущественно снижена нагрузка на сервер при просмотре последних комментариев на сайте. Теперь подсчёт общего количества страниц с комментариями осуществляется только один раз, после чего информация об количестве страниц в разделе кэшируется, и при посещении других страниц по навигации, или повторных посещениях этой же страницы информация берётся из кэша, а не из базы данных для каждой страницы как ранее. Тем самым существенно сокращено количество запросов к базе данных MySQL.

qПереработана и снижена нагрузка на сервер, в случае если просматриваются страницы на сайте, на которых нет контента при просмотре кратких публикаций. В данном случае часть ненужных запросов к MySQL серверу не будет выполняться.

qДля визуального редактора TinyMCE добавлено автоматическое создание уменьшенной копии изображения, в случае переноса картинки в редактор методом Drag & Drop. При этом в редактор будет вставлено изображение и код для увеличения изображения, в случае если согласно настройкам скрипта, необходимо для таких изображений создавать уменьшенные копии.

qВ админпанели в разделе просмотра и редактирования информации о пользователе, добавлены быстрые ссылки на отправку пользователю персонального сообщения, а также просмотр всех его публикаций и комментариев. Тем самым при просмотре карточки пользователя вы можете быстро выполнить вышеуказанные действия, без необходимости перехода в другие разделы сайта.

qВнесены изменения в работу функции "Поделится интересными материалами". Теперь для того, чтобы указать текстом из какого блока на сайте пользователи могут делится, вам необходимо указать для данного блока класс с именем "share-content", а если внутри этого блока необходимо что-либо исключить, то используйте класс "ignore-select". Тем самым вы можете назначить свой любой блок на сайте, где находится контент, с которым пользователи могут делится при выделении текста. Вы можете также назначать несколько блоков, где разрешено делится контентом сайта. В случае если вы используете данную возможность при просмотре кратких публикаций, то для качественного контроля смещения публикаций по мере добавления новых, мы рекомендуем использовать для блоков уникальный ID на основе ID новости, например добавив в шаблон id="news-{news-id}".

qИз настроек скрипта убрана настройка включения и отключения функции "Разрешить пользователям делится интересными материалами". Теперь данная опция включается и отключается автоматически если в шаблоне блоку задан класс CSS "share-content".

qВнесены изменения в работу главной страницы на сайте в случае, если для показа контента на этой странице назначена либо статическая страница, либо публикации с использованием тега {custom ...}. Ранее главной страницей сайта для этих настроек была только страница в URL браузера которой полностью отсутствуют какие-либо параметры. Теперь же параметры, которые не относятся к DLE, будут игнорироваться, а назначенный контент будет отображаться корректно, даже при присутствии посторонних параметрах в URL. Тем самым при переходе на ваш сайт по различным рекламным компаниям, или с дополнительными маркерами от рекламных компаний, контент вашего сайта будет отображаться корректно и 404 ошибка выдаваться не будет. Например, при переходе с Яндекс Директ и прочих сервисов. А во избежание появления дублей страниц, в поисковых системах задействована система канонических ссылок в коде страниц вашего сайта.

qВывод публикаций с использованием тега {content}, а также работа скрипта была переработана таким образом, что больше не выводится и не используется внешняя обёртка контента дополнительным тегом <div id="dle-content"> ... </div>. Это упрощает интеграцию шаблонов с некоторыми HTML Фреймворками. Если вы использовали привязку вёрстки к данному тегу, то вам необходимо внести изменения в вёрстку CSS вашего шаблона.

qВ админпанели, в разделе редактирования шаблонов, добавлена подсветка редактируемого файла шаблона в списке файлов. Тем самым обеспечивается более удобное восприятие редактируемого файла и навигация по списку файлов шаблонов.

qПри сохранении созданного плагина на компьютер, добавлено корректное удаление специальных символов из имени плагина, при создании имени скачиваемого файла. Тем самым будет производится более точная и качественная транслитерация имён плагинов.

qПри массовом назначении текущей даты для публикаций, в разделе редактирования публикаций, добавлено смещение назначаемой даты для каждой предыдущей новости на одну секунду. Что позволяет производить корректную индексацию следующей и предыдущей новости, при показе их на сайте.

qДобавлена система автоматической защиты от перезаписи загружаемых на сервер изображений для публикаций в разделе управления изображениями в админпанели. В случае если изображение уже присутствует на сервере, то пользователю будет указано на это и предложено изменить имя для загружаемого изображения.

qВнесены изменения в работу настройки "Минимальные размеры изображения для загрузки". Теперь данная настройка распространяется только на изображения, загружаемые к публикациям на сайте. И не распространяется на загружаемые аватары на сайте и на модуль управления изображениями в админпанели, как было ранее.

qУлучшена загрузка JS скриптов в фоне в некоторых сценариях работы сайта. Теперь если эти JS скрипты уже ранее были в кэше браузера, то он будет использовать именно кэшированные скрипты, а не загружать повторно с сервера.

qОбновлён до актуальной версии визуальный редактор TinyMCE. Были улучшены и добавлены новые инструменты для работы с таблицами, а также исправлен ряд ошибок в нем. Была добавлена поддержка контекстного меню браузера.

qОбновлён до актуальной версии парсер входящих данных HTML Purifier в DataLife Engine. Добавлена поддержка некоторых новых HTML атрибутов для текстов.

qОбновлена до актуальной версии библиотека PHPMailer в DataLife Engine для отправки писем с сайта.

qДля поддержки всех новых функций минимальные требования к PHP подняты. Для корректной работы требуется PHP 7.2 и выше.

qИсправлена проблема, при которой некорректно производилась ротация рекламных материалов, указанных в админпанели, при просмотре полных новостей.

qИсправлена проблема, при которой не выводилась отладочная информация функцией GzipOut при использовании PHP 8.xx

qИсправлена проблема, при которой в некоторых случаях могла происходить MySQL ошибка при выполнении заданий по крону.

Список изменений относительно версии 14.2:

qПолностью переработан инсталлятор DataLife Engine. Он сделан более простым и универсальным. При установке вы можете теперь самостоятельно выбрать на каком языке будет происходить установка, а также какой язык будет основным для сайта. В зависимости от выбранного языка, будут установлены соответствующие шаблоны, на выбранном языке, а также сделаны соответствующие записи в базе данных. Вся установка происходит также с использованием технологии AJAX в полностью автоматическом режиме.

qДля языковых пакетов, находящихся в папке /language/ добавлена возможность указывать дополнительную информацию о языке, которая в дальнейшем может быть использована при выводе списка языков. Например, вывод названия на национальном языке, для более удобного восприятия нужного языка человеком. А не просто имени папки, в которой находится языковой пакет.

qДля шаблонов, находящихся в папке /templates/ добавлена возможность указывать дополнительную информацию о шаблоне, которая в дальнейшем может быть использована при выводе списка шаблонов. Например, вывод названия шаблона, в списке шаблонов на сайте, для более удобного восприятия нужного имени шаблона. А не просто имени папки, в которой находится шаблон.

qДобавлена украинская локализация скрипта Datalife Engine. Украинский язык теперь также включён в состав стандартного дистрибутива, и будет поддерживаться в дальнейшем при обновлении.

qДобавлена возможность смены языка панели управления DataLife Engine на лету, находясь на любой странице в панели управления, без необходимости разлогинивания, и повторного входа в панель управления. Пользователь админпанели может выбрать любой из доступных в системе языков.

qДобавлена возможность устанавливать порядок категорий у публикаций, в случае если для новости разрешено добавление публикации в несколько категорий. Порядок категорий будет выставляться в том порядке, в котором их выбрал пользователь при добавлении или редактировании публикации, а не в таком порядке, в котором они отсортированы в админпанели. Например, если первая по списку категория "В мире", а вторая "Спорт", и пользователь первой выбрал "Спорт" и только потом "В мире", то их сортировка и вывод у новости будут также соблюдаться в данном порядке.

qДобавлена возможность просмотра уменьшенной копии изображения, вставленной в комментарий, непосредственно сразу после добавления комментария, без необходимости перезагрузки страницы. В случае если был добавлен комментарий, который содержит в себе уменьшенную копию оригинального изображения, то просмотр увеличенной копии, будет доступен по клику, сразу после появления комментария на странице.

qДобавлена возможность просмотра оригинального изображения из уменьшенной копии картинок для комментариев, в случае если на сайте включена AJAX навигация или динамическая загрузка комментариев.

qДобавлена поддержка отправки HTTP заголовка Last-Modified для всех страниц сайта, осуществляющих показ кратких публикаций, а не только полных новостей как ранее. При этом ведётся учёт даты добавления или редактирования для всех публикаций, размещённых на странице, и отдаётся корректная дата последней добавленной или отредактированной публикации на странице.

qДля всех страниц сайта, которые осуществляют вывод кратких публикаций, добавлена поддержка отдачи HTTP заголовка "304 Not Modified", в случае отправки на сервер соответствующего запроса от поисковых систем. При этом учитываются даты добавления или редактирования всех публикаций, опубликованных на странице, как с использованием тега {content}, так и тегов {custom}. Что позволит снизить расход трафика на сервере, и существенно ускорить индексацию и переиндексацию сайта поисковыми системами.

qДобавлена поддержка вывода рекламных материалов, которые задаются в разделе управления рекламой в админпанели для шаблонов и публикаций, которые выводятся с использованием пользовательского вывода тегом {custom ...}. Теперь вы можете использовать баннерные теги, заданные в админпанели в шаблонах, которые назначаете при выводе публикаций.

qДля пользовательского вывода публикаций с использованием тега {custom ...} добавлена поддержка нового параметра banners="yes", который включает или отключает вывод рекламных материалов, которые назначены для вывода между публикациями. Данный параметр может принимать два значения "yes" для включения вывода, и "no" для отключения вывода. По умолчанию если данный параметр отсутствует в теги, вывод рекламных материалов между публикациями будет отключён.

qПолностью переработана логика и принципы формирования метатега описания (description) для страниц сайта, отображающих краткие публикации. Теперь описание, указанное в настройках скрипта, используется только для главной страницы вашего сайта, а описание, указанное в параметрах категории, только для первой страницы категории, для всех остальных страниц, данный метатег формируется автоматически, на основе контента публикаций, которые выводятся на данной странице. Тем самым все страницы имеют свой уникальный метатег описания, что положительно повлияет на SEO оптимизацию вашего сайта.

qДля системы кеширования Memcache добавлена новая система нахождения ключей, хранящихся в кэше, что приводит к более корректной очистке элементов кэша и обновления контента на странице. Особенно это касается нагруженных проектов.

qВ настройки скрипта добавлена возможность выбора, как должна выводится форма ответов на комментарии, в случае если включена поддержка древовидных комментариев. Доступно три варианта для выбора "Под комментарием без редактора", "Под комментарием с редактором", "В всплывающем окне".

qМодуль "Поделится интересными материалами" был полностью интегрирован в языковую систему DataLife Engine и для формирования информации использует языковые файлы скрипта. Тем самым при использовании других языков переключение будет автоматическим и не требует правки файлов. Также в данном модуле добавлена проверка контрольных сумм на предмет изменения контента, и в случае его изменения текст не будет выделятся если контрольная сумма не совпадает, чтобы не происходило выделение не того текста, с которым посетитель сайта делился.

qОбновлена до актуальной версии система подсветки исходного кода, опубликованного в тегах [cоde] ... [/cоde] до актуальной версии. Помимо этого, она была существенно переработана для более лучшего и качественного автоматического распознавания языка опубликованного кода. А также была добавлена поддержка большого количества языков, и различных конфигураций. Теперь осуществляется качественная подсветка не только HTML или JS, но и других языков и кодов.

qПереработана и улучшена система отображения добавления публикаций в закладки и удаления их, а также вывода информации о том находится ли новость в закладках или нет. Теперь независимо от того включено или отключено кеширование на сайте, посетитель сайта при просмотре кратких новостей, всегда будет видеть актуальную информацию, находится ли его публикация в закладках или нет, даже если включено кеширование. При этом функции кеширования никак не теряются и используется.

qДля типографской обработки текста в редакторах добавлена возможность исключения обработки публикуемого контента в BB тегах исходного кода [cоde] ... [/cоde], а также в соответствующих HTML тегах, которые используются для публикации исходного кода.

qВизуальный редактор TinyMCE был обновлен до актуальной линейки 5.7.x, а также он был существенно переработан для более комфортной работы. Данный редактор был назначен по умолчанию при установке DataLife Engine на сервер.

qДля визуального редактора TinyMCE добавлена возможность загружать изображения на сервер посредством простого переноса файлов картинок методом "Drag and Drop" в редактор, а также загрузка изображений на сервер из буфера обмена браузера.

qДля визуального редактора TinyMCE добавлена защита от возможной случайной потери данных при написании публикаций. Например, в случае если при написании публикации и ее не сохранении случайно нажать на какую-либо ссылку, которая приводит к тому, что пользователь покинет страницу, то ему будет выведено предупреждение что данные могут быть потеряны и необходимо будет дополнительно подтвердить действие. Также в случае, если браузер завис или пользователь все равно покинул страницу, то в редакторе он может восстановить последний сохранённый в локальном хранилище контент. Автосохранение происходит каждые 20 секунд, а данные для восстановления хранятся в течении 10 минут.

qДля визуального редактора TinyMCE добавлена возможность редактирования загруженных или вставленных изображений. Функции редактирования содержат такие возможности, как изменение размеров, изменение ориентации, зеркалирование, изменение яркости и контрастности и т.д. Изменённое изображение в редакторе, будет автоматически загружено на сервер.

qДля визуального редактора TinyMCE добавлена возможность управлять через шаблоны визуальным оформлением содержимого редактора, при написании публикации или комментариев. Для этого в корне вашего шаблона достаточно разместить файл editor.css с необходимыми вами стилями оформления. Данное нововведение будет полезно для того, чтобы текст, который пишут пользователи был максимально приближен к оформлению контента, который используется в шаблоне. Размещение данного файла в шаблоне необязательно, в случае его отсутствия, будет использовано стандартное оформление контента.

qДля визуальных редакторов TinyMCE и Froala, используемых на сайте для комментариев, переработана и улучшена система цитирования выделенного на сайте текста комментариев других пользователей. Теперь используются визуальные цитаты, вместо BBCODES тегов, а также добавлены переносы строк, если они присутствуют в выделенном тексте.

qВнесены изменения в систему загрузки изображений на сервер с использованием DataLife Engine. В случае если имя не содержит временного префикса загрузки, то он будет добавлен в имени, а в случае, если имя уже содержит данный префикс, то дополнительно он уже добавляться не будет. Временные префиксы добавляются к имени, чтобы избежать дублирования имён загружаемых файлов на сервер, и тем самым защищают от перезаписи другие изображения, загруженные ранее с тем же именем на сервер. Данное нововведение будет полезно в случае копирования изображений с других сайтов на DLE или использующих аналогичную систему маркировки имён, так как позволяет избежать многократного дублирования префикса в имени изображения при копировании.

qДля шаблонов вывода статических страниц (static.tpl) добавлена поддержка новых тегов: {full-link} который выводит URL для данной статической страницы, а также {print-link} который выводит URL версии для печати для данной страницы. Данные теги будут полезны, когда необходимо собственное оформление для ссылок на странице, или их особенного вывода, например, для вывода QR кода для мобильных устройств и т.д.

qСущественна улучшена работа крона на сайте. В случае если по крону необходимо выполнить какие-либо тяжёлые операции, например множественное удаление большого числа пользователей, а ресурсы сервера не позволяют выполнить все сразу, по каким то своим лимитам, то крон будет выполняться каждые две минуты до тех пор, пока все необходимые действия не будут осуществлены.

qПереработана и улучшена система AJAX добавления комментариев на сайте. В случае если в настройках скрипта включено объединение комментариев на сайте, и пользователь добавляет ещё комментарий в дополнение к своему, то на странице будет обновлён и дополнен именно текст его предыдущего комментария. А в случае, если объединение отключено, то его дополнительные комментарии будут добавляться последовательно друг за другом и будут все видны сразу без перезагрузки страницы.

qСущественно переработана и улучшена система AJAX ответов на комментарии в случае, если включены древовидные комментарии. Изменения коснулись улучшения позиционирования добавляемых ответов, а также формирования DOM структуры элементов, которые больше не используют промежуточных слоёв и элементов, что позволяет лучше адаптироваться под вёрстку шаблона.

qДля микроразметки рейтинга публикаций, добавлено использование дробного значения параметра itemprop="ratingValue", теперь в данном значении вместо целого значения, например, 4, будет использоваться более точное значение, например, 4.3. Это позволит поисковым системам при выдаче отображать более точную шкалу рейтинга в результатах выдачи.

qВнесены изменения в работу системы автоматического удаления пользователей, если они не посещали сайт указанное в настройках время. В случае если в настройках сайта включено автоматическое удаление пользователей, то будет происходить удаление пользователей из всех групп, за исключением группы администраторов. Ранее удаление осуществлялось только из стандартной группы "Посетители", а другие группы не затрагивались.

qУлучшена система синхронизации данных кэша счётчика просмотров публикаций с данными, отображаемыми на сайте, предотвращающее неконтролируемое накопление данных в таблице, на высоконагруженных и посещаемых сайтах.

q Улучшена система массовой рассылки писем в панели управления скриптом в модуле "Рассылка сообщений". Переработана система обработки возможных ошибок при отправке писем. В случае если ваш сервер не ответил корректно, или возникли любые ошибки или ограничения, то все ответы сервера будут обработаны корректно. Администратор получит подробный ответ от сервера, а также будет предоставлена возможность продолжить рассылку сообщений без перезагрузки страницы. Исключены возможные зависания отправки без объяснения причин при массовой рассылке сообщений.

qПереработана и улучшена система поиска по сайту, в случае если поиск ведётся, по ключевым словам, содержащим в себе специальные символы. Например, кавычки и другие символы. Поиск, по данным словам, теперь проходит более корректно и релевантно.

qОптимизировано отображение некоторых элементов панели управления на мобильных устройствах. Устранены обнаруженные недостатки отображения некоторых элементов страниц панели управления.

qОбновлён до актуальной версии плеер DLE, проведён ряд оптимизаций и исправлений ошибок, а также в случае использования на сайте видео с адаптивным битрейтом, размер загружаемого кода плеера был существенно сокращён, что ускоряет загрузку страниц где расположено данное видео.

qУлучшено формирование метатега og:description протокола Open Graph при просмотре полных новостей. Теперь при формировании данного тега в случае, если в тексте присутствует текстовые ссылки, без формирования кода, то они также удаляются и не используются. Например, если в тексте ссылка https://site.ru, то она удаляется. Данное нововведение позволяет не участвовать в формировании описания ссылки, которые просто публикуются в текстовых дополнительных и других полях. Что делает описание более корректным и правильным.

qУлучшена система отправки E-Mail писем с сайта, а также предотвращено возможное аварийное завершение рассылки писем, если почтовый адрес какого-либо получателя письма является некорректным.

qУлучшена система автоматического обновления DataLife Engine. В случае если произошло аварийное завершение автоматического обновления, по причине неожиданной ошибки сервера, администратору будет отображена полная информация об ошибке который вернул сервер, а также отображён ответ, который пришёл с сервера, а не просто уведомление о том, что произошла ошибка. Данная информация поможет устранить администратору сайта причины возникновения проблемы.

qОбновлена библиотека PHPMailer для отправки писем с сайта до актуальной версии.

qВнесены изменения в систему показа рекламных материалов, назначенных для показа "между краткими новостями". Теперь они всегда будут отображаться именно между краткими новостями, независимо от количества новостей на странице, и никогда не будут отображаться до или после новостей.

qВнесены изменения в систему работы шаблонных тегов [if ..] [/if], в случе если если используется сокращённый вывод какой-либо информации, то поиск по указанным параметрам в этих тегах, все равно будет осуществлён по полному значению. Например, при выводе на сайте сокращённой информации тегом {short-story limit="200"}, то при использовании [if short_story~"text"] ... [/if] поиск будет произведён по всему краткому описанию, а не только по первым 200 символам.

qПрекращена поддержка PHP линейки 5.xx. Разработка и поддержка PHP 5 прекращена разработчиками PHP уже несколько лет назад. Мы не делали никаких необратимых и не поддерживаемых изменений в коде, которые бы не работали на линейке PHP 5, тем не менее данная линейка является больше не поддерживаемой. Тестирование DLE на ней не производится. Минимально требуемой версией PHP является 7.0 и выше.

qПрекращена поддержка расширенного метода авторизации в панели управления DataLife Engine. Данный метод был введён в DLE версии 5.3 и по своей сути морально устарел. Он не добавлял уже в текущих условиях и реалиях никакой дополнительной защиты относительно обычного метода защиты реализованной в DLE актуальных версий, и использовал для HTTP авторизации тот же основной пароль. Пользователи, которые все же хотят добавить дополнительную защиту для своей админпанели, могут использовать и дальше HTTP авторизацию, только для этого необходимо разместить отдельно свой файл .htpasswd и прописать к нему путь в .htaccess. И сделать тем самым авторизацию независимым от DLE и с дополнительным своим паролем.

qИсправлена проблема, при которой не работала система автоподсказок и автозаполнение для дополнительных полей, имеющих тип "перекрёстные ссылки", для слов, которые содержат некоторые специальные символы, например символ амперсанда "&" и ряд других.

qИсправлена проблема, при которой не работала система автоподсказок и автозаполнение для облака тегов, в случае если использовались слова, которые содержали некоторые специальные символы, например символ амперсанда "&" и ряд других.

qИсправлена проблема, при которой могло происходить некорректное отображение некоторых символов при цитировании комментариев, содержащих в себе теги вставки исходного кода, с использованием BBCODES редактора.

qИсправлена проблема, при которой не работал корректно раздел "IP Утилиты" в админпанели, при использовании PHP линейки 8.xx

qИсправлена проблема, при которой не работало отображение рекламных материалов с опцией "между публикациями", при использовании PHP линейки 8.xx

qИсправлена проблема, при которой некорректно работали некоторые теги в шаблоне вывода комментариев (comments.tpl)

qИсправлена проблема, при которой не задействовался и не использовался кеш для RSS потоков с сайта.

qИсправлена проблема, при которой не работала выборка категорий при использовании DLE API в сторонних модулях на MySQL 8.xx

qИсправлена проблема, при которой происходило дублирование дополнительных полей, имеющих тип "перекрёстные ссылки", при массовом снятии с модерации публикаций, которые уже не находились на модерации, а были ранее опубликованы.

qИсправлена проблема, при которой не работал вывод дополнительных полей публикаций при одновременном включении 3 типа ЧПУ и вывода полной информации из профиля пользователя.

qИсправлена проблема, при которой в разделе редактирования комментариев в админпанели, происходил сброс искомого ключевого слова, при навигации по страницам.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 14.1:

qДобавлена возможность выводить данные из профиля пользователя, который написал публикацию, в шаблонах вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl). Так как данная возможность требует дополнительной выборки данных из базы данных, то она включается и отключается в настройках скрипта, в разделе оптимизации производительности. Поэтому данную возможность могут включить те, кому она нужна, и отключить если она не используется для увеличения производительности скрипта и снижения нагрузки на сервер. Для реализации данной возможности было введено более тридцати новых тегов для шаблонов, которые содержат в себе информацию из пользовательского профиля, включая данные из его дополнительных полей.

qДля шаблонов вывода комментариев (comments.tpl) добавлена поддержка новых тегов условий сравнения значений. Например, тег [if field = "значение"] текст [/if] выведет текст заключённых в них если значения поля равно указанному значению.

qДобавлена поддержка нового типа кеширования с использованием системы кеширования Redis. В настройках скрипта вы можете выбрать какое именно кеширование использовать: Файлы, Memcache или Redis. Также если ваш Redis сервер требует логина и пароля для авторизации или просто пароля, то вы можете также задать данные авторизации на сервере для этого. Для работы данного типа кеширования, на вашем сервере должен быть установлен сервер Redis, а также расширение для PHP интерпретатора php-redis.

qВнесены изменения в работу кеширования Memcache. Данные изменения призваны предотвратить возможные проблемы с автоматической очисткой кэша на высоконагруженных проектах, когда памяти для кэша выделено не много и информация о кэшированных ключах могла обнулятся, в результате чего кэшированные другие данные могли сохраняться дольше чем положено.

qДля тегов условий сравнения значений [if field = "значение"] текст [/if] добавлена поддержка использования в них других шаблонных тегов. Например, вы можете использовать конструкцию: [if autor = "{profile-login}"]Просматривает автор публикации[/if], которая выведет указанный текст, если публикацию просматривает ее автор. Тем самым вы можете более гибко делать оформление шаблонов.

qПри добавлении и редактировании статических страниц в админпанели, добавлена возможность перехода на просмотр данных страниц на сайте, сразу после их создания или внесения изменений.

qДля тега [mеdia=...] добавлена поддержка более 200 новых сервисов и сайтов. По сути, была добавлена поддержка всех известных сайтов и сервисов поддерживающих протокол oEmbed для обмена данными для вставки в публикации.

qДля шаблона main.tpl добавлена поддержка нового тега {cloudstag} который выводит ключевое слово из облако тегов, при просмотре раздела сайта, который показывает публикации по определённому ключевому слову из облака тегов. Данное нововведение будет полезно для вебмастеров, которые хотят выводить просматриваемое ключевое слово в каком-либо отдельном месте, например с использованием HTML тегов h1 и т.д.

qДля шаблона вывода меню категорий (categorymenu.tpl) добавлена возможность вывода описания категории в меню. Для этого добавлена поддержка новых тегов: {description} - который выводит описание категории, [description] текст [/description] - которые выводят текст заключённый в них если задано описание категории, а также обратные теги: [not-description] текст [/not-description] - которые выводят текст заключённый в них если не было задано описание категории.

qДля шаблона вывода меню категорий (categorymenu.tpl) добавлена поддержка новых тегов: [not-parent] текст [/not-parent] которые выводят текст, заключённый в них, если категория не является родительской и не содержит в себе подкатегории. По своей сути данный тег является обратным уже существующему тегу: [isparent] текст [/isparent].

qДля шаблона вывода меню категорий (categorymenu.tpl) добавлена поддержка новых тегов: [is-children] текст [/is-children] которые выводят текст, заключённый в них, если категория является подкатегорией другой категории, а также добавлена поддержка обратных тегов: [not-children] текст [/not-children] которые выводят текст заключённый в них, если категория не является подкатегорией другой категории.

qДля дополнительного поля с типом: "Переключатель 'Да' или 'Нет'", изменено его заполнение на сайте, вместо HTML тега select добавлено использование тега input (checkbox). Тем самым заполнение поля на сайте приведено в соответствие с заполнением его в админпанели.

qДля дополнительных полей, имеющих свойство "использовать как перекрёстные ссылки" добавлена возможность использовать в их значениях символа слеша "/".

qДля тега пользовательского вывода комментариев {customcomments ....} добавлен новый параметр newsid="1,3,5-15" где вы можете перечислить ID публикаций из которых нужно выбирать комментарии. Также данный параметр может включать в себя шаблонные теги других шаблонов, например, если в шаблоне полной новости разместить тег {customcomments newsid="{news-id}" order="rating"} он покажет комментарии из данной публикации, отсортированные по рейтингу.

qДля тега пользовательского вывода комментариев {customcomments ....} добавлен новый параметр newsidexclude="1,3,5-15" где вы можете перечислить ID публикаций которые нужно исключить при показе комментариев. Например, при использовании тега {customcomments newsidexclude="3-10"} будут показаны комментарии из всех публикаций, кроме публикаций ID которых от 3 до 10.

qДля тега пользовательского вывода новостей {custom ....} добавлен новый параметр subcat="yes". Данный параметр может использоваться совместно с параметрами category="список" или categoryexclude="список". Данный параметр указывает необходимо ли включать в выборку также публикации, находящиеся в подкатегориях или нет. Данный параметр может принимать следующие значения: subcat="yes" который указывает, что также нужно выбрать все публикации находящиеся и в подкатегориях указанной категории, а также значение subcat="only" который указывает, что нужно выбрать публикации только из подкатегорий, без учета указанной категории. Например, у вас на сайте есть категории с ID 1, 2 и 3. Категории 2 и 3 при этом являются подкатегориями первой. При использовании тега {custom category="1" subcat="yes"} будут выбраны все новости, из категорий 1, 2 и 3. А при использовании тега {custom category="1" subcat="only"} будут выбраны все публикации только из категорий 2 и 3. Тем самым вы можете гибко указывать нужные параметры выборки, без перечисления всех категорий в теге, а также публикации будут автоматически показываться при добавлении в админпанели новых подкатегорий, без необходимости правки шаблонов.

qДля ключевых слов из облака тегов добавлена возможность использовать в их значениях символа слеша "/".

qВ связи с тем, что сервис Instagram перешел под управление Facebook, а тот в свою очередь для встраивания своего контента на сайт требует обязательно иметь зарегистрированное на сервисе приложение для получения данных, то для вставки в новости постов из Instagram с использованием тега [mеdia=...] теперь в DLE используются данные приложения, указанного в настройках скрипта для авторизации через социальную сеть Facebook. При этом в настройках самого приложения на сайте Facebook вам необходимо дать доступ к получению контента через oEmbed. После чего вставка из Instagram и Facebook c использованием тега [mеdia=...] будет доступна. Подробнее о том как добавить данные права в свое приложение вы можете прочитать в документации https://developers.facebook.com/docs/plugins/oembed

qВ настройки скрипта добавлена возможность включать или отключать установку параметра NOREFERRER для всех внешних ссылок, которые публикуются в новостях. Если вы включили данную настройку, то для всех внешних ссылок, которые публикуются в новостях, будет устанавливаться параметр NOREFERRER, который будет запрещать браузерам передавать информацию на внешние сайты о том откуда пришёл пользователь.

qВ настройки скрипта добавлена возможность включать или отключать установку параметра NOREFERRER для всех внешних ссылок, которые публикуются в комментариях. Если вы включили данную настройку, то для всех внешних ссылок, которые публикуются в комментариях, будет устанавливаться параметр NOREFERRER, который будет запрещать браузерам передавать информацию на внешние сайты о том откуда пришёл пользователь.

qПри загрузке файлов с расширениями webm и m3u8 добавлено автоматическое распознавание их как видеофайлов и соответственно они могут быть вставлены в новость автоматически для их проигрывания на сайте с использованием видеоплеера.

qДля публикаций добавлена поддержка отдачи заголовка "304 Not Modified", в случае отправки на сервер соответствующего запроса от поисковых систем. Если публикация не редактировалась за указанный период, то DLE будет отдавать просто короткий соответствующий HTTP с кодом 304. Что позволит снизить расход трафика на сервере, и несколько снизить нагрузку на сервер.

qДля персональных сообщений на сайте добавлен более информативный вывод ошибок, в случае их возникновения. Например, если пользователь просто попадает в раздел персональных сообщений и при этом не авторизован на сайте, ему будет указано на это и предложено авторизоваться на сайте или зарегистрироваться. А если он по ссылке из письма уведомления о новом персональном сообщении пытается прочитать его, но при этом уже не авторизован на сайте, то ему будет предложено авторизоваться на сайте, чтобы прочитать данное сообщение.

q Добавлена возможность просмотра правил сайта, сразу непосредственно после их редактирования в административной панели управления.

qБиблиотека jQuery обновлена до актуальной линейки 3.6.x при использовании, в случае если в настройках скрипта в админпанели включено использование jQuery 3 на сайте.

qДля визуального редактора Froala добавлена возможность быстрой вставки некоторых обьектов, например, таблиц, списков изображений и видео.

qДобавлена возможность вставки виджетов из apple музыки для проигрывания музыки на сайте с использованием тегов iframe. А также для HTML тегов iframe добавлена возможность установки политики доступа с использованием атрибута allow.

qДобавлена возможность использования символов одиночных кавычек ('), а также символов амперсанда (&) в фильтре слов. Тем самым вы можете использовать такие слова как Жанна д'Арк и другие аналогичные.

qДобавлена поддержка настройки: "Разрешить индексацию поисковыми системами ссылок, опубликованных в комментариях" для используемых на сайте визуальных WYSIWYG редакторов. Ранее данная настройка действовала только при использовании в комментариях BBCODES редактора и ссылок, публикуемых только с использованием BB тегов.

qДля заметок, публикуемых в плагинах, было добавлено корректное отображение исходного кода, публикуемого ББ тегами [cоde] ... [/cоde], а также была добавлена подсветка исходного кода и его тегов, для более улучшенного визуального восприятия текста.

qВ связи с изменением сервисом YouTube алгоритмов работы по протоколу Oembed, и по умолчанию он стал отдавать код видео маленьких размеров. В работу тега [mеdia=...] были внесены изменения, и теперь при вставке видео из данного сервиса используются настройки видео проигрывателя DLE, а высоту DLE рассчитывает автоматически. Тем самым вставка видео осуществляется правильных размеров, и соответствующих другим видео на сайте, размещённых с использованием плеера DLE.

qИз метатегов страниц сайта, таких как заголовок, описание, ключевые слова и прочие, больше не удаляются такие символы как квадратные и фигурные скобки, а корректно переводятся в HTML сущности для их корректного отображения браузером.

qВнесены изменения в логику работы показа загруженных изображений к публикациям. Ранее в списке отображались только те изображения, которые загружены на сервер через скрипт DLE, а также присутствуют физически на сервере. Теперь же, если изображение по каким-либо причинам было удалено с сервера физически, минуя скрипт DLE, то вместо изображения будет показана специальная заглушка, которая показывает, что изображение удалено с сервера. Это нововведение будет полезно, если для пользователей были введены лимиты на количество изображений к новости, и в случае отсутствия изображения, его можно было удалить из привязки к публикациям, и как следствие лимит на количество будет корректно соблюдаться.

q Видеоплеер DLE был обновлён до актуальной версии. Был исправлен ряд ошибок в отображении плеера на разных устройствах и браузерах.

qПарсер входящего HTML кода для публикаций был обновлён до актуальной версии. Была добавлена поддержка ряда новых параметров HTML атрибутов для поддержки HTML5.

qВ систему цитирования комментариев внесены изменения. В случае цитирования комментария, содержащего скрытый текст, и пользователь, который цитирует комментарий, имеет доступ к его просмотру, то при цитировании данного текста комментария, скрытый текст также будет включён в цитируемый контекст включая теги скрытия текста. А в случае, если пользователь не имеет доступа к просмотру скрытого текста, то он будет также исключён из цитаты. Ранее текст исключался из цитирования, независимо от того имеет пользователь доступа к просмотру скрытого текста или нет.

qДобавлена дополнительная проверка ошибочных действий администратора сайта, при редактировании прав групп пользователей в панели управления, например ранее администратор при настройке прав на категории мог одновременно выбрать случайно и доступ ко всем категориям, и ограничить к некоторым, что могло приводить к некорректной работе некоторых функций DataLife Engine.

qДобавлена дополнительная проверка ошибочных действий администратора сайта, при редактировании прав групп пользователей в панели управления, например ранее администратор при настройке прав на категории мог одновременно выбрать случайно и доступ ко всем категориям, и ограничить к некоторым, что могло приводить к некорректной работе некоторых функций DataLife Engine.

qДобавлена поддержка PHP линейки 8.xx

qОбновлена библиотека отправки писем до актуальной версии. Для более расширенной поддержки различных SMTP серверов и сервисов

qОбновлена библиотека распознавания мобильных устройств до актуальной версии. Для более расширенной поддержки различных носимых устройств и как следствие более точная работа шаблонных тегов, которые используют данные возможности.

qВнесены изменения в алгоритм формирования канонических ссылок, в случае если сайт доступен по двум протоколам HTTP и HTTPS. В случае если пользователь заходит по HTTPS протоколу или включено принудительное использование всегда HTTPS в настройках, то и каноническая ссылка также всегда будет формироваться с использованием HTTPS протокола, независимо от того какой протокол указан в настройках скрипта для адреса сайта, либо если не указан вообще.

qУлучшено формирование метатега og:description протокола Open Graph при просмотре полных новостей. Теперь при формировании данного тега в случае, если задействуются дополнительные поля публикаций, то учитываются только текстовые поля, такие как: одна строка или несколько строк, и при этом исключены другие поля, такие как изображения или файлы.

qУлучшено формирование метатега og:image протокола Open Graph при просмотре полных новостей. Теперь при формировании данного тега в случае, если текст краткого и полного описания не имеет картинок, то данная картинка будет взята из дополнительного поля с типом изображение или галерея изображений.

qДобавлен учет последней даты комментария, расположенного на странице полной новости, при отдаче HTTP заголовка Last-Modified для более корректной отдачи в браузер информации о том когда была изменена страница.

qИсправлена проблема, при которой неверно формировались ссылки на публикации в админпанели и в карте сайта, если они находятся в категориях, которые были в впоследствии отключены в настройках категорий.

q Исправлена проблема, при которой подсветка активных страниц в навигации по страницам в админпанели, могла работать некорректно в некоторых случаях.

qИсправлена проблема, при которой некоторые персональные сообщения могли некорректно отображаться в предосмотре в панели управления скриптом.

qИсправлена проблема, при которой в некоторых случаях после редактирования статических страниц, мог осуществляться переход к списку публикаций, а не к списку статических страниц.

qИсправлена проблема, при которой нельзя было удалить пользователя из списка игнорируемых, а также удалить привязанные социальные сети, если пользователь использует браузер Firefox.

qИсправлена проблема, при которой неверно обрабатывались теги вывода иконок категорий в шаблонах вывода краткой и полной новости, если категории были назначены другие файлы шаблонов, отличные от стандартных (shortstory.tpl и fullstory.tpl).

qИсправлена проблема, при которой не работали теги [if ..] ... [/if] если значение поля содержало символы в верхнем регистре.

qИсправлена проблема, при которой не работали теги [if ..] ... [/if] если значение поля поле содержало несколько различных значений, например новость в нескольких категориях, и при этом проверка проверялась по отрицательному значению с комбинированием условий. Например, происходило некорректное сравнение условия [if category != "1" AND category != "2"]не 1 и не 2[/if] если новость при этом была опубликована в несколько категорий, а не только в одной категории.

q Исправлена проблема, при которой теги [not-ios] ... [/not-ios] и [not-android] ... [/not-android] не работали в случае если в шаблоне отсутствовали их обратные теги.

qИсправлена проблема, при которой некорректно сохранялись категории при импорте публикаций из RSS каналов на сайт.

qИсправлена проблема, при которой неверно формировалась каноническая ссылка на страницах просмотра публикаций, содержащих определённые дополнительные поля, в случае если был включён ЧПУ, а пользователь заходил по ссылке с отключённым ЧПУ. Данное действие могло быть, если менялись настройки сайта, и сайт был проиндексирован поисковиками.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 14.0:

qПолностью переработан модуль управления загруженными картинками в админпанели. Теперь в данном разделе вы можете осуществлять навигацию по всем папкам, независимо от уровня вложенности. Помимо стандартных папок, вы можете заходить и управлять картинками в самостоятельно созданных папках. Также добавлен предосмотр картинок по клику на них на полный экран.

qДобавлена поддержка проигрывания видео с адаптивным битрейтом (HLS файлов с расширением .m3u8) для видеопроигрывателя DataLife Engine.

qДля шаблонов вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl) добавлена поддержка новых тегов условий сравнения значений. Например, тег [if field = "значение"] текст [/if] выведет текст заключённых в них если значения поля равно указанному значению. Данный тег может сравнивать не только равенство, но и также проводить сравнения больше или меньше, находить вхождения.

qДобавлена возможность временной автоматической блокировки аккаунта при его бездействии в админпанели сайта. Вы можете в настройках скрипта указать таймаут в минутах, по истечении которых, если пользователь ничего не делал в браузере в админпанели, то его сессия будет временно приостановлена до ввода пароля. При этом пользователю будет показано уведомление и если он продолжает ничего не делать, то сессия будет приостановлена. Данное нововведение будет полезно для обеспечения дополнительной безопасности, если пользователь временно отошёл от своего компьютера, с открытой вкладкой админпанели. Для возобновления сессии достаточно ввести пароль без необходимости ввода логина.

qДобавлена возможность привязки к аккаунту на сайте любой доступной социальной сети к своему аккаунту. Пользователь сайта может привязать к своему аккаунту одну или сразу несколько сетей. И в дальнейшем их использовать для входа на сайт под своим аккаунтом. Для того чтобы привязать социальную сеть к своему аккаунту, пользователь должен быть авторизован на сайте, зайти в свой профиль и там осуществить привязку. При этом аккаунт в социальной сети может быть любым и не имеет никаких требований по совпадению, например e-mail адресов. Для привязки социальных сетей в шаблоне профиля пользователя используются те же теги для авторизации через социальные сети, какие используются в шаблоне login.tpl: {vk_url}, {odnoklassniki_url}, {facebook_url}, {google_url}, {mailru_url}, {yandex_url}

qДобавлена возможность отвязать от аккаунта на сайте любую из социальных сетей. Даже если она изначально использовалась для первоначального входа на сайт и первой регистрации. Для этого в шаблоне вывода профиля пользователя добавлена поддержка тега {social-list} который выводит список привязанных социальных сетей и ссылки на их отключения от данного аккаунта.

qВ настройки категорий в админпанели скрипта, добавлена возможность назначения каждой категории своего отдельного типа рейтинга для публикаций. Теперь каждая категория может иметь свой отдельный вид рейтинга, а не только один общий для всего сайта.

qВ админпанели в разделе редактирования публикаций, добавлена возможность пересчёта количества комментариев у публикации. Вы можете запускать пересчёт не только комментариев у всех публикаций, что является очень долгим и ресурсоёмким процессом, но пересчитать комментарии только конкретной публикации. Данная функция будет полезна если работа в базе данных над комментариями была произведена, минуя DLE, например импорт в БД информации, удаление или некорректная работа сторонних плагинов.

qВ админпанели в разделе редактирования публикаций, для массовых действий для выбранных публикаций, добавлена возможность пересчёта комментариев. Тем самым вы можете в один клик сделать пересчёт всех комментариев, только для выбранных публикаций.

qВ админпанели в разделе редактирования публикаций, для массовых действий для выбранных публикаций, добавлена возможность удаления всех. Тем самым вы можете в один клик удалить все комментарии для выбранных вами публикаций.

qПри добавлении или редактировании публикаций, в случае если какое-либо дополнительное поле является обязательным, добавлен вывод информации о том какое именно поле является не заполненным и его необходимо заполнить. Ранее выводилась общая ошибка о том, что какое-либо поле не заполнено, и пользователю приходилось самостоятельно искать какое именно поле является обязательным.

qДобавлена возможность загружать иконки для категорий непосредственно с использованием админпанели DataLife Engine. Осуществить загрузку иконок можно в разделе управления категориями, при добавлении или редактировании категории.

qДля шаблонов вывода публикаций, а также для шаблона вывода меню категорий добавлена поддержка новых тегов: [category-icon] текст [/category-icon] выводят текст, заключенный в них, если для категории, где находится публикация, была задана иконка в настройках категории. А также добавлена поддержка противоположных тегов: [not-category-icon] текст [/not-category-icon] которые выводят текст если для категории, где находится публикация, не задана иконка. Тем самым вы можете более гибко создавать оформление ваших шаблонов в зависимости от того есть ли у категории иконка или нет.

qДля шаблона вывода меню категорий добавлен вывод ссылки на иконку по умолчанию, в случае если для категории не была указана ссылка на иконку категории. Ранее тегом вывода иконки выводилось пустое значение если иконка не была задана в настройках категории.

qДобавлена возможность использования в поиске по сайту символов @ и ~, которые являлись служебными при полнотекстовом поиске на таблицах, использующих InnoDB.

qДобавлена поддержка сжатия данных по алгоритму Brotli для JS, CSS и HTML, которые формирует DataLife Engine. Данный метод является более эффективным и более быстрым чем обычное zip сжатие данных. Для использования данного алгоритма сжатия на сервере должны быть установлены соответствующие серверные расширения для PHP. Использование данного алгоритма происходит полностью автоматически если DLE определит поддержку этого алгоритма вашим сервером, в случае отсутствия поддержки то сжатие будет автоматически осуществляться доступными средствами, например, zip сжатием.

qДобавлена поддержка сжатия данных по алгоритму Brotli для JS, CSS и HTML, которые формирует DataLife Engine. Данный метод является более эффективным и более быстрым чем обычное zip сжатие данных. Для использования данного алгоритма сжатия на сервере должны быть установлены соответствующие серверные расширения для PHP. Использование данного алгоритма происходит полностью автоматически если DLE определит поддержку этого алгоритма вашим сервером, в случае отсутствия поддержки то сжатие будет автоматически осуществляться доступными средствами, например, zip сжатием.

qДобавлена возможность в настройках скрипта в админпанели указывать символ разделитель для ключевых слов, назначенных для облака тегов, при их выводе в публикациях на сайте.

qДобавлена возможность для разделителей вывода категорий и для модуля хлебных крошек, использовать HTML код, при их задании в настройках скрипта. Например, вы можете задать там "</span><span class="test">" для того чтобы сделать более гибкое и разнообразное оформление вашего шаблона.

qДобавлена поддержка отложенной загрузки видеороликов Youtube опубликованных с использованием тега [media=...] а также любого иного контента, опубликованного при использовании HTML тега iframe. В случае включения отложенной загрузки изображений в настройках скрипта, данная отложенная загрузка будет также осуществляться и для вышеуказанного контента. Что также будет дополнительно ускорять загрузку страниц вашего сайта, т.к. необходимый контент будет загружаться в браузер только по мере прокрутки страницы пользователем.

qДобавлена поддержка отложенной загрузки изображений, для изображений опубликованных в текстах комментариев пользователей. Ранее поддержка отложенной загрузки изображений была только для новостей.

qВ окно загрузки файлов, при выводе информации о ограничениях на размер и объём загружаемых данных, добавлен также учёт ограничений, установленных в серверных настройках. Например, если в настройках скрипта для пользователя разрешено загружать файл размером в 5 мегабайт, а серверные настройки не позволяют загружать более 2 мегабайт, то также при загрузке будет указан что максимальный объём именно 2 мегабайта. Что позволяет сразу избегать путаницы если есть расхождение между настройками скрипта и сервера.

qДля модуля загрузки изображений и файлов добавлен показ также количества файлов, которые может загружать пользователь, если установлено ограничение на количество в настройках.

qДля расширенного поиска публикаций в админпанели добавлена возможность поиска запрещённых для индексации поисковиками публикаций. Тем самым вы можете быстро найти публикации, где необходимо изменить данную опцию.

qДля расширенного поиска публикаций в админпанели добавлена возможность поиска запрещённых для поиска на сайте публикаций. Тем самым вы можете быстро найти публикации, где необходимо изменить данную опцию.

qВнесены изменения в логику работы подсчёта количества новостей для меню категорий. Ранее подсчёт осуществлялся на основе глобальной настройки осуществлять или нет вывод новостей, принадлежащих подкатегориям. Теперь же подсчёт осуществляется на основе настройки каждой категории, назначенной персонально для каждой категории.

qДля публикуемых ссылок на сайте, добавлена поддержка протоколов viber://, tg://, skype://, market:// которые позволяют открывать ссылки на сайте в приложениях, установленных для телефона. Таких как Вайбер, Телеграмм, Скайп и Андроид Маркет

qДля модуля создания резервной копии базы данных добавлена совместимость переноса базы данных с более высокой версии на более низкую. Например, сайт был изначально создан на MySQL 8.0 и переносится на другой сервер где установлен MySQL 5.7. Бекап базы в данном случае будет создан в совместимом с MySQL 5.7 формате.

qВ случае если на странице расположено несколько плееров с видео и аудио, добавлена автоматическая остановка проигрываемых файлов, если пользователь на данной странице включает видео или аудио, находящихся в других плеерах.

qВнесены изменения в систему формирования меню категорий. В случае если в настройках групп запрещён просмотр каких-либо категорий, и при этом также запрещён просмотр кратких новостей из этих категорий, то данные категории будут также автоматически исключены из показа в меню для данной группы пользователей.

qВидеоплеер DLE обновлён до актуальной версии. Был исправлен ряд небольших ошибок, и улучшено воспроизведение видео на мобильных устройствах.

qДля модуля "Поиск и Замена" в админпанели добавлен также поиск и замена в заголовках новостей, если указан поиск по новостям и заголовкам статических страниц, если указан поиск и замена по статическим страницам.

qПри регистрации пользователя на сайте добавлена автоматическая проверка логинов, по ключевым словам, заданным в модуле "Фильтр слов" в админпанели. В случае совпадения с фильтром в регистрации пользователю будет отказано. Данная возможность будет полезна в том случае если вы задаёте фильтр матерных слов, и нет необходимости дополнительно заполнять запрещённые для регистрации имена в фильтрах, предназначенных для регистрации.

qДобавлено автоматическое удаление тегов вывода значений дополнительных полей из шаблона, в случае если данные этих дополнительных полей отсутствуют. Например, есть дополнительное поле с типом "галерея", и вы выводите ее значения не единым тегом вывода, а каждую картинку по отдельности при помощи тега [xfvalue_X image="Nr"], и в случае если какое либо изображение не было загруженных из указанных, то тег его вывода будет автоматически скрыт. Данное нововведение касается не только вывода изображений, а вообще вывода любых дополнительных полей и их значений.

qДобавлен запрет на отправку персональных сообщений пользователям, которые находятся в группе, для которой, запрещено использование персональными сообщениями. Ранее сообщения можно было отправлять, но прочитать пользователи могли их только когда этот запрет будет снят.

qДобавлено автоматическое сохранение сортировки дополнительных полей профиля пользователей в админпанели. Сохранение осуществляется автоматически при изменении порядка, без необходимости нажатия отдельной дополнительной кнопки для сохранения.

qДобавлено автоматическое скрытие комментария, ожидающего модерации, в админпанели в разделе управления данными комментариями, после его редактирования и публикации на сайте. Тем самым модератор может быстро дальше переходить к обработке следующего комментария.

qДобавлен автоматический пересчёт статистики в панели управления в случае редактирования комментариев ожидающих модерации.

qВнесены изменения в систему фильтрации входящих данных, предназначенной для поиска по сайту, в связи с чем улучшен поиск по некоторым ключевым словам.

qОптимизирована сортировка дополнительных полей для публикаций в админпанели. Тем самым добавлена возможность производить многократную сортировку или действия над полями, без необходимости предварительной самостоятельной перегрузки страницы.

qУлучшена система определения используемого протокола сайта http или https, предотвращающая некорректное чтение настроек сервера на определённых конфигурациях.

qУлучшена система контроля неверных ссылок ЧПУ для некоторых разделов сайта и ссылок.

qОбновлены визуальные редакторы TinyMCE и Froala до актуальных версий. Исправлен ряд выявленных ошибок в данных редакторах.

qВнесены изменения в работу системы контроля учётов голосов при выставлении рейтинга для публикаций и комментариев, исправляющие проблему при которой некоторые пользователи не могли изменить свой голос.

qИсправлена проблема с формированием ссылки на полную новость, если категория была отключена, и она являлось при этом первой категорией из списка нескольких категорий.

qИсправлена проблема, при которой возникали JS ошибки в случае включения использования нативных смайлов Emoji и отключения редактора для комментариев.

qИсправлена проблема, при которой возникали JS ошибки в случае включения использования нативных смайлов Emoji и отключения редактора для комментариев.

qИсправлена проблема, при которой не убирались автоматически опции новости "Публиковать на главной", "Разрешить комментарии" и "Разрешить рейтинг" при добавлении или редактировании публикаций в админпанели, если одновременно несколько категорий имели запрет на использование данных опций у публикации.

qИсправлена проблема, при которой дублировался заголовок List-Unsubscribe при массовой рассылке писем с сайта.

qИсправлена проблема, при которой в ряде случаев, могли удаляться опубликованные комментарии и производится неверный подсчёт комментариев при работе с ожидающими модерации комментариями.

qИсправлена проблема, при которой не работал расширенный поиск по комментариям, если был включён полнотекстовый поиск в настройках скрипта, а также включена модерация комментариев.

qИсправлена проблема, при которой не работал расширенный поиск по комментариям, если был задан временной период за которые необходимо искать комментарии.

qИсправлена проблема, при которой неверно формировался метатег description, если новость не добавлялась и не редактировалась в админпанели, при этом контент публикации слишком маленький.

Список изменений относительно версии 13.3:

qДобавлен новый плеер для проигрывания видео на сайте. Новый плеер обладает улучшенной поддержкой актуальных браузеров и устройств и имеет более современный дизайн. Помимо визуальных улучшений новый плеер имеет и новые функциональные возможности, а именно поддерживает режим "Картинка в Картинке" для браузера, а для устройств Apple поддерживает проигрывание видео по AirPlay на другие устройства. Также в плеере реализовано несколько различных цветовых схем, которые вы можете выбрать в настройках плеера в админпанели.

qДля автоматической системы обновления плагинов, добавлена передача версии DLE на сервер проверки наличия новых версий плагина, при помощи параметра 'version', который содержит в себе версию установленного скрипта DLE на данном сайте. Сервер разработчика плагина может проверить какая версия DLE используется и в зависимости от этого либо отдавать информацию о наличии новой версии или нет. А также может отдавать разные версии и копии плагина для разных версий DLE. Тем самым можно исключить, когда новая версия плагина будет отдаваться на сайт с более старой версией DLE, которую данный плагин не поддерживает. Информация о версии DLE может быть передана как POST запросом, так и GET, в зависимости от наличия тех или иных настроек на сайте где работает DLE, поэтому для разработчиков плагинов рекомендуется проверять версию через входящую глобальную переменную $_REQUEST['version'].

qДобавлена возможность использования в редакторах для новостей и комментариев нативных Emoji смайлов. При включении данной настройки вместо картинок со смайлами будет выводится список поддерживаемых операционной системой пользователя Emoji смайлов. Визуальный вид смайлов также напрямую зависит от того на каком устройстве будет просматриваться контент. Общее количество смайлов поддерживаемых DataLife Engine более полутора тысяч. Для удобства Emoji смайлы сгруппированы по категориям, а также на самом верху списка отображаются 16 смайлов, которые пользователь использовал в последний раз. Тем самым наиболее используемые смайлы ему не придется постоянно искать в общем списке. Включается поддержка нативных Emoji в настройках скрипта в админпанели. В случае отключения данной настройки, используется обычная система смайлов, основанная на изображениях, как и ранее. Поддержка нативных Emoji добавлена во всех трех редакторах, имеющихся в DLE.

qДля изображений, загружаемых на сервер добавлена возможность включения обработки изображений при помощи сервиса TinyPNG. Данный сервис производит дополнительное сжатие картинок, по самым современным алгоритмам без потери качества, что позволяет существенно снизить их размер и как следствие существенно ускорить загрузку ваших сайтов. Помимо этого, при создании уменьшенных копий с фиксированными размерами, данный сервис может производить поиск на изображении значимых обьектов (лиц людей, животных) и тем самым создавать более качественные уменьшенные копии с более полезной на них информацией в полностью автоматическом режиме. Включается данная возможность в настройках скрипта в админпанели. Так как бесплатное использование сервиса ограниченно определенным объёмом картинок в месяц, в настройках скрипта вы можете отключить ряд параметров для уменьшения количества использования данного сервиса. Например, можно отключить использование для аватаров, или отключить алгоритмы интеллектуального поиска объектов.

qДля публикаций добавлен новый тип дополнительного поля 'Дата и время'. В данном поле вы можете добавлять дату и время, а для удобства добавления для данного поля используется всплывающий календарь при его заполнении. Данное поле имеет три формата ввода на выбор, это дата и время, только дата и только время. В настройках данного поля вы можете также задать формат вывода указанной даты по своему усмотрению. Также данное поле имеет дополнительные опции где вы можете указать нужно ли локализовать дату при выводе, например, переводить на язык, используемый вашим сайтом, и нужно ли проводить склонение выбранной даты. Также данное поле может использоваться как перекрестные ссылки для взаимосвязи с другими новостями на сайте.

qПолностью переработана цветовая схема ночной темы оформления в админпанели. Новая цветовая схема была разработана специально с учетом комфортной работы с ней как днем, так и ночью. В связи с чем световая палитра была смешена в сторону более мягких цветовых оттенков.

qВ настройки оформления админпанели добавлена возможность включения автоматического включения ночного режима для панели управления. При этом панелью будет учитываться время года, т.к. в разное время года темнеет в разное время. А также будет учитываться часовой пояс пользователя, который он установил в настройках, если он отличается от часового пояса сайта. Все это позволяет админпанели более оптимально автоматически переводить отображение панели на ночную схему.

qДобавлена возможность включать и отключать категории. Данная возможность позволит вам при необходимости временно выключить категорию если она в какой-то момент не нужна, вместо ее удаления. Так как удаление категории и повторное ее добавление меняет его ID и как следствие теряется ее привязка к существующим новостям, включение и отключение категории является альтернативным действием, при котором категория убирается с сайта, но при обратном включении возвращается все в обратное состояние и ранние новости также сохраняют свою привязку к данной категории и появляются в ней автоматически при включении категории.

qПри добавлении и редактировании публикаций добавлена возможность указывать самостоятельно ID похожих новостей для данной публикации. При этом вы можете задать также и порядок вывода похожих новостей, они будут выводится ровно в том порядке, в котором вы их указали. Данное поле можно оставить пустым, в таком случае поиск произойдет автоматически. Также вы можете осуществить повторный автоматический поиск похожих публикаций только для одной конкретной новости, без необходимости сброса кеша похожих публикаций для всех новостей.

qДобавлена возможность выводить навигацию по страницам для вывода кратких новостей и для пользовательского вывода новостей, отдельно от непосредственно самого блока новостей. Для этого в шаблон main.tpl добавлена поддержка следующих тегов: {navigation} выводит блок навигации по страницам, [navigation] текст [/navigation] выводит текст, заключённый в них если навигация по новостям имеется, [not-navigation] текст [/not-navigation] выводит текст, заключённый в них если навигация отсутствует. Все данные теги являются дополнительными и необязательными и в случае их отсутствия навигация будет выводится, как и ранее в блоке непосредственно новостей, согласно настройкам скрипта. Тем самым вы можете более гибко создавать нужное вам оформление сайта в шаблонах.

qДобавлена возможность при удалении пользователя, в случае если он имеет публикации на сайте, назначить нового автора для его публикаций. А также при желании можно оставить автора неизменным.

qДобавлена возможность вывода последних просмотренных пользователем публикаций. Для этого используется тег пользовательского вывода новостей с параметром order="lastviewed", например, {custom order="lastviewed"}. При этом сортировка осуществляется по принципу последний просмотренный, показывается первым. Для осуществления обратной сортировки используется параметр sort="asc". Например, {custom order="lastviewed" sort="desc"} сортировка будет от последнего просмотренного к более раннему, а при {custom order="lastviewed" sort="asc"} сортировка будет от более раннего просмотренного к более позднему. Данная функция будет особенно полезна для сайтов публикующих, например, каталоги, и для показа блоков в которых посетитель может быстро перейти на ранее просмотренные публикации. Включается и отключается учет просмотренных новостей в настройках скрипта в админпанели. DataLife Engine запоминает 20 последних просмотренных публикаций.

qДобавлена возможность выводить данные из профиля пользователя, который просматривает в данный момент сайт, во всех файлах шаблона. Для этого было введено более тридцати новых глобальных тегов, которые содержат в себе информацию из пользовательского профиля, включая данные из его дополнительных полей. Тем самым вы можете вывести данные авторизованного пользователя не только к примеру, в login.tpl, а также и в main.tpl и в других шаблонах, что открывает новые возможности к гибкому созданию шаблонов. Так как эти данные возможны к использованию в любых шаблонах, будьте внимательны к их использованию в шаблонах, которые подлежат полному кешированию, например, шаблон вывода кратких новостей. В таких случаях кеширование нужно будет отключать.

qДля шаблона поиска (search.tpl) добавлена возможность верстать таблицу с параметрами поиска по своему усмотрению. Для этого помимо общего {searchtable} который выводит все параметры для задания поиска целиком, было дополнительно добавлено 15 новых тегов, каждый из которых выводит только одно поле ввода или выбора без привязки к визуальному оформлению. Тем самым вы можете создать свое нужное вам оформление поиска, встроить его в оформление любого HTML фреймворка, убрать ненужные вам поля и опции и так далее.

qВ настройки скрипта добавлена возможность включения и отключения использования Яндекс Дзен при экспорте RSS потока. В случае отключения данной возможности, данная опция не будет отображаться при добавлении и редактировании публикаций.

qВ настройки скрипта добавлена возможность включения и отключения использования Яндекс Турбо при экспорте RSS потока. В случае отключения данной возможности, данная опция не будет отображаться при добавлении и редактировании публикаций.

qВ админпанели, в разделе редактирования публикаций, добавлена возможность при расширенном поиске, осуществить поиск публикаций, содержащих определенные ключевые слова из облака тегов. Тем самым вы можете быстро выбрать для редактирования публикации, которые содержат нужное ключевое слово из облака тегов.

qВ админпанели, в разделе редактирования публикаций, добавлена возможность для массовых действий над новостями, включать и отключать Яндекс Дзен для выбранных публикаций.

qВ админпанели, в разделе редактирования публикаций, добавлена возможность для массовых действий над новостями, включать и отключать Яндекс Турбо для выбранных публикаций.

qВ настройки категорий добавлена возможность указывать включено ли для данной категории использования Яндекс Дзен по умолчанию или нет. В случае отключения данная опция будет автоматически отключена по умолчанию при выборе данной категории при добавлении новости. Тем самым нет необходимости каждый раз отключать эту опцию у каждой новости. Но вы можете всегда включить эту опцию у новости отдельно при желании.

qВ настройки категорий добавлена возможность указывать включено ли для данной категории использования Яндекс Турбо по умолчанию или нет. В случае отключения данная опция будет автоматически отключена по умолчанию при выборе данной категории при добавлении новости. Тем самым нет необходимости каждый раз отключать эту опцию у каждой новости. Но вы можете всегда включить эту опцию у новости отдельно при желании.

qДля пользовательского вывода публикаций на сайте при помощи тега {custom ...} добавлена поддержка нового параметра sortbyuser="yes" который разрешает возможность использования пользовательской сортировки [sort]{sort}[/sort] для данного блока публикаций. В случае если включен данный параметр, то посетители сайта могут сами выставлять удобную им сортировку новостей для даннного блока по своему желанию, аналогично как они это могут делать для тега {content}.

qДобавлена возможность автоматического импорта аватаров пользователей при их авторизации на сайте с помощью сервисов Google и Яндекса.

qВ связи с появлением нового API 2.0 для авторизации на сайте с использованием mail.ru, и возможным скорым отключением поддержки старого API на данном сервисе, добавлена поддержка нового API 2.0 https://o2.mail.ru. Внимание новое API требует создание нового приложения на сервисе. Поэтому если на вашем сайте уже присутствует авторизация через mail.ru, то вам необходимо создать новое приложение https://help.mail.ru/developers/oauth/app после чего задать данные этого приложения в настройках DataLife Engine в админпанели.

qДобавлено формирование метатега og:description протокола Open Graph при просмотре статических страниц на сайте.

qДля шаблонов вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl) добавлена поддержка новых тегов [not-image-x] текст [/not-image-x] которые выводят текст, указанный в них только в случае если картинка с номером X отсутствует в новости. Данные теги будут полезны для вывода, например, каких-либо собственных заглушек, если отсутствует нужная картинка в тексте публикации.

qДля комментариев (шаблон comments.tpl) добавлена поддержка использования баннерных тегов {banner_X} из модуля рекламных материалов в админпанели. Тем самым вы можете, например, вставлять рекламные теги между комментариями в определенных местах.

qДля комментариев (шаблон comments.tpl) добавлена поддержка использования баннерных тегов {banner_X} из модуля рекламных материалов в админпанели. Тем самым вы можете, например, вставлять рекламные теги между комментариями в определенных местах.

qДля рейтинга публикаций добавлено использование нового тега {ratingscore} в шаблонах вывода краткой и полной новости (shortstory.tpl и fullstory.tpl). Данный тег выводит число усредненного рейтинга от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д. Данный тег позволяет задать, например, собственное оформление звезд рейтинга с частичным заполнением, а не только 2 или 4 заполненных звезды.

qДля рейтинга комментариев также добавлено использование нового тега {ratingscore} в шаблоне вывода комментариев (comments.tpl). Данный тег выводит число усредненного рейтинга от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д. Данный тег позволяет задать, например, собственное оформление звезд рейтинга с частичным заполнением, а не только 2 или 4 заполненных звезды.

qПри использовании массовой рассылки писем в админпанели, добавлено использование рекомендованного заголовка Precedence: bulk; в письмах. В целях избегания попадания вашей рассылки в спам.

qДобавлена поддержка поиска автоматической подсказки без учета регистра букв при заполнении облака тегов и дополнительных полей, имеющих тип 'перекрестные ссылки'. При этом сами поля сохраняются в базе данных с учетом указанного при заполнении полей регистра букв.

qДобавлена поддержка тегов {title limit="X"} и {short-story limit="X"} для шаблонов вывода RSS потока.

qАдаптирован показ подсказок в админпанели, в зависимости от размеров экрана мониторов. Теперь расположение подсказок будет таким, чтобы они помещались на экран корректно, независимо от размеров экрана монитора и его разрешения.

qДля дополнительных полей, имеющих тип "перекрестные ссылки", добавлена поддержка использования символов фигурных и квадратных скобок, а также двоеточия.

qУвеличена скорость перестроения публикаций в админпанели, а также исправлены проблемы, которые могли приводить к некорректной конвертации некоторых символов в дополнительных полях.

qДобавлена регистронезависимая проверка логинов и e-mail адресов, запрещенных для регистрации, написанных на кириллице и других языках, отличных от английского.

qДобавлена поддержка копирования аватаров пользователей из социальной сети Вконтакте после изменений в API данной социальной сети.

qПроведена адаптация кода и добавлена поддержка PHP 7.4.xx

qОбновлена библиотека HTML Purifier до актуальной версии.

qДля функции GzipOut добавлена возможность передачи второго параметра, при использовании которого в отладочной информации будет выведена вся информация по MySQL запросам, а именно сколько времени заняло выполнение того или иного MySQL запроса, и какой запрос был осуществлен к базе данных. Например при использовании GzipOut(true) будет выведена общая отладочная информация по скрипту, а при использовании GzipOut(true, true) будет выведена также дополнительная информация по каждому MySQL запросу к БД. Данное нововведение будет полезно разработчикам модулей и оптимизаторам сайтов для выявления проблем и диагностики.

qПри редактировании пользователей в админпанели и на сайте изменен формат вывода даты в поле, в котором указана дата, до которой он находится во временной группе. Формат был адаптирован под используемый всплывающим календарем, чтобы в календаре отображалась указанная дата и время.

qИсправлена проблема, при которой не работала динамическая загрузка комментариев с использованием Ajax при включении в настройках скрипта jQuery 3.xx

qИсправлена проблема, при которой нельзя было удалить пользователя при редактировании его профиля непосредственно на сайте.

qИсправлена проблема, при которой при одновременной смене e-mail адреса и включении двухфакторной авторизации в настройках профиля, невозможно было подтвердить смену e-mail адреса, если старый почтовый ящик недоступен.

qИсправлена проблема, при которой не работал переход в полноэкранный режим админпанели в браузере Chrome.

qИсправлена проблема, при которой могло некорректно работать цитирование выделенного текста в публикациях при использовании визуального редактора Froala

qИсправлена проблема, при которой некорректно работали теги [sort] ... [/sort] при просмотре полной новости.

qИсправлена проблема, при которой некорректно мог обрабатываться тег {THEME} если он был опубликован в текстах новостей при перестроении публикаций в админпанели.

qИсправлена проблема, при которой некорректно работало добавление блокировки по IP в настройках профиля на сайте, если использовались звездочки вместо IP маски.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 13.2:

qДля системы плагинов добавлены заметки. Вы можете для каждого плагина в соответствующей вкладке написать заметки, памятки или инструкции. Вы можете также указать, выводить ли данные заметки на главной странице в списке плагинов или нет. При этом сами заметки могут содержать HTML оформление либо могуть быть написаны с использованием BB тегов.

qДобавлена возможность устанавливать порядок сортировки плагинов в панели управления. Выставление сортировки осуществляется удобным способом, в виде простого переноса элементов непосредственно на странице админпанели. При этом изменение порядка сортировки также влияет и на порядок выполнения плагинов.

qПри редактировании плагина, в случае если в нем зафиксированы ошибки, добавлена новая вкладка со списком данных ошибок. Тем самым вы можете удобно видеть ошибки, исправлять их непосредственно при редактировании данного плагина, оставаясь на одной странице в браузере.

qДля модуля "Заголовки, описания, метатеги" добавлена возможность назначать метатег robots для страниц. Тем самым вы можете для каждой страницы при необходимости задать собственные правила для индексирования страницы, или запрета индексации.

qДобавлена возможность в настройках скрипта в админпанели указывать минимальное количество символов, при котором будет осуществляться поиск по сайту. Ранее данное значение было жестко зафиксировано на 4 минимальных символах. Теперь администраторы сайтов сами могут устанавливать данное значение непосредственно через настройки.

qДобавлена возможность отдельно включать или исключать из RSS потока каждую новость. Для этого при добавлении или редактировании публикации в админпанели, для нее добавлена соответствующая опция. Тем самым вы можете тонко определять какую публикацию вы хотите добавлять в RSS поток, а какую нет. Данная опция разрешена только для групп пользователей со статусом не ниже главного редактора сайта.

qДобавлена возможность устанавливать для каждой публикации отдельно разрешено ли ее использование в Яндекс Турбо или нет. Для этого при добавлении или редактировании публикации в админпанели, для нее добавлена соответствующая опция. А также для поддержки этой опции в шаблон rss.tpl введены новые шаблонные теги: {allow-turbo} выводит текст "true" или "false" в зависимости от того включено ли использование турбо опции или нет, и теги [allow-turbo] текст [/allow-turbo] которые выводят текст, заключенный в них если Яндекс Турбо для публикации включен.

qДобавлена возможность устанавливать для каждой публикации отдельно разрешено ли ее использование в Яндекс Дзен или нет. Включается и отключается данная опция при добавлении или редактировании публикации в админпанели. Для поддержки этой опции в шаблон rss.tpl введены новые шаблонные теги: [allow-dzen] текст [/allow-dzen] которые выводят текст, заключенный в них если Яндекс Дзен для публикации включен.

qДобавлена возможность для изображений, загружаемых к публикациям, устанавливать лимит на минимальные размеры в настройках скрипта. Если изображение меньше указанных размеров, то оно не будет загружено, а пользователю будет выведено соответствующее уведомление. Тем самым вы можете ограничить добавление изображений к публикациям, которые не соответствуют вашим критериям.

qДля дополнительных полей, имеющих тип "Изображение" и "Галерея изображений", добавлена возможность указывать минимальные размеры для загружаемых изображений. Если размеры изображения будут меньше, то оно не будет загружено, а пользователь увидит соответствующее уведомление. Тем самым вы можете ограничить добавление изображений к публикациям, которые не соответствуют вашим критериям.

qДля изображений, добавляемых к комментариям, добавлена также возможность указывать минимальные размеры в настройках групп пользователей. Если размеры изображения будут меньше, то оно не будет загружено, а пользователь увидит соответствующее уведомление.

qВ настройки скрипта в админпанели добавлена возможность выбирать какую линейку jQuery использовать на сайте. Вы можете выбрать использование либо линейки 2.xx либо использование 3.xx. Тем самым вы можете либо использовать новейшие версии библиотек, либо использовать совместимые со своими JS плагинами библиотеки. При использовании линейки jQuery 3.xx подключается также использование новейшей версии библиотеки jQueryUI.

qВ настройки скрипта в админпанели добавлена возможность указывать, необходимо ли склонять дату публикации, при ее выводе при помощи пользовательского тега. При включении данной настройки, если дата публикации выводится при помощи тега {date=формат даты}, то название месяца будет склоняться на основе информации из языковых файлов. Например, публикация была добавлена в январе, то будет выводится '1 января', а при отключенной настройке '1 январь'.

qМикроразметка хлебных крошек была полностью переведена на использование стандарта schema.org вместо устаревшего стандарта data-vocabulary.org

qДобавлена поддержка HTML тегов map и area в текстах публикаций. Данные теги позволяют производить разметку изображений поделив их на секции с ссылками.

qДля e-mail писем, отправляемых в админпанели в разделе "Рассылка сообщений", добавлено использование служебного заголовка List-Unsubscribe, что позволит пользователям быстро и удобно отписываться от рассылок непосредственно через интерфейс почтового сервиса. Данный заголовок не включается в письмо если оно отправляется на сервис mail.ru, причины этому вы можете прочитать по адресу https://habr.com/ru/post/280141/

qДобавлены новые глобальные шаблонные теги: {category-icon} - выводит иконку просматриваемой пользователем категории, либо категории новости, если просматривается полная новость, а также добавлен тег {category-url} - который выводит URL просматриваемой категории. Глобальные шаблонные теги могут использоваться в любых файлах шаблонов, например, в main.tpl. Данные шаблонные теги будут полезны как для дополнительного оформления контента на страницах сайта, так и при формировании метатегов страницы.

qДля системы жалоб на сайте, в случае отправки жалобы незарегистрированным пользователем, добавлена возможность указания им своего E-mail адреса, чтобы администрация сайта в дальнейшем могла ответить ему на его жалобу. Указание E-Mail адреса для посетителя является не обязательным, он может оставить это поле по своему желанию пустым.

qДобавлен контроль имен ЧПУ для публикаций, в случае если на сайте включен тип ЧПУ номер 3. В случае если в этот день уже была ранее добавлена публикация с таким же именем ЧПУ, то добавить публикацию с такой же ЧПУ ссылкой не получится. И для пользователя будет предложено изменить имя ЧПУ на любое другое. Тем самым избегается конфликт адресов, для публикаций с одним и тем же заголовком или ЧПУ ссылкой, опубликованных в один и тот же день.

qДобавлена поддержка новых глобальных тегов: [ios] текст [/ios] которые выводят текст заключенных в них, в случае если устройство посетителя сайта использует операционную систему iOS от Apple, а также добавлена поддержка противоположных тегов: [not-ios] текст [/not-ios] которые выводят текст заключенных в них, в случае если устройство посетителя сайта не использует операционную систему iOS. Поддержка данных тегов позволяет не только определять тип устройства пользователя, но и его принадлежность, применяя нужное оформление сайта, например давать ссылку на скачивание подходящего приложения из магазина приложений Apple.

qДобавлена поддержка новых глобальных тегов: [android] текст [/android] которые выводять текст заключенных в них, в случае если устройство посетителя сайта использует операционную систему Android от Google, а также добавлена поддержка противоположных тегов: [not-android] текст [/not-android] которые выводят текст заключенных в них, в случае если устройство посетителя сайта не использует операционную систему Android. Поддержка данных тегов позволяет не только определять тип устройства пользователя, но и его принадлежность, применяя нужное оформление сайта, например, давать ссылку на скачивание подходящего приложения из магазина приложений Google.

qДобавлена поддержка загрузки и обработки изображений в формате WEBP для комментариев и аватаров для профилей пользователей, а также в разделе управления изображениями в админпанели.

qДобавлена поддержка формата WEBP для тегов вывода изображений {image-x}. А также добавлена поддержка этого формата для использования метатегах OpenGraph для социальных сетей.

qДобавлена запись в логи действий в админпанели действий по добавлению публикации с сайта, в случае если данная новость публикуется на сайте сразу без модерации. Ранее в логах фиксировалось добавление публикации только в панели управления.

qДобавлено сохранение параметров публикации в случае если ее редактирует пользователь, которому разрешено изменять не все параметры публикации. Например, исключать публикацию из поиска или из индексации могут только пользователи из групп не ниже чем главный редактор или администратор, и в случае если новость редактирует журналист, то эти параметры останутся такими, какими их установил администратор сайта.

qДобавлена поддержка отложенной загрузки изображений для статических страниц на сайте.

qДобавлена поддержка вывода заголовков публикаций при выводе ссылок на предыдущую и следующую новости. Для этого в шаблон вывода полной новости добавлена поддержка следующих тегов: {prev-title} - который выводит заголовок предыдущей новости, {next-title} - который выводит заголовок следующей новости.

qДля HTML тегов < vidео > и < аudio > добавлена поддержка всех HTML атрибутов согласно спецификации HTML5.

qПроведена оптимизация быстрого редактирования публикаций на сайте. Добавлено автоматическое определение необходимости автоматического переноса строк, в зависимости от редактора, и при использовании визуальных редакторов, опция "автоматический перенос строк" больше не выводится и не используется.

qВ админпанели скрипта на главной странице, добавлен вывод информации о возникновении ошибок в работе установленных плагинов. Тем самым вы можете быстро увидеть, что каком-либо плагине возникли ошибки, например, после обновления скрипта до актуальной версии, без необходимости посещения раздела управления плагинами. Также с главной страницы вы можете сразу перейти к просмотру возникших ошибок.

qПри просмотре всех опросов на сайте в соответствующем всплывающем окне изменен порядок показа опросов. Теперь сначала показываются актуальные опросы.

qВ случае если добавление публикации на сайте осуществляется по пользовательской ссылке, с указанием предустановленных категорий, то при после добавления публикации на сайт, если пользователь захочет добавить еще одну публикацию, то по ссылке "Добавить еще", он будет возвращен на страницу добавления публикации также с ранее предустановленными категориями.

qДля пользовательского вывода публикаций {custom xfields="..." ...}, улучшена обработка параметра поиска публикаций по дополнительным полям xfields="...", в данном параметре теперь можно использовать одинарные кавычки для поиска значений, а также ряд других специальных символов ранее недоступных для поиска.

qДобавлена полная поддержка PHP линейки 7.3.x

qДобавлена полная поддержка PHP линейки 7.3.x

qВнесены изменения в работу подсчета счетчика публикаций в категориях. Ранее учитывались только общая настройка "выводить или нет новости в подкатегориях" при подсчете публикаций, теперь же учитываются персональные настройки каждой категории, указанные в разделе управления категориями.

qВнесены изменения в работу тега [xfvalue_thumb_url_X] для дополнительных полей, имеющих тип "Изображение". В случае если для данного поля не была создана уменьшенная копия, т.к. оригинальное изображение меньше изначально, то данный тег выведет ссылку на оригинальное изображение. Тем самым не будет возникать случаев, когда на странице вывода публикаций, данный тег ничего не выводит если нет уменьшенных копий.

qУлучшена система сортировки категорий и дополнительных полей в админпанели. Все изменения в сортировке сохраняются сразу автоматически после изменения порядка, без необходимости сохранения изменений по нажатию отдельной кнопки.

qУлучшено формирование метатега og:description протокола Open Graph при просмотре полных новостей. Формирование происходит более корректно с автоматическим удалением ряда служебных тегов, например, тегов рекламных баннеров и т.д.

qУлучшено и оптимизировано автоматическое формирование метатега для описания страницы Description. Добавлена фильтрация некоторых служебных тегов и предотвращено появление двойных пробелов.

qУлучшена производительность и снижена нагрузка на сервер, при обработке показа страниц для несуществующих категорий на сайте.

qОбновлены визуальные редакторы TinyMCE и Floara до актуальных версий, без смены линейки редакторов. В редакторах был исправлен ряд незначительных ошибок в них, при этом линейка осталась неизменной для сохранения привычной функциональности и вида редакторов.

qИсправлена проблема, при которой не отображались изображения, на страницах для печати, в случае если была включена отложенная загрузка изображений в настройках скрипта.

qИсправлена проблема, при которой могли возникать дубли страниц, для облака тегов и поиска по дополнительным полям, в случае написания значений с использованием разного регистра букв.

qИсправлена проблема, при которой происходило неверное удаление выбранных изображений у новости, в случае если выбрано несколько изображений для удаления, а также используется PHP 7.x на сервере.

qИсправлена проблема, при которой в некоторых случаях не работала быстрая загрузка изображений в визуальном редакторе Froala при использовании быстрого редактирования на сайте.

qИсправлена проблема, при которой неверно производился подсчёт страниц навигации в разделе управления облаком тегов.

qИсправлена проблема, при которой нельзя было использовать кавычки в описании загруженных изображений при их вставке их в визуальные редакторы непосредственно после загрузки на сервер.

qИсправлена проблема, при которой некорректно работал выбор цветов в редакторе TinyMCE.

qИсправлена проблема, при которой в некоторых случаях, новость, защищенная паролем, могла отображаться без запроса пароля.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 13.1:

qДобавлен мастер переноса адреса вашего сайта с одного домена на другой. Вы можете быстро в один клик сменить имя домена вашего сайта со старого на новый. Данный мастер проведет автоматическую замену вашего домена в публикациях, комментариях, статических страницах, баннерах и аватарах пользователей. Запускается данный мастер в панели управления, в настройках скрипта, рядом с настройкой адреса вашего сайта.

qДля системы плагинов добавлена возможность указывать исполняемый PHP код, при установке плагина, его обновлении, включении, отключении и удалении. Тем самым плагин при выполнении этих действий может выполнять какие-либо более сложные действия при необходимости.

qДля системы плагинов добавлена возможность указывать c какого вхождения производить действия с искомыми строками. Например, в файле находится несколько одинаковых строк, и вам необходимо произвести действия только начиная со второй нужной строки, то вы можете это указать в плагине.

qДля системы плагинов добавлена возможность указывать для плагина обязательное наличие другого плагина. Вы можете в плагине указать имя другого плагина, который должен быть обязательно установлен. При этом данный плагин будет выполнен уже после выполнения основного плагина. Тем самым вы можете создавать дополнения не только для стандартного DLE, но и для плагинов. И создавать плагины для плагинов.

qДля системы плагинов добавлена корректная работа с переносом на новую строку, в заменяемом коде, если данный перенос стоит в самом начале кода, на который необходимо заменить или который необходимо добавить.

qДля MySQL запросов, использующихся в плагинах, добавлено использование тега {engine}, который указывает, какой движок MySQL использует DLE при создании таблиц в базе данных. Может принимать значения InnoDB или MyISAM.

qВнесены изменения в систему установки и включения плагинов, в случаях, когда плагин не соответствует требованиям необходимым требованиям. В случаях, когда, например, плагин требует наличие какой-либо версии DLE, а установленная версия DLE не соответствует этому, то плагин все равно будет добавлен на сайт, но при этом будет добавлен в выключенном состоянии. Тем самым пользователь сможет самостоятельно отредактировать в дальнейшем плагин, и внести в него необходимые изменения непосредственно в админпанели. Тоже самое и касается других требований плагина. Включить плагин на сайте можно будет только, если несоответствия требованиям были устранены.

qДобавлена стандартизация порядка выполнения плагинов в системе. Плагины будут выполняться строго по принципу: первый добавленный в систему, будет выполнен раньше. Выполнение плагинов будет независимо от того, редактировался ли плагин в админпанели или нет. Также если плагин имеет зависимость от другого плагина, то в первую очередь будет выполнен плагин, от которого он зависит.

qДобавлена поддержка отложенной загрузки изображений в браузер для публикаций. Данная возможность включается в настройках скрипта в панели управления. При включении данной опции, изображения в новостях будут загружаться в браузер не сразу при загрузке страницы, а по мере прокрутки пользователем страницы и непосредственного просмотра данных картинок. Данное нововведение позволяет ускорить загрузку страниц в браузер и снизить расход трафика сервера.

qДобавлена поддержка reCAPTCHA v3. При использовании данного вида каптчи, вашим пользователям не придется больше выбирать какие-либо картинки, и вообще осуществлять каких-либо дополнительные действия на сайте. Проверка на то робот это или человек осуществляется полностью автоматически в фоновом режиме, незаметно для посетителей вашего сайта. Внимание! При включении данного вида каптчи вам необходимо будет сформировать новые ключи на сайте сервиса Google, непосредственно для reCAPTCHA v3.

qДля автоматического обновления скрипта добавлена поддержка ручных изменений в файле .htaccess, находящегося в корне сайта. При обновлении данный файл не будет полностью заменен на оригинальный, а в нем будут лишь произведены необходимые изменения в стандартных функциях. Тем самым все ручные изменения, сделанные в нем владельцем сайта, останутся неизменными. Тоже самое осуществляется и для файла крона, который вы настроите для выполнения своих действий по крону.

qВнесены изменения в работу автоматического обновления скрипта в пределах одной версии. При выходе патчей, исправляющее какие-либо ошибки в пределах одной версии скрипта, будет происходить только установка изменений в виде патча, обновляя только измененные файлы, а не всех файлов целиком, как ранее.

qДля предварительного просмотра публикаций добавлено автоматическое распознавание выбранной категории, и в случае если для нее назначен отдельный шаблон, то будет загружен тот шаблон для просмотра, который назначен для данной категории. Тем самым если для разных категорий назначены различные шаблоны, то они будут также использоваться и при предварительном просмотре.

qДля модуля "Перекрестные ссылки" в панели управления скриптом, добавлена возможность использования подсказок для ссылок (атрибут title). Данное нововведение позволяет улучшить SEO оптимизацию сайта, а также более гибко создавать сайты для людей с ограниченными возможностями.

qДобавлено автоматическое перестроение похожих публикаций для новости в случае ее редактирования. При редактировании новости, для нее будет автоматически произведен поиск похожих новостей. Ранее для повторного поиска похожих публикаций, требовалось сбросить кеш похожих новостей в соответствующем разделе админпанели.

qДобавлено автоматическое перестроение похожих публикаций для новости в случае ее редактирования. При редактировании новости, для нее будет автоматически произведен поиск похожих новостей. Ранее для повторного поиска похожих публикаций, требовалось сбросить кеш похожих новостей в соответствующем разделе админпанели.

qДобавлена поддержка протокола magnet: для ссылок публикуемых на сайте при помощи BB тегов и в визуальных редакторах.

qДобавлена поддержка загрузки и обработки изображений в формате WEBP. Теперь изображения в этом формате можно напрямую загружать с использованием DataLife Engine, при этом он будет создавать уменьшенные копии и накладывать водяные знаки, если это необходимо.

qДобавлена полная поддержка MySQL линейки 8.x.

qДобавлена полная поддержка PHP линейки 7.3.x.

qДля тега [ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue] который выводит текст в случае если значение тега совпадает с указанным значением, добавлена поддержка перечисления нескольких значений через запятую. Например, тег [ifxfvalue gorod="Москва, Казань, Екатеринбург"] Текст [/ifxfvalue] выведет указанный текст, если дополнительное поле с именем gorod содержит в себе одно из указанных значений. Тем самым значительно упрощается верстка шаблона в различных сценариях.

qДля системы управления рекламными материалами в админпанели, добавлена возможность поиска по ним. Вы можете осуществлять поиск по названиям, по описаниям и по используемому рекламному коду в них.

qВ админпанели, в разделе управления баннерами, добавлена более информативная визуализация того отображается ли баннер на сайте или нет. Например, если баннер имеет ограничения на показ по времени или по просмотрам, или по кликам, и согласно им, баннер уже отключен от показа, то в разделе редактирования баннеров также будет отображено, что баннер на текущий момент выключен.

qДобавлена возможность поиска по новостям и статическим страницам на мобильных устройствах (смартфоны, планшеты) в панели управления скриптом.

qДля расширенного поиска по статическим страницам добавлена возможность выбора области поиска. Вы можете осуществить либо поиск по всем полям, либо отдельно по названию, описанию, и тексту статической страницы.

qСущественно улучшены алгоритмы поиска по статическим страницам. Благодаря этого поиск по статическим страницам осуществляется более точно, и позволяет более правильно искать необходимые страницы, по заданным критериям поиска.

qСущественно улучшено быстродействие DataLife Engine и снижена нагрузка на базу данных, при использовании на сайте мультикатегорий. Запросы к базе данных были переписаны таким образом, что больше не используют регулярных выражений при обращении к БД, тем самым было существенно улучшено быстродействие скрипта и снижена нагрузка на сервер.

qСущественно улучшено быстродействие DataLife Engine и снижена нагрузка на базу данных, при показе публикаций по ключевым словам, из облака тегов.

qСущественно улучшено быстродействие DataLife Engine и снижена нагрузка на базу данных, при показе публикаций, найденных при использовании дополнительных полей, имеющих свойство "использование как перекрестных ссылок".

qДля расширенного поиска по новостям и статическим страницам, добавлена возможность быстрого сброса параметров поиска на значения по умолчанию.

qЛимит на количество символов метатега Description для статических страниц увеличен до 300 символов. Максимальная длина соответствует теперь максимальной длине, установленной поисковой системой Google, для вывода данной информации в результатах поиска.

qВнесены изменения в механизмы формирования метатега og:image, предназначенного для публикации данный в социальные сети. Теперь, в случае если в публикации стоит уменьшенная копия, то в данном теге будет формироваться ссылка на полное оригинальное изображение, тем самым, социальные сети содержащие ограничения на минимальные размеры картинок, будут получать максимально возможный оригинал изображения.

qДобавлен контроль неверных ЧПУ при просмотре публикаций на основе каталога по символьному коду, заданному в публикациях. А также улучшен контроль неверных ЧПУ при просмотре полных новостей.

qДобавлена возможность использования запятых, при написании описаний в дополнительных полях, имеющих тип "изображение" и "галерея изображений".

qДля дополнительных полей, имеющих тип "Перекрестные ссылки", добавлена возможность использования в значениях символа плюса, например, можно использовать такие значения как C++ и т.д.

qДля ключевых слов, предназначенных для облака тегов публикаций, добавлена поддержка таких символов как двойные кавычки, плюс, и ряд других. Убраны практически любые ограничения на символы в облаке, оставлены ограничения только на использование HTML кода.

qДля шаблона RSS потока, добавлена возможность использования HTML форматирования разбитого на несколько строк, использующегося для формирования турбо контента для яндекса.

qУлучшена обработка изображений в формате PNG в случаях использования некоторых прозрачных изображений. А также улучшено наложение водяных знаков на данные картинки.

qДобавлена поддержка работы тегов [newscount=X] текст [/newscount] и [not-newscount=X] текст [/not-newscount] для пользовательского вывода публикаций при помощи тега {custom ...}, в случаях если этот вывод используется в шаблонах вывода кратких публикаций.

qДобавлена возможность использования пробелов для разделителей списка перекрестных ссылок в дополнительных полях, если для данных полей включена опция: "Использовать значения полей как перекрестные гиперссылки".

qОбновлены визуальные редакторы TinyMCE и Froala до актуальных версий. Исправлен ряд выявленных ошибок в данных редакторах.

qИсправлена проблема, при которой некорректно работала система контроля неверных ЧПУ для дополнительных полей публикаций, имеющих тип перекрестные ссылки, в случае если значения этих полей содержали кавычки.

qИсправлена проблема, при которой в закладках на сайте могли отображаться отправленные на модерацию публикации.

qИсправлена проблема, при которой некорректно отображались фигурные скобки в комментариях при использовании на сайте AJAX навигации для комментариев.

qИсправлена проблема, при которой не все шаблонные теги дополнительных полей публикаций, корректно обрабатывались в шаблоне main.tpl в случае если пользователь переходил на отсутствующую новость.

qИсправлена проблема, при которой теги {news-id} некорректно обрабатывались при показе публикаций с использованием тега {custom ...}, в случае если при этом пользователем просматривалась полная новость.

qИсправлена проблема с работой тегов [available ...] и [not-available ...], в случае просмотра пользователем страниц публикаций по символьному коду, если символьный код не указан, либо равен, например, нулю "0".

qИсправлена проблема, при которой в некоторых случаях мог некорректно работать контроль неверных ЧПУ в полных новостях, в случае если DLE был установлен не в корне сайта, в подпапки.

qИсправлена проблема, при которой могли выводится новости, при просмотре следующих и предыдущих публикаций, опубликованные на будущее время, несмотря на запрет на их вывод в настройках скрипта.

qИсправлена проблема, при которой могли не отображаться дополнительные поля, имеющие тип галерея и изображение, при предварительном просмотре публикации, если в данных полях использовались описания к картинкам.

Список изменений относительно версии 13.0:

qДобавлена возможность автоматического обновления скрипта в админпанели в пределах одной версии скрипта, в случаях, когда выходят, например, исправления найденных уязвимостей или других багов. В случаях, если в пределах одной версии вносятся изменения в дистрибутив, например, при выходе исправлений уязвимостей, или других выявленных проблем со скриптом, в админпанели возможно будет обновить скрипт, в рамках данной текущей версии скрипта.

qДобавлена возможность автоматического обновления плагинов на сайте. Для этого в плагине задается URL для получения информации о наличии новой версии. По данному URL сайт разработчика плагина должен отдавать массив в JSON формате, который должен содержать информацию о актуальной версии плагина, а также ссылку на загрузку актуальной версии плагина. Например, по данному URL должно возвращаться значение {"version":"2.0","url":"https://dle-news.ru/test/test.zip"}. После чего, при проверке обновлений, администратор сайта сможет узнать о наличии новых версий плагина и обновить плагины в админпанели в один клик.

qДля системы управления плагинами, добавлена возможность указывать количество замен, которые нужно провести, по каждому критерию поиска в файле. Например, вам нужно найти и заменить какой-либо код в файле, который встречается в этом файле несколько раз, вы можете указать сколько раз необходимо заменить данный код. Для замены всех вхождений этого кода, вы можете оставить данный параметр пустым, тем самым замена будет произведена везде, где встречается указанный вами код.

qДля системы управления плагинами, добавлена возможность автоматического удаления загруженных вместе с плагином в архиве дополнительных файлов, в случае если плагин удаляется с сайта. Для этого в параметры плагина добавляется возможность выбора, удалять дополнительные файлы или нет. Тем самым вы можете самостоятельно решать, необходимо ли зачищать сервер от дополнительных файлов в случае его удаления с сайта, или же их необходимо оставить.

qДля системы управления плагинами, добавлена возможность использовать в именах папок, находящихся в ZIP архивах, тег {THEME}. При загрузке архива через систему плагинов, данный тег будет заменен на имя используемого шаблона. Например, разместив в архиве файл /templates/{THEME}/test.tpl, ваш файл шаблона будет помещен в используемый на сайте шаблон. Тем самым, при использовании сложных плагинов, которые содержат в себе примеры файлов шаблонов, они могут сразу загружаться в нужную папку, содержащую используемый пользователем шаблон.

qДля системы управления плагинами, добавлена возможность использовать в действии "Поиск и замена" в строке замены управляющие символы функции preg_replace, такие как \\1 и т.д., что снимает ограничения на поиск и замену некоторых кодов в DLE.

qДля дополнительных полей, имеющих тип "Изображение" и "Галерея изображений", добавлена возможность назначать каждому изображению в отдельности, свое персональное описание, которое также используется в качестве HTML атрибута alt, при выводе данных дополнительных полей на сайте.

qДля дополнительных полей, имеющих тип "Галерея изображений", добавлена возможность изменять порядок сортировки загруженных картинок, просто переместив их мышью. После загрузки изображений вы можете поменять местами изображения по вашему желанию. Также загруженные изображения могут быть перенесены в другие дополнительные поля.

qДля публикаций и комментариев добавлен новый тип рейтинга "Нравится и Не нравится", который ведет отдельный учет как количества лайков, так и количества дизлайков. Для этого для шаблонов вывода публикаций и комментариев добавлены новые теги: {likes} - который выводит количество лайков, {dislikes} - который выводит количество дизлайков, а также тег [rating-type-4] текст [/rating-type-4] - который выводит текст, заключенный в теге, в случае если в настройках включен данный тип рейтинга.

qВ настройки профилей пользователей в админпанели, добавлена возможность устанавливать список категорий, в которые данному конкретному пользователю разрешено добавление публикаций. Это позволит, например, журналистам, вести личные рубрики, в которые другие журналисты (или часть из них) не имеют права публикации. Или наоборот — исключить журналиста из конкретной категории новостей, если он, например, в ней некомпетентен.

qВ настройки профилей пользователей в админпанели, добавлена возможность устанавливать список доверительных категорий, в которые данному конкретному пользователю разрешено добавление публикаций без модерации. Такая персонализация позволит значительно более гибко разграничивать права, не создавая при этом кучу групп пользователей, в том числе и групп под каждого конкретного журналиста.

qДля расширенного поиска публикаций в админпанели, в разделе редактирования публикаций, добавлена возможность выбирать где необходимо произвести поиск. Вы можете произвести поиск по всему контенту, можете отдельно по заголовкам, краткому описанию, полному описанию и дополнительным полям. Также существенно улучшены алгоритмы поиска, для более корректного нахождения публикаций.

qДля расширенного поиска публикаций в админпанели, в разделе редактирования публикаций, добавлена возможность поиска одновременно по нескольким категориям на выбор.

qДля облака тегов добавлена возможность использования символов "&" и "#", что позволяет, например, использовать в облаке имена различных брендов, например, "H&M" и т.д.

qВ настройки скрипта в админпанели, добавлена возможность разрешения для администрации сайта авторизоваться на сайте при помощи социальных сетей. При включении данной настройки, пользователи, находящиеся в группе администраторы, также могут авторизоваться на сайте при помощи своих аккаунтов в социальных сетях.

qВ админпанели, в разделе редактирования комментариев, добавлена возможность поиска комментариев по тексту. В данном разделе вы можете произвести поиск необходимых вам для редактирования комментариев, по каким-либо ключевым словам. Тем самым редактирование комментариев становится более удобным.

qВ админпанели, в разделе управления перекрестными ссылками, добавлена возможность для массовых действий над ссылками, устанавливать замену "Только в статических страницах", а также "В статических страницах, новостях и комментариях".

qДля предосмотра баннеров в разделе управления рекламой в админпанели, добавлено подключение стилей вашего шаблона из файла preview.css. Тем самым вы можете видеть более правильное оформление вашего рекламного кода, в случае если он использует классы из вашего шаблона.

qДля шаблона вывода кратких новостей (shortstory.tpl) добавлено использование тегов [not-news] текст [/not-news], которые выводят заключенный текст в них, в случае если публикации по данным критериям отсутствуют. Тем самым вы можете переназначить стандартное системное сообщение об отсутствии публикаций в каком-либо отдельном разделе сайта, сделав его уникальным, например, для каждого раздела сайта. Также данные теги можно использовать и в шаблонах, которые используются при пользовательском выводе публикаций с помощью тега {custom ...}

qДля шаблона E-Mail сообщения, которое отправляется при восстановлении забытого пароля, добавлено использование новых тегов: {%losturl%}, который выводит только URL ссылки на сброс и генерацию нового пароля, а также {%ipurl%}, который выводит только URL ссылки на сброс блокировки по IP. Тем самым вы можете отдельно задавать нужное вам оформление в письме данных ссылок, например, в виде кнопок. А также вы можете, например, отказаться от вывода ссылки на снятие блокировки по IP, если не используете эту возможность на своем сайте.

qУлучшена система удаления категорий в админпанели. В случае если удаляемая категория, содержит в себе подкатегории, которые также подлежат удалению, то все действия для публикаций, которые содержат удаляемую категорию, будут автоматически распространены и на публикации, которые содержат также и удаляемые подкатегории. И к данным публикациям в подкатегориях, будут применены те же действия.

qДля модуля "Фильтр по: IP, Логину или E-Mail" добавлена возможность добавления блокируемых адресов или логинов, или e-mail сразу целыми списками, а не по одному. Что существенно ускоряет процесс добавления, если у вас уже есть готовый список из того что необходимо заблокировать.

qДля модуля "Фильтр по: IP, Логину или E-Mail" добавлена возможность редактирования уже существующих правил. Вы можете выбрать и отредактировать любое правило, без необходимости его удаления и повторного добавления.

qДля модуля "Фильтр по: IP, Логину или E-Mail" добавлена возможность выбора одновременно нескольких или всех добавленных правил, и массовой разблокировки данных правил в один клик.

qДля модуля "Фильтр по: IP, Логину или E-Mail" добавлена поддержка использования IPv6 адресов, которые можно указать для блокировки доступа на сайт. Также добавлена возможность указания IPv6 подсетей для блокировки.

qДобавлена возможность указания IPv6 адресов в профиле пользователя, с которых разрешена авторизация для пользователя. Также вы можете указать не только отдельный адрес, но и IPv6 подсеть.

qДля модуля пользовательской сортировки публикаций на сайте, выводимых тегом {sort} добавлена возможность выставления сортировки для каждой конкретной категории, а не для всех категорий одновременно.

qДля ссылок, публикуемых в публикациях, добавлена возможность использование в них блочных элементов, таких как "p", "div" и т.д. Что позволяет DataLife Еngine более точно и правильнее соответствовать стандартам HTML5.

qДобавлена возможность добавления новых пользователей в панели управления DataLife Engine, при работе с панелью с использованием смартфонов.

qВнесены изменения в работу древовидных комментариев. В случае если достигнута максимальная вложенность для ответов на комментарии, то в случае ответа на комментарий, данные ответы остаются в ветке обсуждения на максимальной вложенности. Ранее при достижении максимальной вложенности, ответить на комментарий было нельзя. Теперь возможность ответа остается в любом случае.

qДля дополнительных полей, имеющих тип "Перекрестные ссылки", добавлена возможность использования в значениях символа двойных кавычек, и символа амперсанда.

qВ случае если для шаблона E-Mail сообщения, которое отправляется при восстановлении забытого пароля, установлено использование HTML формата для данного письма, то ссылки, которые генерирует тег {%lostlink%} в этом шаблоне, будут формироваться уже в виде готового HTML кода, а не просто текстовые ссылки.

qВ настройки скрипта добавлена возможность установки сортировки публикаций по умолчанию, по количеству комментариев. Тоже самое было добавлено и для настройки критериев сортировки при просмотре каталога.

qДля настроек категорий добавлена возможность в критериях сортировки публикаций, добавить по умолчанию критерий сортировки публикаций по количеству комментариев.

qВнесены изменения в работу дополнительных полей, в случае если поле имеет ограничения на добавление по группам пользователей. Если значение дополнительного поля было добавлено пользователем, имеющим на это право, а в последствии публикация редактируется пользователем, у которого нет прав на заполнение этого поля, то значение данного поля больше не очищается, а остается таким, каким его заполнил ранее пользователь, имеющий на это право.

qЛимит на количество символов метатега Description для категорий увеличен до 300 символов. Максимальная длина соответствует теперь максимальной длине, установленной поисковой системой Google, для вывода данной информации в результатах поиска.

qУлучшен поиск похожих новостей на сайте. Показ похожих новостей стал более релевантным по сортировки найденных публикаций.

qУлучшена поддержка IPv6 адресов посетителей сайта. В некоторых определенных случаях полный адрес мог не помещаться в базу данных. Теперь длина полей зарезервирована согласно спецификации RFC 4291.

qУлучшено формирование метатега og:description протокола Open Graph при просмотре полных новостей. Формирование происходит более корректно при использовании в качестве основного контента дополнительных полей для публикаций.

qУлучшена работа системы безопасности DataLife Engine, с целью более корректной проверки данных на поддоменах, на некоторых хостингах, имеющий структуру поддоменов, в виде подпапок основного домена.

qДобавлена поддержка протокола tel: для ссылок публикуемых на сайте при помощи BB тегов.

qОбновлены визуальные редакторы TinyMCE и Froala до актуальных версий. Исправлен ряд выявленных ошибок в данных редакторах.

qИсправлена проблема, с использованием в дополнительных полях профиля пользователей, полей с типом "Список", в которых использовались значения с использованием символа "|".

qИсправлена проблема, при которой в разделе управления плагинами, если изменялось действие над файлом в меню, некоторые символы могли некорректно изменяться в указанных в полях значениях.

qИсправлена проблема, при которой нельзя было использовать теги [lееch] для внутренних страниц сайта, и разрешалось использование только для внешних сайтов.

qИсправлена проблема, при которой нельзя было приступить к обновлению сайта на новую версию, в случае если сайт был в кодировке отличной от UTF-8 при этом логин или пароль администратора содержал в себе буквы, написанные на кириллице.

qИсправлена проблема, при которой не появлялось всплывающее окно о поступлении новых персональных сообщений, если пользователь самостоятельно вышел из своего аккаунта на сайте, а после чего опять вошел в него спустя какое-то время.

qИсправлена проблема, при которой не работало редактирование комментариев в панели управления скриптом, в случае если в настройках скрипта был включен TinyMCE редактор.

qИсправлена проблема, при которой не отображалось количество дней, в течении которых можно добавлять комментарии к публикации, если такие лимиты были установлены в настройках скрипта в админпанели.

qИсправлена проблема, при которой дополнительное поле, имеющее тип "Загружаемый файл", не отображалось на сайте в виде ссылки на скачивание файла, а выводилось простым тегом.

Список изменений относительно версии 12.1:

qПрекращена поддержка кодировки windows-1251.

qДобавлена новая система автоматического обновления скрипта DataLife Engine.

qДобавлена новая система установки и управления плагинами на сайте.

qВ настройки скрипта в админпанели добавлена возможность включать и отключать поддержку системы плагинов на сайте. Если вы не используете данную систему, то ее можно отключить в настройках скрипта, для большего увеличения производительности скрипта и снижения нагрузки на сервер.

qДля сайтов, использующих кодировку utf8 для базы данных, но не использующих четырехбайтную кодировку utf8mb4, добавлена возможность сконвертировать вашу базу данных автоматически непосредственно из админпанели. Данные кодировки полностью совместимы между собой, но переведя ваш сайт на utf8mb4 вы добавите полную поддержку всех символов на своем сайте. Например, поддержку смайлов Emoji, музыкальных символов и многих других.

qДобавлена возможность отображать ссылки на предыдущую и следующую публикации при просмотре полной новости.

qТег {news-id} получил глобальную поддержку во всех шаблонах в случае просмотра полной новости.

qВ админпанели, в разделе управления пользователями, добавлена возможность поиска пользователей, которым запрещено добавление публикаций на сайт. А также добавлена возможность поиска пользователей, которым запрещена публикация комментариев.

qДля пользователей демоверсией скрипта добавлена возможность автоматического перехода на платный дистрибутив после ввода лицензионного ключа.

qДля расширенного поиска публикаций в панели управления, добавлена возможность поиска публикаций для которых были добавлены опросы к этим публикациям. А также добавлена возможность поиска публикаций, для которых назначены пароли.

qСущественно улучшен поиск в разделе "Список действий в админпанели". Теперь вы можете искать нужную информацию не только по логину или ip, но и по непосредственно самому действию. Например, написав "удаление новости", вы увидите весь список, связанный с удалением публикаций и т.д. по любому действию.

qДля модуля "Мастер оптимизации" в панели управления скриптом, добавлена возможность выбирать категории, из которых нужно удалить устаревшие новости. Тем самым вы можете фильтровать и указывать из каких категорий не нужно удалять старые публикации.

qДля модуля "Мастер оптимизации" в панели управления скриптом, добавлена возможность выбрать: очистить все персональные сообщения, либо очистить только уже ранее прочитанные сообщения. Тем самым, сообщения, которые не были прочитаны, можно оставить для пользователей.

qДобавлена возможность написания персональных сообщений, с использованием технологии AJAX.

qДобавлено формирование метатега og:description протокола Open Graph при просмотре полных новостей.

qПри добавлении, либо при редактировании публикации в панели управления, добавлена возможность сразу перейти на просмотр данной публикации на сайте, после ее сохранения.

qДля редактора BBCODES, в случае использования типографской обработки текста, все необходимые неразрывные пробелы, сразу будут использоваться в виде готовых UTF-8 символов, а не в виде HTML сущностей. Что существенно облегчает чтение и редактирование текста в редакторе, и позволяет избежать неудобного для дальнейшей работы слитного текста.

qПри показе опросов и голосований на сайте, убран автоматический выбор первого варианта ответа в голосовании или опросе. Тем самым прежде чем принять выбор в голосовании или опросе, пользователь должен осуществить осознанный выбор нужного варианта, что исключает случайное голосование за первый вариант в проводимом опросе.

qДобавлена очистка RSS потока сайта от спойлеров. Теперь DLE автоматически удаляет из потока всю неработающую в RSS функциональность оставляя только контент, который был указан в спойлере.

qДля RSS экспорта добавлена возможность использование тега {full-stоry} совместно с другими тегами

qДля обычного поиска по сайту добавлена возможность автоматического поиска по статическим страницам. В случае, если ведется обычный поиск по сайту и в публикациях ничего не было найдено, будет произведен автоматический поиск также и по статическим страницам. Тем самым посетителю не нужно переходить в расширенный поиск и выбирать для поиска статические страницы, чтобы найти что-то нужное. Данное нововведение будет особенно полезно тем сайтам, которые используют много статических страниц, и практически не используют новости на сайте.

qДля быстрого поиска по сайту также добавлена возможность автоматического поиска по статическим страницам. В случае если при поиске, в публикациях ничего не было найдено, скрипт произведет также автоматический поиск и по статическим страницам, и отобразит ссылки на них если были найдены совпадения.

qДобавлена возможность вывода опросов, назначенных публикациями, при выводе публикаций с помощью пользовательского тега {custom ...}. Для показа опросов используется тег {poll} в шаблоне, также, как и в шаблонах вывода кратких и полных публикаций.

qДля RSS импорта публикаций и для RSS информеров, добавлено использование сайтов источников в любой кодировке, независимо от вашего сайта. DataLife Engine автоматически определит кодировку сайта источника данных и перекодирует данные в кодировку вашего сайта.

qЛимит на количество символов метатега Description для публикаций увеличен до 300 символов. Максимальная длина соответствует теперь максимальной длине, установленной поисковой системой google, для вывода данной информации в результатах поиска.

qУлучшена система автоматического уменьшения размеров внешних изображений, если это включено в настройках скрипта. Для этого добавлена небольшая задержка перед запуском соответствующей JS функции, что позволяет более правильно устанавливать размеры картинок, при медленном интернет соединении. А также добавлено автоматическое определение натуральных размеров изображений, а не их размеров в блоке страницы. Что позволяет, например, увеличивать их при клике на изображения, на экранах с небольшими размерами.

qУлучшена система формирования канонических ссылок и метатегов социальных сетей для статических страниц. В случае если статическая страница была разбита на несколько страниц, то для каждой страницы будут формироваться отдельные собственные канонические ссылки, а не только ведущие на первую страницу.

qВнесены небольшие изменения в видеоплеер DLE, делающий просмотр видео более удобным. Был существенно уменьшен размер плеера, что ускоряет его загрузку в браузер, а также убрано автоматическое добавление атрибута title для HTML тегов video.

qСущественно ускорена работа Gzip сжатия JS и CSS файлов, которые использует DataLife Engine, при включении сжатия в настройках скрипта.

qДля модуля "Перекрестные ссылки" улучшено распознавание адресов страниц, на которых находится пользователь, содержащих в себе символы кириллицы и другие unicode символы. Что позволяет более корректно проводить проверку на то, что страница ссылается на саму себя, и не производить замену ключевых слов для данных страниц.

qДля модуля "Редиректы" улучшено распознавание адресов страниц, на которых находится пользователь, содержащих в себе символы кириллицы и другие unicode символы. Что позволяет более корректно производить редиректы с указанных в данном модуле страниц.

qДобавлена возможность добавления новых категорий в админпанели при использовании панели управления скриптом со смартфонов.

qДля авторизации на сайте с использованием социальной сети "Вконтакте", добавлена поддержка актуальной версии API данной социальной сети. А также добавлена возможность авторизации для пользователей, которые не имеют E-mail адреса в данной сети.

qПереработана и улучшена система изоляции шаблонных тегов друг от друга, чтобы они не вмешивались в работу и вывод информации между собой.

qПереработан ряд защитных механизмов сайта от выполнения несанкционированных действий, направленных на усиление защиты сайтов.

qДобавлена полная поддержка PHP линейки 7.2.x

qУлучшена система транслитерации для русского языка. Транслитерация будет проходить по более правильным правилам, что улучшает читабельность русского текста на латинице.

qОптимизирована и упрощена установка DataLife Engine на сервер. При установке скрипта на сервер, вам необходимо будет ввести и выбрать самый минимум данных. Все остальное скрипт установки DataLife Engine определит автоматически.

qОбновлены визуальные редакторы TinyMCE и Froala до актуальных версий. Исправлен ряд выявленных ошибок в данных редакторах.

qИсправлена проблема, при которой нельзя было ответить на комментарий, на странице показа всех комментариев, если для группы пользователя был включен ввод рекаптчи в настройках группы.

qИсправлена проблема в DLE API при которой API не проводило проверку авторизации пользователя, если его аккаунт еще не был переведен на новую систему хранения пароля.

qИсправлена проблема, при которой могло происходит неверное сохранение данных дополнительных полей при изменении сортировки данных полей.

qИсправлена проблема, при которой могло происходить неверное объединение комментариев администратором сайта, если включены древовидные комментарии и порядок сортировки комментариев установлен по убыванию.

qИсправлена проблема, при которой могли не загружаться файлы и изображения для публикаций, для дополнительных полей при быстром редактировании публикаций на сайте.

qИсправлена проблема, при которой меню категорий не учитывало настройки скрипта, на предмет того, включено ли в настройках скрипта ЧПУ или нет, и формировало ссылки всегда с ЧПУ.

qИсправлена проблема, при которой вставленный исходный код при помощи тегов [cоde] [/cоde], либо в визуальных редакторах при помощи соответствующей кнопки вставки примеров кода, мог некорректно преобразовываться из HTML сущностей в их ASCII символы.

qИсправлена проблема, при которой могла не выводится информация тегом [xfvalue_X image="Nr"] в шаблоне полной новости при выводе отдельного изображения из доп. поля с типом "Галерея изображений".

qИсправлена проблема, при которой нельзя было вставить смайлы в комментарии или публикации, на мобильных устройствах, при использовании редактора визуального редактора Froala.

qИсправлена проблема, при которой нельзя было использовать некоторые буквы русского алфавита при регистрации пользователей, на сайтах, с использованием кодировки UTF-8.

Список изменений относительно версии 12.0:

qВ модуле управления рекламными добавлена поддержка рубрик. Вы можете в данном модуле создавать рубрики и уже в этих рубриках размещать ваши рекламные материалы. Рубрики выводятся в самом верху, перед списком добавленных рекламных материалов, в виде папок. В самих рубриках также можно создавать дополнительные подрубрики в неограниченном количестве. Тем самым при большом количестве рекламных материалов вы можете разместить их для удобства навигации по ним, в различных рубриках и подрубриках.

qДобавлена возможность учета количества просмотров для рекламных материалов, добавляемых в панели управления скриптом. Учет просмотров ведется только для реальных пользователей, которые зашли на сайт с использованием браузера. Боты, сканирующие сайт, не учитываются. Учет просмотров включается непосредственно для каждого баннера, поэтому вы можете учитывать просмотр только для нужных рекламных материалов. Также у вас есть возможность указать, нужно ли учитывать все просмотры баннера, или учитывать только просмотры от уникальных пользователей.

qДля рекламных материалов в админпанели добавлена возможность ограничивать показ баннера на основе количества его просмотров, и вы можете отключить баннер при достижении указанного максимального количества просмотров.

qДобавлена возможность учета количества кликов для рекламных материалов, добавляемых в панели управления скриптом. DataLife Engine автоматически перехватывает HTML теги, опубликованные с использованием тегов <а href="...">, и автоматически ведет учет кликов по ним. Какого-либо особого оформления этих ссылок не требуется, они могут вести по любым нужным вам адресам. Также у вас есть возможность указать, нужно ли учитывать все клики по ссылке, или учитывать только клики от уникальных пользователей.

qДля рекламных материалов в админпанели добавлена возможность ограничивать показ баннера на основе количества кликов по вашему баннеру, и вы можете отключить показ баннера при достижении указанного максимального количества кликов по нему.

qДля рекламных материалов в админпанели добавлена возможность очистки количества просмотров и кликов для каждого рекламного баннера.

qДобавлено использование канонических ссылок, в коде страниц, для всех страниц сайта включая навигацию по разделам, просмотр полной новости и т.д. Данная возможность позволяет повысить SEO оптимизацию сайтов, а также позволяет избегать дублей страниц в случае если где-либо в сети интернет публикуются некорректные ссылки на ваш сайт, либо если по каким-либо причинам необходимо отключить контроль неверных ЧПУ.

qВ настройки категорий в панели управления, добавлена возможность устанавливать по умолчанию для категории, разрешено ли публиковать новости из данной категории на главной странице сайта. Данные настройки действуют в момент добавления или редактирования публикации, и если для категории запрещена публикация на главной странице, то соответствующая опция убирается в момент добавления или редактирования публикации.

qВ настройки категорий в панели управления, добавлена возможность устанавливать по умолчанию для категории, разрешены ли комментарии для публикаций из данной категории. Данные настройки действуют в момент добавления или редактирования публикации, и если для категории отключены комментарии, то соответствующая опция убирается в момент добавления или редактирования публикации.

qВ настройки категорий в панели управления, добавлена возможность устанавливать по умолчанию для категории, разрешен ли рейтинг для публикаций из данной категории. Данные настройки действуют в момент добавления или редактирования публикации, и если для категории отключено использование рейтинга, то соответствующая опция убирается в момент добавления или редактирования публикации.

qВ настройки скрипта в панели управления, в раздел настроек безопасности, добавлена возможность включения автоматической защиты сайта от встраивания во фреймы на посторонних сайтах. При включении данной настройки, показ вашего сайта будет автоматически блокирован, если он встроен в iframe на чужом сайте. Тем самым вы можете защитить свой сайт от таких атак как кликджекинг.

qРасширены возможности модуля "Метатеги", данный модуль был переименован в "Заголовки, описания, метатеги". Теперь в данном модуле вы можете задавать для страниц не только метатеги, но и отдельный заголовок для страницы и описание страницы, которые вы в дальнейшем можете вывести в любом месте вашего шаблона. Для этого добавлены новые глобальные теги для шаблонов: {page-title} - выводит указанный вами заголовок для страницы, {page-description} - выводит указанное вами описание для страницы. В описании страницы также допустимо использование BB и HTML тегов. Тем самым при помощи данного модуля, вы можете, например, создать и вывести заголовки и описания для облака тегов к каждому тегу персонально и т.д.

qДобавлены новые глобальные шаблонные теги [page-title] текст [/page-title], которые выводят текст, заключенный в них если в модуле "Заголовки, описания, метатеги" был задан заголовок для просматриваемой страницы. А также добавлены противоположные теги [not-page-title] текст [/not-page-title] которые выводят текст, заключенный в них если заголовок для просматриваемой страницы не был задан. Также были добавлены аналогичные теги и для описания: [page-description] текст [/page-description], которые выводят текст, заключенный в них если в модуле "Заголовки, описания, метатеги" было задано описание для просматриваемой страницы, [not-page-description] текст [/not-page-description] которые выводят текст, заключенный в них если описание для просматриваемой страницы не было задано.

qДля шаблона меню категорий (categorymenu.tpl) добавлена поддержка новых тегов [not-active] текст [/not-active], которые выводят текст, заключенный в них, если просматриваемая на сайте категория, или новость, не принадлежит категории из меню. Данный тег может использоваться только внутри тегов [item] [/item] и используется, например, для вывода какой-либо информации (например ссылок) только для не активных категорий из меню.

qРасширены возможности по выводу публикаций на основе значений дополнительных полей в публикациях. При обращении по адресу http://вашсайт/xfsearch/имя поля/значение поля/ будут выводится публикации, как и ранее, содержащие указанное значение в данном конкретном поле, если для поля задана опция "использовать как перекрестные ссылки". При обращении по адресу http://вашсайт/xfsearch/значение поля/ будут выводится публикации содержащие данное значение по всем дополнительным полям. При обращении по адресу http://вашсайт/xfsearch/имя поля/ будут выводится все публикации, в которых заполнено данное указанное поле.

qВ настройки скрипта добавлена возможность назначения отдельной страницы с именем 404.html в корне вашего сайта, для вывода страниц, контент для которых отсутствует. В случае включения данной настройки, вместо стандартного системного сообщения "К сожалению, данная страница для Вас недоступна, возможно был изменён её адрес или она была удалена.", вы можете вывести отдельную специально подготовленную заранее страницу, с полностью отдельным оформлением. Данное нововведение будет полезно для вебмастеров, которые хотят сделать отдельное оформление 404 страниц своего сайта.

qВ настройки скрипта добавлена возможность назначения HTTP заголовка, откуда необходимо получать IP адреса пользователей. Данное нововведение будет полезно для сайтов, которые используют различные внешние прокси серверы, и не имеют возможности правильно перенастроить сервер под них, для получения корректных реальных IP адресов посетителей. Например, при использовании сервиса cloudflare и других для защиты от DDOS атак и использовании обычного хостинг тарифа без доступа к серверным настройкам. Теперь вы можете в настройках скрипта в админпанели указать скрипту откуда ему брать IP адрес посетителей сайта.

qПри удалении категории в панели управления скриптом, добавлена возможность выбора, как поступить с публикациями, которые находятся в данной категории. Вы можете: "Убрать данную категорию из публикаций", "Заменить категорию на другую или другие категории", а также "Удалить все публикации находящиеся в данной категории". При этом если происходит удаление или замена категории из публикации, то будет убрана или заменена только удаляемая категория. Например, ваша публикация находится в категориях "В мире", "Новости", "Популярное", и вы к примеру, удаляете категорию "В мире", то у публикаций, находящихся в данной категории, только категория "В мире" будет удалена или заменена, все остальные категории в списке у данных публикаций останутся на месте.

qДля публикаций добавлен новый тип дополнительного поля: "Чистый HTML и JS". При использовании данного поля, DataLife Engine не будет вмешиваться в текст, написанный в нём, и не будет проводить фильтрацию HTML кода этого текста, а также разрешает написание в нём чистого jаvascript кода. Данное поле будет полезно, когда вам в новость нужно вставить какой-то код, над которым не нужно проводить проверку безопасности, например, какой-либо свой плеер и т.д. Внимание, с учетом того скрипт не будет фильтровать текст из этого поля, при его создании обязательно установите ограничения, каким группам его разрешено использовать. Не разрешайте его использование обычным пользователям, которым вы не доверяете, в противном случае это может нести угрозу безопасности вашего сайта.

qДля дополнительных полей публикаций, имеющих опцию "Использовать как перекрестные ссылки", добавлена возможность указания разделителя данных ссылок. Вы можете указать как отдельные символы, так и HTML код в качестве разделителя. Ранее в качестве разделителя списка использовалась запятая, теперь вы можете задать свой персональный разделитель для каждого поля, что позволяет создать для каждого поля свое уникальное оформление вывода в шаблоне.

qДобавлена поддержка технологии "Яндекс Турбо" для обычных RSS каналов, без использования включения в настройках типа RSS потока как "Яндекс новости", для этого добавлена поддержка вывода полной новости тегом {full-story} для любого типа RSS потока. A также обновлен стандартный шаблон /templates/rss.xml в котором демонстрируется как должен выглядеть шаблон с полной поддержкой "Яндекс Турбо". Аналогично поддерживается полностью и возможность настройки шаблона RSS для технологии "Яндекс Дзен".

qДобавлена возможность отвечать на комментарии при просмотре всех последних комментариев на сайте, в случае если в настройках скрипта включена поддержка древовидных комментариев. Тем самым вы можете, например, быстро отвечать на поступившие комментарии на сайт, не заходя в каждую новость при этом.

qУскорена и улучшена загрузка страниц сайта в браузер, в связи с тем, что часть тяжелых скриптов была переведена на отложенную и независимую от рендеринга страницы загрузку. Данные скрипты загружаются в браузер параллельно с рендерингом страницы и запускаются только после завершения формирования страницы в браузере. Что визуально обеспечивает более быстрый показ страницы.

qДобавлена возможность, для незарегистрированных на сайте пользователей, отправлять администрации сайта жалобы на новости и комментарии, точно также как такая возможность существовала ранее только для зарегистрированных пользователей.

qДобавлено использование микроразметки schema.org для вывода рейтинга с типом "Оценка". Использование данной микроразметки позволяет для полных новостей при выводе их в результатах поиска в Google выводить также и рейтинг публикации.

qДобавлено автоматическое определение ориентации фотографий при их загрузке на сервер, на основе метаинформации, содержащейся в графических файлах. В случае если оригинальная фотография была перевернута, то при при ее загрузке на сервер, скрипт также автоматически ее развернет в нужное положение. Тем самым отпадает необходимость дополнительно редактировать картинки на компьютере, если при фотографировании фотоаппарат был повернут.

qДобавлена возможность автоматического уведомления администрации сайта о поступлении новой новости от пользователей, находящейся на модерации (в случае если это включено в настройках скрипта), если новость была добавлена из панели управления скриптом. Ранее уведомление отправлялось только если публикация добавлялась непосредственно с сайта.

qВ случае если пользователь редактирует публикацию в панели управления, которая ранее была уже опубликована на сайте, но согласно настройкам его группы, ему запрещено публиковать без модерации, или разрешено публиковать не во все категории, то администрации сайта также будет отправлено соответствующее e-mail уведомление, что данная новость ожидает модерации.

qВнесены изменения в работу модуля хлебных крошек (Breadcrumbs) на сайте. В случае если просматриваются новости из определенной категории, то для категории, в которой непосредственно находится пользователь, данная категория будет выводится в виде обычного текста, а не ссылки. В виде ссылки будут отображаться только категории, находящиеся выше по иерархии, или ссылка на эту категорию будет, если, например, пользователь ушел дальше по навигации по страницам в этой категории. Тем самым это нововведение позволяет избежать циклических ссылок страниц на самих себя.

qДля модуля "Перекрестные ссылки" в панели управления, добавлены две новые области замены для ссылок. Вы можете дополнительно указать замену только в статических страницах, а также выбрать замену в статических страницах, новостях и комментариях.

qДля модуля "Поиск и Замена" в панели управления, добавлена возможность массовой замены текста в опросах к публикациям и в голосованиях на сайте.

qДобавлена возможность удаления всех публикаций, ожидающих модерации у определенного пользователя. Для этого необходимо в разделе управления пользователями нажать на количество его публикаций и выбрать соответствующий пункт меню.

qВ админпанели скрипта добавлен форматированный вывод количества различных счетчиков (просмотры, публикации, комментарии). Вывод этих счетчиков осуществляется в форматированном виде в виде разделения пробелом сотен, тысяч, миллионов и т.д. Что дает более наглядное представление и восприятие данных чисел.

qДля шаблонов вывода комментариев и добавления комментариев (addcomments.tpl и comments.tpl) добавлена поддержка новых тегов [catlist=id1,id2....] текст [/catlist] - выводит текст в теге, если новость принадлежит указанным категориям, а также тегов: [not-catlist=id1,id2....] текст [/not-catlist] - выводит текст в теге, если новость не принадлежит указанным категориям. Тем самым вы можете задать разное оформление вывода комментариев и добавления комментариев для публикаций из разных категорий.

qДобавлена поддержка склонений слов для тега вывода количества голосов, которые были выставлены для рейтинга публикаций. Например, вы можете использовать {vote-num} [declination={vote-num}]отзыв||а|ов[/declination]. Ранее для этого тега это было недоступно, т.к. он содержит в себе HTML код, а не просто число.

qВ случае если в настройках скрипта включено использование сайта только по HTTPS протоколу, то cookies браузером также будут отправляться на сервер только по HTTPS протоколу и автоматически блокироваться если используется обычный HTTP протокол.

qДобавлен контроль неверных ЧПУ для статических страниц, текст публикации которых разбит на несколько страниц. В случае если указан некорректный номер страницы, будет производится автоматический 301 редирект на начальный адрес данной страницы.

qДля RSS импорта публикаций добавлена поддержка импорта картинок из тега enclosure содержащего изображение к публикации. В случае если краткое описание в потоке RSS является просто текстом, а картинка дана в нем отдельным тегом, то к краткой новости при импорте в самое начало будет добавлена также и картинка к этой публикации.

qДобавлена поддержка редиректов для получения полных новостей при использовании RSS импорта публикаций. В случае если ссылка из RSS потока является редиректом для дальнейшего перехода к полному тексту новости на сайте источнике, то DataLife Engine автоматически последует по этому редиректу и будет брать контент из конечного источника. Тем самым получение полных новостей будет более качественным чем ранее.

qВнесены изменения в работу тегов [comments] [/comments] и [not-comments] [/not-comments]. В случае если для конкретной публикации запрещено использование и добавление комментариев, то эти теги также будут скрывать содержимое в них.

qВ случае если комментарии разрешены для публикации, но при этом пользователю или группе пользователей согласно другим настройкам была запрещена публикация комментариев, то сообщение об этом будет выводиться не в конце всех комментариев, а в том месте, где вы в своем шаблоне определяете вывод формы добавления комментария тегом {addcomments}, тем самым вы можете сами определять местоположение данного сообщения на вашем сайте.

qДля авторизации с использованием социальной сети "Одноклассники", добавлена возможность автоматического получения E-mail пользователя, при условии, что само приложение получило соответствующие права от Одноклассников. Внимание, по умолчанию Одноклассники не дают прав на получение E-mail, и для получения соответствующего доступа вам необходимо дополнительно обращаться в соц. сеть для разрешения получения e-mail. Если разрешение получено, то DLE также автоматически будет импортировать e-mail адрес.

qУлучшена система вычисления пропорций изображения при создании уменьшенных копий. Тем самым создается более корректная и качественная уменьшенная копия.

qУлучшена система поиска публикаций при включенном в настройках скрипта, простом типе поиска. Новый алгоритм позволяет более точно и правильно находить публикации.

qУлучшена система контроля появления дублей страниц, при просмотре всех последних комментариев на сайте.

qОптимизирована обработка дополнительных полей публикаций при показе кратких публикаций, а также при работе модуля вывода популярных публикаций.

qОбновлены визуальные редакторы TinyMCE и Froala до актуальных версий. Исправлен ряд выявленных ошибок в данных редакторах.

qДля редактора TinyMCE добавлена поддержка вставки тегов скрытого текста, c использованием соответствующей кнопки в редакторе.

qПри использовании редактора Floara для комментариев, добавлена возможность быстрой загрузки и вставки изображений в комментарий. Вы можете либо нажать на иконку вставки картинки и выбрать файл для загрузки, либо просто перенести файл картинки с компьютера в поле редактора мышью, после чего картинка автоматически будет загружена и вставлена в позицию курсора в редакторе.

qВнесены небольшие изменения в верстке панели управления скриптом, направленные на устранение некоторых ошибок в верстке и улучшение взаимодействия с панелью управления.

qОбновлены до актуальных версий библиотека отправки почты с сайта, а также библиотека определения мобильных устройств.

qИсправлена проблема, при которой в предварительном просмотре публикаций не обрабатывались теги [comments] и [not-comments].

qИсправлена проблема, при которой некорректно формировались метатеги для соц. сетей видео и аудио, если видео было опубликовано в доп. полях и состояло из плейлистов и описаний видео и аудио файлов.

qИсправлена проблема, при которой при определенных ситуациях и настроек сервера мог не работать предосмотр публикаций, при добавлении публикаций с сайта.

qИсправлена проблема, при которой не работала динамическая загрузка комментариев, если это включено в настройках скрипта, и при этом тег {jsfiles} размещен в самом низу сайта.

qИсправлена проблема, при которой не работал показ последних комментариев, в случае если для определенной группы был запрещен просмотр некоторых категорий.

Список изменений относительно версии 11.3:

qДобавлен абсолютно новый дизайн панели управления. Данный дизайн мы постарались сделать более современным, читаемым и контрастным. Помимо визуальных изменений, новый дизайн имеет и ряд функциональных особенностей. В новой панели управления представлена не одна, а сразу десять цветовых схем, плюс одна специальная ночная схема, оформленная в темных тонах, для комфортной работы в тёмное время суток. Также добавлена возможность управлять шириной бокового меню разделов, и общей шириной панели управления. А при работе на устройствах с небольшими размерами экранов, добавлена возможность перехода в полноэкранный режим, скрыв строку браузера и вкладки, для увеличения рабочего пространства панели. Каждый пользователь админпанели имеет возможность самостоятельно только для себя настроить как будет выглядеть панель, ее параметры и цветовую схему. При этом для сохранения параметров панели используется специальная двойная система хранения настроек. Настройки сохраняются как на сервере, так и в локальном хранилище браузера. Что обеспечивают уникальные возможности при использовании настроек панели управления. Так серверное сохранение настроек позволяет избегать эффекта "мерцания" при применении выбранного пользователем дизайна, и при использовании другого браузера также использовать автоматически выбранные настройки. А сохранение параметров в локальном хранилище позволяет восстанавливать выбранные настройки при полном сбросе параметров на сервере, например, в случае переустановки скрипта или при его глобальном обновлении, например, на новые версии.

qВ панели управления скриптом добавлен краткий предосмотр последних полученных персональных сообщений на сайте. Тем самым пользователь сможет при необходимости быстро перейти к нужному сообщению непосредственно сразу из панели управления.

qВ админпанели, при добавлении публикаций на сайт, сразу после добавления публикации, добавлена возможность выбора следующего действия. На выбор предлагается: "Добавить ещё одну публикацию", "Перейти сразу к редактированию только что добавленной публикации", "Перейти к списку публикаций". Тем самым можно быстро перейти к наиболее частым действиям в один клик.

qВ админпанели, при редактировании публикации, сразу после ее успешного сохранения, добавлена возможность выбора: "Переход к списку публикаций" либо "Продолжить редактирование данной публикации". Тем самым пользователи, которые периодически сохраняют публикацию, в случае редактирования, могут быстро перейти к продолжению начатого редактирования.

qВ админпанели в разделе управления статическими страницами, добавлено сохранение статуса где находится пользователь, перед редактированием или добавлением страницы, и после редактирования страницы он будет возвращаться туда же где и был. Данное нововведение удобно при наличии большого количества страниц, и, например, задании каких-либо параметров поиска, пользователю по возвращении после редактирования, не придётся искать или переходить на нужную страницу заново.

qВ админпанели в разделе управления статическими страницами, добавлено сохранение статуса где находится пользователь, перед редактированием или добавлением страницы, и после редактирования страницы он будет возвращаться туда же где и был. Данное нововведение удобно при наличии большого количества страниц, и, например, задании каких-либо параметров поиска, пользователю по возвращении после редактирования, не придётся искать или переходить на нужную страницу заново.

qВ админпанели также при редактировании статической страницы, сразу после ее сохранения, добавлена возможность выбора: "Переход к списку страниц" либо "Продолжить редактирование данной страницы". Тем самым пользователи, которые периодически сохраняют публикацию, в случае редактирования, могут быстро перейти к продолжению начатого редактирования.

qВ админпанели при выделении публикаций, комментариев, статических страниц, и т.д., для совершения массовых действий над ними, добавлена подсветка выбранных элементов. Тем самым вы сможете удобно видеть какие элементы вы выбрали.

qПолностью переработано редактирование профилей пользователей в панели управления. Теперь в админпанели доступно редактирование всех параметров пользователей, которые раньше были доступны только в редактировании профилей на сайте.

qДобавлен новый модуль "Метатеги". Данный модуль позволяет переназначить в админпанели метатеги title, description, keywords для определённых страниц сайта. Скрипт DLE формирует данные метатеги для всех страниц сайта автоматически, но иногда необходимо задать для определённых страниц свои собственные отдельные значения, например, сделать так, чтобы на странице обратной связи использовались не стандартные из настроек скрипта, а определённые только для данной страницы. Теперь при помощи данного модуля, вы можете это сделать в админпанели вашего сайта. В данном модуле вы задаёте URL страницы для которой хотите переназначить метатеги, и задаёте новые значения этих тегов. После чего для данной страницы будут применяться указанные вами значения. Вы можете переназначить как все поля для данной страницы, так и отдельные. Например, если вы оставите поле keywords пустым, то для него будут применены значения по умолчанию для этого поля и для этой страницы. Вы можете указать непосредственно адрес страницы, для которой вы хотите изменить метатеги, а также вы можете указать группу ссылок используя символ '*', который означает поиск по любому символу, например, указав /page/*/ указанные метатеги будут использоваться для страниц /page/1/, /page/2/, /page/любой текст/ и т.д.

qДобавлена возможность экспорта пользователей с сайта. Если вы используете для организации рассылок сообщений пользователям сторонние сервисы или программы, то при помощи экспорта вы можете быстро сформировать нужные данные. Экспорт пользователей осуществляется в админпанели в разделе редактирования пользователей. Вы можете экспортировать как всех пользователей, так и соответствующих определённым критериям. Экспорт осуществляется либо в формате CSV либо Exel на выбор.

qДобавлена возможность переносить публикации в другие категории при наступлении определённого времени. Для этого при добавлении или редактировании публикации, в настройке "Срок действия до", вы можете выбрать действие "Переместить в другую категорию", и назначить одну или несколько категорий в которые нужно будет перенести публикации при наступлении указанной даты.

qДобавлена возможность исключать определённые новости из поиска по сайту. При добавлении или редактировании новости в админпанели вы можете установить опцию "Исключить из поиска" для каждой публикации отдельно. Тем самым вы можете исключить из поиска новости, для которых вы не хотите, чтобы они принимали участие в поиске по сайту.

qДобавлена возможность назначать каждой новости пароль или список паролей, необходимый для просмотра данной публикации. В случае если публикации задан пароль, то в случае перехода на полную новость, у пользователя будет запрошен ввод пароля, и публикация будет показана только в случае ввода правильного пароля. Введённый пароль будет действовать до тех пор, пока пользователь не закроет браузер, и в пределах одной сессии работы с сайтом, пароль не будет запрашиваться повторно.

qДобавлена возможность назначать каждой новости пароль или список паролей, необходимый для просмотра данной публикации. В случае если публикации задан пароль, то в случае перехода на полную новость, у пользователя будет запрошен ввод пароля, и публикация будет показана только в случае ввода правильного пароля. Введённый пароль будет действовать до тех пор, пока пользователь не закроет браузер, и в пределах одной сессии работы с сайтом, пароль не будет запрашиваться повторно.

qДобавлена возможность назначать каждой статической странице пароль или список паролей, необходимый для просмотра данной статической страницы. В случае если для страницы задан пароль, то в случае перехода на данную страницу, у пользователя будет запрошен ввод пароля, и страница будет показана только в случае ввода правильного пароля. Введённый пароль будет действовать до тех пор, пока пользователь не закроет браузер, и в пределах одной сессии работы с сайтом, пароль не будет запрашиваться повторно.

qДля дополнительный полей, имеющих тип "перекрёстные ссылки", добавлен вывод автоподсказок при добавлении и редактировании публикаций, в виде списка уже имеющихся в базе данных слов. Тем самым облегчается заполнение данных полей, а также снижается вероятность ошибочного заполнения поля.

qДля модуля редиректов добавлена возможность использования масок для задания шаблона по которым производить редиректы. Для этого при задании URL, с которого нужно производить редирект, используется символ "*", который означает что вместо "*" может находится в URL любой набор символов. Например, вы можете задать /page/*/, где и будет производится редирект со всех страниц, таких как /page/1/, /page/2/, /page/text/ и т.д.

qВ админпанели, в разделе редактирования пользователей, добавлена возможность быстрого перехода к редактированию группы конкретного пользователя.

qВ админпанели, в разделе редактирования пользователей, добавлена возможность быстрого перехода к редактированию группы конкретного пользователя.

qДля тега пользовательского вывода публикаций {custom ....} добавлен новый параметр сортировки публикаций "id_as_list" который работает совместо с параметром "id", и сортирует публикации так как они указаны в списке. Например, тег {custom id="3,4,1,2" order="id_as_list"} выведет сначала новость c ID 3 потом 4 потом 1 потом 2. Данное нововведение полезно, когда вы хотите вывести нужные публикации в строго заданном порядке.

qДля тега пользовательского вывода публикаций {custom ....} добавлен новый параметр сортировки публикаций "id_as_list" который работает совместо с параметром "id", и сортирует публикации так как они указаны в списке. Например, тег {custom id="3,4,1,2" order="id_as_list"} выведет сначала новость c ID 3 потом 4 потом 1 потом 2. Данное нововведение полезно, когда вы хотите вывести нужные публикации в строго заданном порядке.

qВ настройки групп пользователей добавлена возможность включать разрешение на публикацию в комментариях видео с использованием тегов [vidео=...]. Тем самым вы можете разрешить или запретить для каждой группы пользователей, разрешено ли им публиковать в комментариях к публикации видео, или нет.

qВ настройки групп пользователей добавлена возможность включать разрешение на публикацию в комментариях видео с использованием тегов [vidео=...]. Тем самым вы можете разрешить или запретить для каждой группы пользователей, разрешено ли им публиковать в комментариях к публикации видео, или нет.

qВнесены изменения в работу быстрого редактирования публикаций на сайте. Теперь при быстром редактировании показываются только те поля, которые были ранее заполнены при добавлении публикации или полном редактировании. Это касается и полей краткого и полного текста для публикации. Если поля краткого описания или полного описания были не заполнены, они больше не отображаются при быстром редактировании. Данное нововведение будет полезно для тех кто использует только доп. поля для публикации, они не будут видеть лишних полей при быстром редактировании на сайте.

qДобавлена возможность убирать из шаблона добавления публикации на сайте такие поля как "краткое" и "полное" описание, с сохранением всей прочей функциональности, например, редакторов. Данное нововведение будет полезно тем, кто строит добавление публикаций исключительно с использованием дополнительных полей.

qДобавлена возможность убирать из шаблона добавления публикации на сайте такие поля как "краткое" и "полное" описание, с сохранением всей прочей функциональности, например, редакторов. Данное нововведение будет полезно тем, кто строит добавление публикаций исключительно с использованием дополнительных полей.

qДобавлен новый глобальный тег для шаблонов {category-title}, который выводит имя просматриваемой посетителем сайта категории. Данный тег будет полезен, когда на сайте нужно отдельно вывести имя просматриваемой категории.

qДля категорий добавлена возможность задать полноценное краткое описание. Описание создаётся в админпанели при добавлении или редактировании категорий в соответствующем разделе. В описании категории вы можете использовать как BBCODES теги, так и HTML теги. Для вывода описания на сайте используется новый глобальный тег для шаблонов {category-description}, который выводит заданное описание, когда пользователь просматривает данную категорию, также вывод доступен и при выводе полных публикаций.

qДля тега вывода меню категорий {catmenu ...}, для его параметра "subcat" добавлена возможность использования нового значения "only", которое означает что нужно выводить только подкатегории из указанной категории. Например, при использовании тега {catmenu id="1" subcat="only"} будут выведены только подкатегории принадлежащие категории с ID "1". Данное нововведение полезно, когда при посещении определённой категории нужно будет вывести список ее подкатегорий. Например, при помощи простой конструкции [available=cat] {catmenu id="{category-id}" subcat="only"} [/avalilable] вы можете автоматически выводить список подкатегорий у просматриваемой на сайте категории.

qВ настройки категорий в панели управления, добавлена возможность исключить выбранную категорию из поиска. Тем самым вы можете для каждой категории задать будет ли она участвовать в поиске по сайту. Если категория исключена из поиска, то при поиске публикаций на сайте, новости из данной категории не будут отображаться в найденных результатах.

qДля дополнительных полей, имеющих тип "Галерея изображений", добавлена возможность выводить загруженные изображения по отдельности. Для этого в шаблонах используется тег [xfvalue_X image="Nr"], где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи. Например, при использовании [xfvalue_test image="2"] будет выведено изображение номер два, загруженное в дополнительное поле с именем "test". Тем самым вы можете использовать одно поле, и при этом выводить превью галереи из одной картинки в кратких новостях, а полностью галерею уже при просмотре полных новостей.

qДобавлена возможность безопасного использования тега {titlе} в HTML атрибутах, при выводе публикаций. Например, вы можете использовать alt="{titlе}" и текст будет сохранять валидность документа, если в заголовке есть кавычки.

qДля тега [mediа=...] добавлена поддержка публикации видео и постов с сервиса Facebook.

qДобавлено Gzip сжатие для CSS файлов, используемых скриптом, что позволяет существенно сократить размер CSS файлов, и как следствие ускорить загрузку страниц. Сжатие включается совместно с сжатием JS файлов в настройках скрипта. При включении сжатия, сжимаются только служебные CSS файлы непосредственно DLE.

qДобавлен автоматический сброс кеша браузера для CSS и JS файлов, используемых скриптом, при обновлении скрипта на новую версию. Данное нововведение позволит браузеру при обновлении скрипта, сразу загружать актуальные файлы от новой версии, а не использовать старые из кеша.

qДобавлена поддержка тега {THEME} в предварительном просмотре рекламных материалов в панели управления скриптом.

qПри добавлении каких-либо данных в админпанели, добавлена визуальная подсветка сколько символов добавлено в данное поле, и сколько максимум ещё можно добавить. Данное нововведение позволяет визуально видеть, сколько можно ещё ввести, чтобы не выйти за ограничения на длину поля.

qВ случае если в настройках скрипта не указан протокол вашего сайта, начиная с данной версии DLE будет использовать безопасное SSL соединение и будет генерировать ссылки на https протокол.

qДобавлены превентивные меры защиты сайта от "бесконечных" редиректов, в случае если в настройках скрипта включено использование только HTTPS протокола, но при этом сервер не настроен корректно и не передаёт информации о используемом сайтом протокола.

qДобавлены превентивные меры защиты сайта от "бесконечных" редиректов, в случае если в настройках скрипта включено использование только HTTPS протокола, но при этом сервер не настроен корректно и не передаёт информации о используемом сайтом протокола.

qДля страниц персональных закладок публикаций, добавлена отправка 403 HTTP кода (доступ запрещён) в браузер, в случае если по адресу закладок, заходит незарегистрированный пользователь. Тем самым данные страницы будут запрещены к индексации для поисковых систем, и они не будут ошибочно индексировать данную страницу с одним единственным сообщением об ошибке доступа к разделу.

qСущественно снижена нагрузка на базу данных при показе последних комментариев на сайте, для сайтов с большим количеством комментариев.

qОптимизирован показ блока облака тегов, на базах данных с большим количеством публикаций на сайте. Запрос к базе данных был улучшен и ускорен.

qДобавлена поддержка фигурных скобок { и } в модуле "Фильтр слов", теперь вы можете использовать в фильтре слова, содержащие данные символы.

qДобавлено автоматическое исключение публикаций из карты сайта для поисковых систем, в случае если в самой публикации во вкладке "Доступ" был запрещён просмотр публикации для гостей.

qДобавлено автоматическое исключение публикаций из карты сайта для поисковых систем, в случае если в самой публикации во вкладке "Доступ" был запрещён просмотр публикации для гостей.

qОбновлён до актуальной версии парсер HTML кода для добавляемых на сайт публикаций.

qИсправлена проблема, связанная с некорректным уведомлением поисковых систем по крону о обновлении карты сайта, в случае если имя сайта в настройках скрипта было задано без указания протокола.

qИсправлена проблема, при которой могли не отображаться визуальные редакторы на странице добавления публикации на сайте, в случае если на этой же страницы находились теги custom.

qИсправлена проблема, при которой могли не отображаться визуальные редакторы на странице добавления публикации на сайте, в случае если на этой же страницы находились теги custom.

qИсправлена проблема, при которой в уведомлениях на E-mail, о новых комментариях или персональных сообщений, отправлялся слитный текст без переносов строк.

qИсправлена проблема, при которой терялся перенос строк в пустых незаполненных строках при использовании редактора TinyMCE в новостях.

qИсправлена проблема, при которой терялся перенос строк в пустых незаполненных строках при использовании редактора TinyMCE в новостях.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 11.2:

qДобавлен новый модуль "Редиректы" для админпанели скрипта. В данном модуле вы можете задавать ссылки для редиректов с одних страниц на другие. Данный модуль будет особенно полезен, когда вы что-либо удалили или перенесли в другое место. Например, удалили одну категорию, и заменили ее на другую, теперь вы можете сделать редирект со старой категории на новую указав старый и новый адрес в данном модуле. При посещении старого адреса будет произведён 301 редирект на новый адрес, что позволит и пользователям попасть на нужную страницу автоматически, и поисковикам правильно склеить нужные адреса. Также данный модуль может использоваться если какие-то ссылки у вас неверно попали в индекс поисковых систем.

qПолностью переписана система кеширования для memcache, для данного типа кеширования введено понятие префиксов данных. Поэтому теперь при использовании данного типа кеширования, при изменении информации в БД, кэш будет очищаться только у необходимых элементов, а не полностью, как было ранее. Тем самым существенно снижена нагрузка на сервер при использовании данного типа кеширования.

qВ настройки скрипта добавлена возможность указания количества страниц, при показе кратких публикаций, которое необходимо кешировать. Ранее в скрипте кэшировались только первые 10 страниц по навигации по сайту. Теперь вы можете по своему желанию указать любое количество страниц, которое необходимо кешировать.

qВ настройки скрипта добавлена возможность указания использования только https протокола при работе с сайтом. При включении данной настройки, все пользователи, которые посещают страницы вашего сайта через обычный http протокол, будут принудительно перенаправлены на использование безопасного SSL соединения. Тем самым больше нет необходимости править файлы .htaccess и настройки nginx для организации принудительных редиректов.

qВ настройки скрипта добавлена возможность включения для визуальных редакторов WYSIWYG, режима использования ББ тегов для изображений. При включении данного режима картинки будут вставляться в виде текстовых ББ тегов. Данное нововведение будет полезно пользователям, которые хотят использовать визуальное редактирование для публикаций, но при этом оптимизировать занимаемое место в редакторе картинками. При отключении данной настройки, изображения будут вставляться в обычном визуальном режиме в виде картинок.

qДобавлена возможность отправлять в обратной связи прикреплённые к письмам файлы. Для этого в настройках групп можете задать для каждой группы пользователей разрешено ли им прикреплять к письмам файлы. Также можете указать сколько максимально файлов они могут приложить к письму, их максимальный суммарный размер, а также какие типы расширений файлов, которые они могут отправлять.

qДля шаблона обратной связи (feedback.tpl) добавлено использование тегов [attachments] текст [/attachments], которые выводят текст, заключённый в них, если разрешена отправка файлов в обратной связи для данной группы пользователей.

qДобавлена возможность использования нескольких форм обратной связи на сайте. Для этого используется специально сформированный URL в браузере. Для отправки стандартной формы обратной связи используется адрес http://вашсайт.ru/index.php?do=feedback Для того чтобы добавить ещё одну форму связи вы можете использовать адрес http://вашсайт.ru/index.php?do=feedback&template=X1&mailtemplate=X2, где X1 это имя шаблона для шаблона формы обратной связи, а X2 это имя шаблона письма, которое будет отправляться через эту форму. При этом если задан шаблон X1, то на сервере в папке шаблона у вас должен находится файл с именем feedback_X1.tpl, а если задан шаблон X2, то на сервере в папке шаблона у вас должен находится файл с именем email_X2.tpl. Например, при использовании URL http://вашсайт.ru/index.php?do=feedback&template=test&mailtemplate=test в папке вашего шаблона должен находится файл feedback_test.tpl для формы обратной связи и email_test.tpl для шаблона отправляемого сообщения. Эти файлы поддерживают все те же теги что и стандартная форма обратной связи, и стандартный шаблон e-mail сообщений в админпанели. Тем самым с учётом того что формы обратной связи поддерживают дополнительные поля разного типа, вы можете организовать на своём сайте, несколько различных форм обратной связи.

qВсе публикуемые изображения при помощи BBCODES тегов автоматически получают свойства адаптивности, чтобы они не выходили за границы элементов сайта, в которых они опубликованы. Данное нововведение облегчает вёрстку шаблонов для новичков.

qДля модуля "Список действий в админпанели" добавлена возможность поиска нужных данных по логину, IP или дате. Просто вводите в строку поиска нужные вам данные и скрипт автоматически найдёт записи подпадающие под данные критерии. Тем самым предоставляется возможность удобного нахождения в логах необходимых данных.

qДля модуля "Перекрёстные ссылки", добавлено игнорирование тегов заголовков h1...h5 в данных тегах замены текста на перекрёстные ссылки производится не будет.

qДля модуля "Поиск и замена" в панели управления скриптом, добавлен поиск и замена текста в рекламных материалах.

qДля модуля "Перестроение публикаций" добавлена возможность указания с какой публикации начать перестроение. Например, в случае остановки перестроения публикаций, или случайного закрытия окна, вы можете продолжить перестроение с нужного места, без необходимости все начинать с начала.

qДля модуля "Перестроение публикаций" добавлена возможность перестроения комментариев. Тем самым в случае изменений в парсере или настроек сайта, вы можете запустить автоматическое перестроение также и для всех комментариев на сайте, чтобы изменения вступили в силу в уже опубликованных ранее комментариях.

qУвеличена скорость перестроения публикаций в разделе перестроения публикаций в панели управления скриптом, а также улучшена система обработки ошибок, в случае их возникновения.

qДля модулей редактирования комментариев, в панели управления, добавлена поддержка редакторов для редактирования выбранных комментариев, вместо обычного текстового поля. Тем самым вы можете более удобно править текст комментариев.

qДля модулей редактирования комментариев, в панели управления, добавлена возможность выбора всех комментариев одним кликом, для более быстрого осуществления над ними массовых действий.

qПри добавлении комментария незарегистрированным пользователем, добавлен контроль используемого им имени и e-mail на соответствие с фильтром по: "IP, Логину или E-Mail." В случае если указанные там логины или e-mail запрещены, то будет также автоматический запрет на публикацию комментария с этими данными.

qДля модуля добавления публикаций на сайте добавлена возможность передавать в URL браузера категории, которые необходимо сделать выбранными по умолчанию. Для этого используется URL http://вашсайт.ru/index.php?do=addnews&category=X где "X" это ID нужных вам категорий, перечисленные через запятую. Например, по адресу http://вашсайт.ru/index.php?do=addnews&category=3,4,5 в форме добавления новости на сайте будут выбраны по умолчанию категории с ID 1, 2 и 3. Данное нововведение будет полезно для сайтов, которые используют доп. поля для публикаций назначенные разным категориям, и хотят дать пользователям при добавлении публикаций несколько уже предустановленных форм добавления публикации, для различных категорий.

qДобавлена поддержка написания микроразметки (такие атрибуты как: itemprop, itemtype, itemscope) непосредственно в тексте публикаций.

qДобавлено автоматическое разбиение длинных слов также и для персональных сообщений на сайте, а не только для комментариев.

qДля RSS информеров добавлена поддержка тега enclosure в RSS потоке для определения картинок. В случае если в тексте публикации RSS потока отсутствуют картинки, но при этом они определены тегом enclosure, то для тега {image-1} будет назначена картинка из тега enclosure. Данное нововведение например будет полезно для RSS информеров погоды и т.д.

qДля тега вывода скрытого текста ([hidе] текст [/hidе]) добавлена возможность указания, каким группам разрешён просмотр указанного в тегах текста. Вы можете указать в параметрах тега каким группам разрешено просматривать содержимое. Например, вы можете написать [hidе=3] текст [/hidе], в данном случае просмотр содержимого тега будет доступен только журналистам. Группы также допускается перечислять через запятую, например, [hidе=2,3,4] текст [/hidе]. В случае если параметр группы не указан, то действуют настройки групп, указанные в панели управления, на предмет того разрешено ли пользователю просматривать текст или нет. Администраторы сайта видят скрытый текст всегда, независимо от указанных а теге параметрах.

qПолностью переосмыслен тег [media=...] в новостях. Теперь данный тег предназначен не только для встраивания видео с сервиса youtube, но и для встраивания различных фотографий, аудио, видео, документов и виджетов с большого количества сайтов и сервисов. Для этого данный тег был переведён на использование открытого протокола oembed, благодаря которому сервисы сообщают необходимый код для вставки. На данный момент добавлена поддержка 16 сервисов: youtube, instagram, twitter, facebook, flickr, vimeo, docs.com, vine, gettyimages, codepen.io, dailymotion, mixcloud, soundcloud, coub, ifixit, Apple Keynote. При необходимости новые сервисы, поддерживающие oembed могут быть легко добавлены.

qДля пользовательского вывода публикаций при помощи тега {custom ...} добавлена возможность использования нового параметра futureannounce="yes". Данный параметр работает совместно с параметром days="X", и указывает что публикации нужно брать из будущих дат. Например, тег {custom futureannounce="yes" days="1"} означает что необходимо вывести публикации, дата которых назначена на завтра, т.е. на +1 дней, а тег {custom futureannounce="yes" days="2"} выводит публикации дата которых назначена на завтра и послезавтра, и т.д. Данных параметр будет полезен вебмастерам, для вывода грядущих анонсов на своём сайте.

qВ случае если включена настройка скрипта: "Блокировать скачивание файлов с других серверов", и ссылка на ваш файл была опубликована на стороннем сайте, то пользователи при переходе по данной ссылке, будут перебрасываться не на главную страницу вашего сайта, а непосредственно в ту новость или статическую страницу, в которой данный файл опубликован.

qДля шаблонов вывода меню категорий (categorymenu.tpl) добавлен новый тег {id}, который выводит ID категории. Данный тег будет полезен, когда нужно визуально выделить какую-либо категорию.

qВ языковые файлы панели управления скриптов, добавлена возможность указания формата для выводимых в панели управления дат. Данное нововведение будет полезно при локализации скрипта на различные языки, для стран, где представление даты отличается от российского.

qДобавлены превентивные меры защиты от случайного удаления загруженных картинок к новости, в случае нажатия кнопки "Удалить выбранное". При нажатии на удаление, необходимо будет дополнительно подтвердить необходимость удаления выбранных картинок.

qДобавлена автоматическая поддержка определения типов картинок в случае несоответствия реальных данных с расширением файла. Например, если картинка имеет расширение jpg, а по факту ее содержимое является gif картинкой, то скрипт больше не будет выдавать сообщение о ошибке файла, а будет обрабатывать автоматически картинку как gif.

qДобавлена типографская обработка текста для визуальных редакторов TinyMCE и Froala, а также произведены общие улучшения правил типографской обработки текстов.

qОптимизирована нагрузка на базу данных, при выводе публикаций при помощи пользовательского тега {custom ...} если в качестве критериев выборки публикаций заданы категории, а также в настройках групп есть ограничения на показ новостей из определённых категорий.

qДобавлено автоматическое определение кодировки URL строки при показе публикаций из облака тегов и при выводе результатов поиска по доп. полям. Кодировка таких ссылок будет автоматически определяться, для того чтобы при переходе на другую кодировку, они не терялись. Например, при переводе сайта с кодировки windows-1251 на utf-8.

qУлучшена система контроля неверных ЧПУ при выводе публикаций из облака тегов, при выводе результатов поиска по доп. полям, а также при выводе категорий.

qУлучшена система кеширования блоков публикаций при их выводе с использованием пользовательского тега {custom ...}

qДобавлена автоматическая очистка логов опросов и рейтингов от удаляемых с сайта пользователей. Например, если пользователи массово автоматически удаляются по прошествии указанного времени в течении которого они не посещали сайт, то и информация о них в логах также очищается. Тем самым, если впоследствии, зарегистрируются пользователи с аналогичными логинами то они сами также смогут принять участие в выставлении рейтингов и в опросах.

qУлучшена система безопасной вставки флэша в тексты публикаций. Имена допустимых переменных больше не чувствительны к регистру символов, и могут быть написаны в любом регистре.

qОбновлена библитека PHPMailer для отправки писем с сайта до актуальной версии.

qОбновлены визуальные редакторы TinyMCE и FroalaEditor. При этом для редактора FroalaEditor помимо всего прочего была добавлена возможность улучшенной вставки текстов, отформатированных в Word с возможным сохранением форматирования на выбор.

qДобавлен автоматический контроль кодировки ссылок, опубликованных при помощи тега [lееch=...] текст [/lееch]. В случае если ссылка была добавлена в одной кодировке сайта, а потом сайт был переведён на другую кодировку, то ссылка, содержащая символы, отличные от латинских, также будет автоматически сконвертирована корректно при редактировании.

qПри выставлении рейтинга публикации, добавлен контроль на предмет того, разрешено ли выставление рейтинга для данной конкретной новости или нет. Это позволяет предотвратить накрутку рейтинга пользователя в случае если для определённых публикаций, запрещено выставление рейтинга.

qДобавлены новые превентивные механизмы для защиты сайта от действий злоумышленников, использующих методы социальной инженерии.

qОптимизирована и ускорена загрузка и рендеринг страниц сайта, при использовании визуальных (WYSIWYG) редакторов на сайте. Добавлена поддержка Gzip сжатия для TinyMCE редактора. Убрана дублирующая загрузка редакторов при редактировании публикаций и комментариев, а также при ответах на комментарии.

qПрекращена поддержка воспроизведения flv видеороликов со стороны плеера DLE.

qИсправлена проблема, при которой не обрабатывался тег [videо=...] если в пути к видео отсутствовало полное имя домена с протоколом.

qИсправлена проблема, при которой могло быть повреждение вёрстки сайта, в случае использования служебных тегов DLE в заголовках публикаций.

qИсправлена проблема, при которой в случае добавления комментариев на сайте, содержащих теги скрытого текста, пользователям, подписанным на уведомления о комментариях, также отправлялось содержание скрытого текста, несмотря на то что им может быть запрещён просмотр скрытого текста.

qИсправлена проблема, при которой в качестве логинов пользователей было разрешено использовать неразрывные пробелы, что позволяло создавать не видимые визуально логины пользователей.

qИсправлена проблема, при которой могли возникнуть проблемы с пользовательским выводом доп. полей при добавлении публикаций на сайте, если выводились не все доп. поля в шаблоне добавления публикаций.

qИсправлена проблема, при которой отправлялась неверная подпись, в письме на подтверждение смены E-Mail адреса, если был задан не полный адрес сайта в настройках скрипта, без указания протокола.

qИсправлена проблема, при которой невозможно было задать 0 в качестве значения в дополнительных полях пользователей.

Список изменений относительно версии 11.1:

qДобавлена возможность использования двухфакторной авторизации на сайте. Включается данная возможность в настройках скрипта в панели управления. После ее включения, все пользователи смогут включить двухфакторную авторизацию на сайте в своем профиле. При активации данного типа авторизации, пользователю, после успешного ввода своего логина и пароля, на его E-mail адрес будет отправлен одноразовый пин-код, который он должен будет ввести на сайте. В случае включения данной опции в профиле пользователя, для него также автоматически включается "контроль изменения IP" и "контроль используемого браузера и компьютера". Данная возможность существенно увеличивает безопасность пользовательских данных. Например, в случае кражи у них доступа от сайта, им невозможно будет воспользоваться без доступа к их E-mail адресу.

qДля шаблона вывода и редактирования профиля пользователя (userinfo.tpl) добавлено использование нового тега {twofactor-auth}, который выводит чекбокс для включения или отключения двухфакторной авторизации на сайте для пользователя.

qДобавлена возможность подсчета количества публикаций у каждой категории. Подсчет количества публикаций у категорий ведется с учетом различных настроек сайта и параметров самой новости. Например, если новость опубликована в подкатегории и при этом включен показ новостей из подкатегорий в родительских категориях, то для всех родительских категорий также будет учтена данная новость, но если родительская категория указана дополнительно и в списке категорий самой новости, то двойного учета уже не будет. Для подсчета данной информации был использован наиболее эффективный механизм, призванный снизить расходы памяти и нагрузки, для этого часть подсчетов ведет MySQL сервер, а недостающую часть PHP, при этом если включено кеширование на сайте, то подсчитанное количество публикаций также кэшируется. Несмотря на наиболее оптимальный механизм подсчета, данная возможность увеличивает нагрузку на сервер, поэтому вы можете ее включить или отключить в настройках скрипта в панели управления. Данную информацию можно выводить на сайте различными способами, которые описаны в описании данного релиза ниже.

qДобавлена возможность выводить и формировать меню из категорий сайта в шаблонах. Для вывода меню категорий используется тег {catmenu}. Данный тег вы можете использовать в любом файле шаблонов, он является глобальным. Данный тег в свою очередь использует и подключает файл шаблона categorymenu.tpl.

qПомимо вывода меню категорий при помощи тега {catmenu} добавлено также использование данного тега с пользовательскими параметрами. Вы можете использовать в данном теге следующие параметры: {catmenu id="1,2,3-5" subcat="yes" template="custom" cache="yes"}

qДобавлен новый глобальный тег {catnewscount id="X"} для шаблонов. Который выводит количество публикаций для указанной категории, где X это ID нужной вам категории. Данный тег будет полезен для вывода количества публикаций, в уже сформированных вручную в шаблонах меню на сайтах.

qДобавлено использование абсолютно нового парсера кода HTML для публикаций на сайте. Данный парсер используется для фильтрации входящего HTML кода, при написании новостей и статических страниц. Новый парсер в отличии от старого, не только фильтрует весь введенный текст на предмет безопасности HTML кода, но и автоматически исправляет пользовательские ошибки в данном коде. Например, закрываются незакрытые HTML теги, удаляются ошибочные или неправильные стили CSS, а также исправляются ошибки, связанные с валидностью введенного HTML кода. Несмотря на множество добавленных возможностей в парсере, фильтрация HTML кода в нем проводиться намного быстрее старого парсера (в сравнении с предыдущей версией 11.1)

qВесь генерируемый в текстах новостей HTML код, с использованием DLE, был переведен на соответствие спецификациям HTML5 вместо устаревшего XHTML.

qДобавлена полностью новая система хранения паролей пользователей в базе данных MySQL. Ранее для хранения хешей паролей использовались алгоритмы md5, которые уже устарели позволяют довольно быстро подобрать исходных пароль методом перебора, если злоумышленники получили доступ к хешу пароля. Новая система хранения паролей использует алгоритм хеширования CRYPT_BLOWFISH, и является на данный момент очень криптостойким алгоритмом. Данное нововведение призвано в первую очередь защитить исходные пароли пользователей в случае компрометации базы данных, например, в случае если злоумышленник получил прямой доступ к базе данных. Т.к. исходные пароли изначально не хранятся в базе данных, замена хешей паролей будет происходить в "мягком режиме", по мере того как пользователи будут входить на сайт под своим логином и паролем на сайт. Тем самым все существующие пароли пользователей будут действовать, а по мере первого входа на сайт, алгоритм хеширования будет заменен. Также новая система хранения паролей предусматривает автоматическое обновление алгоритмов хеширования паролей, в случае появления новых криптостойких алгоритмов в PHP, тем самым хеши паролей всегда будут храниться в безопасном виде.

qБлагодаря новой системе хранения паролей, при объединении аккаунта на сайте с аккаунтом в социальной сети, исходные пароли больше не сбрасываются. Если вы были ранее зарегистрированы на сайте и авторизовались при помощи социальной сети, то также можете продолжать пользоваться своим старым паролем для входа на сайт.

qДобавлена возможность более упрощенной вставки флэш роликов и флэш плееров. Теперь скрипт автоматически приведет код вставки флэша в безопасный вид, вместо того удаления его из текста новости. Несмотря на то, что флэш уже устарел как технология, многие сайты им продолжают еще пользоваться.

qДобавлена возможность восстановления забытого пароля непосредственно на странице входа в панель управления скриптом.

qДля массовой рассылки писем и сообщений в админпанели добавлена возможность выбора интервала даты регистраций пользователей, которым будут отправлены письма. Тем самым вы можете более гибко выбрать целевую аудиторию для своих сообщений

qДля массовой рассылки писем и сообщений в админпанели добавлена возможность выбора интервала даты регистраций пользователей, которым будут отправлены письма. Тем самым вы можете более гибко выбрать целевую аудиторию для своих сообщений.

qДля вывода публикаций в пользовательском формате тега {custom ...} добавлена возможность указывать порядок сортировки публикаций по дате их редактирования. Для этого используется параметр order="editdate". Например, при использовании тега {custom order="editdate" sort="desc" limit="5"} выведутся пять последних отредактированных новости. Данный вывод будет полезен для вывода блоков новостей с новой актуальной информацией, например, при обновлении ссылок в них и т.д.

qПри создании дополнительных полей к публикациям, добавлена возможность добавлять тексты подсказок, которые будут выводится пользователям при добавлении новостей. Тем самым вы можете задать инструкции для пользователей, как их необходимо заполнять данные поля в публикации.

qПри создании дополнительных полей к публикациям, добавлена возможность добавлять тексты подсказок, которые будут выводится пользователям при добавлении новостей. Тем самым вы можете задать инструкции для пользователей, как их необходимо заполнять данные поля в публикации.

qПри создании дополнительных полей к публикациям, добавлена возможность указывать каким группам пользователей разрешено видеть эти поля в опубликованных новостях на сайте. Тем самым упрощается процесс верстки шаблонов, если каким-то группам запрещен просмотр определенных доп. полей, и это можно легко включить и отключить непосредственно в панели управления.

qДля шаблона RSS вывода новостей (rss.tpl), добавлена поддержка тегов {image-x} и [image-x]текст[/image-x], которые выводят URL "X" картинки, и показывают текст заключенных в них, если картинка присутствует.

qДля тегов {image-x} и [image-x]текст[/image-x] добавлена поддержка текста не только из краткого описания новости, но и из текста дополнительных полей в публикации. При этом нумерация картинок идет сначала из текста краткого описания, потом из текста дополнительных полей. Данное нововведение будет полезно для вебмастеров, которые не используют краткое описание публикации, а картинки публикуют в текстах дополнительных полей.

qДля тегов {image-x} и [image-x]текст[/image-x] добавлено игнорирование смайлов, опубликованных в текстах. Например, если в тексте публикации были опубликованы смайлы, то они также учитывались и выводились этим тегом. Теперь они полностью игнорируются и не учитываются, а ведется вывод только именно изображений, опубликованных в тексте новостей.

qДобавлено автоматическое снятие новости с показа в похожий публикациях, в случае если новость снимается с показа на сайте и отправляется на модерацию. Ранее для ее снятия с данного блока необходимо было делать сброс кэша похожих публикаций.

qДобавлено автоматическое определение режима работы PHP интерпретатора на сервере. В случае если режим работы был изменен в настройках сервера, будут автоматически отключены не поддерживаемые им возможности. Например, если включен расширенный режим авторизации в панели управления скрипта, а PHP был переключен в режим CGI или FastCGI, в котором данный режим не поддерживается сервером, то данная настройка будет автоматически отключена, и администратор сможет также без проблем авторизоваться в панели управления.

qДобавлена возможность подписываться на комментарии к публикациям, без необходимости оставлять комментарий на сайте к данной публикации. Для этого в шаблонах вывода полной новости (fullstory.tpl) и добавления комментария (addcomments.tpl), добавлены новые теги [comments-subscribe] текст [/comments-subscribe], которые выводят текст, заключенный в них в виде ссылки на подписку на уведомления о новых комментариях. Тем самым посетители сайта могут подписываться на комментарии к нужной публикации, без необходимости написания собственного комментария.

qДобавлена возможность использования дополнительных полей в разделе обратной связи на сайте. Для того чтобы добавить дополнительное поле в форму обратной связи, вам необходимо только разместить необходимое поле с определенным именем в форме, после чего оно будет доступно для использования в шаблонах e-mail сообщений. Для добавления дополнительного поля в форму, для поля ввода необходимо использовать атрибут с именем: name="xfield[X]", где X это имя поля, написанное латинскими буквами.

qДля раздела управления рекламными материалами в админпанели, добавлена возможность указывать рекламным материалам, на каких устройствах их нужно показывать. Вы можете как отдельно, так и вместе указать на каких пользовательских устройствах будет показана ваша реклама, это могут быть компьютеры, планшеты или смартфоны. Указав нужные устройства, вы можете упростить верстку шаблона, и немного уменьшить расход трафика, если на каких-то устройствах рекламу данную показывать не нужно.

qДля раздела управления рекламными материалами в админпанели, добавлена возможность указывать рекламным материалам, на каких устройствах их нужно показывать. Вы можете как отдельно, так и вместе указать на каких пользовательских устройствах будет показана ваша реклама, это могут быть компьютеры, планшеты или смартфоны. Указав нужные устройства, вы можете упростить верстку шаблона, и немного уменьшить расход трафика, если на каких-то устройствах рекламу данную показывать не нужно.

qДля системы логирования администраторских действий, добавлено логирование успешных авторизаций пользователей на сайте, имеющих доступ к панели управления скриптом. Ранее фиксировались только неудачные попытки авторизации, и успешные авторизации при переходе в панель управления.

qДля загружаемых файлов на сервер с использованием скрипта, добавлено вычисление размера и контрольных сумм для этих файлов и последующее их сохранение в базе данных вместе с другой информацией о файлах. И при показе на сайте вложений для скачивания, данная информация берется из базы данных, а не вычисляется на лету для каждого показываемого файла. Данное нововведение существенно снижает нагрузку на сервер при публикации большого количества файлов.

qДля визуального редактора FroalaEditor добавлена возможность задавать описания для уменьшенных копий изображений. Для задания описания достаточно написать альтернативный текст для картинки, по соответствующей кнопке на изображении. Данные описания будут показываться при увеличении уменьшенных копий до оригинальных копий.

qДля визуального редактора TinyMCE изменена вставка уменьшенных копий загруженных изображений. Теперь вместо использования ББ тегов в данном редакторе, вставляется HTML код для показа уменьшенной копии. Тем самым в редакторе сразу отображается вставленная картинка, и над ней можно производить действия используя возможности визуального редактора, например, задать описание и т.д.

qВ целях обеспечения более качественной SEO оптимизации сайта внесены изменения в формирование тега [img ...]. Теперь для данного тега атрибут alt будет заполнятся автоматически (в случае отсутствия ручного описания) заголовком новости только для первой картинки в поле текста, для всех других картинок в данном поле он будет оставаться пустым. Использование одинаковых описаний для разных картинок может негативно влиять на поисковую оптимизацию, поэтому если нужно максимально ее улучшить, задавайте картинкам ручные описания. Для вступления данных изменений для старых ранее опубликованных новостей, необходимо будет запустить перестроение публикаций в панели управления скриптом.

qВ целях обеспечения более качественной SEO оптимизации сайта и избавления от избыточного кода, для генерации показа уменьшенных копий изображений внесены изменения. Теперь описание к картинкам будет браться автоматически из атрибута alt, данный атрибут не будет автоматически заполняться названием новости в случае отсутствия ручного описания. Для вступления данных изменений для старых ранее опубликованных новостей, необходимо будет запустить перестроение публикаций в панели управления скриптом.

qДля генерируемого кода уменьшенных копий изображений, в целях обеспечения валидности генерируемого кода, убрано использование атрибута "rel".

qПри скачивании файлов, загруженных через скрипт, добавлена проверка параметров доступа установленных для разных групп, непосредственно в настройках самой публикации во вкладке "Доступ". Например, если для новости запрещен просмотр для определенной группы, то и скачивание файлов, прикрепленных к этой новости будет запрещено для этой группы.

qПри скачивании файлов, загруженных через скрипт, добавлена проверка параметров доступа к различным категориям публикаций, установленных для данной группы пользователей. Например, если пользователям определенной группы, запрещена к просмотру какая-либо категория, то и скачивание прикрепленных файлов из публикаций данной категории также будет автоматически запрещено для данных пользователей.

qДля модуля перекрестных ссылок улучшена система определения ссылок на самих себя, при которых автозамена не производится. Ранее ссылку нужно было писать в полном формате включая домен, например http://site.com/test/1-test.html и только тогда замена на такой странице не проводилась, теперь достаточно написать сокращенный ее вариант, без указания домена /test/1-test.html и при посещении данной страницы, замены для ключевого слова проводится не будет. Данное нововведение будет полезно при использовании на сайте одновременно разных протоколов http и https, а также при использовании на сайте нескольких доменов зеркал.

qПри добавлении новой категории в массовых действиях, в разделе управления публикациями в админпанели, добавлен контроль присутствует ли добавляемая категория уже в публикации, если да, то ее повторное добавление не осуществляется. Данное нововведение позволяет избежать ошибочного повторного добавления категории для публикации.

qПри добавлении новой категории в массовых действиях, в разделе управления публикациями в админпанели, добавлен контроль присутствует ли добавляемая категория уже в публикации, если да, то ее повторное добавление не осуществляется. Данное нововведение позволяет избежать ошибочного повторного добавления категории для публикации.

qУлучшена работа выпадающий меню в админпанели, таким образом, чтобы они не выходили за пределы экрана при недостаточном месте по высоте.

qВнесены изменения в порядок сортировки загруженных изображений на сервер. Ранее при загрузке изображений на сервер, они сортировались в порядке их загрузки на сервер, а после удаления любой из картинок они отсортировывались в алфавитном в порядке, что приводило к путанице, в случае если картинок для публикации очень много, и осложняло их поиск для вставки в публикацию. Теперь при загрузке картинок на сервер, они также выводятся в том же порядке, что и были загружены на сервер, а при удалении любой из картинок данный порядок также полностью сохраняется.

qВнесены изменения в порядок сортировки загруженных изображений на сервер. Ранее при загрузке изображений на сервер, они сортировались в порядке их загрузки на сервер, а после удаления любой из картинок они отсортировывались в алфавитном в порядке, что приводило к путанице, в случае если картинок для публикации очень много, и осложняло их поиск для вставки в публикацию. Теперь при загрузке картинок на сервер, они также выводятся в том же порядке, что и были загружены на сервер, а при удалении любой из картинок данный порядок также полностью сохраняется.

qУлучшена совместимость скрипта с MySQL линейки 5.7.x

qОбновлены визуальные редакторы TinyMCE и FroalaEditor до актуальных версий. Были исправлены многие ошибки в работе данных редакторов, с различными браузерами.

qИсправлена проблема, при которой не сохранялся полный путь к загруженному аватару, при использовании авторизации через социальные сети, что могло приводить к проблемам при показе аватара если используется несколько разных доменов и сайтов с единой регистрацией пользователей.

qИсправлена проблема, при которой могла иногда происходить неверная выборка публикаций, если используется тег {custom ...} в комбинации различных нескольких параметров.

qИсправлена проблема, при которой могло происходит некорректно отображение дополнительных полей с типом "Галерея изображений", в случае если разные доп. поля выводятся одновременно и в шаблоне полной новости (fullstory.tpl) и общем шаблоне (main.tpl)

qИсправлена проблема, при которой могла возникать ошибка "Слишком длинное значение поля" для полей, которые автоматически генерируются скриптом. Например, для метатегов описания.

qИсправлена проблема, при которой не обновлялся код рекаптчи после успешного добавления комментария на сайт.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 11.0:

qДобавлена возможность загружать на сервер изображения к публикуемым на сайте комментариям. Данная возможность включается и настраивается в настройках групп. Для каждой группы пользователей вы можете разрешить или запретить загрузку изображений к комментариям. Также для каждой группы вы можете задать различные отдельные параметры для загружаемых изображений, например, максимальное количество загружаемых изображений к комментариям, их размеры и вес и т.д. При загрузке изображений к комментарям пользователю доступна упрощенная форма загрузки комментариев, и изображения загружаются согласно заданным в настройках групп параметрам. Пользователю при этом доступно управление своими загруженными изображениями. Он может их удалить или заменить, если ему разрешено редактировать свои комментарии.

qДобавлена поддержка движка InnoDB для базы данных MySQL. При установке скрипта вы можете выбрать, какой тип хранения использовать. Для выбора доступно использование либо InnoDB либо MyISAM. При выборе движка мы рекомендуем руководствоваться следующими критериями. Если ваш сайт будет редко обновляться новым контентом (регистрация большого количества пользователей, активное добавление новых комментариев и т.д.) т.е. сайт "справочник", то рекомендуется использовать MyISAM тип, он быстрее при выборке из базы данных. Если на сайте планируется активное обсуждение чего-либо большим количеством пользователей, то рекомендуется использовать InnoDB тип. Для большинства сайтов оптимальным выбором будет именно InnoDB, т.к. в будущем он более легко масштабируется. Выбор движка базы данных доступен только если на вашем сервере установлена версия MySQL не ниже чем 5.6.4. Если версия MySQL сервера ниже, то доступно использование только MyISAM.

qДобавлена возможность создания и использования плейлистов при воспроизведении видео на сайте. Для этого видеофайлы просто перечисляется в теге video через запятую. Например: [video=http://site.ru/video1.mp4,http://site.ru/video2.mp4,http://site.ru/video3.mp4]

qДобавлена возможность создания описания, для видео которое будет видно при показе в плеере, для этого в теге вставки видео используется следующий формат: [videо=путь к видео файлу|путь к постеру для видео|описание видео], тоже самое можно задать для всех файлов если используется плейлист файлов, добавленный через запятую. Пример отображения вы можете увидеть на скриншоте выше.

qДобавлена возможность использовать в теге [videо=...], также ссылки на видео в сервисе Youtube. Тем самым вы можете организовывать смешанные плейлисты включающие в себя ваше видео и видео на сервисе Youtube.

qДобавлена возможность создания и использования плейлистов при воспроизведении аудио на сайте. Для этого аудиофайлы просто перечисляется в теге audio через запятую. Например: [audio=http://site.ru/audio1.mp3,http://site.ru/audio2.mp3,http://site.ru/audio3.mp3]

qДобавлена возможность создания описания, для аудио которое будет видно при воспроизведении музыки в плеере, для этого в теге вставки аудио используется следующий формат: [audiо=путь к аудио файлу|описание аудио]. Пример отображения вы можете увидеть на скриншоте выше.

qДля аудио проигрывателя добавлена возможность добавления ссылок для воспроизведения потокового аудио. Тем самым вы можете задавать и выводить плейлисты для прослушивания на своем сайте радиостанций.

qВ настройки проигрывателей, в админпанели, добавлена возможность выбора темы для плеера. Для выбора доступна либо темная, либо светлая тема для плеера, что делает отображение плеера на вашем сайте более органичным.

qУлучшена процедура вставки видео и аудио материалов в редакторах. При добавлении видео, вы можете сразу создавать плейлисты, а также вы можете сразу задать в окне ввода не только ссылку на видео и аудио, но и ссылки к постерам для них, и описание для видео и аудио файлов.

qВ состав DataLife Engine добавлен новый WYSIWYG редактор. Название нового редактора FroalaEditor. Данный редактор обладает легким и понятным интерфейсом (на наш взгляд лучшим интерфейсом) для создания и редактирования контента, HTML код генерируемый им является одним из самых чистых и не имеет практически ничего лишнего, имеет относительно небольшой вес обладает быстрым рендерингом редактора на странице.

qДобавлен новый тип для дополнительных полей публикаций: "Загружаемая галерея изображений". При создании данного типа поля вы можете задать параметры для загружаемых изображений, а также максимальное количество изображений, которое может быть загружено для данной галереи. При добавлении публикации в админпанели или на сайте изображение можно будет загружать в один клик. При выводе данного поля на сайте, изображения будут группироваться в галерею картинок, которые также можно перелистывать между собой при просмотре, в случае если для картинок были созданы уменьшенные копии.

qДля дополнительных полей, имеющих тип "Загружаемое изображение" и "Загружаемый файл", добавлен автоматический запрет на повторную загрузку изображений и файлов, до тех пор, пока предыдущее загруженное изображение или файл не будут удалены. Тем самым снижается вероятность прикрепления к новости, не использующихся файлов и изображений.

qДля дополнительных полей, имеющих тип "Загружаемое изображение" добавлены новые теги: [xfvalue_thumb_url_X] и [xfvalue_image_url_X], которые выводят только URL для уменьшенной копии загруженного изображения и URL для полного изображения соответственно, где "X" это имя дополнительного поля. Данные теги будут полезны для вебмастеров, которые хотят персонального оформления загруженных публикаций на сайте, например, совместно с другими дополнительными полями.

qДля дополнительный полей, имеющих тип "Переключатель Да или Нет", добавлена возможность назначения состояния «Включено» или «Выключено» по умолчанию, которое будет использоваться при добавлении новой публикации.

qДобавлена возможность онлайн просмотра документов, загружаемых на сайт через скрипт DataLife Engine. Для этого в шаблон вывода загруженных файлов (attachment.tpl) были добавлены следующие теги: {online-view-link} который выводит ссылку URL на просмотр документа онлайн в браузере, а также теги [allow-online] текст [/allow-online], которые выводят заключенный в них текст, если загруженный документ имеет поддерживаемый для просмотра формат. Для онлайн просмотра поддерживаются следующие типы документов: Adobe PDF, Microsoft Word, Microsoft Excel. Просмотр документов происходит непосредственно в браузере посетителя, при помощи сервиса Google Docs Viewer, поэтому посетителям не нужно иметь установленные программы от Microsoft или Adobe.

qВ связи с тем, что разработчики WYSIWYG редактора LiveEditor решили прекратить какие-либо работы по данному редактору, и он уже не получал несколько лет каких-либо обновлений, было принято решение убрать данный редактор из состава DataLife Engine. Сайты, которые ранее использовали данный редактор, будут автоматически переключены на использование редактора FroalaEditor.

qДобавлена возможность задать описание изображений (атрибут alt) при массовой вставке изображений в новость. Для этого вам нужно выбрать нужные изображения, и кликнув по любому из них, задать описание. После чего нажать на кнопку "Вставить выбранное". Заданное описание будет также добавлено для всех картинок при вставке.

qДобавлен автоматический сброс кэша Zend OPCache при изменении настроек сайта. Тем самым, при включенном данном кешировании в настройках сервера, вам не нужно самостоятельно сбрасывать кэш, или ждать пока изменения вступят в силу.

qПри просмотре списка категорий в админпанели, в разделе редактирования категорий, изменен вид отображения списка категорий. Теперь все подкатегории показываются в свернутом виде, и могут быть открыты непосредственно при необходимости для конкретной родительской категории. А также добавлены кнопки, благодаря которым можно быстро в один клик развернуть или свернуть все категории в списке. Добавление новой категории осуществляется в всплывающем окне. Тем самым упрощается работа с большим количеством категорий и подкатегорий в админпанели.

qДобавлена возможность отписать всех пользователей, подписанных на комментарии, для каждой новости отдельно. В случае если у новости есть подписанные пользователи, то при редактировании данной новости в панели управления, во вкладке "Дополнительно", вы можете увидеть количество подписчиков и отписать их от комментариев к данной конкретной публикации. Данное нововведение будет полезно, например, если новость закрывается от дальнейшего комментирования.

qДобавлена возможность подписываться на комментарии к новости, при публикации комментария, даже когда комментарий уходит на модерацию.

qВ профиле пользователя на сайте, добавлена возможность отписаться от подписанных комментариев к публикациям, с указанием количества публикаций, на которые подписан пользователь. Для этого в шаблоне userinfo.tpl добавлено использование нового тега {unsubscribe}, который выводит чекбокс на отписку от комментариев, и количество подписанных публикаций.

qВ профиле пользователя на сайте, добавлена возможность автоматически подписаться на получение уведомлений о новых комментариях, которые добавляются к новостям, автором которых он является. Тем самым пользователю не нужно подписываться отдельно на каждую свою новость, достаточно отменить соответствующий чекбокс в настройках своего профиля. Для вывода чекбокса, в шаблоне userinfo.tpl добавлено использование нового тега {news-subscribe}.

qВ профиле пользователя на сайте, добавлена возможность автоматически подписаться на получение уведомлений о новых комментариях, которые являются ответами на его собственные комментарии. Для этого достаточно отменить соответствующий чекбокс в настройках своего профиля. Для вывода чекбокса, в шаблоне userinfo.tpl добавлено использование нового тега {comments-reply-subscribe}.

qДобавлена поддержка расширения PHP Memcached. Скрипт DLE автоматически определяет какое именно расширение PHP установлено, Memcache или Memcached на сервере, и в зависимости от этого использует то или иное PHP расширение, в случае если в настройках скрипта включено Memcache кеширование. Тем самым больше нет необходимости ставить на сервер именно расширение PHP Memcache.

qВ админпанели, в разделе редактирования публикаций, в список массовых действий над публикациями, добавлена возможность добавления категорий к публикациям. В отличии от существующего пункт "Изменить категории", пункт "Добавить категорию", позволяет массово назначить публикациям новые выбранные категории, без изменения старых, ранее добавленных категорий.

qДля шаблонного тега тега [news=1,2,3] Текст [/news] добавлена возможность указать диапазон новостей с использованием символа тире. Например, вы можете указать [news=1,2,50-60] Текст [/news]. Аналогично диапазон можно задать и для противоположного тега [not-news=1,2,50-60] Текст [/not-news]. Тем самым облегчается создание нужного вам оформления, и не нет необходимости прописывать все ID нужный публикаций через запятую.

qДля шаблонного тега тега [page-count=1,2,3] Текст [/page-count] добавлена возможность указать диапазон нужных страниц с использованием символа тире. Например, вы можете указать [page-count=1,2,50-60] Текст [/page-count]. Аналогично диапазон можно задать и для противоположного тега [not-page-count=1,2,50-60] Текст [/not-page-count]. Тем самым облегчается создание нужного вам оформления, и не нет необходимости прописывать все номера нужных вам страниц через запятую.

qДобавлена возможность отписываться пользователям сайта от рассылок писем, которые отправляются с раздела "Рассылка сообщений" админпанели. Для этого при рассылке писем, вы можете задать либо в шаблоне, либо непосредственно в тексте сообщения тег {%unsubscribe%}, который выводит в отправляемом письме URL на отписку от получения рассылки для пользователя. При переходе по данной ссылке, для профиля пользователя, устанавливается статус "Не получать писем с сайта". При этом, пользователю достаточно просто пройти по ссылке, ему не нужно авторизовываться или производить какие-либо другие действия на сайте. Тем самым он может легко отписаться от писем с сайта, если он давно потерял интерес к сайту. Несмотря на то что рассылка писем позволяет все равно отправить сообщение пользователю, даже если он изъявил желание не получать писем. Мы настоятельно рекомендуем вебмастерам, во избежание попадания сервера в спам фильтры, всегда при рассылке сообщений учитывать статус, который пользователь установил в своем профиле.

qДобавлено автоматическое добавление для всех внешних ссылок, которые публикуются в новостях и комментариях, атрибута rel, содержащего в себе параметры "external noopener noreferrer". Данный атрибут позволяет снизить вероятность возможной атаки на сайт с использованием механизмов социальной инженерии.

qВ настройки скрипта, добавлена возможность указания количества дней, в течение которых кешировать полную новость после ее публикации. Создание и обновление кэша, эта тоже ресурсоемкая операция. По истечении времени, публикация также теряет свою популярность, и если она не часто читается, то создавать и контролировать кэш постоянно для нее нецелесообразно. Если на вашем сайте публикуется мало новостей, то вы можете увеличить количество дней в течении которых кешировать, если много, то уменьшить. В любом случае мы не рекомендуем устанавливать время кеширования менее 30 дней. Небольшое количество дней используйте только если есть проблемы с свободным местом на жестком диске сервера, либо если публикуете очень большое количество новостей в месяц. А вот тем, у кого немного новостей на сайте, мы рекомендуем увеличить это значение.

qВ админпанели, в разделе редактирования пользователей, добавлена возможность быстрого переноса всех публикаций от одного пользователя, другому. Для этого нужно нажать на количество публикаций пользователя, выбрать перенос публикаций другому пользователю, и указать логин пользователя, на который нужно перенести публикации. Данное нововведение будет полезно, если перед удалением пользователя из базы данных, нужно перенести все его публикации другому пользователю.

qВ админпанели, в разделе редактирования пользователей, добавлена возможность быстрого пересчета количества публикаций у пользователя. Для этого нужно нажать на количество публикаций пользователя и выбрать в меню пересчет публикаций. Данная опция будет полезна, если производилось массовые манипуляции с публикациями, или добавления в базу данных минуя скрипт.

qВ админпанели, в разделе редактирования пользователей, добавлена возможность быстрого пересчета количества комментариев у пользователя. Для этого нужно нажать на количество комментариев пользователя и выбрать в меню пересчет комментариев. Данная опция будет полезна, если производилось массовые манипуляции с комментариями, или добавления в базу данных минуя скрипт.

qУлучшено быстродействие работы вывода новостей при использовании сортировок по рейтингу и просмотрам. Также улучшено быстродействие вывода комментариев, использующих сортировку по рейтингу.

qУлучшена система учета количества комментариев пользователя в статистике его профиля. При массовом удалении новостей происходит также автоматический пересчет и комментариев пользователей. Тем самым отпадает необходимость периодического пересчета статистики.

qПроведена оптимизация отображения админпанели DataLife Engine на мобильных устройствах в портретной ориентации. Тем самым панель управления стала более удобной при ее использовании на смартфонах.

qБиблиотека Jquery была обновлена до линейки 2.xx

qОбновлен редактор TinyMCE до актуальной версии.

qИсправлена проблема, при которой было невозможно использовать точку в доп. полях, имеющих тип перекрестных ссылок.

qИсправлена проблема, при которой формировалась невалидная верстка HTML комментариев при использовании древовидных комментариев.

qИсправлена проблема, при которой для тега {category-url} выводился URL на категорию с использованием ЧПУ, независимо от настроек ЧПУ в админпанели скрипта.

qИсправлена проблема, при которой происходило дублирование индексов дополнительных полей, имеющий опцию перекрестных ссылок, в случае если новость публикуется в несколько категорий.

qИсправлена проблема, при которой некорректно работали теги [available=main] текст [/available] и [not-available=main] текст [/not-available] для главной страницы, в случае если в настройках скрипта была включен показ статической страницы на главной в качестве основной.

qИсправлена проблема, при которой если в разделе редактирования публикаций производилась очистка новости от комментариев, то происходил всегда возврат на первую страницу раздела редактирования новостей, независимо от выставленных фильтров поиска и показа публикаций для редактирования.

qИсправлена проблема, при которой невозможно было ввести правильный ответ на систему "Вопрос-Ответ", в случае если пользователь отвечает на комментарий, а не добавляет новый.

Список изменений относительно версии 10.6:

qВ состав дистрибутива включены три абсолютно новых шаблона. Данные шаблоны созданы с использованием HTML5 стандартов. Являются полностью адаптивными, как под декстопные браузеры, так и под планшеты и смартфоны. Также в верстке шаблонов активно использована векторная графика, что обеспечивает их качественное отображение на HiDPI (Retina) дисплеях.

qДобавлен новый тип дополнительных полей для публикаций: "Загружаемое изображение". При данном типе поля, пользователю предлагается загрузить картинку для данной новости, которая будет выводится потом при показе новостей на сайте. Для данного типа поля вы можете задать такие параметры как ограничения на вес и размер картинки, нужно ли создавать для нее уменьшенную копию, размеры уменьшенной копии, накладывать ли на нее водяной знак. Тем самым с использованием данного типа поля облегчается процесс написания новостей, например, вы можете создать различные типы картинок (постеры, скриншоты и т.д.) и оформить их вывод в шаблоне, а при добавлении новостей останется лишь их только загрузить в один клик.

qДобавлен новый тип дополнительных полей для публикаций: "Загружаемый файл". При данном типе поля, пользователю предлагается загрузить файл для данной новости, который потом будет скачиваться как вложение. В настройках данного поля вы можете задать расширения файлов, которые допустимы для данного поля при загрузке, а также максимальный вес, загружаемого файла. Тем самым с использованием данного типа поля облегчается процесс написания новостей, например, вы можете создать различные типы файлов, в том числе и картинки непосредственно для скачивания (обои в разных разрешениях) и оформить их вывод в шаблоне, а при добавлении новостей останется лишь их только загрузить в один клик.

qДобавлен новый тип дополнительных полей для публикаций: "Переключатель 'Да' или 'Нет'". При написании новостей данный тип поля выводится в виде переключателя 'Да' или 'Нет' (Включено или Выключено). В качестве значения данное поле выводит 'Да' или 'Нет' в зависимости от того что было установлено при написании новости. Однако основное назначение данного поля — это управление тегами [xfgiven_X] текст [/xfgiven_X] и [xfnotgiven_X] текст [/xfnotgiven_X]. В случае если переключатель был включен, то теги [xfgiven_X] текст [/xfgiven_X] выведут соответствующих текст, а теги [xfnotgiven_X] текст [/xfnotgiven_X] уберут его, и наоборот. Тем самым при помощи данных дополнительных полей вы можете легко управлять выводимой информацией на сайте в шаблонах, применительно к каждой конкретной новости. Например, включать или отключать вывод каких-либо вкладок с описанием на странице, либо организовать вывод галерей со скриншотами или постерами и т.д.

qДля дополнительных полей новостей, имеющих тип поля "Список", добавлена возможность создавать отдельные значения, которые отображаются в списке при добавлении публикации, и те, которые отображаются на сайте после выбора пользователем в качестве значений. Для этого при добавлении поля, нужно использовать разделитель '|' в списке значений, например: Yes|Да. При написании новости, пользователю для выбора будет указан пункт Да, а на сайте будет выведено значение поля как Yes.

qДля дополнительных полей профиля пользователей, имеющих тип поля "Список", также добавлена возможность создавать отдельные значения, которые отображаются в списке при редактировании профиля, и те которые отображаются на сайте после выбора пользователем в качестве значений. Для этого при добавлении поля, нужно также использовать разделитель '|' в списке значений, например Yes|Да. При редактировании профиля, пользователю для выбора будет указан пункт Да, а на сайте будет выведено значение поля как Yes.

qСущественно переработан и улучшен режим работы "Использовать как перекрестные гиперссылки" для дополнительных полей новости. В случае если поле имеет данную опцию, то поиск новостей по значению поля производится на основе полного совпадения данного значения у других новостей, а также совпадения именно данного конкретного поля. Например, если раньше вы создавали поле "Год выпуска", и задавали значение 2015, и при этом у вас было другое поле, в котором была, например, загружена картинка, в пути которой также было 2015, то старая система выводила обе новости, т.к. поиск осуществлялся исключительно по вхождению искомого слова. Что приводило к тому что показывались не совсем ожидаемые новости. Теперь же будут показаны только те новости, у которых именно поле "Год выпуска" будет иметь значение 2015. Никакие другие поля и их значения учитываться больше не будут, что позволяет более расширенно использовать дополнительные поля, для организации перекрестного связывания между собой. Например, по году выпуска, актерам, режиссерам и т.д. Новый тип поиска автоматически применяется только для новых добавляемых новостей. Если вы хотите, чтобы и старые существующие новости участвовали в данном поиске, то вам нужно будет в админпанели, в разделе "Перестроение публикаций", запустить перестроение новостей, и тем самым будет создан индекс значений полей и для старых существующих новостей.

qДля основного шаблона (main.tpl) добавлена возможность вывода в нем дополнительных полей новостей при просмотре полной новости на сайте. Для этого в данном шаблоне вы можете использовать те же теги, что и для вывода дополнительных полей в шаблонах краткой и полной новости. Это теги: [xfgiven_X] текст [/xfgiven_X], [xfnotgiven_X] текст [/xfnotgiven_X] и [xfvalue_X]

qДля шаблонов, поддерживающих вывод дополнительных полей новостей, добавлена поддержка новых тегов [ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue], которые выводят текст заключенный в них, если значение дополнительного поля совпадает с указанным. А также добавлена возможность использования тегов [ifxfvalue tagname!="tagvalue"] Текст [/ifxfvalue], которые выведут текст, если значение поля не совпадает с указанным. Где tagmane это имя дополнительного поля, а tagvalue это его значение. Например, [ifxfvalue test="m"] Мужской пол [/ifxfvalue], данный тег выведет текст "Мужской пол", если значению поля test будет установлено "m" при написании публикации. Это открывает большие возможности по созданию различных оформлений шаблонов в зависимости от значений полей, установленных при написании этих публикаций. Например, создав поле с типом "список", можно в зависимости от выбранного пункта, применить различное оформление.

qУлучшено отображение дополнительных полей при быстром редактировании публикаций на сайте, для этого добавлены дополнительные вспомогательные классы CSS для формы редактирования, которые можно использовать для оформления полей при быстром редактировании.

qПри использовании авторизации на сайте с помощью социальных сетей, добавлена возможность для пользователей задать свой персональный логин для сайта, который будет в дальнейшем использоваться. Запрос логина осуществляется только в момент первой авторизации на сайте при помощи социальной сети и будет использоваться в дальнейшем автоматически. Данное нововведение будет полезно для посетителей вашего сайта, которые не хотят использовать данные, полученные автоматически из социальной сети, например, когда в качестве логина используется имя и фамилия пользователя.

qДобавлена поддержка смайлов для HiDPI (Retina) мониторов. Для этого при используется две копии смайлов, в обычном разрешении, и в высококачественном. В случае если монитор имеет обычную пиксельную плотность, то на нем выводится обычный смайлик, если монитор имеет HiDPI (Retina) плотность, то выводится его высококачественная копия. Определение и использование смайлов происходит в автоматическом режиме. Для этого вам нужно разместить в папке со смайлами две копии смайлика, например, с именем smile.gif для обычного смайла и smile@2x.gif для HiDPI (Retina) смайла. В случае если копия смайла в высоком разрешении отсутствует, то будет использоваться во всех случаях вывод обычного смайла.

qВ состав дистрибутива включено 60 новых смайлов. Все они имеет поддержку HiDPI (Retina) дисплеев.

qДобавлена автоматическая поддержка смайлов в формате .png. Поддержка осуществляется также в автоматическом режиме. Для этого нужно просто скопировать файлы в папку со смайлами с расширением .png и указать имя смайлика в настройках скрипта.

qДобавлен новый глобальный тег: {customcomments id="1,2,5-8" category="2,3,5-8" author="x" days="x" template="custom" available="global" from="0" limit="10" order="date" sort="desc" cache="yes"}

qДля шаблонов вывода комментариев (comments.tpl) добавлена поддержка нового тега {comment limit="X"}, который выводит текст комментария без HTML форматирования, при этом сам текст комментария сокращается до указанного "x" количества символов. При этом сокращение текста происходит до последнего логического слова, а не обрывает текст на середине слова. Данный тег будет полезен при использовании пользовательского вывода комментариев, с использованием тега {customcomments ...}, когда нужно вывести не весь комментарий целиком, а только его анонс.

qДля шаблонов вывода комментариев (comments.tpl) добавлена поддержка нового тега {news-link}, который выводит URL новости, которой принадлежит данный комментарий. Данный тег будет полезен при использовании пользовательского вывода комментариев и при показе последних комментариев.

qДля шаблонов вывода комментариев (comments.tpl) добавлена поддержка нового тега {news-title}, который выводит HTML безопасный заголовок новости, которой принадлежит данный комментарий. Данный тег будет полезен при использовании пользовательского вывода комментариев и при показе последних комментариев.

qВ настройки групп добавлена возможность указания того, какие категории запрещены данной группе пользователей для просмотра. Данная новая настройка является дополнением к существующей, где вы перечисляете разрешенные для просмотра категории. Если ранее, для того чтобы запретить, например, всего одну категорию из большого списка категорий, вам нужно было выбирать все доступные категории, за исключением всего одной запрещенной категории, то теперь вы можете просто выбрать одну запрещенную категорию и списка, и все. Предыдущая настройка в админпанели также была сохранена, поэтому вы сами можете выбрать как вам удобнее, вы можете выбрать как список доступных категорий, так и просто указать список недоступных.

qДобавлена возможность продвижения пользователей из одной группы в другую, по прошествии определенного количества дней с момента регистрации на сайте. Для этого в настройках групп добавлена соответствующая настройка, где вы можете указать, через сколько дней и в какую группу перевести пользователя после его регистрации. Тем самым открываются новые возможности по предоставлению пользователям каких-либо прав или привилегий на сайте.

qДобавлена возможность продвижения пользователей из одной группы в другую, при наборе им определенного количества новостей на сайте. Для этого в настройках групп добавлена соответствующая настройка, где вы можете указать, сколько новостей необходимо иметь и в какую группу переместить пользователя при наборе им данного количества публикаций. Публикации, находящиеся на модерации, при этом не учитываются. Тем самым вы можете предоставлять пользователям, которые заслужили определенное доверие какие-либо дополнительные права и преференции.

qДобавлена возможность продвижения пользователей из одной группы в другую при наборе им определенного количества комментариев на сайте. Для этого в настройках групп добавлена соответствующая настройка, где вы можете указать, сколько комментариев необходимо иметь и в какую группу переместить пользователя им данного количества комментариев. Комментарии, находящиеся на модерации, при этом не учитываются. Тем самым вы можете предоставлять пользователям, которые заслужили определенное доверие какие-либо дополнительные права и преференции.

qДобавлена возможность продвижения пользователей из одной группы в другую при наборе им определенного рейтинга их публикаций на сайте. Для этого в настройках групп добавлена соответствующая настройка, где вы можете указать, какой суммарный рейтинг им необходимо набрать, и в какую группу переместить пользователя при получении ими данного рейтинга.

qДля шаблонов вывода комментариев и персональных сообщений (comments.tpl и pm.tpl) добавлена поддержка форматированного вывода количества комментариев и публикаций пользователя. Например, при выводе количества комментариев 252501 будет выведено 252 501. Что облегчает восприятие больших цифр.

qДля шаблонов вывода профиля пользователя (userinfo.tpl и profile_popup.tpl) добавлена поддержка форматированного вывода числового рейтинга. Например, при выводе общего рейтинга пользователя +252501, будет выведено +252 501. Что облегчает восприятие больших цифр.

qДобавлена поддержка нового глобального шаблонного тега: {* Закомментированный код *}. Данный тег предназначен для комментирования кода, все что заключено между "{*" и "*}" будет удалено из шаблона. И будет отсутствовать при выводе на сайте. Данные теги будут полезны разработчикам шаблонов, для отладки той или иной функциональности, когда нужно временно закомментировать ту или иную функциональность. Данный тег является глобальным и может использоваться во всех шаблонах.

qДобавлен автоматический сброс индекса похожих новостей при изменении количества выводимых похожих новостей в настройках скрипта. Тем самым больше нет необходимости после изменения данной настройки заходить в перестроение публикаций и там делать перестроение кеша похожих новостей.

qВ настройки скрипта добавлена возможность указания нужно ли выводить в профиле пользователя его публикации, ожидающие модерации, или нет. В случае включения данной настройки, то пользователь может увидеть в своем профиле новости, которые ожидают модерации, и отредактировать их. Если данная настройка отключена, то в его профиле данные новости отображатся не будут, и также не будет отображатся сообщение о том, что у него нет публикаций, ожидающих модерации.

qВнесены изменения в работу обратной связи на сайте, в случае если пишет незарегистрированный пользователь на сайте. В случае если пользователь не зарегистрирован, то не проводится проверка совпадения введенного им логина с теми, что уже зарегистрированы на сайте. Вместо этого к его введенному имени добавляется префикс "Незарегистрированный пользователь". Тем самым администрация или получатель письма с сайта будет легко видеть, что письмо ему отправил именно незарегистрированный посетитель сайта. А для самого посетителя сайта не будет неудобной обязанности придумывать другое имя, если то имя что он написал, занято зарегистрированным пользователем.

qВнесены изменения в работу добавления комментариев на сайте, в случае если комментарий пишет незарегистрированный посетитель сайта. Если введенное им имя совпадает с зарегистрированным логином, то к его имени добавляется префикс "Гость". Например, посетитель написал имя "Татьяна", и на сайте уже есть зарегистрированный логин "Татьяна", то комментарий будет добавлен от имени "Гость Татьяна". Тем самым имеется визуальное отличие, что этот пользователь не является зарегистрированным на сайте, а также посетитель сайта избавляется от неудобной обязанности придумывать себе другое имя. Если же такого нет имени среди зарегистрированных, то префикс добавляться не будет.

qДобавлена поддержка уведомлений о новых комментариях, для комментариев, которые отправляются на модерацию. Ранее уведомления отправлялись только если комментарий публиковался сразу на сайте минуя модерацию администрацией сайта. Теперь уведомления также будут отправлятся после того как администрация сайта проверила комментарий и опубликовала его на сайте.

qВ раздел управления облаком тегов в админпанели добавлена возможность поиска ключевых слов по заданному слову. Что существенно облегчает поиск и редактирование нужного слова, при большом объеме заданных слов.

qВ раздел управления перекрестными ссылками в админпанели добавлена возможность поиска по ключевым словам и ссылкам. Что существенно облегчает поиск и редактирование нужного слова, при большом объеме заданных слов.

qДля модуля "Перекрестные ссылки" добавлена возможность установки новой опции: "Открывать ссылку в новом окне". Тем самым вы можете устанавливать где вам открывать нужную вам ссылку в этом же окне браузера, или в новом окне браузера.

qДля массовых действий в модуле "Перекрестные ссылки" также была добавлена возможность назначать ссылкам каким образом открывать данные ссылки, в новом окне браузера или в текущем окне браузера.

qВ админпанели, в разделе управления пользователями, добавлена новая опция "Точное совпадение логина", при поиске пользователей по логину. В случае если данная опция отмечена, то поиск будет проходит по точному совпадению логина с указанным в поиске. Тем самым облегчается поиск нужного пользователя, имеющего короткий логин, в случае если на сайте зарегистрировано большое количество пользователей.

qВоспроизведение флеш видео файлов в формате .flv приведено к единому плееру. Теперь для воспроизведения данного видео используется тот же плеер что и для воспроизведения HTML5 видео. Тем самым всё видео на сайте, имеет единый визуальный вид.

qДля более лучшего и качественного продвижения публикаций в поисковых системах, при просмотре полных новостей, добавлено автоматическое использование ключевых слов из облака тегов, в специально сформированном метатеге для поисковых систем.

qУлучшена обработка текста, опубликованного в тегах code в парсере новостей. Было исключено какое-либо пересечение публикуемого кода с тегами и фильтрами DLE, что позволяет публиковать в нем исходных код, без какого-либо вмешательства в текст со стороны DLE.

qДобавлена поддержка копирования аватаров при авторизации на сайте с использованием социальной сети "Одноклассники".

qОбновлен до актуальной версии визуальный редактор TinyMCE. Помимо исправления ранее обнаруженных ошибок, в данном редакторе было добавлено много других изменений. Внешний вид редактора изменен на более классический для вебсайтов (все функции представлены в виде кнопок, без меню), в нем была улучшена вставка ББ тегов для видео и Youtube и других. В редакторе улучшена вставка и обработка примеров исходных кодов (тега [cоde] [/cоde]), добавлена подсветка этого кода непосредственно в редакторе, а также добавлено удобное окно для вставки примеров кодов. В редакторе добавлена подсветка синтаксиса HTML кода, при редактировании исходного кода HTML.

qВнесены изменения в механизмы формирования карты сайта. В случае если для незарегистрированных пользователей запрещены какие-либо категории для просмотра, то из карты также исключаются эти категории и публикации из этих категорий.

qВнесены изменения в код вывода ключевых слов для облака тегов, благодаря которым появилось больше возможностей по различному оформлению данных тегов на сайте.

qДобавлена поддержка кодировки utf8mb4 для MySQL сервера версии 5.7.x

qИсправлена проблема, при которой некорректно работали теги [dеclination=x] Текст [/dеclination] в случае использования их совместно с числами для которых применен форматированный вывод.

qИсправлена проблема, при которой некорректно выводились новости с использованием тега {custom ...} c параметрами author и catalog, в случае если использовалось несколько тегов на странице одновременно с этими параметрами, с включенном кешировании при этом.

qИсправлена проблема с цитированием комментариев, которые содержат в себе HTML теги, при использовании стандартного редактора для комментариев. Теперь при цитировании в поле редактора, также вставляются эти HTML теги, а не их HTML сущности.

qИсправлена проблема с получением писем в кодировке UTF-8 на некоторые типы почтовых сервисов.

qИсправлена проблема, при которой некорректно переименовывалось имя авторов для загруженных к новостям файлов, в случае переименования логина пользователя в панели управления пользователями.

qИсправлена проблема, при которой не очищался кеш новости, если она находилась на модерации и редактировалась автором этой новости на сайте.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 10.5:

qДобавлена поддержка четырех байтовой кодировки базы данных для сайтов, использующих кодировку UTF-8. При установке скрипта в кодировке UTF-8 вы можете включить поддержку четырех байтов для данной кодировки в БД. Это необходимо если вы, например, захотите использовать не буквенные символы в базе данных. Например, смайлики Emoji, музыкальные символы и т.д.

qДля шаблона main.tpl добавлен новый тег {jsfiles}, данный тег выводит подключение всех JS скриптов, которые использует DLE в указанном месте шаблона. При помощи данного тега вы можете, например, перенести все JS скрипты в самый низ страницы, для ускорения загрузки и рендеринга ваших страниц. Данный тег является необязательным, и в случае его отсутствия в шаблоне, все скрипты будут подключены, как и ранее к тегу {headers}. Внимание, если вы переносите подключение скриптов, то должны иметь ввиду, что тег {AJAX} также должен находится ниже тега {jsfiles}, а также вы должны предусмотреть работу всех своих сторонних скриптов в шаблоне, если они используют, например, библиотеку Jquery, чтобы они не запускались раньше, чем выполнится подключение всех скриптов. Мы настоятельно не рекомендуем новичкам пользоваться данным тегом, он предназначен для опытных вебмастеров, которые имеют опыт в работе с JS скриптами.

qДля рейтинга новостей и комментариев добавлен вывод информации в виде в всплывающего окна, в случае если его голос не может быть учтен, с описанием причины по которым его голос не может быть принят. Например, он выставляет эту же оценку повторно, или голосует за собственную новость или комментарий.

qДля рейтинга новостей и комментариев добавлен запрет на выставление оценки собственной новости или собственному комментарию.

qДля рейтинга новостей и комментариев добавлена возможность изменения для посетителей сайта своего голоса или оценки. Например, если вы если пользователь поставил одну оценку или голос за новость или комментарий, то передумав он может изменить свою оценку. При этом старая его оценка будет отменена и добавлена новая.

qВ настройки скрипта добавлена возможность указывать максимальное количество страниц найденных результатов поиска по сайту. Тем самым вы можете как ограничить показ найденных результатов, в целях снижения нагрузки на сервер, так и показывать все найденные результаты.

qДобавлен форматированный вывод количества просмотров новости, количества комментариев у новости, количества новостей и комментариев у пользователя в профиле. Например, при выводе количества просмотров у новости вместо 252501 будет выведено 252 501. Что облегчает восприятие больших цифр.

qДля тегов [aviable=x] Текст [/aviable] и [not-aviable=x] Текст [/not-aviable] добавлены теги синонимы [available=x] Текст [/available] и [not-available=x] Текст [/not-available] соответственно. Данные теги являются полностью идентичными синонимами и несут одну функциональную нагрузку, просто написание available является правильным и созвучным для англоязычных пользователей скрипта.

qДобавлена поддержка вложенности друг в друга для тегов [available=x] Текст [/available] и [not-available=x] Текст [/not-available]. Например, вы можете использовать в шаблоне конструкцию: [available=main|cat] Текст 1 [available=cat] Текст 2 [/available] [/available]. Которая выведет "Текст 1" при просмотре главной странице и категорий, а "Текст 2" только при просмотре категорий. Тем самым упрощается логика верстки шаблона, а также добавляются новые возможности при верстке шаблона.

qДобавлена поддержка вложенности друг в друга для тегов [group=x] Текст [/group] и [not-group=x] Текст [/not-group]. Например, вы можете использовать в шаблоне следующую конструкцию: [group=1,2,3,4] Текст 1 [group=1] Текст 2 [/group] [/group]. Которая выведет "Текст 1" для всех зарегистрированных пользователей, а "Текст 2" только для администраторов.

qДля BBCODES редактора для сайта, добавлена поддержка вставки заголовков текста. Заголовки вставляются с использованием специальной новой кнопки в редакторе и могут использоваться заголовки от <H1> до <H6>.

qУлучшены алгоритмы работы модуля "Перекрестные ссылки". Теперь модуль корректно распознает разные слова, имеющие одинаковые вхождения. Например, если были заданы слова "Терминатор" и "Терминатор Генезис" с разными ссылками, то будет проведена корректная замена каждого отдельного ключевого слова, независимо друг от друга и независимо от того, когда она были добавлены в скрипте.

qВ настройки видеопроигрывателей в админпанели добавлена возможность включать или отключать предварительную загрузку метаданных видео. Если данная настройка включена, то плеер подгружает предварительно для видео данные о видео, а именно его продолжительность и первый стоп кадр видео для превью в плеере. В случае отключения данной настройки эти данные не загружаются, тем самым вы можете экономить трафик сервера и пользователей, если они не будут просматривать данное видео.

qДобавлен новый более удобный формат вывода публикаций в закладках. Сортируется вывод теперь не по параметрам общих настроек в скрипте, а по принципу: "последний добавленный показывается первым", т.е. новости которые были добавлены в закладки позднее показываются в списке раньше, тем самым при наличии большого количества закладок на сайте, пользователю будет удобнее видеть, какие новости он в последний раз добавлял.

qДля тегов [category=x] текст [/category], [not-category=x] текст [/not-category], [catlist=x] текст [/catlist], [not-catlist=x] текст [/not-catlist] добавлена возможность перечислять список категорий с использованием дефиса, например, вы можете указать [category=3-7,15] текст [/category], и данные теги выведут текст на страницах категорий, имеющих ID с 3 по 7, и 15.

qДля шаблонов вывода комментариев (comments.tpl) добавлены новые теги [rootcomments] текст [/rootcomments], которые выводят текст, заключенных в них, в случае если комментарий является основным родительским к новости, а не является ответом на какой-либо другой комментарий. А также добавлены теги [childrencomments] текст [/childrencomments] которые выводят текст, заключенных в них, в случае если комментарий является ответом на другой комментарий. Тем самым вы можете гибко визуально настраивать внешний вид дерева комментариев, например, заключить родительские комментарии в отдельный блок, или для ответов на комментарии сократить количество визуального оформления и информации.

qДля пользовательского вывода новостей при помощи тега {custom ...}, для параметра author, добавлена возможность перечислять нескольких авторов. Например, вы можете указать {custom author="test,admin"}, и тогда будет выведены новости авторов с логином "admin" и логином "test".

qДля пользовательского вывода новостей при помощи тега {custom ...} добавлено использование нового параметра authorexclude="X", при котором выводятся публикации всех авторов, кроме указанного, где X это имя логина автора. Логины авторов в данном параметре также можно перечислять через запятую. Например, при использовании {custom authorexclude="admin,test"} будут выведены новости всех авторов, кроме авторов с логином "admin" и логином "test".

qДля пользовательского вывода новостей при помощи тега {custom ...} добавлено использование нового параметра catalog="X", при котором выводятся все публикации содержащие указанный в параметре символьный код, где X это назначенный новостям символьный код. Допускается также перечисление символьных кодов в параметре через запятую. Например, при использовании {custom catalog="а,б"} будут выведены новости, которые содержат символьные коды "а" или "б".

qДля пользовательского вывода новостей при помощи тега {custom ...} добавлено использование нового параметра catalogexclude="X", при котором выводятся все публикации, которые не содержат указанный в параметре символьный код, где X это назначенный новостям символьный код. Допускается также перечисление символьных кодов в параметре через запятую. Например, при использовании {custom catalogexclude="а,б"} будут выведены новости, которые не содержат символьные коды "а" и "б".

qДля пользовательского вывода новостей при помощи тега {custom ...} добавлено использование нового параметра xfields="X", при котором выводятся все публикации, содержащие указанное в параметре значение дополнительных полей новостей, где X это значение дополнительного поля. Допускается также перечисление значений в параметре через запятую. Например, при использовании {custom xfields="значение 1,значение 2"} будут выведены новости, в которых есть дополнительные поля содержащие "значение 1" или "значение 2".

qДля пользовательского вывода новостей при помощи тега {custom ...} добавлено использование нового параметра xfieldsexclude="X", при котором выводятся все публикации, не содержащие указанное в параметре значение дополнительных полей новостей, где X это значение дополнительного поля. Допускается также перечисление значений в параметре через запятую. Например, при использовании {custom xfieldsexclude="значение 1,значение 2"} будут выведены новости, в которых нет дополнительных полей содержащих "значение 1" и "значение 2".

qДля шаблонов вывода профиля пользователей (userinfo.tpl и profile_popup.tpl) добавлена поддержка новых тегов [profile-user-group=X] Текст [/profile-user-group], которые выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, принадлежит указанной группе X. Где X это номер группы. Допускается также перечисление нужных групп через запятую. Например, вы можете указать [profile-user-group=1,2] Текст [/profile-user-group] и в данном случае будет выведен текст, если просматривается профиль администратора или главного редактора. Тем самым вы можете для разных групп пользователей, делать различное оформление их профиля.

qДля шаблонов вывода профиля пользователей (userinfo.tpl и profile_popup.tpl) добавлена поддержка новых тегов [not-profile-user-group=X] Текст [/not-profile-user-group], которые выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, не принадлежит указанной группе X. Где X это номер группы. Назначение данных тегов противоположно описанным в предыдущем пункте. Например, вы можете указать [not-profile-user-group=1,2] Текст [/not-profile-user-group] и в данном случае будет выведен текст, если просматривается профиль пользователя, не принадлежащий администраторам и главным редакторам. Тем самым вы можете для разных групп пользователей, делать различное оформление их профиля.

qДля шаблона вывода статической страницы (static.tpl или любого другого шаблона, назначенного странице) добавлен новый тег {text limit="x"} который выводит только текст добавленных для статической страницы без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов. При этом сокращение текста происходит до последнего логического слова, а не обрывается на середине слова.

qДля шаблона вывода статической страницы (static.tpl или любого другого шаблона, назначенного странице) добавлено использование новых тегов: {image-x} который выводит URL картинки, находящейся в тексте статической страницы, где "x" это номер картинки в тексте страницы, например, {image-1} выведет URL первой картинки в тексте страницы. Добавлено использование тегов [image-x] текст [/image-x], которые выводят указанный в них текст, только если картинка с номером "x" присутствует в тексте страницы

qДля статических страниц добавлена специальная разметка в метатегах согласно протоколу Open Graph http://ogp.me/, благодаря ей, для социальных сетей и поисковиков, в метатегах будут добавляться название сайта, ссылка на изображение в статической странице, ссылка на видео (если таковое присутствует в статической странице и опубликовано при помощи тега [video]), а также ссылка на аудио (если таковое присутствует в статической странице и опубликовано при помощи тега [audio]). Все это позволяет более лучше и качественнее индексировать ваш сайт и интегрировать его с социальными сетями.

qДля шаблона вывода прикрепленных к новости файлов (attachment.tpl) добавлена поддержка нового тега {extension}, который выводит расширение загруженного к новости файла. Тем самым вы можете, например, задавать в шаблоне для вывода загруженных файлов различные пиктограммы, в зависимости от типа файла и его расширения.

qДля каждого всплывающего окна, которое вызывает скрипт, добавлено назначение собственного уникального класса. Тем самым вы можете легко переназначить для него визуальное оформление окна, персонально для каждого окна. Например, его размеры, или визуальный вид.

qДобавлена поддержка изменения дизайна админпанели скрипта при помощи своих шаблонов, созданных для сайта. Для этого достаточно разместить в папке своего шаблона, который у вас назначен по умолчанию в настройках скрипта, файл adminpanel.css в котором вы можете разместить и переназначить оформление классов CSS, которые используются панелью управления. В случае, если такой файл присутствует у вас в папке шаблона, то он будет подключен панелью управления автоматически. Так как вся верстка панели управления основана на CSS, вы можете из своего шаблона полностью изменить визуальное оформление панели управления, например, цветовое оформление. При этом при обновлении на новые версии скрипта, ваши изменения также будут сохраняться и автоматически действовать и на новых версиях.

qПереработано формирование воспроизведения видео на сайте. Для всех современных форматов видео, применяется исключительно HTML5 плеер, возможность использования для них устаревшего флэш плеера отключена. Флэш плеер используется только в случае если вставляется флэш видео в формате .flv. Для воспроизведения аудио, также применяется только HTML5 плеер. Данное нововведение необходимо для более качественной поддержки всех типов устройств, для воспроизведения видео, включая смартфоны и планшеты.

qВнесены изменения в работу парсинга текста новостей относительно обратной конвертации HTML тегов для изображений (тега img). В случае если картинка была вставлена в виде ББ тегов, то при редактировании она также переводится в ББ теги. В случае если картинка была вставлена при помощи HTML тега, то при редактировании она также остается в виде HTML тега. Данное нововведение позволяет более гибко писать тексты новостей, если картинкам нужно задать какие-то дополнительные HTML свойства, например, стили или классы CSS и т.д.

qДобавлена поддержка сжатия изображений для PNG формата при их загрузке на сервер, что позволяет снизить размер картинок, после их загрузки на сервер.

qОптимизирован вывод загруженных к новостям файлов. А именно подсчет размеров файлов и его хеш сумм производится только в случае если соответствующие теги стоят в шаблоне attachment.tpl, и в случае если их нет, то работа по получению этой информации скриптом не производится. Что позволяет существенно сократить скорость работы скрипта и снизить нагрузку на сервер.

qС сожалением были вынуждены отключить поддержку сервиса "Чистый Веб" от Яндекса. В связи с прекращением поддержки данного сервиса со стороны Яндекса.

qДобавлено автоматическое подключение плеера DLE для видео опубликованного в новостях, и которые выводятся тегом {custom ...} на сайте.

qУлучшена работа админпанели при работе со смартфонами, в частности улучшена загрузка файлов со смартфонов, а также работа всплывающих окон в админпанели, улучшена контрастность некоторых элементов админпанели.

qДобавлена возможность перемещения всплывающих окон по экрану для сенсорных устройств, не имеющих мышки (смартфоны, планшеты и т.д.).

qДобавлена поддержка скриптом линейки MySQL 5.7.x

qПереработан и адаптирован код скрипта, для поддержки линейки PHP 7.xx

qОбновлен до актуальной версии PHP класс для работы с почтой, улучшена совместимость с некоторыми SMTP серверами.

qОбновлен HTML5 плеер до актуальной версии, улучшена поддержка и его работа на некоторых моделях смартфонов.

qОбновлен визуальный редактор TinyMCE до актуальной версии, улучшена его работа в новом браузере Edge от Microsoft.

qИсправлена проблема, при которой если дополнительному полю было указано использование без редактора, то при быстром редактировании новости на сайте, редактор все равно подключался.

qИсправлена проблема, связанная с некорректной обработкой вывода прикрепленных загруженных файлов, в случае вывода новостей при помощи тега {custom ...}

qИсправлена проблема, при которой не работало удаление всех комментариев у конкретной новости, в разделе редактирования новостей в админпанели скрипта.

qИсправлена проблема, при которой при создании новой категории в админпанели, не сохранялась информация, о том, что не нужно транслировать новости в RSS поток, если это указывалось.

qИсправлена проблема, при которой неверно формировались ссылки в письмах, если в настройках скрипта в качестве URL сайта было просто указано "/".

qИсправлена проблема, при которой не очищался автоматически кеш RSS информеров каждый час.

Список изменений относительно версии 10.4:

qДобавлена новая система древовидных комментариев к новостям. Данная система комментирования, позволяет посетителям отвечать на конкретные отдельные комментарии, и выводить комментарии к новостям в виде дерева. Данная система комментирования включается в админпанели в настройках комментариев. При этом вы также можете указать максимальный уровень вложенных комментариев. При включении данной системы на сайте, мы рекомендуем вам также обратить внимание на такой параметр настроек, как количество комментариев на одну страницу. В случае использования древовидных комментариев, это будет количество именно родительских комментариев на одну страницу, а реальное количество комментариев с учетом вложенных ответов может быть больше.

qДля шаблона вывода комментариев (comments.tpl) добавлен новый тег [reply] текст [/reply], который выводит текст в них, в виде ссылки на открытие всплывающего окна для ответа на комментарий, в случае если включена поддержка древовидных комментариев, а в случае если она отключена вставляет логин выбранного комментатора в форму добавления комментариев.

qДля шаблона вывода комментариев (comments.tpl) добавлены новые теги [treecomments] текст [/treecomments], которые выводят текст, заключенных в них, в случае если включены древовидные комментарии в настройках скрипта. А также добавлены теги [not-treecomments] текст [/not-treecomments], которые выводят текст, заключенный в них, в случае если древовидные комментарии отключены. Данные теги позволят вебмастерам создавать более гибкие шаблоны, которые будут выводится по-разному в зависимости от настроек скрипта в данном вопросе.

qДля шаблона вывода комментариев (comments.tpl) добавлен новый тег {replycount}, который выводит количество имеющихся ответов на данный комментарий.

qВ настройки скрипта в админпанели, добавлена возможность отключать редактор для комментариев и персональных сообщений. В случае отключения редактора, пользователи не будут иметь возможности использовать какое-либо оформление при добавлении комментариев, а смогут писать только текст. При этом также отключается обработка всех ББ тегов и их ручное написание не будет иметь какого-либо эффекта, за исключением одного тега цитаты "quote", который необходим для функционирования цитирования и ответов на комментарии и персональные сообщения. Данная возможность будет полезна тем вебмастерам, которые хотят минимизировать возможности по оформлению текстов комментариев и персональных сообщений.

qВ настройки скрипта в админпанели, добавлена возможность включать режим быстрого ответа на комментарий. При данном режиме, ответ на комментарий вводится не в отдельном всплывающем окне, а выводится упрощенная форма ответа на комментарий, чуть ниже самого комментария. Также запрашивается минимальный набор необходимых данных, и отключается редактор для ответа на комментарий. Другими словами, основной комментарий может публиковаться полноценно, с использованием форматирования, а ответы на него уже в упрощенном виде.

qСнижена нагрузка на базу данных MySQL при просмотре комментариев к публикациям на сайте.

qПолностью переработан дизайн стандартного BBCODES редактора в админпанели. Он получил современный дизайн, соответствующий оформлению админпанели. Для кнопок были использованы векторные шрифты, что делает кнопки контрастными и хорошо читаемыми на мониторах, имеющих высокое пиксельное разрешение и при масштабировании в OS.

qДля BBCODES редактора в админпанели, добавлена поддержка следующих новых кнопок и BB тегов: [sub] текст [/sub] - выводят текст в нижнем индексе[sup] текст [/sup] - выводят текст в верхнем индексе [justify] текст [/justify] - выравнивает текст по обеим сторонам и слева и справа

qДля BBCODES редактора в админпанели, добавлена поддержка вставки заголовков текста. Заголовки вставляются с использованием специальной новой кнопки в редакторе и могут использоваться заголовки от <H1> до <H6>.

qДобавлена поддержка нового файла шаблона для вывода загруженных и прикрепленных к новостям файлов. Имя нового файла шаблона: attachment.tpl, в котором вы можете задать оформление для показа прикрепленных файлов. Тем самым вы можете гибко задать любое визуальное оформление тега [аttachment=...], который вы используете при вставке в текст новостей.

qДобавлена глобальная поддержка во всех шаблонах тега для пользовательского вывода новостей {custom ....}. Теперь вы можете использовать данный тег во всех без исключения файлах шаблона, а не только в строго определенных.

qДля тега пользовательского вывода новостей {custom ....}, добавлена поддержка использования динамических параметров, на основе других шаблонных тегов. Например, если ранее вы могли использовать данный тег в шаблонах только с использованием заранее определенных в шаблоне параметрах {custom id="1,2"}, то теперь можете использовать этот тег с параметрами {custom id="[xfvalue_x]"}, а значения ID новостей задавать при добавлении новости в доп. полях новостей. Тем самым открываются практически безграничные возможности по выводу контента новостей на страницах вашего сайта.

qДобавлено автоматическое акцептирование введенных значений для облака тегов, метатегов и дополнительных полей, имеющих опцию перекрестных ссылок, без необходимости нажатия кнопки Enter на этих полях.

qДобавлена новая автоматическая система защиты комментариев от спама на основе облачного сервиса "Яндекс Чистый Веб". Подробнее об этом сервисе вы можете прочитать на странице https://tech.yandex.ru/. Особенностью данной защиты является то что анализируется непосредственно сам текст комментариев на наличие признаков спама, а не только на основе IP и e-mail пользователя, хотя эти данные также учитываются.

qУлучшена поддержка SSL для сайтов. Добавлена автоматическая поддержка https протокола, при использовании внешних сервисов (таких как gravatar) и плееров (youtube и другие) сайта, если ваш сайт использует https протокол.

qДобавлена поддержка и использование HTML5 плеера, при вставке аудиофайлов, если данный плеер включен в настройках проигрывателей.

qПереработана и улучшена система фильтрации тега iframe в новостях, которая позволяет добавлять iframe только для доверенных доменов. Проверка стала универсальной и проверяет только имя домена без протокола и www алиаса данного домена. Тем самым в случае если видео сервис вносит изменения в свой код плеера, то он продолжает работать и приниматься скриптом DLE. Например, если раньше видеосервис youtube публиковал ссылки на свой плеер как //www.youtube.com/ а сейчас изменил на https://www.youtube.com/, то новая система автоматически будет акцептировать и эти ссылки.

qДля шаблона вывода комментариев (comments.tpl) добавлены новые теги [comments-author] текст [/comments-author], которые выводят текст, заключенный в них, если пользователь, просматривающий страницу сайта, является автором данного комментария. А также теги [not-comments-author] текст [/not-comments-author], которые выводят текст, заключенный в них, если пользователь, просматривающий страницу сайта, не является автором данного комментария. Данные теги позволяют вебмастерам делать шаблон комментариев таким образом, чтобы посетители сайта могли сразу видеть визуально свои собственные комментарии, например, по отличительному цветовому оформлению его комментариев.

qДля шаблона вывода комментариев (comments.tpl) добавлены новые теги [news-author] текст [/news-author], которые выводят текст, заключенный в них, если комментарий принадлежит автору данной новости, а также теги [not-news-author] текст [/not-news-author], которые выводят текст, заключенный в них, если комментарий не принадлежит автору данной новости. Тем самым вы можете визуально выделять на страницах вашего сайта, те комментарии, которые пишет автор публикации.

qДля шаблона вывода комментариев (comments.tpl) добавлены новые теги [positive-comment] текст [/positive-comment], которые выводят текст, заключенный в них, если комментарий имеет позитивный рейтинг, [negative-comment] текст [/negative-comment], которые выводят текст, заключенный в них, если комментарий имеет негативный рейтинг, [neutral-comment] текст [/neutral-comment], которые выводят текст, заключенный в них, если комментарий имеет нейтральный рейтинг. Тем самым вы можете визуально выделять на странице или скрывать оформление и текст как положительно оцененных комментариев, так и негативно оцененных.

qДобавлена возможность отдельного вывода дополнительных полей для новости в шаблоне добавления новости (addnews.tpl). Для этого были добавлены следующие теги: [xfinput_X], где X это имя дополнительного поля для новостей, которые выводят ваше выбранное дополнительное поле в форме добавления новости в нужном вам месте. Тем самым вы можете как угодно и где угодно расположить добавление нужного поля в вашей форме, а не только общим тегом {xfields}

qДобавлена возможность отдельного вывода дополнительных полей профиля пользователей в шаблонах регистрации и профиля пользователей (registration.tpl и userinfo.tpl). Для этого были добавлены следующие теги: [xfinput_X], где X это имя дополнительного поля для профиля, которые выводят ваше выбранное дополнительное поле в форме регистрации и редактировании профиля пользователя в нужном вам месте. Тем самым вы можете как угодно и где угодно расположить добавление нужного поля в вашей форме, а не только общим тегом {xfields}

qВ настройки профиля на сайте для удобства посетителей вашего сайта, в список часовых поясов, добавлено указание какой часовой пояс используется на сайте по умолчанию, тем самым они могут решить, стоит им его менять в настройках своего профиля или нет.

qДобавлена возможность задавать ограничение на доступ к аккаунту пользователя на сайте или к админпанели с использованием маски подсети. Например указывать не только 10.96.*.*, но и например 10.96.0.0/11, что будет являться диапазону адресов с 10.96.0.0 до 10.127.255.255. Использование маски позволяет более точно описывать диапазон динамических адресов вашего интернет провайдера, для ограничений доступов к аккаунту.

qДобавлена поддержка подключения к серверу Memcache c использованием UNIX сокетов, можно указывать не только сервер и порт, но указывать путь к сокету, например, "unix:///home/login/.system/memcache/socket".

qДобавлена возможность очистки результатов опросов, назначенных новости, при редактировании данной новости в админпанели.

qВ админпанели, в разделе редактирования исходного кода рекламных материалов, добавлен редактор с подсветкой исходного кода, для удобства его редактирования.

qВ настройки групп в админпанели добавлена возможность ограничивать время, в течении которого группе разрешено редактировать новости. Вы можете указать для выбранной группы, в течении скольких дней, после публикации новости ее разрешено редактировать. По истечении указанного количества дней, пользователи из данной группы больше не смогут редактировать эти новости. Данное нововведение будет полезно администраторам сайтов, которые не хотят, чтобы старые новости подвергались какому-либо изменению со стороны других пользователей.

qПри отправке персонального сообщения на сайте добавлена проверка на основе облачного сервиса, является ли отправитель спамером или нет. Данная возможность включается и отключается для каждой группы пользователей персонально в настройках групп в админпанели. Тем самым вы получаете дополнительные механизмы защиты персональных сообщений от спама.

qДля шаблона регистрации (registration.tpl) добавлена поддержка тегов быстрой авторизации через социальные сети. Это те же теги, что и используются в шаблоне login.tpl, такие как [vk] {vk_url} [/vk] и т.д.

qДобавлена поддержка новой системы защиты от спам ботов Recaptcha 2.0. Использование данной новой системы позволяет вашим сайтам более дружественно относится к пользователям, и более легко подтверждать что они не являются роботами, а также более надежно защищать ваши сайты от спам ботов. Внимание при переходе на данную систему, если вы ранее использовали общие ключи, которые шли в комплекте со скриптом, то вам необходимо зарегистрировать ваши сайты персонально на сервисе рекаптчи, и использовать свои собственные ключи. Общие ключи больше недействительны.

qДля вывода новостей в пользовательском формате тегом {custom ....} добавлен новый параметр tags="слово1,слово2", который выводит новости которые содержат перечисленные ключевые слова из облака тегов. Например тег {custom tags="новости,шаблоны"} выведет все новости, которые содержат ключевые слова из облака тегов "новости" и "шаблоны".

qПереработана и улучшена система отправки писем с сайта, основным классом для отправки писем стал использоваться класс PHPMailer 5.2.9. Что позволило существенно увеличить совместимость с различными SMTP серверами, а также были устранены проблемы с отправкой писем с использованием некоторых SMTP серверов (например, при использовании SMTP сервера от mail.ru). Для разработчиков сторонних дополнительных модулей, использующих стандартный класс для отправки писем, добавлена возможность отправлять вложенные файлы в письмах.

qПри загрузке аватаров посетителями сайта в свой профиль, добавлено также сохранение в базе данных и имени домена где находится и храниться аватар. Данное нововведение будет особенно полезно сайтам, которые используют используют несколько доменов и сайтов для своего проекта и объединяют базу данных пользователей в единую. Тем самым вашим посетителям не придется на каждом из ваших сайтов загружать аватар повторно, он будет корректно и отображаться на других доменах и сайтах в рамках объединённого проекта.

qСогласно новым требованиям системы "Яндекс Новости", для RSS была изменена система логотипов для данной системы. Теперь обычный логотип должен находиться в файле yandexlogo.png в корне вашего сайта, а квадратный логотип 180 на 180 пикселей должен находиться в файле yandexsquarelogo.png в корне вашего сайта.

qУлучшено отображение формы добавления публикаций в админпанели, при использовании мониторов с небольшим разрешением экрана, а также мониторов, имеющих большую пиксельную плотность, но не большие физические размеры.

qДобавлено использование Gzip сжатия для HTML5 плеера. Тем при использовании сжатия JS файлов в настройках скрипта, он также будет сжиматься и как следствие быстрее загружаться.

qДобавлена возможность указания домашней страницы сайта в настройках скрипта, без указания протокола. Например, вы можете указать вместо "http://site.ru/" просто "//site.ru/" или "/". Данное нововведение будет особенно полезно, для тех, кто делает сайт доступным одновременно по HTTP и HTTPS протоколам. Или планирует в дальнейшем переключить сайт с одного протокола на другой.

qДобавлено отображение количества проголосовавших в опросах к публикациям, сразу после голосования, либо при нажатии на кнопку "Результаты".

qОбновлен визуальный редактор TinyMCE до актуальной версии. Подробнее об изменениях вы можете прочитать на странице http://www.tinymce.com/develop/changelog/index.php?type=tinymce

qИсправлена проблема, связанная с некорректной работой календаря в админпанели скрипта, при перелистывании месяцев в календаре, если текущая дата больше чем количество дней в следующем месяце.

qИсправлена проблема, при которой не принимались размеры для средней копии загружаемой картинки, указываемые в окне загрузки изображений, при загрузке изображений через внешний URL.

qИсправлена проблема, при которой происходило удаление обратного слеша при сохранении информации в блокноте панели управления.

qИсправлена проблема, при которой не показывался HTML5 плеер при предварительном просмотре новостей, перед публикацией их на сайте.

qИсправлена проблема, при которой нельзя было редактировать дополнительные поля при быстром редактировании, если в их значении было указано "0"

qИсправлена проблема, при которой невозможно было загрузить файлы на сервер, если перед его расширением было две точки.

Список изменений относительно версии 10.3:

qДобавлена новая система выставления рейтинга для опубликованных новостей на сайте. Теперь в настройках скрипта вы можете выбрать тип используемого рейтинга на сайте. В настройках скрипта, в админпанели, Вы можете выбрать из трех доступных систем:

Оценка - при данном типе используется пятизвездочный рейтинг публикации. Посетители могут выставлять оценку новости от 1 до 5 и рейтинг выводится в виде усредненной оценки. По сути это существовавший ранее в скрипте рейтинг для публикаций.

Только 'Нравится' - при данном типе, посетитель может отметить, что ему нравится данная публикация (система лайков) и выводится количество пользователей, которым понравилась ваша публикация.

'Нравится' или 'Не нравится' - при данном типе посетители отмечают нравится ли им публикация или не нравится. В данном случае выводится общее значение рейтинга, например, +20 или -10 и т.д.

qДля поддержки новой системы рейтинга в шаблоны краткой и полной (shortstory.tpl и fullstory.tpl) новости добавлена поддержка следующих новых шаблонных тегов:

[rating-type-1] текст [/rating-type-1] - выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[rating-minus] текст [/rating-minus] - выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга публикации, выводится данная ссылка только если используется третий тип рейтинга.

[rating-plus] текст [/rating-plus] - выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга публикации, выводится данная ссылка только если используется второй и третий тип рейтинга.

Также поддержка тегов [rating-type-1] текст [/rating-type-1], [rating-type-2] текст [/rating-type-2], [rating-type-2] текст [/rating-type-2] добавлена и для шаблона вывода профиля пользователя userinfo.tpl

qДобавлена поддержка новой системы выставления рейтинга для комментариев, опубликованных на сайте. Включение рейтинга для комментариев осуществляется в настройках скрипта в админпанели скрипта. А также в настройках групп пользователей вы можете разрешить или запретить выставление рейтинга для комментариев, для каждой группы пользователей персонально. Также, как и для рейтинга публикаций, в настройках скрипта вы можете выбрать какой тип рейтинга использовать для комментариев. Вы можете выбрать из трех доступных систем:

Оценка - при данном типе используется пятизвездочный рейтинг комментариев. Посетители могут выставлять оценку комментарию от 1 до 5 и рейтинг выводится в виде усредненной оценки.

Только 'Нравится' - при данном типе, посетитель может отметить что ему нравится данный комментарий (система лайков) и выводится количество пользователей, которым понравился данный комментарий.

'Нравится' или 'Не нравится' - при данном типе посетители отмечают нравится ли им комментарий или не нравится. В данном случае выводится общее значение рейтинга, например, +20 или -10 и т.д.

qДля поддержки новой системы рейтинга комментариев в шаблон вывода комментариев (comments.tpl) добавлена поддержка следующих новых шаблонных тегов:

[rating-type-1] текст [/rating-type-1] - выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[rating-minus] текст [/rating-minus] - выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга комментария, выводится данная ссылка только если используется третий тип рейтинга.

[rating-plus] текст [/rating-plus] - выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга комментария, выводится данная ссылка только если используется второй и третий тип рейтинга.

{rating} - выводит выставленный для комментария рейтинг.

{vote-num} - выводит количество пользователей, которые выставили рейтинг для данного комментария.

qДля шаблонов вывода профиля пользователя (userinfo.tpl и profile_popup.tpl) добавлена поддержка следующих новых тегов для вывода суммарного рейтинга комментариев пользователя:

[comments-rating-type-1] текст [/rating-type-1] - выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев первого типа рейтинга 'Оценка'.

[comments-rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев второго типа рейтинга 'Только Нравится'.

[comments-rating-type-2] текст [/rating-type-2] - выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев третьего типа рейтинга 'Нравится' или 'Не нравится'.

{commentsrate} - выводит суммарный рейтинг всех комментариев данного пользователя.

qДобавлена возможность объединения старых, уже зарегистрированных аккаунтов на сайте, с авторизацией при помощи социальных сетей. В случае если пользователь уже был зарегистрирован на сайте, и при этом входит на сайт с использованием социальной сети, в которой используется тот же e-mail адрес что и на сайте, то на его e-mail адрес будет отправлено письмо с подтверждением на объединение данных аккаунтов. И в случае подтверждения, он сможет входить в свой аккаунт на сайте через данную социальную сеть. Также если он пользуется несколькими социальными сетями, с одним и тем e-mail адресом, он может использовать любую из них для авторизации. В целях безопасности данная опция отключена для пользователей, находящихся в группе администраторов сайта.

qДобавлена возможность для всех шаблонов e-mail сообщений, устанавливать, в каком формате необходимо отправлять письма в HTML формате или в текстовом формате. Тем самым при использовании HTML формата писем, вы можете задать индивидуальное оформление HTML для писем, которые отправляются с вашего сайта.

qВ админпанели, в разделе настроек шаблонов для E-mail сообщений, добавлен новый шаблон для писем, отправляемых при использовании массовой рассылки писем через панель управления скриптом. В данном шаблоне вы задаете необходимое вам HTML оформление писем, тем самым можете сделать персонализированное оформление писем для вашего сайта.

qВ админпанели, в разделе управления пользователями, добавлена возможность удаления всех новостей определенного пользователя. Для этого в разделе управления пользователями, вам необходимо кликнуть по количеству новостей у пользователя и выбрать пункт "Удалить все".

qВ настройки скрипта в раздел настроек безопасности, добавлена возможность указания интервала, в течении которого будет блокироваться IP посетителя на авторизацию, после указанного количества ошибочных вводов пароля. Ранее этот интервал был по умолчанию на 20 минут, а теперь вы можете его установить сами по своему желанию на более больший период времени, что позволит наиболее лучше обезопасить сайт от перебора паролей к аккаунтам.

qДобавлена полная поддержка скриптом протокола IPv6. Если посетитель вашего сайта будет иметь адрес IP в данной версии протокола IP, то он также будет поддерживаться скриптом, предоставляя пользователю все доступные возможности скрипта.

qДобавлена возможность при вставке ссылки в стандартном редакторе BBCODES, указывать также и всплывающую подсказку (title) для данной ссылки.

qДобавлено корректное изменение URL браузера при включении навигации по комментариям при помощи AJAX. Теперь при использовании данной навигации, автоматически также изменяется и URL браузера, что необходимо если посетитель решит перегрузить страницу браузера или скопировать URL.

qДобавлена автоматическая защита от удаления публикаций, путем случайного выставления даты на удаление во вкладке "дополнительно", при добавлении или редактировании публикаций. Теперь помимо того, что необходимо выбрать дату, также необходимо выбрать обязательно и действие, которое необходимо произвести с публикацией по истечении указанного срока.

qВ систему ведения логов действий в админпанели, добавлена также и автоматическая запись информации о том, что публикация была удалена по истечении срока, установленного в параметрах данной новости.

qВ админпанели в разделе редактирования новостей, для расширенного поиска, добавлена возможность выбора порядка сортировки новостей по количеству комментариев и по количеству просмотров.

qДобавлена возможность использования шаблонов при выводе RSS вашего сайта. Для этого используется файл шаблона rss.tpl в общей папке шаблонов /templates/. Тем самым вы можете гибко формировать выводимую информацию в вашем RSS потоке, например, включать туда вывод информации из доп. полей новостей.

qВ настройки категорий в админпанели управления скриптом, добавлена возможность включать или исключать новости опубликованные в данной категории из общего RSS потока. Данное нововведение будет полезно для сайтов, которые хотят исключить определенные категории из RSS, например, при публикации потока в системе Яндекс Новости.

qДля шаблонов main.tpl, fullstory.tpl и addcomments.tpl добавлена возможность использования тегов вывода авторизации пользователей на сайте с использованием социальных сетей. Это те же теги, что и используются в шаблоне login.tpl, такие как [vk] {vk_url} [/vk] и т.д. Тем самым вы можете гибко на страницах вашего сайта предлагать посетителям авторизоваться на вашем сайте, чтобы им не приходилось искать форму авторизации на вашем сайте. Например, если посетитель пролистал вашу страницу до конца читая комментарии к публикации и хочет оставить комментарий, то в форме добавления комментария, вы можете предложить ему также сразу авторизоваться на вашем сайте.

qДля тега вывода публикаций в пользовательском формате {custom ...} добавлен новый параметр categoryexclude="список категорий", который полностью противоположен параметру category="список категорий" и позволяет вывести новости, которые не принадлежат указанным в параметре категориям. Например, {custom categoryexclude="2,7"} выведет все новости которые не принадлежат категориям и id 2 и 7.

qДля тега вывода публикаций в пользовательском формате {custom ...} добавлен новый параметр idexclude="список id новостей", который полностью противоположен параметру id="список id новостей" и позволяет вывести новости, которые не принадлежат указанным в параметре id. Например, {custom idexclude="5-10"} выведет все новости, id которых не принадлежит диапазону от пяти до десяти.

qДля тега вывода публикаций в пользовательском формате {custom ...} добавлен новый параметр sort="asc" и sort="desc", который позволяет указать порядок сортировки публикаций. При использовании значения desc публикации сортируются по убыванию, а при использовании asc по возрастанию. Критерий сортировки указывается также, как и ранее в параметре order.

qДля шаблона вывода RSS информеров (informer.tpl) добавлен новый тег {link} который предназначен для вывода только URL ссылки на страницу источника публикации. Данный тег предназначен для более гибкого оформления шаблона RSS информера и оформления ссылки со своими специальными дополнительными параметрами.

qВ настройки скрипта добавлена возможность включения авторизации на сайте только с использованием социальных сетей. При включении данной настройки, внутренняя регистрация на сайте, автоматически отключается и на сайте смогут авторизоваться только пользователи, имеющие аккаунты в социальных сетях.

qДобавлено автоматическое удаление сортировки публикаций по комментариям, при выводе пользовательской сортировки публикаций с использованием тега {sort} в шаблоне main.tpl, в случае если в настройках скрипта было запрещено комментирование публикаций.

qПроведена адаптация скрипта для корректной поддержки линейки PHP 5.6.x

qДобавлена поддержка настройки, запрещающей регистрацию нескольких пользователей с одного IP на сайте, также и для авторизации на сайте через социальные сети.

qДобавлена более правильное и интеллектуальное сокращение текста в метатеге 'description' при его автоматическом формировании. Сокращение текста производится по завершении логического слова, а не обрывается посередине слова.

qДобавлено ограничение на использование символа '#' в логинах пользователей при их регистрации на сайтах. Т.к. данный символ некорректно обрабатывается модулем mod_rewrite для Апача, в правилах ЧПУ, что может приводить к проблемам с просмотром профилей на сайте данных пользователей при включенном ЧПУ.

qДобавлена система автоматического полного сброса кеша скрипта, после восстановления базы данных из резервных копий.

qДобавлено автоматическое сжатие JS скриптов для HTML5 плеера, если такое сжатие включено в настройках скрипта. Что позволяет ускорить загрузку страниц, использующих данный плеер, в браузер.

qВнесены изменения в логику работы тегов [declination=X] текст [/declination]. Если ранее данный тег выводил число X вместе со словом "текст" в нужном склонении. То теперь данный тег выводит только текст в нужном склонении без числа. Например, если раньше тег [declination={comments-num}]комментари|й|я|ев[/declination] выводил "2 комментария", то теперь тег выводит просто "комментария". Что позволяет использовать данный тег для построения более сложных предложений с нужными склонениями состоящими из нескольких слов. Также данный тег получил глобальную поддержку во всех шаблонах.

qДля шаблона RSS информеров добавлена поддержка нового тега {date=формат даты}, который выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком, но и ее отдельные части. Формат даты задается задается согласно формату, принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время.

qДобавлена поддержка новых российских часовых поясов, введенных после 26 октября 2014 года.

qПроведены улучшения в верстке панели управления скриптом, исправлены некоторые ошибки. Улучшена контрастность текста, для повышения удобства чтения текстов.

qОбновлен визуальный редактор TinyMCE до актуальной версии.

qИсправлена проблема, при которой всегда создавалась средняя копия картинки при загрузке изображения по URL, даже если это отключалось соответствующей галочкой перед непосредственной загрузкой файла.

qИсправлена проблема, связанная с некорректным цитированием комментариев при использовании визуальных WYSIWYG редакторов, если комментарий начинался с какого-либо HTML тега.

qИсправлена проблема при автоматическом переносе длинных слов в комментариях, при которой происходил повторный перенос слов в случае редактирования комментария повторно.

qИсправлена проблема, связанная с некорректной работой редактора шаблонов в админпанели скрипта, на компьютерах Mac c OS X.

qИсправлена проблема, при которой мог происходить некорректный поиск похожих новостей, если была включена опция поиска похожих новостей, находящихся в той же категории что и сама новость.

qИсправлена проблема с обработкой ББ тегов, связанная с возможным повреждением общей верстки шаблона, при определенной комбинации тегов в тексте и верстки шаблона.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 10.2:

q1. Добавлена возможность авторизации на сайте с использованием социальный сетей. Включается данная поддержка в настройках скрипта в панели управления. А настройка непосредственно социальных сетей осуществляется в специальном новом разделе панели управления: "Настройка социальный сетей". В данном разделе вы можете настроить какие именно социальные сети вы хотите поддерживать на своем сайте, а также указать необходимые параметры и ключи для работы конкретной социальной сети. Также в данном разделе предоставлена подробная справка как создавать приложения в социальных сетях для авторизации. Всего на данный момент поддерживается шесть социальных сетей: Вконтакте, Одноклассники, Facebook, Яндекс, Mail.ru, Google. Тем самым ваши посетители могут быстро авторизоваться на вашем сайте использованием своего логина и пароля в социальных сетях, без необходимости прохождения процедуры регистрации с вводом каптч, подтверждением E-mail и прочего.

qДобавлена возможность создавать при загрузке изображений на сервер не только уменьшенных копий, но и копий среднего размера загружаемых изображений. Тем самым теперь вы можете создавать при загрузке изображений маленькое превью картинки, среднюю уменьшенную копию и оригинальное изображение.

qДобавлена возможность при вставке загруженных к новостям картинок указывать в каком виде их вставлять. А именно, увеличивать их при клике на них до оригинального изображения, или вставлять их просто в виде изображений, без каких-либо ссылок в них.

qВ настройках скрипта в панели управления скриптом, была убрана настройка смещения времени. Вместо нее, добавлен более удобный выбор часового пояса сервера, по которому будет работать скрипт. Использование часовых поясов более удобно, т.к. автоматически будет производится переход на летнее и зимнее время (например, если сервер находится в Европе, а вы установили Московский часовой пояс, то вам не нужно производить настройки два раза в год). А также в RSS будет транслироваться корректный часовой пояс вашего сервера.

qДобавлена возможность персонального выбора каждым зарегистрированным пользователем своего часового пояса в котором он находится. Данная возможность позволяет посетителям сайта видеть для себя корректное время публикации статей и комментариев. Например, сервер и администрация сайта находится в Москве, а зарегистрированный пользователей находится в Красноярске, то этот пользователь может зайти на сайте в настройки своего профиля и выбрать Красноярский часовой пояс, и после этого он будет видеть дату и время новостей и комментариев уже по своему Красноярскому времени, и т.д.

qДля шаблона редактирования профиля пользователя (userinfo.tpl) добавлен новый тег {timezones} который выводит список доступных часовых поясов в системе, и позволяет выбрать ему свой часовой пояс для своего профиля на сайте.

qДобавлена возможность для опросов, добавленных к публикациям, выводить их не только при просмотре полных новостей, но и при просмотре кратких новостей. Для этого в шаблоне кратких новостей (shortstory.tpl) вы можете использовать тег {poll}. Оформление самого опроса осуществляется также в шаблоне poll.tpl

qДля шаблонов вывода кратких новостей (shortstory.tpl) добавлена возможность использования тегов баннеров, добавленных в управлении рекламными материалами в админпанели. Тем самым вы можете очень гибко выводить баннеры на страницах своего сайта совместно с тегами [newscount=x] {banner_x} [/newscount] и самостоятельно определять после какой новости на странице вы хотите осуществить вывод рекламы.

qДля шаблонов вывода кратких и полных новостей (shortstory.tpl и fullstory.tpl) добавлены новые теги [add-favorites] текст [/add-favorites], которые выводят текст в них в виде ссылки на добавление новость в закладки на сайте, а также добавлены теги [del-favorites] текст [/del-favorites], которые выводят текст в них в виде ссылки удаление новости из закладок на сайте. Данные теги позволят более гибко настраивать дизайн своего сайта, для тех, кто хочет отказаться от общего тега {favorites}, который выводит только одну заранее запрограммированную картинку на данные действия.

qДобавлены новые глобальные теги для шаблонов: [smartphone] текст [/smartphone], которые выводят текст, заключенный в них, если сайт просматривается при помощи смартфона, а также теги [not-smartphone] текст [/not-smartphone], которые выводят текст, заключенный в них, если сайт просматривается посетителем не со смартфона. Данные теги являются глобальными и могут использоваться во всех файлах шаблона. Тем самым вы можете гибко настраивать вывод контента своего сайта, в зависимости от используемого посетителем устройства, например, управлять выводом рекламы для устройств и многое другое.

qДобавлены новые глобальные теги для шаблонов: [tablet] текст [/tablet], которые выводят текст, заключенный в них, если сайт просматривается при помощи планшета, а также теги [not-tablet] текст [/not-tablet], которые выводят текст, заключенный в них, если сайт просматривается посетителем не с использованием планшета. Данные теги являются глобальными и могут использоваться во всех файлах шаблона. Тем самым вы можете гибко настраивать вывод контента своего сайта, в зависимости от используемого посетителем устройства, например, управлять выводом рекламы для устройств и многое другое.

qДобавлены новые глобальные теги для шаблонов: [desktop] текст [/desktop], которые выводят текст, заключенный в них, если сайт просматривается при помощи десктопного браузера (настольные компьютеры, ноутбуки), а также теги [not-desktop] текст [/not-desktop], которые выводят текст, заключенный в них, если сайт просматривается посетителем не с использованием десктопного браузера. Данные теги являются глобальными и могут использоваться во всех файлах шаблона. Тем самым вы можете гибко настраивать вывод контента своего сайта, в зависимости от используемого посетителем устройства, например, управлять выводом рекламы для устройств и многое другое.

qДобавлена возможность указывать для статический страниц файлы шаблонов, находящиеся не только в корневой папке шаблона, но и файлы, находящиеся в подпапках шаблона.

qДобавлена возможность в модуле перекрестных ссылок назначать для каждого ключевого слова, сколько замен данного слова должно производится на странице.

qДля полнотекстового поиска на сайте добавлен логический режим работы поиска, что позволяет существенно улучшить поиск по сайту и релевантность найденной информации по поисковому запросу. Данное нововведение позволяет показывать посетителю наиболее подходящие под его запрос найденные новости, комментарии или статические страницы.

qУлучшен алгоритм обработки уже находящихся ссылок на странице при замене ключевых слов из модуля перекрестных ссылок. Теперь больше не требуется обязательное отсутствие HTML тегов внутри ссылок, замена в них не будет производится независимо от этого.

qУлучшен алгоритм нахождения и замены ключевых слов из модуля перекрестных ссылок, благодаря чему удалось существенно увеличить скорость работы скрипта при большом объёме ссылок.

qДля модуля управления перекрестными ссылками в админпанели скрипта добавлена возможность массовой установки области замены ключевых слов, а также добавлена возможность массово устанавливать учитывать регистр букв или нет.

qДобавлена возможность редактирования значений дополнительных полей для профиля пользователя, непосредственно в админпанели скрипта в разделе настроек собственного профиля пользователем.

qДля шаблона вывода информации о зарегистрированном пользователе на сайте (login.tpl) добавлена возможность вывода значений его дополнительных полей, которые он заполнил при регистрации или в настройках своего профиля. Для вывода дополнительных полей профиля используются точно такие же теги, как и в шаблонах профиля (userinfo.tpl) и в шаблонах комментариев (comments.tpl).

qИз базы данных профилей пользователей убрано стационарное поле ICQ. Данное решение принято с тем что данный мессенджер потерял свою актуальность и использование этого поля незначительно, при том что оно занимает место в базе данных. При этом при необходимости вы можете создать данное поле как дополнительное поле для профиля и использовать его при необходимости на сайте.

qДобавлено указание номера просматриваемой страницы полной новости, в метатеге title, если новость была разбита на несколько страниц.

qВ настройки скрипта добавлена возможность назначение символа - разделителя, для модуля 'speedbar' (хлебные крошки). Данный символ будет использоваться при выводе навигации данного модуля, разделяя разделы сайта. Тем самым вы можете указать любой собственный разделитель, вместо постоянно используемого ранее символа "»".

qВ настройки скрипта добавлена возможность назначение символа - разделителя, для списка категорий, назначенных новости. Данный символ будет использоваться при выводе списка категорий при показе новостей на сайте, разделяя назначенные категории. Тем самым вы можете указать любой собственный разделитель, вместо постоянно используемого ранее символа "»".

qДобавлен вывод информации о сторонних модулях, установленных в панели управления скриптом, в левой боковой панели быстрой навигации по модулям в админпанели.

qПереработано управление ключевыми словами для облака тегов, метатегов и значений доп. полей, имеющих тип перекрестные ссылки. Теперь вы можете не только удалять их в один клик, но и редактировать без удаления, для этого необходимо дважды кликнуть по нужному вам слову. А также добавлен автоматический разбор вставленных слов при помощи Ctr-V, без необходимости нажатия Enter.

qВ панели управления скриптом, добавлена кнопка для быстрого сворачивания и разворачивания боковой панели. Данное нововведение будет полезным для пользователей, имеющих мониторы с низким разрешением экрана, для увеличения рабочей области.

qДобавлен автоматический сброс Кеша сжатых CSS и JS файлов, при редактировании данных файлов в редакторе шаблонов панели управления.

qДля шаблона панели авторизации (login.tpl) добавлен новый тег {group}, который выводит название группы пользователя сайта в которой он находится в данный момент.

qДобавлена поддержка апострофов, для дополнительных полей новостей, имеющих тип "Использовать значения как гиперссылки", и для которых при этом не был включен безопасный режим. Тем самым вы можете использовать, например, такие слова как О'Брайен, д'Артаньян и т.д.

qДобавлено автоматическое формирование имени ЧПУ для категории, при ее создании в админпанели, если оно не было задано пользователем. При этом при создании данного имени применяется транслитерация от указанного имени категории.

qПри добавлении и редактировании категорий в админпанели скрипта, добавлен контроль зарезервированных имен ЧПУ ссылок для категорий, чтобы пользователями не добавлялись имена, которые зарезервированы в DL

qE для других нужд. Например, вы не сможете добавить корневую категорию с именем "catalog", потому как это имя используется для организации на сайте каталогов, но сможете использовать это имя для подкатегории, где данное имя уже не зарезервировано и т.д.

qДобавлен более удобный выбор категорий при создании или редактировании дополнительных полей новостей в панели управления скриптом.

qВ настройки скрипта добавлена возможность указывать количество дней, в течении которых, необходимо хранить логи скрипта, для модуля "Список всех действий, выполненных в админпанели скрипта". При этом минимальным количеством дней в целях безопасности остается 30 дней, чтобы злоумышленник не мог удалить логи действий, а администратор сайта при желании может увеличить необходимое количество дней, например, до трех месяцев или года и т.д.

qОбновлена библиотека Jquery до актуальной версии v1.11.1

qОбновлен визуальный редактор TinyMCE до актуальной версии.

qОбновлен до актуальной версии HTML5 плеер, в котором были исправлены некоторые ошибки с воспроизведением.

qИсправлена проблема, при которой не работало управление настройками скрипта в админпанели, при использовании смартфонов и планшетов.

qИсправлена проблема, при которой происходила некорректная проверка на заполненность доп. полей, если перед полем с типом "список", было обязательное поле с другим типом.

qИсправлена проблема, при которой если поиск производится повторно, а пользователь при этом находился не на первой странице поисковой выдачи, он мог получать пустую страницу, если в новых результатах найдено меньшее количество новостей. Теперь новый поиск возвращает пользователя на первую страницу поисковой выдачи.

qИсправлена проблема, при которой модуль 'speedbar' (хлебные крошки), выводил вложенное нахождение пользователя на статической странице, а при этом фактически он находился на главной странице сайте, если в настройках скрипта был включен показ статической страницы по умолчанию для главной страницы сайта.

qИсправлена проблема, при которой если пользователь редактировал новость, ожидающую модерацию на сайте, не мог управлять загруженными к данной новости картинками, а если при редактировании новости загружал повторно картинки, они не назначались данной новости.

qИсправлена проблема, связанная с некорректной работой тегов [newscount=x] текст [/newscount], при использовании их в пользовательском выводе новостей тега {custom ...}

Список изменений относительно версии 10.1:

qПолностью принципиально новая панель управления скриптом DLE. Дорогие друзья, в данной версии скрипта мы хотим вам предоставить полностью обновлённую панель управления скриптом. Данная панель была разработана с использованием всех последний новейших технологий, которые позволяют сделать процесс управления новостями и другими разделами скрипта, более удобными и информативно понятными. Помимо нового современного дизайна, данная панель управления является адаптивной и способной самостоятельно подстраиваться под используемые устройства, тем самым обеспечивается более удобное управление как с использованием десктопного компьютера, так и с использованием планшетов и смартфонов. Учитывая важность таких моментов как мышечная и зрительная память, а также привычка, мы постарались создать новую панель управления такой, чтобы все для вас оставалось на привычных местах, и вам не пришлось затрачивать много времени на освоение и изучение новой панели управления. Мы очень надеемся, что новая панель вам понравиться, и вы оцените ее по достоинству. В связи с тем, что в новой панели управления активно используются HTML5 и CSS3 стандарты, мы были вынуждены отказаться от поддержки устаревших браузеров IE, для работы в новой панели вам понадобится IE10 и выше, а также актуальные версии браузеров Chrome, Firefox и Opera.

qВсе javascript файлы административной панели DLE теперь отделены от пользовательской части сайта и работают независимо. Например, если вы захотите самостоятельно обновить библиотеки сайта, например такие как Jquery и Jquery UI, вы можете это делать не опасаясь за совместимость с работой административной панели.

qДобавлена новая система управления ключевыми словами для облака тегов и ключевыми словами для мета тегов при редактировании новостей в админпанели. Теперь вы сможете легко в один клик удалять не нужные вам ключевые слова, а также добавлять новые. Перечислять их через запятую больше не нужно, все заполняется интуитивно понятно.

qВ админпанели в разделе управления группами добавлена возможность указания, на основе какой группы, создавать новую группу. Тем самым вы можете создавать новые группы, на основе каких-либо настроенных групп, в качестве шаблона для новой группы.

qВнесены изменения в логику показа рекламных материалов в админпанели, теперь вместо показа добавленного рекламного кода, показывается подсвеченный его исходный код, тем самым при добавлении каких-либо фрагментов HTML тегов, не будет нарушаться верстка админпанели, и вы всегда сможете управлять и редактировать код, непосредственно панели управления.

qСущественно улучшен и переработан модуль редактирования комментариев в админпанели скрипта. Добавлена возможность одиночного удаления комментариев при помощи технологии AJAX, а также добавлена возможность пометки комментария как "Спам" и как следствие автоматического бана спамера и удаления всех его комментариев, и уведомление облачного сервиса о спамере, если это включено в настройках скрипта.

qДобавлена функция динамической загрузки комментариев по мере просмотра посетителем страницы с полной новостью и чтения им комментариев. Данная функциональность основана на принципе: "Отложенная загрузка" и применяется с использованием технологии AJAX. Например, вы установили показывать 30 комментариев на каждую страницу, а у новости 100 комментариев, то при заходе на страницу с новостью, для пользователя будет показано первые 30 комментариев, по мере скроллинга страницы вниз и чтения комментариев, по окончании списка комментариев, вместо навигации по комментариям, на страницу будут автоматически подгружены следующие 30 комментариев и т.д. по мере скроллинга страницы, пока не будут показаны все комментарии к новости. Данная функциональность включается и отключается в настройках скрипта.

qДобавлена возможность указывать заголовок страницы правил сайта непосредственно в админпанели, при редактировании правил для сайта.

qДля вывода новостей с использованием пользовательского тега {custom ...} добавлена возможность вывода навигации по страницам. Для этого добавлен новый параметр тега navigation="yes". При добавлении данного параметра к пользовательскому тегу, будет выводится постраничная навигация по новостям, выводимым данным тегом. Тем самым вы можете осуществлять вывод новостей именно по вашим параметрам и при этом сохранять навигацию по страницам, если новостей по данным параметрами много. Навигация выводится только для страниц сайта, которые поддерживают навигацию для тега {content}, например, главная страница, страницы категорий и т.д. Если же страница не поддерживает навигации, например, вывод полной новости, или статической страницы, то для данного тега навигация автоматически также будет отключена.

qДля тега пользовательского вывода новостей {custom ...} добавлен новый параметр fixed="without", который выводит только новости, которые не были зафиксированы при публикации.

qОбновлен HTML5 плеер до актуальной версии, добавлена поддержка полноэкранного режима в браузере IE11.

qВ модуле перекрестных ссылок добавлена возможность использования ссылок, содержащих в себе URL кодированные символы.

qДобавлена проверка e-mail пользователя при его смене в профиле на то, находится ли данный адрес или пул адресов в списке адресов, запрещенных администратором к регистрации на сайте. Ранее данная проверка проводилась только при первоначальной регистрации посетителя на сайте.

qДобавлено указание логина пользователя в e-mail письме, которое отправляется пользователю, в случае смены им своего e-mail адреса в профиле. Данное нововведение будет полезным также администраторам сайтов, в случае если e-mail адрес пытается сменить бот на несуществующий, в результате администраторам приходят письма о недоставке, и они могут видеть кто меняет данные, и соответственно принять меры к данному пользователю.

qДобавлена удобная система добавления и редактирования дополнительных новостей в админпанели, имеющих свойство "Использовать как гиперссылки". Теперь можно удалить ненужные значение в один клик.

qДобавлена возможность разрешать в управлении рекламными материалами на сайте, вставку рекламных тегов непосредственно в текст новостей. Данная возможность устанавливается отдельного для каждого баннера. Вы можете разрешить или запретить вставку рекламного тега в текст новости. Если для тега будет разрешена вставка в текст новости, то при написании данного тега в тексте новостей, рекламный блок будет опубликован на сайте на месте данного тега. Тем самым вы можете размещать рекламу непосредственно в тексте новостей в удобном для вас месте.

qДобавлена возможность предосмотра рекламных материалов, добавленных в админпанели при помощи отдельного всплывающего окна.

qДля модуля управления перекрестными ссылками добавлена возможность указания области применения, где будет производиться замена ключевого слова ссылкой. Вы можете для каждого ключевого слова указать либо замену по всей страницы, либо замену в новостях и комментариях, либо замену только в новостях, либо замену только в комментариях.

qВ модуле управления перекрестными ссылками в админпанели, добавлена проверка на уже существующие в базе данных ключевые слова. Тем самым избегается появление дубликатов ключевых слов.

qДля модуля управления перекрестными ссылками добавлена возможность использование множественного склонения слов в пределах ключевой фразы, с указанием склонения для нескольких слов одновременно. Например, вы можете указать для замены фразу Иван(ов|ова|ову) Ива(н|на|ну) Иванови(ч|ча|чу). А также добавлена возможность комбинирования фразы из нескольких слов, как содержащий склонения, так и не содержащий, например, фраза: Ремон(т|та|ту) мебели.

qИзменен алгоритм вывода информации при помощи тега {title} в шаблоне вывода похожих новостей (relatednews.tpl). При использовании данного тега будет выводится полный заголовок новости без его обрезания до 75 символов как ранее

qДля шаблона вывода похожих новостей (relatednews.tpl) добавлена поддержка нового тега {title limit="x"}, который выводит заголовок новости, сокращенный до указанного количества в теге X символов. При этом сокращение заголовка производится до завершения логического слова, а не обрывается посередине.

qДля шаблона вывода кратких новостей (shortstory.tpl) добавлена поддержка новых тегов [not-newscount=X] текст [/not-newscount], которые является противоположностью уже существующих тегов [newscount=X] текст [/newscount], и выводят текст заключенный в данные теги при показе любых по счету новостей, кроме указанных X новостей. Данный тег будет полезен, если вы хотите выводить какие-либо элементы оформления во всех новостях при показе кратких новостей, кроме вышеуказанных. Например, что-либо не показывать в первой по списку новости.

qДля шаблона вывода комментариев (comments.tpl) добавлена поддержка новых тегов [not-commentscount=X] текст [/not-commentscount], которые является противоположностью уже существующих тегов [commentscount=X] текст [/not-commentscount], и выводят текст заключенный в данные теги при показе любых по счету комментариев, кроме указанных X комментариях. Данный тег будет полезен, если вы хотите выводить какие-либо элементы оформления во всех по счету комментариях, кроме вышеуказанных. Например, что-либо не показывать в первом по списку комментарии.

qДля стандартного ББ редактора добавлена возможность совместного использования ссылок, написанных при помощи ББ тегов и написанных с использованием HTML кода. HTML код ссылки не будет автоматически заменяться на ББ теги при редактировании.

qПри отключении показа видео и аудиоматериалов для мобильной версии сайта, в настройках скрипта, добавлено также отключение показа видеоматериалов, опубликованных в новости при помощи тега [mediа=...].

qДобавлена поддержка вставки видео с сервиса "Видео mail.ru" с использованием прямой вставки получаемого на видео сервисе кода с тегом <ifrаme ...>.

qДобавлена проверка правописания русского языка в визуальном редакторе TinyMCE. Проверка производится с использованием соответствующего сервиса Яндекса.

qВнесены изменения в алгоритмы показа и ротации баннеров, задаваемых в панели управления скриптом. Теперь вы можете задавать баннерам одно и то же имя и при этом указывать им разные условия для показа. Например, вы можете задать одному баннеру показываться в одной категории и другому баннеру с тем же именем в другой категории, что упрощает верстку шаблона, при которой вы можете добавить в шаблон только один тег и управлять его показом в панели управления.

qДобавлено автоматическое удаление пользователя из подписчиков на комментарии, если пользователь банится на сайте. Тем самым забаненному пользователю не будет приходить уведомления о новых комментариях.

qОбновлен до актуальной версии визуальный редактор TinyMCE.

qИсправлена проблема, при которой посетители сайтов могли видеть новость, которая уже опубликована, но время ее публикации еще не наступило, вбив соответствующий номер новости в URL браузера. Теперь просматривать подобные новости могут только администраторы и редакторы сайта.

qИсправлена проблема, при которой если новость в админпанели добавляется не от имени авторизованного пользователя, а указывается другой логин автора, то загруженные картинки от имени данного пользователя не назначались данной новости.

qИсправлена проблема, при которой во время перестроения публикаций в админпанели происходило повреждение текста, опубликованного в тегах [cоde]...[/cоde], если использовались при этом визуальные редакторы.

qИсправлена проблема, при которой мог сбиться счетчик комментариев у новости, если комментарии удалялись в разделе "IP утилиты" и при этом часть комментариев пользователя, находилась на модерации.

qИсправлена проблема, при которой отправлялись уведомления о новых комментариях пользователям, если данные комментарии только отправлялись на модерацию.

qИсправлена проблема с некорректной вставкой тегов [leech] в визуальном редакторе TinyMCE.

qИсправлена проблема при которой не работало цитирование в комментариях, при включении для комментариев редактора TinyMCE.

qИсправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 10.0:

qВ админпанели добавлен новый раздел "Перекрестные ссылки". Данный раздел предназначен для быстрого создания перелинковки по сайту по ключевым словам. В данном разделе вы задаете ключевое слово и URL, в случае нахождения данного ключевого слова на вашей странице, оно будет заменено на гипертекстовую ссылку. В отличии от модуля "фильтр слов", который также имеется в админпанели, в данном модуле ключевые слова ищется по всей странице, включая весь контент (новости, комментарии, шаблоны, сторонние модули и т.д.), а не только в новостях и комментариях. Также любое внесение или изменение ключевых слов в данном разделе, приводит к моментальному применению по всему сайту и всем страницам сайта, и не требуется никакого перестроения публикаций. Также в данном модуле поддерживается указание склонения слов, например вы можете задать ключевое слово "Иван(ов|ова|ову)" и ссылка будет применяться к словам: Иванов, Иванова, Иванову и т.д. Поиск ключевых слов осуществляется только по словам целиком, а не просто по всем вхождениям в тексте.

qДобавлен новый HTML5 плеер для воспроизведения видео на сайте. Данный плеер включается в настройках видеопроигрывателей и применяется когда вы публикуете видео в mp4 формате, сжатого кодеком H.264, используя теги [vidеo=http://site.ru/video.mp4]. А также он применяется при вставке видео с сервиса Youtube при помощи тега [mеdia=http://www.youtube.com/watch?v=rT_OmTMwvZI]. Данный плеер имеет одно очень важное преимущество относительно флэш плеера, а именно он не требует дополнительных плагинов для браузера, и видео может быть просмотрено на вашем сайте, если посетитель использует смартфоны при просмотре вашего сайта.

qДобавлен контроль и обработка неверных ЧПУ ссылок для статических страниц. Теперь совместно с новостями, некорректные ЧПУ ссылки обрабатываются и для статических страниц. Тем самым, если включен ЧПУ на сайте, то все ссылки без ЧПУ на статические страницы будут автоматически, при помощи 301 редиректа, перенаправлены на корректные ссылки.

qВ настройки скрипта добавлена возможность установки поиска похожих новостей для публикации, только из тех категорий, которым принадлежит данная публикация. Тем самым вы можете установить, чтобы похожие новости искались либо по всему сайту, либо только из тех категорий, которым принадлежит опубликованная новость.

qДля RSS экспорта новостей, предназначенных для экспорта в Яндекс новости, добавлена возможность экспортирования в RSS поток ссылок на картинки находящиеся в подробной новости.

qПолностью переработано формирование навигации по страницам полной новости, если текст публикации был разбит на несколько страниц. Теперь для навигации по страницам полной новости введен дополнительный файл шаблона splitnewsnavigation.tpl где вы можете задать любой удобный для вас вид навигации.

qВ настройки категорий в админпанели добавлена возможность для каждой категории отдельно устанавливать настройку: «Выводить новости опубликованные в субкатегориях». При этом глобальная настройка для всех категорий также остается в настройках скрипта. Тем самым вы можете персонально для каждой категории устанавливать нужно ли выводить новости из субкатегорий или нет. Например, вы можете глобально разрешить данную настройку, а для определенных категори

qй запретить, и наоборот.

qВ настройки скрипта добавлена возможность включения и отключения автоматической генерации мета тегов 'description' и 'keywords' в случае если они не были заполнены вручную при публикации новости. Ранее автоматическое формирование мета тегов существовало всегда, теперь при желании вы можете это отключить.

qВ настройки скрипта добавлена возможность устанавливать список IP адресов с которых разрешен доступ к админпанели. В отличие от ограничения по IP в настройках профилей, данное ограничение распространяется только на админпанель DLE и применяется для всех пользователей, имеющих доступ к админпанели, даже если пользователь появится минуя скрипт DLE, например будет внедрен в базу данных MySQL.

qВ настройки групп в админпанели скрипта добавлена возможность разрешать или запрещать для определенных групп пользователей восстановление забытых паролей на сайте. Данную возможность рекомендуется отключать для групп пользователей, имеющих расширенные полномочия на сайте, тем самым в случае кражи у пользователей почтовых аккаунтов, нельзя будет получить доступ к их аккаунтам на вашем сайте, путем функции восстановления забытого пароля.

qДобавлен новый тип автоматической фильтрации спама на сайте, а именно "слабая фильтрация". Тем самым фильтрация теперь работает следующим образом: При слабой фильтрации пользователь или его комментарий будет отклонен если вероятность того что он спамер составляет более 80%, при умеренной фильтрации пользователь или его комментарий будет отклонен если вероятность того что он спамер составляет более 50%, при усиленной фильтрации достаточно его нахождения в спам базе, для отклонения доступа, вероятность при этом не учитывается.

qОбщая настройка автоматической защиты от спама при добавлении комментариев, была перенесена из настроек скрипта, в настройки групп. Тем самым вы можете включать и отключать данную настройку для различных групп пользователей.

qДобавлен контроль E-mail адреса при регистрации, при проверке является ли посетитель возможным спамером. Ранее проверка при регистрации осуществлялась только по IP адресу, теперь проверка осуществляется и по E-mail адресу.

qДля модуля 'хлебные крошки' (speedbar) добавлена нумерация страница страниц при навигации по страницам того или иного раздела сайта.

qДобавлена возможность подключать в шаблонах при помощи тега {include file="file.tpl"} файлы шаблонов, из других шаблонов. Для этого необходимо указать путь к файлу начиная от корня шаблонов /templates/, например {include file="/templates/file.tpl"} или {include file="/templates/Gemini/file.tpl"} и т.д. Данное нововведение будет полезно для сайтов, которые используют несколько шаблонов одновременно на сайте и которым необходимо например подключать во всех шаблонах, один универсальный файл шаблона.

qДобавлены новые режимы работы и возможности для антивируса в админпанели скрипта. Теперь в случае если не был создан снимок системы и вы нажимаете на кнопку "Антивирус" в панели управления скриптом, то происходит проверка только папок скрипта DLE. В случае если вы нажимаете на тщательную проверку, то сканируются все папки в корне вашего сайта, независимо от того принадлежат ли они DLE или нет. В случае если вы создаете снимок файлов, то делается снимок всех без исключения важных файлов на сервере, независимо от их расположения и от того находятся ли они в папках DLE. Тем самым встроенный антивирус в DLE может контролировать изменения в любых важных файлах на сервере, даже в файлах других скриптов, не имеющих отношение непосредственно к DLE.

qДля модуля вывода стандартной каптчи добавлены новые алгоритмы вывода текста, усложняющие автоматическое распознавание.

qДобавлена защита администрации от самих себя при редактировании собственного профиля в разделе редактирования пользователей, а именно они больше не могут менять собственную группу, и тем самым защищаются от случайного переноса в другую группу. Другими словами, неопытные пользователи скрипта, не смогут больше забанить сами себя.

qДобавлена возможность назначения автора публикации еще при первичном написании публикации в админпанели скрипта, а не только при редактировании публикации.

qДобавлен новый механизм ротации баннеров, добавленных в админпанели скрипта в разделе управления рекламными материалами. Ранее, в случае если баннеры имели одинаковые имена, ротация происходила в случайном порядке. Теперь, при первом заходе на сайт, пользователю показывается баннер в случайном порядке, а при посещении последующих страниц сайта, ему будут показываться ранее еще не просмотренные баннеры, тем самым ему будут показаны все баннеры заданные в панели управления.

qДобавлена поддержка нового формата кода, который используется для вставки видео с сервиса Youtube.

qДобавлена поддержка тегов [hidе] текст [/hidе], предназначенных для вывода скрытого текста, в дополнительных полях для новостей, если вывод новостей осуществляется при помощи пользовательского тега {custom ....}

qДля шаблонов вывода краткой и полной новости (shortstory.tpl и fullstory.tpl), а также для шаблонов вывода комментариев и персональных сообщений (comments.tpl и pm.tpl) добавлена поддержка новых тегов [declination=X]текст[/declination], предназначенных для склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "1 комментарий", "2 комментария", "10 комментариев" и т.д. Или например тег [declination={views}]просмотр|а|ов[/declination] в зависимости от количества просмотров новости будет выводить "1 просмотр", "2 просмотра", "5 просмотров" и .д.

qДля шаблонов вывода кратких новостей (shortstory.tpl), а также для шаблонов пользовательского вывода новостей при помощи тега {custom ....} добавлена поддержка нового тега: [newscount=x] текст [/newscount] который выводит текст указанный в тегах если показывается X новость, где X это число показываемой на странице новости. Например [newscount=1] текст [/newscount] покажет текст при показе первой по счету на странице новости. Данный тег полезен для вебмастеров, которые хотят например регулировать где им показывать рекламу на сайте между новостями. Например, добавленный в самый конец шаблона код [newscount=2,5] рекламный код [/newscount], будет показывать рекламу после второй и пятой новости.

qПолностью переработан вывод результатов поиска по сайту. Теперь для шаблона выводов результатов поиска (searchresult.tpl) вы можете использовать точно такие же теги без ограничений, какие вы используете в шаблонах вывода кратких новостей и в шаблонах вывода комментариев. Тем самым страница поиска и выводов результатов больше ничем не ограничена по функциональности и по используемым тегам.

qДобавлена возможность снимать новость с публикации на сайте, при быстром редактировании новости.

qДобавлена возможность поиска похожих новостей, при добавлении новостей на сайте. При этом в отличие от поиска похожих новостей в админпанели, при добавлении на сайте не предлагается удаление или редактирование новостей, только их просмотр.

qУлучшена система вставки ссылок в BBCODES редакторе. Ввод ссылки и текста для ссылки осуществляется в пределах одного окна, а также производится автоматический анализ выделенного текста в редакторе, является она ссылкой или нет, и заполняется соответствующее поле в окне.

qДля шаблона E-mail сообщений, которое используется для отправки уведомлений о появлении нового комментария для администрации сайта и подписчиков, добавлен новый тег {%title%} который выводит заголовок новости в которой был написан новый комментарий. А также добавлена поддержка ЧПУ для тега {%link%} в данном шаблоне.

qДля тега пользовательского вывода публикаций {custom ...} для атрибута id="...", добавлена поддержка указания диапазона ID новостей с использованием тире. Например, тег {custom id="1,4-8,11" aviable="global" order="date"} выведет новости c номером 1, новости с диапазоном id c 4 по 8, а также новость с номером 11.

qДля шаблона вывода персональных сообщений (pm.tpl) добавлена возможность просмотра, является ли пользователь в данный момент онлайн или оффлайн на сайте. Для этого были добавлены теги: [online] текст [/online] - выводят текст если пользователь онлайн, [offline] текст [/offline] - выводят текст если пользователь оффлайн. Статус активности пользователя определяется интервалом в 20 минут, если в течении 20 минут не было никакой активности и посещений сайта от данного пользователя, то его статус автоматически становится оффлайн.

qДля шаблона вывода комментариев (comments.tpl) добавлено использование новых тегов: [commentsgroup=1,2,3] текст [/commentsgroup] которые выводят заключенный в них текст указанных в них, если комментарий был написан пользователем принадлежащем перечисленным группам, также добавлен тег [not-commentsgroup=1,2,3] текст [/not-commentsgroup], который выводит заключенный в них текст если комментарий был написан пользователем не принадлежащем указанным группам. Тем самым у вас появляется возможность сделать разное оформление комментариев написанных различными группами пользователей. Например, вы можете сделать один вид комментариев, оставленных администраторами, и другой вид комментариев оставленных обычными посетителями.

qДля шаблона вывода комментариев (comments.tpl) добавлена поддержка нового тега: [commentscount=x] текст [/commentscount] который выводит текст указанный в тегах если показывается X комментарий, где X это число показываемого на странице комментария. Например [commentscount=1] текст [/commentscount] покажет текст при показе первого по счету на странице комментария. Данный тег полезен для вебмастеров, которые хотят например регулировать где им показывать рекламу на сайте между комментариями. Например, добавленный в самый конец шаблона код [commentscount=1,10] рекламный код [/commentscount], будет показывать рекламу после первого и десятого комментария.

qДобавлена поддержка кириллических доменов для тегов [leech=....] при публикации защищенных ссылок в новостях, для сайтов использующих кодировку windows-1251.

qУлучшена система выбора категорий при публикации и редактировании новостей в админпанели скрипта. Выбранные категории больше не убираются из списка, а остаются, при этом выделяются цветом. Тем самым вы можете и дальше легко ориентироваться в структуре категорий, при их выборе.

qУбран устаревший флэш загрузчик файлов, т.к. одновременную загрузку нескольких файлов поддерживает стандартных загрузчик во всех современных браузерах, а также улучшено визуальное отображение загрузки файлов в стандартном загрузчике.

qОбновлен визуальный редактор TinyMCE до актуальной новой линейки 4.x

qИсправлена проблема, при которой не работал поиск на главной странице, если в качестве главной в настройках скрипта был включен показ статической страницы.

qИсправлена проблема, при которой нельзя было добавлять в фильтр по логину в админпанели скрипта, логины содержащие в себе кириллицу, если на сервере установлена версия PHP 5.4.x. и выше.

qИсправлена проблема, связанная с некорректной публикацией заголовка новости в мета тегах страницы, если заголовок содержит кавычки.

qИсправлена проблема, связанная с некорректной работой каптчи Recaptcha от сервиса Google, при использовании на сайте SSL протокола.


Установка скрипта

Навигация: Работа с движком >

Установка скрипта

Установка скрипта на сервер

Установка скрипта на сервер проходит в автоматическом режиме и не должная вызывать особых проблем, но вам необходимо выполнить некоторые действия по настройке прав доступа на папки.

1.Для начала скопируйте все файлы из папки upload в данном архиве на ваш сервер.

2.Установите права для записи (CHMOD 777) для папок backup, templates, uploads, engine/data, engine/cache.

3.Наберите в URL вашего браузера адрес вашего сайте, например http://адрес вашего сайта/ и следуйте его инструкциям.

Внимание: чистая установка скрипта приводит к удалению данных ранее установленного скрипта DLE, для обновления установленного скрипта читайте инструкцию по обновлению.

Автоматический инсталлятор проверит все необходимые файлы и настроит подключение к базе данных. После завершения установки вы сможете посмотреть работу скрипта на демонстрационной странице http://адрес вашего сайта/ Для доступа к админпанели необходимо запустить http://адрес вашего сайта/admin.php


Обновление скрипта

Навигация: Работа с движком >

Обновление скрипта

Начиная с версии 13.0 для DataLife Engine доступно два типа обновления. Ручное и автоматическое. В случае если вашем сайте установлена версия ниже 13.0 вам необходимо воспользоваться ручным обновлением. В случае если на вашем сайте стоит версия 13.0 и выше вы можете воспользоваться как автоматическим так и ручным обновлением.

Автоматическое обновление:

В админпанели вашего сайта, на главной странице, нажмите на кнопку "Проверить обновления" и в случае наличия новой версии, нажмите на ссылку обновления скрипта, далее следуйте инструкциям на вашем сайте. Также вы можете сразу перейти в админпанели в раздел обновления по адресу http://вашсайт/admin.php?mod=upgrade и следовать дальнейшим инструкциям. По завершению обновления внесите необходимые изменения в ваши шаблоны, согласно списку изменений, опубликованному на сайте по адресу: https://dle-news.ru/templates-changelog.html

Ручное обновление:

1.Создайте резервную копию базы данных и всех файлов скрипта на сервере.

2.Обновите все файлы находящиеся на вашем сервере на файлы из папки /upload/ архива дистрибутива (за исключением шаблонов из папки /templates/). Внимание: Файлы из архива дистрибутива, нужно заливать на сервер поверх существующих, а не удалять предварительно папки на сервере.

3.Войдите в админпанель вашего сайта как администратор и следуйте дальнейшим инструкциям.

4.Внесите необходимые изменения в ваши шаблоны, согласно списку изменений, опубликованному на сайте по адресу: https://dle-news.ru/templates-changelog.html


Начало работы и шаблоны

Навигация: Работа с движком >

Начало работы и шаблоны

Одной из особенностей движка является то, что в него можно подключить любой существующий дизайн не испытывая при этом каких-либо ограничений. Движок поддерживает работу с несколькими шаблонами одновременно. Все шаблоны находятся в папке /tеmplates/. Каждая вложенная папка в этой папке является отдельным макетом сайта. Поэтому если вы скачали новый скин для движка просто скопируйте его в папку и разрешите его использование в админ панели. Также вы можете разрешить смену дизайна для посетителей вашего сайта и они сами смогут выбрать, как будет выглядеть их любимый сайт. Также вы можете установить количество новостей, выводимых на страницу, для этого зайдите в настройки скрипта и установите соответствующий параметр.

Внимание: В файлах шаблона вы можете использовать обычный html текст, либо можете использовать специальные теги, для вставки тех или иных возможностей, прочитать подробнее о допустимых тегах вы сможете в данном руководстве ниже в разделе Шаблоны.


Главные и глобальные теги для шаблонов

Навигация: Работа с движком >

Главные и глобальные теги для шаблонов

Основной макет вашей страницы находится в файле шаблона main.tpl именно этот файл скрипт DLE подгружает в первую очередь и к нему подключаются все другие компоненты движка. Остановимся на основных из них. {AJAX}, {info}, {content}, {custom} именно эти теги отвечают за правильный вывод новостей.

Тег {AJAX} выводит служебные скрипты JavaScript необходимые для нормальной работы движка в целом и технологии AJAX в частности. Рекомендуется размещать в самом начале шаблона после тега <body>

Тег {info} выводит служебную информацию и ошибках о произведенных действиях (например "Вход не выполнен, неверный пароль" или "Необходимо заполнить все поля") рекомендуется устанавливать перед тегом {content}

Тег {content}, отвечает за непосредственный вывод статей и прочих встроенных модулей в движок

Тег {tags}, отвечает за вывод облака тегов (специальных ключевых слов добавленнных в новость)

Теги [sort]{sort}[/sort], отвечают за вывод выбора пользователем порядка сортировки новостей, если это разрешено в настройках скрипта

Глобальные теги, которые можно применить ко всем шаблонам:

Тег {custom}, отвечает за вывод статей в пользовательском формате, имеет следующие параметры:

{custom id="1,2,5-8" category="2,3,5-8" author="x" days="x" template="custom" available="global" navigation="no" from="0" limit="10" fixed="yes" order="date" sort="desc" cache="yes"}

Где

id это список ID новостей которые вы хотите вывести, разделяются запятой без пробелов. Также вы можете указывать диапазон ID новостей при помощи тире. Например 1,4-8,11 выведет новости c ID 1, новости имеющих id c 4 по 8, а также с ID 11.

idexclude полностью противоположен параметру id="список id новостей" и позволяет вывести новости, которые не принадлежат указанным в параметре id. Например, {custom idexclude="5-10"} выведет все новости, id которых не принадлежит диапазону от пяти до десяти.

category это список ID категорий, из которых производить выборку новостей, разделяются запятой без пробелов. Также вы можете указывать диапазон категорий при помощи тире. Например 1,4-8,11 выведет новости из категории 1, категорий имеющих id c 4 по 8, а также из категории 11.

categoryexclude полностью противоположен параметру category="список категорий" и позволяет вывести новости, которые не принадлежат указанным в параметре категориям. Например, {custom categoryexclude="2,7"} выведет все новости которые не принадлежат категориям и id 2 и 7.

tags это список ключевых слов из облака тегов, назначенных новостям. Например тег {custom tags="новости,шаблоны"} выведет все новости, которые содержат ключевые слова из облака тегов "новости" и "шаблоны".

template файл шаблона который будет использоваться при выводе новостей в данном случае это будет custom.tpl если вы используете на сайте несколько шаблонов то данный файл должен присутствовать в каждом шаблоне. В данном шаблоне используются теги аналогичные для короткой новости.

available раздел в котором будет выводится запрашиваемые новости, может принимать следующие значения:

global - во всех разделах

main - на главной странице

date - при просмотре новостей за определенные даты

cat - при просмотре категории

showfull - при просмотре полной новости

search - при просмотре результатов поиска

userinfo - при просмотре профиля

register - при регистрации

stats - при просмотре статистики

pm - при просмотре персональных сообщений

feedback - при просмотре обратной связи

favorites - при просмотре закладок

newposts - при просмотре новых сообщений

addnews - при добавлении новости

lastnews - при просмотре последних новостей на сайте

lastcomments - при просмотре последних комментариев

lostpassword - при восстановлении пароля от аккаунта на сайте

static - при просмотре статических страниц

catalog - при просмотре каталога страниц

alltags - при просмотре облака тегов

tags - при просмотре новостей из облака тегов

allnews - при просмотре всех новостей на сайте или всех новостей какого либо пользователя

Вы можете комбинировать разделы при помощи "|", например available="userinfo|register|main" будет выводить ваши новости на главной, при регистрации и при просмотре профиля пользователя.

from номер новости с которой начнется вывод

limit сколько новостей будет выведено

order критерий сортировки новостей, может принимать следующие значения:

date - сортировка новостей по дате публикации

editdate - сортировка новостей по дате редактирования

rating - сортировка новостей по рейтингу

reads - сортировка новостей по количеству просмотров

comments - сортировка новостей по количеству комментариев

title - сортировка новостей по заголовкам новостей

rand - сортировка новостей в случайном порядке

id_as_list - сортирует публикации так как они указаны в списке для ID публикаций. Например, тег {custom id="3,4,1,2" order="id_as_list"} выведет сначала новость c ID 3 потом 4 потом 1 потом 2.

lastviewed - вывод последних просмотренных пользователем публикаций

sort указывает порядок сортировки публикаций. При использовании значения desc публикации сортируются по убыванию, а при использовании asc по возрастанию.

author логин автора новости, при указании данного параметра будут выводится только новости указанного автора. Допускается перечисление через запятую нескольких авторов. Например, тег {custom author="admin" limit="5"} выведет 5 новостей автора с логином "admin".

authorexclude указывает логины авторов, которые необходимо исключить из показа. Логины авторов в данном параметре также можно перечислять через запятую. Например, при использовании {custom authorexclude="admin,test"} будут выведены новости всех авторов, кроме авторов с логином "admin" и логином "test".

catalog выводятся все публикации содержащие указанный в параметре символьный код. Допускается также перечисление символьных кодов в параметре через запятую. Например, при использовании {custom catalog="а,б"} будут выведены новости, которые содержат символьные коды "а" или "б".

catalogexclude выводятся все публикации, которые не содержат указанный в параметре символьный код. Допускается также перечисление символьных кодов в параметре через запятую. Например, при использовании {custom catalogexclude="а,б"} будут выведены новости, которые не содержат символьные коды "а" и "б".

xfields выводятся все публикации, содержащие указанное в параметре значение дополнительных полей новостей. Допускается также перечисление значений в параметре через запятую. Например, при использовании {custom xfields="значение 1,значение 2"} будут выведены новости, в которых есть дополнительные поля содержащие "значение 1" или "значение 2".

xfieldsexclude выводятся все публикации, не содержащие указанное в параметре значение дополнительных полей новостей. Допускается также перечисление значений в параметре через запятую. Например, при использовании {custom xfieldsexclude="значение 1,значение 2"} будут выведены новости, в которых нет дополнительных полей содержащих "значение 1" и "значение 2".

days указывает временной период, где x это количество дней за которые выводить публикации. Например, тег {custom days="2" limit="5"} выведет 5 новостей за 2 последних дня.

banners принимает значения yes или no. Данный параметр включает или отключает вывод рекламных материалов, которые назначены для вывода между публикациями. По умолчанию если данный параметр отсутствует в теги, вывод рекламных материалов между публикациями будет отключён.

futureannounce принимает значения yes или no. Данный параметр работает совместно с параметром days="X", и указывает что публикации нужно брать из будущих дат. Например, тег {custom futureannounce="yes" days="1"} означает что необходимо вывести публикации, дата которых назначена на завтра, т.е. на +1 дней, а тег {custom futureannounce="yes" days="2"} выводит публикации дата которых назначена на завтра и послезавтра, и т.д. Данных параметр будет полезен вебмастерам, для вывода грядущих анонсов на своём сайте.

cache принимает значения yes или no - устанавливает кешировать вывод или нет, рекомендуется кешировать для снижения нагрузки. Вы можете указывать период в минутах, часах или днях. Для указания времени кеширования используются значения с суффиксами “m”, “h” и “d”. Например, если вы укажите {custom cache="30m" ….} то блок будет принудительно закеширован на 30 минут, если вы укажите {custom cache="2h" ….}, то блок будет кеширован на 2 часа, если указать {custom cache="1d" ….} то блок будет кеширован на один день.

navigation принимает значения yes или no - устанавливает использовать вывод навигации по страницам или нет. Навигация выводится только для страниц сайта, которые поддерживают навигацию для тега {content}, например, главная страница, страницы категорий и т.д. Если же страница не поддерживает навигации, например, вывод полной новости, или статической страницы, то для данного тега навигация автоматически также будет отключена независимо от указанного значения.

fixed принимает значения yes, no, only или without - устанавливает учитывать ли при выводе публикаций, то что новости были зафиксированы или нет. В случае если указано yes, то зафиксированные новости будут выведены в начале, если no, то зафиксированные новости будут выводится в общем списке новостей без учета данного параметра. В случае если указано значение only, то будут выводится только зафиксированные новости. В случае если указано значение without, то зафикисрованные новости не будут вообще выводится.

sortbyuser="yes" принимает только одно значение, и разрешает возможность использования пользовательской сортировки [sort]{sort}[/sort] для данного блока публикаций.

Внимание все параметры данного тега являются необязательными, необходимо указать только как минимум один любой параметр, все остальные параметры, если они не заданы, будут взяты из общих настроек скрипта. Например:

{custom id="1,2" order="date"} - выведет новости с ID 1 и 2 и отсортирует их по дате

{custom category="2,7" from="5" cache="yes"} - выведет новости из категорий 2 и 7 при этом количество новостей будет взято из настроек скрипта, а выборка будет осуществляться после 5 новости, отвечающей данному условию

{custom order="date" from="9" limit="5"} - выведет 5 последних новостей, начиная с десятой новости

Помните что каждое использование этого тега создает дополнительную нагрузку на базу данных, т.к. идет дополнительная выборка, поэтому используйте ее с умом если необходимо экономить на ресурсах.

Тег [available=раздел] текст [/available], выводит текст заключенный в теги если просматривается указанный раздел сайта:

Тег принимает параметры аналогичные параметру available тега {custom}. Вы можете комбинировать разделы при помощи "|", например userinfo|register|main

Для примера:

[available=userinfo|register|main] текст [/available]

будет выводить текст заключенный в теги, на главной, при регистрации и при просмотре профиля пользователя.

Внимание вы можете задать также тег [not-available=userinfo|register|main] текст [/not-available] который полностью противоположен тегу aviable и выводить текст везде кроме перечисленных разделов.

Тег [category=X]текст[/category], выводит текст заключенный в теги если просматривается указанная категория:

Тег принимает в качестве параметра ID категории, и допускает перечисление нескольких категорий

[category=1,2,3,7-10] текст [/category]

будет выводить текст заключенный в теги, если посетитель просматривает категории у которых ID равен 1 или 2 или 3, а также с 7 до 10.

Внимание вы можете задать также тег [not-category=1,2,3,7-10] текст [/not-category] который полностью противоположен тегу category и выводить текст везде кроме перечисленных категорий.

Тег [group=X]текст[/group], выводит текст заключенный в теги если пользователь принадлежит указанной группе пользователей:

Тег принимаем в качестве параметра ID группы, и допускает перечисление нескольких групп

[group=1,2,3] текст [/group]

будет выводить текст заключенный в теги, если посетитель является администратором, главным редактором или журналистом.

Внимание вы можете задать также тег [not-group=1,2,3] текст [/not-group] который полностью противоположен тегу group и выводить текст для всех, кроме перечисленных групп.

[page-count=1,2,3] текст [/page-count]

Будет выводить текст заключенный в них, если пользователь находится на определенной по номеру страницы в навигации по новостям, независимо от раздела сайта, где 1,2,3 это номера страниц в навигации. Данный тег позволит очень гибко настроить вывод той или иной информации, на определенной странице и полезен для информационных блоков и рекламы. Вы можете использовать данный тег совместно с другими, опеределяющими разделы сайта и категории.

Например, комбинация тегов [aviable=cat][category=1][page-count=1] текст [/page-count][/category][/aviable] выведут текст, только если пользователь просматривает первую страницу категории с id1, и при этом просматривает именно краткие новости, и при переходе на другую страницу в этой категории, данного текста он уже не увидит.

[not-page-count=1,2,3] текст [/not-page-count]

Выводит текст опубликованный в тегах на любых номерах страниц кроме указанных в теге.

{banner_имя} этот тег предназначен для вывода рекламной информации на сайте. Само имя для баннера задается в специальном модуле в админпанели.

[banner_имя] текст [/banner_имя] выводят текст заключенных в них, если указанный баннер выводится на странице сайта.

{inform_имя} этот тег предназначен для вывода RSS информеров и новостей с других сайтов. Имя и все настройки для данного тега устанавливаются в админпанели скрипта.

[static=имя страницы] текст [/static]

будет выводить текст заключенный в теги, если посетитель просматривает статическую страницу с указанным именем. Допускается также перечесление страниц в теге через запятую. Например [static=test1,test2,test3] текст [/static] будет выводить текст на страницах test1, test2 и test3

[not-static=имя страницы] текст [/not-static]

будет выводить текст заключенный в теги, если посетитель не просматривает статическую страницу с указанным именем. Допускается также перечесление страниц в теге через запятую.

[smartphone] текст [/smartphone]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт с мобильного телефона.

[not-smartphone] текст [/not-smartphone]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт не с мобильного телефона.

[tablet] текст [/tablet]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт с планшета.

[not-tablet] текст [/not-tablet]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт не с планшета.

[desktop] текст [/desktop]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт со стационарного компьютера или ноутбука.

[not-desktop] текст [/not-desktop]

будет выводить текст заключенный в теги, если посетитель просматривает ваш сайт не со стационарного компьютера или ноутбука.

[ios] текст [/ios]

выводят текст заключенных в них, в случае если устройство посетителя сайта использует операционную систему iOS от Apple

[not-ios] текст [/not-ios]

выводят текст заключенных в них, в случае если устройство посетителя сайта не использует операционную систему iOS

[android] текст [/android]

выводят текст заключенных в них, в случае если устройство посетителя сайта использует операционную систему Android от Google

[not-android] текст [/not-android]

выводят текст заключенных в них, в случае если устройство посетителя сайта не использует операционную систему Android

Также вы можете подключать один шаблон в другой, используя тег {include file="my_block.tpl"} данный тег подключает указанный файл my_block.tpl в шаблон. Тег призван облегчить структуру шаблона, если используется сложная верстка со множеством тегов.

{customcomments id="1,2,5-8" category="2,3,5-8" author="x" days="x" template="custom" available="global" from="0" limit="10" order="date" sort="desc" cache="yes"}

Выводит комментарии в любом месте сайта в пользовательском формате. Данный тег является вспомогательным дополнительным выводом комментариев, и может, например, использоваться для вывода последних комментариев на главной странице сайта в блоке и т.д.

Данный тег может принимать следующие параметры:

id - список ID комментариев, которые вы хотите вывести, разделяются запятой без пробелов. Также вы можете указывать диапазон ID комментариев при помощи тире. Например, 1,4-8,11 выведет комментарии c ID 1, комментарии имеющие id c 4 по 8, а также с ID 11.

newsid – список ID новостей, из которых вы хотите вывести комментарии, разделяются запятой без пробелов. Также вы можете указывать диапазон ID новостей при помощи тире. Например, 1,4-8,11 выведет комментарии из публикаций c ID 1, имеющих id c 4 по 8, а также с ID 11.

newsidexclude - список ID новостей, из которых вы не хотите выводить комментарии, разделяются запятой без пробелов. Также вы можете указывать диапазон ID новостей при помощи тире. Например, 1,4-8,11 выведет комментарии из всех публикаций кроме ID 1, имеющих id c 4 по 8, а также с ID 11.

category - список ID категорий новостей, из которых производить выборку комментариев, разделяются запятой без пробелов. Также вы можете указывать диапазон категорий при помощи тире. Например 1,4-8,11 выведет комментарии из категории 1, категорий имеющих id c 4 по 8, а также из категории 11.

categoryexclude - полностью противоположен параметру category="список категорий" и позволяет вывести комментарии, новости которых не принадлежат указанным в параметре категориям. Например, {customcomments categoryexclude="2,7"} выведет все комментарии у новостей, которые не принадлежат категориям и id 2 и 7.

subcat указывает необходимо ли включать в выборку также публикации, находящиеся в подкатегориях или нет. Данный параметр может принимать следующие значения: subcat="yes" который указывает, что также нужно выбрать все публикации находящиеся и в подкатегориях указанной категории, а также значение subcat="only" который указывает, что нужно выбрать публикации только из подкатегорий, без учета указанной категории. Например, у вас на сайте есть категории с ID 1, 2 и 3. Категории 2 и 3 при этом являются подкатегориями первой. При использовании тега {custom category="1" subcat="yes"} будут выбраны все новости, из категорий 1, 2 и 3. А при использовании тега {custom category="1" subcat="only"} будут выбраны все публикации только из категорий 2 и 3.

author - указывает логин автора комментария, при указании данного параметра будут выводится только комментарии указанного автора. Допускается перечисление через запятую нескольких авторов. Например, тег {customcomments author="admin" limit="5"} выведет 5 комментариев автора с логином "admin".

authorexclude - указывает логины авторов, которые необходимо исключить из показа. Логины авторов в данном параметре также можно перечислять через запятую. Например, при использовании {customcomments authorexclude="admin,test"} будут выведены комментарии всех авторов, кроме авторов с логином "admin" и логином "test".

days - указывает временной период, где x это количество дней, за которые выводить комментарии. Например, тег {customcomments days="2" limit="5"} выведет 5 комментариев за 2 последних дня.

template - файл шаблона который будет использоваться при выводе комментариев в данном случае это будет custom.tpl если вы используете на сайте несколько шаблонов, то данный файл должен присутствовать в каждом шаблоне. В данном шаблоне используются теги аналогичные тем, что вы используете в шаблоне вывода комментариев (comments.tpl).

available раздел в котором будет выводится запрашиваемые комментарии, может принимать следующие значения:

global - во всех разделах

main - на главной странице

date - при просмотре новостей за определенные даты

cat - при просмотре категории

showfull - при просмотре полной новости

search - при просмотре результатов поиска

userinfo - при просмотре профиля

register - при регистрации

stats - при просмотре статистики

pm - при просмотре персональных сообщений

feedback - при просмотре обратной связи

favorites - при просмотре закладок

newposts - при просмотре новых сообщений

addnews - при добавлении новости

lastnews - при просмотре последних новостей на сайте

lastcomments - при просмотре последних комментариев

lostpassword - при восстановлении пароля от аккаунта на сайте

static - при просмотре статических страниц

catalog - при просмотре каталога страниц

alltags - при просмотре облака тегов

tags - при просмотре новостей из облака тегов

allnews - при просмотре всех новостей на сайте или всех новостей какого либо пользователя

Вы можете комбинировать разделы при помощи "|", например available="userinfo|register|main" будет выводить ваши новости на главной, при регистрации и при просмотре профиля пользователя.

from - указывает номер комментария с которой начнется вывод. Нумерация комментариев начинается с нуля. Например, если вы хотите пропустить первый комментарий, который совпадает с вашими условиями, то нужно указывать from="1"

limit - указывает сколько комментариев будет выведено.

order - указывает критерий сортировки комментариев, может принимать следующие значения:

date - сортировка комментариев по дате, например, тег {customcomments order="date" limit="5"} выведет пять последних комментариев.

rating - сортировка комментариев по рейтингу, например, тег {customcomments order="rating" limit="5"} выведет пять самых рейтинговых комментариев.

rand - сортировка комментариев в случайном порядке, например, тег {customcomments order="rand" limit="5"} выведет пять комментариев в случайном порядке.

id_as_list - сортирует публикации так как они указаны в списке для ID публикаций. Например, тег {custom id="3,4,1,2" order="id_as_list"} выведет сначала новость c ID 3 потом 4 потом 1 потом 2.

sort - указывает порядок сортировки комментариев. При использовании значения desc публикации сортируются по убыванию, а при использовании asc по возрастанию.

cache - принимает значения yes или no и указывает кешировать вывод или нет, мы рекомендуем кешировать блоки данного вывода для снижения нагрузки на сервер. Вы можете указывать период в минутах, часах или днях. Для указания времени кеширования используются значения с суффиксами “m”, “h” и “d”. Например, если вы укажите {customcomments cache="30m" ….} то блок с комментариями будет принудительно кеширован на 30 минут, если вы укажите {customcomments cache="2h" ….}, то блок с комментариями будет кеширован на 2 часа, если указать {customcomments cache="1d" ….} то блок с комментариями будет кеширован на один день.

Все параметры данного тега являются необязательными. Достаточно указать одного любого параметра. Вы также можете комбинировать различные параметры данного тега по своему усмотрению.

{* Закомментированный код *}

Данный тег предназначен для комментирования кода, все что заключено между "{*" и "*}" будет удалено из шаблона. И будет отсутствовать при выводе на сайте. Данные теги будут полезны разработчикам шаблонов, для отладки той или иной функциональности, когда нужно временно закомментировать ту или иную функциональность. Данный тег является глобальным и может использоваться во всех шаблонах.

{lang text="LANG_PARAMETER"}

Данный тег предназначен для вывода информации из языкового файла website.tpl, который в данный момент используется, где LANG_PARAMETER это значение параметра, который необходимо вывести. Например, тег {lang text="attach_images"} выведет надпись “Прикрепить изображения” из языкового пакета, в случае использования русского языка и если используется английский язык, то “Attach Images”

{catmenu}

Для вывода меню категорий используется тег {catmenu}. Данный тег вы можете использовать в любом файле шаблонов, он является глобальным. Данный тег в свою очередь использует и подключает файл шаблона categorymenu.tpl.

{catmenu id="1,2,3-5" subcat="yes" template="custom" cache="yes"}

Выводит меню категорий в пользовательском формате, где:

id="1,2,3-5" - список ID категорий которые необходимо вывести в меню. Вы можете перечислить несколько категорий через запятую, либо указать диапазон ID через тире.

subcat="yes" - данный параметр принимает значения "yes", "no" или "only" и используется совместно с параметром id данного тега, и указывает нужно ли автоматически подключать подкатегории для указанного списка категорий. Например, есть категория с ID 1, у данной категории есть подкатегории с ID 2 и ID 3, то при использовании тега {catmenu id="1" subcat="yes"} будет выведена категория 1 и ее подкатегории 2 и 3, а при использовании тега {catmenu id="1" subcat="no"} будет выведена только категория с ID 1. Значение "only" означает что нужно выводить только подкатегории из указанной категории. Например, при использовании тега {catmenu id="1" subcat="only"} будут выведены только подкатегории принадлежащие категории с ID "1". Также например, при помощи простой конструкции [available=cat] {catmenu id="{category-id}" subcat="only"} [/available] вы можете автоматически выводить список подкатегорий у просматриваемой на сайте категории.

template="custom" - указывается имя шаблона, которое будет использоваться для формирования меню вместо стандартного categorymenu.tpl

cache="yes" - данный параметр принимает значения "yes" или "no" и указывает кешировать данный блок или нет. При включении кеширования, автоматически пропадет возможность управлять подсветкой активной просматриваемой категории через теги [active] текст [/active] в шаблоне.

{catnewscount id="X"}

Выводит количество публикаций для указанной категории, где X это ID нужной вам категории. Данный тег будет полезен для вывода количества публикаций, в уже сформированных вручную в шаблонах меню на сайтах.

{category-id}

Выводит ID просматриваемой посетителем сайта категории. Данный тег будет полезен при организации меню на сайте, а также когда нужно быстро переназначить какие-либо CSS классы или сами имена файлов шаблонов, при оформлении шаблонов вывода публикаций.

{category-title}

Выводит имя просматриваемой посетителем сайта категории. Данный тег будет полезен, когда на сайте нужно отдельно вывести имя просматриваемой категории.

{category-description}

Выводит заданное описание категории, когда пользователь просматривает данную категорию, также вывод доступен и при выводе полных публикаций

[category-description] текст [/category-description]

Выводят текст заключённый в них если просматриваемая категория имеет заданное описание категории

[not-category-description] текст [/not-category-description]

Выводят текст заключённый в них, если категория не имеет описания.

{category-icon}

Выводит иконку просматриваемой пользователем категории, либо категории новости, если просматривается полная новость

{category-url}

Выводит URL просматриваемой категории

{page-title}

Выводит указанный вами в разделе "Заголовки, описания, метатеги" заголовок для страницы

{page-description}

Выводит указанное вами в разделе "Заголовки, описания, метатеги" описание для страницы

{page-count}

Выводит номер страницы, на которой находится пользователь

[script] код [/script] Глобальные теги которые позволяют разместить исполняемый jаvascript код. При этом данный код будет размещён непосредственно в исполняемом блоке других JS скриптов DataLife Engine, и будет запущен непосредственно после загрузки других JS скриптов, которые используются при подключении. Тем самым вы можете упорядочить все JS коды в шаблоне, стандартизировать их порядок исполнения, и в будущем избегать каких-либо конфликтов.

{cache-id}

Выводит текущий актуальный ID кэша

Данные из профиля пользователя:

{profile-link} - Выводит ссылку на профиль пользователя

{profile-login} - Выводит логин пользователя

{ip} - Выводит IP пользователя

{foto} - Выводит ссылку на аватар пользователя

{fullname} - Выводит полное имя пользователя

[fullname] текст [/fullname] - Выводит текст заключенный в теги в случае если полное имя указано в профиле пользователя

{land} - Выводит страну пользователя

[land] текст [/land] - Выводит текст заключенный в теги в случае если страна указана в профиле пользователя

{mail} - Выводит E-mail адрес пользователя

{group} - Выводит группу пользователя

{registration} - Выводит дату регистрации пользователя

{lastdate} - Выводит дату последнего посещения пользователя

{group-icon} - Выводит иконку группы пользователя

{time_limit} - Выводит дату до которой пользователь находится в группе, если группа является временной

[time_limit] текст [/time_limit] - Выводит текст заключенный в теги в случае если пользователь находится во временной группе

{comm-num} - Выводит количество комментариев пользователя

{comments} - Выводит адрес ссылки на комментарии пользователя

[comm-num] текст [/comm-num] - Выводит текст заключенный в теги если пользователь имеет комментарии на сайте

[not-comm-num] текст [/not-comm-num] - Выводит текст заключенный в теги если пользователь не имеет комментариев на сайте

{news} - Выводит адрес ссылки на новости пользователя

{rss} - Выводит адрес ссылки на RSS новостей пользователя

{news-num} - Выводит количество новостей пользователя

[news-num] текст [/news-num] - Выводит текст заключенный в теги если пользователь имеет новости на сайте

[not-news-num] текст [/not-news-num] - Выводит текст заключенный в теги если пользователь не имеет новостей на сайте

{new-pm} - Выводит количество непрочитанных персональных сообщений пользователя

{all-pm} - Выводит общее количество персональных сообщений пользователя

{favorite-count} - Выводит общее количество публикаций в закладках пользователя

[profile_xfvalue_X] - Выводит значение дополнительного поля с именем "X" из его профиля

[profile_xfgiven_X] текст [/profile_xfgiven_X] - Выводит текст заключенный в теги если дополнительное поле с именем "X" указано в его профиле

[profile_xfnotgiven_X] текст [/profile_xfnotgiven_X] - Выводит текст заключенный в теги если дополнительное поле с именем "X" не указано в его профиле

{admin-link} - Выводит ссылку на админпанель если он имеет к ней доступ

[admin-link] текст [/admin-link] - Выводит текст заключенный в теги если пользователь имеет доступ к админпанели


Теги при написании новостей

Навигация: Работа с движком >

Теги при написании новостей

При написании новостей допустимо использование следующих тегов, если вы не используете WYSIWYG редактор:

[b] текст [/b] Выделяет текст жирным шрифтом

[i] текст [/i] Выделяет текст наклонным шрифтом

[s] текст [/s] Зачеркивает текст

[u] текст [/u] Подчеркивает текст

[sub] текст [/sub] - выводят текст в нижнем индексе

[sup] текст [/sup] - выводят текст в верхнем индексе

[code] текст [/code] отменяет использование форматирования текста заключенного в теги

[left] текст [/left] Выравнивает текст по левому краю

[center] текст [/center] Выравнивает текст по центру

[right] текст [/right] Выравнивает текст по правому краю

[justify] текст [/justify] - выравнивает текст по обеим сторонам и слева и справа

[url=ссылка] текст [/url] Вставка ссылки в новость

[leech=ссылка] текст [/leech] Полностью аналогичен тегу URL, за исключением того что производит шифрование ссылки

[email=ссылка] текст [/email] Вставка e-mail адреса в новость

[img] ссылка [/img] Вставка картинки новость

[img=выравнивание] ссылка [/img] Вставка картинки новость и выравнивание ее по указанному параметру

[img=выравнивание|свой текст для alt] ссылка [/img] Вставка картинки новость и выравнивание ее по указанному параметру, а также назначение картинке собственного описания

[color=цвет] текст [/color] Изменение цвета текста на указанный

[quote] текст [/quote] Цитата

[hide] текст [/hide] Показывает скрытый текст только для пользователей, которым разрешен просмотр скрытого текста в настройках групп

[hide=2,3,4] текст [/hide] Показывает скрытый текст только для пользователей, группы которые перечислены в теге. Где 2,3,4 это ID групп пользователей которым разрешен просмотр данного текста.

{pagebreak} Разрыв страницы

[page=номер страницы] текст [/page] Вставка ссылки на указанный номер страницы внутри новости

[thumb] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку

[thumb=выравнивание] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку и выравнивание ее по указанному параметру

[thumb=выравнивание|свой текст для alt] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку и выравнивание ее по указанному параметру, а также назначение картинке собственного описания

[video=http://test.ru/video.avi] Позволяет установить проигрывание видеофайла в новости

[videо=300x250,http://site.ru/video.mp4] Данный тег позволяет установить размеры видео для данного конкретного тега

[video=http://test.ru/video.avi|http://test.ru/sample.jpg] Позволяет установить проигрывание видеофайла в новости, а также картинку предосмотра для перед началом проигрывания.

[video=http://test.ru/video.avi|http://test.ru/sample.jpg|Описание для видео] Позволяет установить проигрывание видеофайла в новости, установить картинку предосмотра перед началом проигрывания, а также задать отдельное описание для видео, которое будет показано в проигрывателе.

[video=http://test.ru/video.mp4,http://test.ru/video2.mp4] Позволяет установить проигрывание двух видеофайлов в новости, для этого будет создан плейлист из двух видеофайлов. Им также могут быть заданы и картинка для превью и описание, так как указано выше.

[audio=http://test.ru/music.mp3] Позволяет установит проигрывание MP3 в новости

[audio=http://test.ru/music1.mp3,http://test.ru/music2.mp3] Позволяет установит проигрывание плейлиста из нескольких MP3 файлов в новости

[font=имя шрифта] текст [/font] Написание текста определенным шрифтом

[size=размер] текст [/size] Написание текста определенным размером шрифта

[spоiler] текст [/spoiler] Скрывает указанный в теге текст и показывает его при клике на него

[spоiler=Заголовок] текст [/spoiler] Выводит собственный заголовок по щелчку на который будет показан скрытый текст

[media=ссылка на страницу с видео] предназначен для публикации видео и другого контента на сайте с сервисов поддерживающих oEmbed, таких как youtube.com, instagram, twitter, facebook, flickr, vimeo, docs.com, vine, gettyimages, codepen.io, dailymotion, mixcloud, soundcloud, coub, ifixit, Apple Keynote. В данном теге вы просто указываете URL страницы где размещено видео или нужный контент, скрипт автоматически распознает тип хранилища и вставит нужный HTML код для просмотра видео или виджета.

[media=300x250,http://....] Данный тег позволяет установить размеры видео для данного конкретного тега

[flash=ширина,высота] Путь к ролику [/flash] предназначенный для вставки флеш роликов в формате swf.

[list]

[*]пункт 1

[*]пункт 2

[/list] Вывод списка на сайте

[ol=1]

[*]пункт 1

[*]пункт 2

[/ol] Вывод пронумерованного списка на сайте

Небольшие пояснения к вставке кодов:

Например если вы хотите вставить картинку в текст то используйте тег [img]http://website/image.jpg[/img], если хотите ее выровнять по левому или по правому краю то используйте [img=left]http://website/image.jpg[/img], если же картинку нужно выровнять по центру то используйте следующее написание [center][img]http://website/image.jpg[/img][/center]. Аналогичный принцип действует и для тега [thumb]. Например, ваша статья содержит несколько страниц, и вы хотите на какой-либо странице помимо стандартной навигации между ними, зашитой в шаблоне, использовать свою ссылку на какую-либо страницу, то вставьте следующий код [page=3] для просмотра 3 страницы жми тут[/page] где 3 это номер страницы вашей новости.


Избранное / Фавориты

Навигация: Работа с движком >

Избранное / Фавориты

Возможности движка позволяют каждому зарегистрированному пользователю добавлять понравившуюся новость в свои закладки. Не путайте с закладками браузера. После авторизации на сайте каждый посетитель может добавить новость в закладки нажав на плюсик, после этого он может легко просмотреть новость или комментарии к ней, независимо от даты новости и не используя при этом поиск.


Персональные сообщения

Навигация: Работа с движком >

Персональные сообщения

Все авторизованные на сайте пользователи могут отправлять друг другу персональные сообщения. Данные сообщения в дальнейшем можно просматривать, удалять их, а также отвечать на них. Для этого используется определенный шаблон для их вывода. При редактировании этого шаблона будьте предельно внимательны. Чтобы не нарушить функциональность этого модуля. Для редактирования этого шаблона не требуется знание PHP, однако вы должны разбираться в HTML и его особенностях. Другими словами просто не изменяйте без особой надобности поля для ввода информации из форм.


ЧПУ и настройка

Навигация: Работа с движком >

ЧПУ и настройка

DataLife Engine использует в своей работе для вывода новостей ЧПУ (человеко-понятный URL), что позволяет тему статьи или любой другой текст добавить в URL браузера, благодаря этому индексация сайта в поисковых системах будет более качественной, что приведет больше посетителей на ваш сайт с поисковых систем. Для работы ЧПУ необходимо чтобы на вашем сервере был установлен модуль modrewrite. Если Ваш сервер не поддерживает этого, то вы можете отключить эту функцию. Для этого вам необходимо обязательно удалить с корневого каталога файл .htaccess и при установке скрипта отключить поддержку этой функции. Для более корректной работы ЧПУ мы рекомендуем устанавливать скрипт в корневую папку вашего сайта.

При включенном ЧПУ ссылки будут имеют следующий вид

Полная новость

С использованием ЧПУ зависит от типа ЧПУ установленного в настройках скрипта

http://website.com/index.php?newsid=1234543 - без использования ЧПУ

Добавление новостей на сайт вашими посетителями

http://website.com/addnews.html - с использованием ЧПУ

http://website.com/index.php?do=addnews - без использования ЧПУ

Профиль пользователя

http://website.com/user/имя пользователя/ - с использованием ЧПУ

http://website.com/index.php?subaction=userinfo&user= имя - без использования ЧПУ

Регистрация на сайте

http://website.com/index.php?do=register - без использования ЧПУ

Обзор непрочитанных сообщений

http://website.com/newposts/ - с использованием ЧПУ

http://website.com/index.php?subaction=newposts - без использования ЧПУ

Вывод всех новостей

http://website.com/lastnews/ - с использованием ЧПУ

http://website.com/index.php?do=lastnews - без использованиия ЧПУ

Вывод всех новостей указанной категории

http://website.com/альтернативное имя категории/ - с использованием ЧПУ

http://website.com/index.php?do=cat&category=альтернативное имя - без использования ЧПУ

Вывод всех новостей за 2005 год

http://website.com/2005/ - с использованием ЧПУ

http://website.com/index.php?year=2005 - без использованиия ЧПУ

Вывод всех новостей за указанный месяц

http://website.com/2005/12/ - с использованием ЧПУ

http://website.com/index.php?year=2005&month=04 - без использования ЧПУ

Вывод всех новостей за указанный день

http://website.com/2005/12/01/ - с использованием ЧПУ

http://website.com/ index.php?year=2005&month=04&day=30 - без использования ЧПУ

Обратная связь с администрацией сайта и другими участниками

http://website.com/index.php?do=feedback

Каталог сайта (сортировка по символьному коду)

http://website.com/catalog/a/ - с использованием ЧПУ

http://website.com/index.php?catalog=а - без использованиия ЧПУ

Вывод облака тегов

http://website.com/tags/ - с использованием ЧПУ

http://website.com/index.php?do=tags - без использованиия ЧПУ

Правила сайта

http://website.com/rules.html - с использованием ЧПУ

http://website.com/index.php?do=rules - без использованиия ЧПУ

Ссылки для вывода всех новостей указанной категории вы должны самостоятельно добавить в дизайн вашей страницы. Более подробно о создании категорий читайте ниже.


Поддержка Смартфонов

Навигация: Работа с движком >

Поддержка Смартфонов

Datalife Engine позволяет автоматически определять с использованием чего посетитель заходит на ваш сайт. И в случае если пользователь заходит на ваш сайт с мобильного аппарата, то DataLife Engine способен распознать это и подготовить для вывода специальную облегченную версию вашего сайта, с минимумом графики и использованного для передачи трафика.

Для включения данной возможности вам необходимо в Админпанели в настройках скрипта включить пункт: Включить автоматическую поддержку смартфонов, там же в настройках скрипта вы можете включить вывод в новостях картинок или отключить. Также можно принудительно включить отображение версии сайта для смартфонов, для этого нужно перейти по ссылке http://site.ru/index.php?action=mobile

Также в вашей папке шаблонов /templates/ должна находится папка с шаблоном smartphone именно этот шаблон используется для вывода сайта в случае если пользователь зашел на ваш сайт с использованием мобильного телефона. В данном шаблоне вы можете использовать все теже возможности что и в обычном шаблоне. Все теги и возможности полностью идентичны обычному шаблону. Но мы рекомендуем использовать самый минимум и не забывать о размерах экрана мобильного телефона. В архиве дистрибутива мы подготовили один такой стандартный шаблон с самым минимумом информации и размером. На него мы и рекомендуем опираться, при создании собственного шаблона.


Система жалоб на грамматические ошибки на сайте

Навигация: Работа с движком >

Система жалоб на грамматические ошибки на сайте

В скрипте DataLife Engine присутствует система жалоб на грамматические и иные ошибки на сайте. Посетитель может выделить любой текст в браузере, нажать Ctrl+Enter, и ему будет предложено отправить уведомление администрации сайта о наличии ошибки в выделенном тексте. При этом пользователь может выделить любой текст на любой странице вашего сайта.

Рекомендуем вам разместить, в какой-либо видимой части вашего сайта, блок-уведомление о наличии такой возможности для ваших посетителей.

Управление жалобами на грамматические ошибки осуществляется в админпанели в разделе управления жалобами. Само уведомление отправляется с сайта с использованием технологии AJAX без перезагрузки страницы, и не доставляет неудобств пользователям.


Добавление новостей

Навигация: Работа с админпанелью >

Добавление новостей

Вход в админцентр осуществляется по адресу http://website.com/admin.php После авторизации вы сможете добавлять, редактировать и удалять новость, управлять пользователями и шаблонами, производить настройку скрипта, управлять картинками и многое другое.

При добавлении новости на сайт Вам необходимо задать заголовок статьи. Поле ЧПУ URL статьи является необязательным используется при включенных ЧПУ. Вы можете задать там свой текст, который будет в строке браузера, либо можете оставить его пустым, тогда текст будет сформирован из заголовка статьи, с учетом правил транслитации. Поле Дата задает дату новости, если отмечена галочка Текущая дата то будет автоматически вставлена текущая дата, с учетом коррекции времени, либо вы можете снять эту галочку, и ввести дату самостоятельно используя удобный календарь, нажав на значок рядом с полем. Если указать дату которая не наступила, то новость будет автоматически опубликована при наступлении указанной даты, при условии что новость допущена к публикации. Также вы можете выбрать категорию к которой принадлежит статья. После этого используя удобные кнопки для вставки тегов напишите вашу новость в кратком и полном описании, также если созданы дополнительные поля введите информацию и там. Внимание поле Полное описание не является обязательным, если оно пустое, то текст будет автоматически взят с Краткого описания. Используя ссылку [Загрузить картинку] вы сможете вставить в текст новости загруженные на сервер картинки либо загрузить непосредственно для этой статьи свою картинку. Также имеется возможность загрузки картинки непосредственно с другого сервера, минуя загрузку на собственный компьютер. Внимание если вы загружаете для этой статьи собственные картинки, то они будут автоматически удалены с сервера, при удалении новости.


Редактирование новостей

Навигация: Работа с админпанелью >

Редактирование новостей

Редактирование новостей идентично их добавлению за исключением поля Дата. Вы можете либо не изменять дату, для этого оставьте отмеченным Не изменять дату новости, либо снимите с него флажок и установите на Текущая дата и время, либо введите свою дату используя календарь.


Личные настройки

Навигация: Работа с админпанелью >

Личные настройки

В данном разделе вы сможете редактировать свой собственный профиль, изменить E-mail адрес, поменять дополнительные поля в виде полного имени, места жительства, установить новый пароль.


Настройка системы

Навигация: Работа с админпанелью >

Настройка системы

В данной разделе осуществляется общая настройка параметров системы, обратите внимание на то что настройка разбиты на разделы и для выбора раздела просто нажмите на соответствующую иконку.


Система плагинов

Навигация: Работа с админпанелью >

Система плагинов

Данная система плагинов позволяет модифицировать любую функциональность скрипта по своему усмотрению. Установка плагинов на сайт, обновление плагинов, осуществляется в один клик, непосредственно в панели управления DataLife Engine. Если плагин разработан под новую систему, то пользователям больше не придется читать инструкции по установке, что-то править непосредственно в файлах скрипта, и т.д. Им достаточно будет просто закачать плагин в админпанели и все.

Cистема плагинов построена по технологии виртуальной файловой системы. Вы описываете в плагине, в каком файле и какие действия нужно произвести, на основе этой информации DataLife Engine создаст виртуальные копии этих файлов, со всеми нужными изменениями и модификациями, и будет работать с созданными виртуальными копиями, не затрагивая при этом оригинальных файлов. При этом вы можете описать изменения практически во всех файлах, за исключением ряда базовых, например корневых файлов, но они не несут какого либо функционала, кроме как подключение других файлов. Также может быть изменена функциональность файлов, отвечающих за AJAX функции, для этого они были полностью переписаны для работы через контроллер. Какие это преимущества дает? Во-первых, оригинальные файлы всегда остаются неизменными, поэтому плагины могут быть легко изменены, удалены, обновлены и т.д. Во вторых эта система использует минимально возможную нагрузку на сайты в целом, т.к. виртуальные копии файлов создаются всего один раз, в момент установки или обновления плагинов, после чего DataLife Engine работает с этими измененными файлами как с обычными нативными файлами и нет никаких расходов памяти на точки вызова, хранение и контроль информации о том где и какую функциональность нужно менять и т.д. Нагрузка на сервер увеличится только на ту нагрузку, которую принесет с собой сам плагин, а система управления плагинами не будет вызывать какой либо дополнительной нагрузки. В-третьих, нет никаких проблем непосредственно с обновлением скрипта, скрипт может обновляться, на новые версии, а ваши плагины автоматически применяться к новым версиям. При этом различные плагины могут модифицировать один и тот же файл не вызывая конфликтов, при условии конечно если разные плагины не производят прямо противоположных друг другу действий.

Итак в самом модуле управления плагинами, вы можете либо создать плагин непосредственно в панели управления, либо загрузить готовый плагин. Рассмотрим добавление нового плагина в непосредственно в панели управления:

На первой вкладке вы задаете общие данные о плагине. Его название, его краткое описание. Для удобства различения с другими плагинами, вы можете указать ему иконку, которую он будет использовать в списке плагинов. Также вы задаете версию непосредственно самого плагина, и версию DataLife Engine c которой он совместим.

На следующей вкладке, вы задаете непосредственно действия над файлами, которые необходимо произвести. Вы можете добавить один или несколько файлов над которыми необходимо произвести действия, а также каждому файлу назначить одно или несколько действий, которые необходимо произвести. В файлах вы можете произвести следующие действия:

1. Найти и заменить какой либо код.

2. Найти и добавить выше нужный код.

3. Найти и добавить ниже какой либо код.

4. Полностью заменить содержимое файла на свое.

5. Создать новый виртуальный файл, который не существует в оригинальном DLE.

Вы можете в любое время также добавлять или удалять файлы, менять или удалять действия над файлами. Для удобства восприятия и редактирования, весь код при этом подсвечивается, а поля могут динамически растягиваться.

Тем самым, ситуация, при которой вы раньше вручную правили файлы скрипта, а изменения где то хранили у себя в блокноте, и каждый раз при обновлении скрипта, повторно вносили их в файлы скрипта, с новой версией полностью уходит в прошлое. Вы можете самостоятельно создать свой личный плагин непосредственно в админпанели, описав один раз нужные вам изменения в скрипте, и при обновлении скрипта до новой версии, вам не придется больше об этом заботиться, ваши изменения будут автоматически применяться к новым версиям.

На следующей вкладке вы можете добавить необходимые действия в базе данных MySQL, которые должен производить плагин в тех или иных ситуациях. Вы можете задать список MySQL запросов которые необходимо выполнить при установке плагина, при его обновлении, при его отключении, при его включении, при его удалении. При этом на каждое действие вы можете задать как один, так и список из нескольких запросов к базе данных.

Для существующего плагина, вы можете выполнить следующие действия: Вы можете его отключить, при этом он остается на сайте, но полностью игнорируется скриптом, и все его действия над файлами приостанавливаются. Вы можете его обновить до более новой версии, если таковая есть. Скачать плагин на компьютер для установки его на другой сайт. При этом сам файл скачивается в XML формате, и в данном XML содержится описание всех действий. По сути плагин представляет собой XML файл, который может быть установлен на сайт в админпанели.

Рассмотрим загрузку уже готового плагина на сайт. Вы можете загрузить и установить на свой сайт уже готовый плагин. При нажатии соответствующей кнопки вы можете загрузить либо XML файл с плагином. Либо ZIP архив с плагином. Это позволяет создавать очень сложные плагины, содержащие в себе большое количество других дополнительных файлов, как графических, так и PHP файлов. Чтобы например не описывать все действия непосредственно в самом плагине, можно создать дополнительные файлы и упаковать их в архив, разложив по новым местам. При этом важно знать, что в архиве могут быть только те PHP файлы, которые не входят в состав дистрибутива, а только ваши дополнительные файлы, в случае если будут файлы входящие в дистрибутив, такая загрузка будет заблокирована. Модификацию стандартных файлов, нужно описывать уже в самом плагине. Сам файл с XML плагином должен находится в корне вашего архива.

В случае если вы загружаете архив с плагином, и у DataLife Engine не будет прав на запись находящихся в вашем архиве файлов. Он автоматически запросит FTP доступ для того чтобы загрузить ваш архив. Если доступов не требуется, то все будет скопировано автоматически без них. При этом эти доступы не будут нигде храниться, а будут автоматически удалены после того как будут не нужны.

Новая система управления плагинами, обладает также встроенной системой логирования ошибок в плагине. В случае если какое либо действие над файлами не может быть выполнено, или произойдут какие либо ошибки, вы можете их легко увидеть и исправить. Например, это крайне удобно, если ваш плагин будет не совместим со следующей версией DLE, вы это быстро увидите, и можно легко адаптировать плагин.


Голосования

Навигация: Работа с админпанелью >

Голосования

В данном разделе вы можете создавать, редактировать и удалять опросы на сайте. Вы можете создавать опросы которые будут видны на всех страницах сайта, а также опросы которые будут видны только при просмотре определенных категорий.


Статические страницы

Навигация: Работа с админпанелью >

Статические страницы

Помимо написания динамически изменяемых новостей движок позволяет также написание статических страниц, частое изменение которых не планируется. Для того чтобы создать статическую страницу выберите "Создать новую страницу" после этого напишите название страницы, причем только латинскими буквами, потому что оно будет передаваться в URL сайта для просмотра, также введите описание страницы, это информация только для вас, и последнее создайте шаблон самой страницы, разрешено использование HTML. После создания страницы вы сможете ее просмотреть, изменить, либо удалить.

Адрес статической страницы с использование ЧПУ выглядит так: http://webseite.com/название страницы.html

Адрес статической страницы без ЧПУ выглядит так: http://webseite.com/index.php?do=static&page=название страницы


Группы пользователей

Навигация: Работа с админпанелью >

Группы пользователей

В данном разделе вы можете добавлять и редактировать новые и существующие группы пользователей. При добавлении новой группы пользователей вы выставляете ей доступные категории и права на сайте.

Доступные разделы: Разделы в которые имеет доступ выбранная группа

Доверительные разделы: В случае если разрешаете группе публиковать новости на сайте без предварительной модерации, либо разрешаете редактировать новости других пользователей, то в данном пункте вы указываете какие разделы вы доверяете группе. Редактирование новостей в неуказанных группах будет запрещено. Посетитель всегда может добавлять новости в доступные ему разделы, но если одна из категорий будет не в доверительном разделе то вся новость не будет опубликована без предварительной модерации. Категории в которые неразрешено добавлять новости без модерации выделяются красным цветом при добавлении.

Разрешить доступ в админпанель: данная опция разрешает пользователю доступ в админпанель, но не предоставляет доступа ко всем ее функциям. Разрешается доступ только для добавления или редактирования новостей из админпанели. Доступ ко всем функциям имеют только Администраторы.

Скрывать только полную новость из недоступных разделов: В случае если пользователю запрещен доступ в раздел вы можете выбрать, запретить ему полный доступ, либо запретить только просмотр полных новостей. В случае если вы запретите просмотр только полных новостей вы существенно сократите нагрузку на сервер и время выборки новостей.

Разрешить добавлять новости Вы можете запретить либо разрешить пользователям добавлять новости на сайт.

Публиковать новости без проверки: Разрешение на публикацию новостей в доверительные разделы без предварительной модерации

Разрешить фиксировать новости: Разрешение пользователям фиксировать новости на сайте

Редактирование собственных новостей: Разрешение пользователям редактировать собственные новости уже после опубликования на сайте

Редактирование всех новостей: Разрешение пользователям редактировать любые новости из доверительных разделов.

Разрешить добавление комментариев: Разрешение пользователям оставлять комментарии на сайте

Изменение своих комментариев: Разрешение пользователям редактировать собственные комментарии

Удаление своих комментариев: Разрешение пользователям удалять собственные комментарии

Изменение всех комментариев: Разрешение пользователям производить изменение любых комментариев

Удаление всех комментариев: Разрешение пользователям проводить удаление любых комментариев на сайте

Просмотр скрытого текста: Разрешение пользователям на просмотр содержимого тега [hide] [/hide]

Разрешить использование PM: Разрешение пользователям использование персональных сообщений на сайте.

Разрешить скачивание файлов: Разрешение пользователям скачивать загруженные на сервер файлы

Использование обратной связи: Разрешение пользователям использовать обратную связь на сайте

Использование поиска по сайту: Разрешение пользователям использовать поиск по сайту

Временное размещение в группе: Вы можете временно размещать пользователей в данной группе, при переносе пользователя в данную группу укажите до какого срока он будет размещен в данной группе, после окончания данного срока, пользователь будет автоматически перемещен в основную группу

Основная группа по окончании лимита: Укажите основную группу пользователя в которую он будет перемещен после окончания срока пребывания во временной группе.


Настройка категорий

Навигация: Работа с админпанелью >

Настройка категорий

В данном разделе вы можете создавать и редактировать категории. При создании новой категории вы указываете ее имя, альтернативное имя категории, путь для иконки категории, выбрать является ли новая категория подкатегорией и где. А также дополнительно вы можете указать какой шаблон будет использоваться при показе статей из данной категории, а также при просмотре этой категории. Иконка является необязательным параметром. Внимание: альтернативное имя задается только латинскими буквами и служит для вывода всех новостей данной категории. Например вы создаете категорию с именем «Софт», и альтернативным именем «soft», то для просмотра всех новостей из указанной новости при включенном ЧПУ в строке браузера необходимо набрать http://website.com/soft/, а при выключенном ЧПУ необходимо набрать http://website.com/?do=cat&category=soft


Дополнительные поля

Навигация: Работа с админпанелью >

Дополнительные поля

В данном разделе вы сможете создавать и редактировать дополнительные поля. Дополнительные поля, позволяют облегчать добавление информации на сайт, по умолчанию имеются только два поля, это краткое и полное описание новости. Однако вы можете создать и другие поля для ввода информации, например ссылку на источник или на программу, и настроив вывод поля всего один раз в шаблонах, отпадает необходимость постоянного форматирования часто повторяющегося ввода информации.

При добавлении нового поля вы вводите его название (латинскими буквами), описание поля (выводится рядом с полем ввода), категорию к которой принадлежит данное поле (вы можете выбрать, вводить ли данное поле для всех категорий или данное поле принадлежать только одной категории, вы можете назначать также выборочно, категории к которым будет принадлежать данное поле, для этого выберите нужные категории в списке удерживая кнопку Ctrl), тип поля (вы можете выбрать три типа поля, либо это одна строка, либо это какой то большой текст, либо это выпадающее меню со списком значений), также можете назначить значение поля по умолчанию. Если вы хотите чтобы поле являлось необязательным при вводе информации, поставьте соответствующую галочку, в противном случае новость не будет добавлена, если данное поле не введено.


Фильтр по IP, Логину или E-Mail

Навигация: Работа с админпанелью >

Фильтр по IP, Логину или E-Mail

Вы можете воспользоваться данным разделом, чтобы заблокировать определенные IP адреса, или заблокировать определенные электронные адреса, имена пользователей при регистрации. При вводе IP адреса, то доступ на сайт данному IP или подсети закрывается полностью, а не только для регистрации.

Примечание: вы можете воспользоваться в фильтре символом звездочки * для подстановки в имя пользователя, IP адрес или электронный адрес (например: 127.0.*.*, *@mail.ru, username*).


IP утилиты

Навигация: Работа с админпанелью >

IP утилиты

Данный модуль предназначен, для быстрого и удобного поиска и редактирования пользователей, использовавших для регистрации или авторизации указанный IP адрес. Допускается поиск как по полному IP адресу, так и по сокращенному. Также в данном модуле вы можете найти все IP адреса которые использовал определенный пользователь.


Управление рекламой

Навигация: Работа с админпанелью >

Управление рекламой

Данный модуль предназначен, для быстрого и удобного размещения и управления вашими рекламными материалами на сайте. Для того чтобы разместить на сайте ваш баннер, вам достаточно один раз добавить тег баннера в шаблон, после чего вы можете без проблем менять или редактировать код баннера в админпанели, не затрагивая при этом шаблоны.

После добавления своего баннера вы можете разместить его тег в шаблонах main.tpl или fullstory.tpl. Если вы добавляете баннер для показа между короткими новостями, то добавлять тег в шаблон ненужно, баннер будет добавлен между новостями автоматически.

Пример работы:

- Название: header
- Описание: Верхний баннер
- Включить показ баннера: Да
- Показывать только на главной: Нет
- Закрепить в расположении: Нет
- Расположение в коротких новостях: Нет

Если вы хотите чтобы данных баннер показывался только для определенных групп, то вы можете выбрать при добавлении баннера те группы пользователей, для которых необходимо показывать данный баннер. Также вы можете установить дополнительно время и дату начала показа баннера и время и дату окончания показа

После этого вы можете добавить в ваш шаблон в main.tpl или fullstory.tpl тег для вывода баннера: {banner_header}

Вы можете при добавлении кода баннера использовать HTML и JavaScript.


Анализ производительности

Навигация: Работа с админпанелью >

Анализ производительности

В данном разделе производится анализ всех настроек скрипта и настроек групп пользователей, и по результатам анализа выдаются рекомендации по изменению и отключению тех или иных возможностей скрипта. При этом результаты выводятся с подробными описаниями, почему нужно отключить ту или иную возможность, а также результаты выводятся в специальных графически выделенных блоках, определяющих степень нагрузки той или иной возможности. Рекомендации выделенным красным, необходимо выполнять в первую очередь, т.к. позволяют снизить существенно нагрузку на сервер. Рекомендации в желтом блоке указывают на среднюю степень нагрузки. Рекомендации, выделенные зеленым, способны лишь незначительно снизить нагрузку. Тем самым использование данного раздела рекомендуется в первую очередь, тем, кто испытывает проблемы с нагрузкой на сайт, на своем хостинге и хочет попытаться решить проблему "малой кровью", без смены тарифного плана на хостинге и перехода на более мощные ресурсы. Данный раздел будет полезен как новичкам, недавно пользующимся скриптом, так и более опытным пользователям.


Система Вопрос - Ответ

Навигация: Работа с админпанелью >

Система Вопрос - Ответ

Система «Вопрос-ответ» позволяет пресечь деятельность спам ботов при регистрации, добавлении новостей или комментариев. Для этого администратор должен задать список вопросов и ответов к ним в специальном разделе. При этом данная система может включаться отдельно для регистрации, добавления новостей, добавления комментариев. Для регистрации посетителей на сайте, система включается в настройках скрипта, а для добавления новостей и комментариев включается в настройках групп, и может включаться только для некоторых групп пользователей. Система «Вопрос-ответ» является полностью автономной и независимой от каптчи на сайте и может использоваться как совместно с каптчей, так и отдельно.

Данная система работает со следующими тегами:

Шаблонные теги [question] и [/question] выводят текст, заключенный между ними, только в том случае, если система активирована.

Тег {question} выводит вопрос для посетителя.


Перекрестные ссылки

Навигация: Работа с админпанелью >

Перекрестные ссылки

Данный модуль предназначен, для быстрого и удобного создания перелинковки по сайту по ключевым словам. В данном разделе вы задаете ключевое слово и URL, в случае нахождения данного ключевого слова на вашей странице, оно будет заменено на гипертекстовую ссылку. В отличии от модуля "фильтр слов", который также присутствует в скрипте, в данном модуле ключевые слова ищутся по всей странице, включая весь контент (новости, комментарии, шаблоны, сторонние модули и т.д.), а не только в новостях и комментариях. Также любое внесение или изменение ключевых слов в данном разделе, приводит к моментальному применению на всех страницах вашего сайта, не требуя перестроения публикаций. Также в данном модуле поддерживается указание склонения слов, например, вы можете задать ключевое слово "Иван(ов|ова|ову)" и ссылка будет применяться к словам: Иванов, Иванова, Иванову и т.д. Поиск ключевых слов осуществляется только по словам целиком, а не просто по всем вхождениям в тексте.


Система логов админпанели

Навигация: Работа с админпанелью >

Система логов админпанели

В данном разделе собираются все действия пользователей, осуществляемых в админпанели скрипта, за последние 30 дней, тем самым администратор сайта может всегда посмотреть, какие действия осуществлял тот или иной пользователь админпанели. Собираемые скриптом данные удалить в скрипте нельзя, они автоматически удаляются скриптом по истечении 30 дней, с момента их осуществления.


RSS информер

Навигация: Работа с админпанелью >

RSS информер

Данный модуль предназначен для публикации новостей ваших партнеров с других сайтов в определенном блоке на вашем сайте. Зайдя в админпанель для добавления нового информера вы задаете ему следующие параметры:

Название RSS информера - в данном поле вы указываете имя для информера имя может быть уникальным а может быть таким же как и у других информеров. В случае если имя одинаковое то информеры показываются в режиме ротации.

Описание RSS информера - краткое описание предназначенное для вас этого информера

Категория - вы можете указать категорию в которой показывать этот информер, либо сделать доступным показ во всех категориях

URL для RSS информера - здесь вы указываете путь к RSS источнику из которого будут братся новости

Шаблон для информера - укажите шаблон который будет подгружатся для показа отформатированной информации в этом блоке. Например informer.tpl

Количество новостей в блоке - укажите количество новостей которые должны показываться в данном блоке

Количество символов в заголовке - укажите максимальное количество символов в заголовке, при превышении данного лимита заголовок будет автоматически обрезаться. Вы можете установить значение 0, тогда заголовок будет импортироватся целиком

Количество символов в тексте новости- укажите максимальное количество символов в новости, при превышении данного лимита новость будет автоматически обрезаться. Вы можете установить значение 0, тогда новость будет импортироватся целиком


Используемые классы CSS

Навигация: Шаблоны >

Используемые классы CSS

DataLife Engine использует следующие классы CSS:

.calendar - Вывод таблицы календаря

.monthlink - Ссылка перехода по месяцам в календаре

.day-active-v - Класс для рабочих дней если новости есть

.day-active - Субботние и воскресные дни в которых есть новости
.day - Класс для рабочих дней если новостей нет
.weekday - Субботний и воскресный дни в которых нет новостей

.day-current - Текущая дата, или если посетитель просматривает новости за данный день

.archives - Вывод списка архивов

.xfields - Ввод дополнительный полей в добавлении новости

.rating - Вывод рейтинга

.quote - Используется для вывода цитаты или информации о скрытом тексте

.scriptcode - Используется для вывода информации, заключенной в тег [CODE]

.pm - Таблица при выводе списка полученных приватных сообщений

.pm_head - Заголовок таблицы

.pm_list - Список самих сообщений

.pm_progress_bar - Шкала заполненности ящика персональных сообщений

#dropmenudiv - Выпадающее меню при использовании быстрого или полного редактирования

#newpm, #newpmheader - Для настройки уведомления о получении нового персонального сообщения

.editor_button,

.editor_buttoncl,

.editbclose, .editor_button_brk - Стили для настройки кнопок BB редактора при быстром редактировании новостей на сайте.

.editor - общий стиль для BB редактора.

.clouds_xsmall, .clouds_small, .clouds_medium, .clouds_large, .clouds_xlarge - Для настройки размеров различных ключевых слов в облаке тегов, в зависимости от их популярности

.highslide-active-anchor, .highslide-image-blur, .highslide-html-content, .highslide-loading, a.highslide-full-expand, .highslide-display-block, .highslide-display-none - Для настройки показа всплывающего окна с оригинальным изображением из уменьшенной копии

.highslide-dimming - Используется для задания затемняющего фона при включении режима "Галереи" для показа загруженных изображений.

#loading-layer - оформление информационного окна о выполнении AJAX действия.

#searchsuggestions - оформление быстрого поиска на сайте.

.mass_comments_action - оформление меню выбора действия над комментариями на сайте.

Не забудьте использовать данные стили в вашем главном шаблоне.


Общая информация

Навигация: Шаблоны >

Общая информация

DataLife Engine позволяет использовать шаблонную систему для вывода новостей, а также для вывода различных модулей. Мы попытались максимально упростить использование шаблонов в движке, для того чтобы их использовать вам не надо обладать никакими знаниями языков программирования, только язык верстки HTML. Однако для более полного и легкого использования шаблонов мы рекомендуем вам внимательно прочитать руководство по работе с шаблонами, чтобы выяснить какие теги используются в шаблонах и для чего они предназначены.

Шаблоном в DLE является папка которая находится в свою очередь в папке /temlates/. Файлы находящиеся в папке шаблона, являются файлами одного шаблона.

Также вы можете подключать один файл шаблона в другой, используя тег {include file="my_block.tpl"} данный тег подключает указанный файл my_block.tpl в шаблон. Тег призван облегчить структуру шаблона, если используется сложная верстка со множеством тегов. Данный тег действует во всех шаблонных файлах .tpl Подключаемый файл должен находится в папке вашего шаблона или его вложенных папках, если вы хотите подключить файл шаблона, находящийся в другом шаблоне, необходимо использовать полный путь от корня где установлен скрипт, например, {include file="/templates/mytemplate/my_block.tpl"}. Также вы можете подлючать при помощи данного тега стили CSS вашего шаблона {include file="{THEME}/css/styles.css"} или JS файлы.

Теги в подключаемом шаблоне должны быть такие же, какие допустимы в шаблоне где подключается файл, например если файл my_block.tpl подключается в шаблоне main.tpl, то и теги в этом файлы будут работать только те которые возможны в main.tpl


Главная страница сайта

Навигация: Шаблоны >

Главная страница сайта

Вывод данного раздела настраивается в файле main.tpl В этом разделе настраиваются шаблоны вашей главной и основной страницы, куда подключаются другие компоненты движка. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно.

{headers} | Выводит сгенерированные метатеги о кодировке страницы, title, keywords, description. А также подключает все необходимые скрипты. Размещаеться в шаблоне между тегами <head>. Данный тег обязателен в шаблоне.
{jsfiles} | Выводит подключение всех JS скриптов, которые использует DLE в указанном месте шаблона. При помощи данного тега вы можете, например, перенести все JS скрипты в самый низ страницы, для ускорения загрузки и рендеринга ваших страниц. Данный тег является необязательным, и в случае его отсутствия в шаблоне, все скрипты будут подключены, как и ранее к тегу {headers}. Внимание, если вы переносите подключение скриптов, то должны иметь ввиду, что тег {AJAX} также должен находится ниже тега {jsfiles}, а также вы должны предусмотреть работу всех своих сторонних скриптов в шаблоне, если они используют, например, библиотеку Jquery, чтобы они не запускались раньше, чем выполнится подключение всех скриптов. Мы настоятельно не рекомендуем новичкам пользоваться данным тегом, он предназначен для опытных вебмастеров, которые имеют опыт в работе с JS скриптами.
{THEME} | Путь к выбранному шаблону
{login} | Вставка панели для входа и регистрации посетителей
{vote} | Вставка опроса на сайте
{changeskin} | Вставка формы для смены скинов на сайте
{calendar} | Вставка модуля календаря
{topnews} | Вывод самых рейтинговых статей, добавленных за последний месяц
{archives} | Вывод архивов
{info} | выводит служебную информацию движка, в случае если возникла необходимость. Присутствие тега обязательно в шаблоне.
{content} | Вывод непосредственно самого контекста на сайте, новостей, обратной связи регистрации и прочего, в общем основная колонка. Присутствие тега практически обязательно в шаблоне, за исключением крайне редких случаев, в зависимости от необходимых возможностей самого сайта.
{custom} | Смотрите раздел "Вывод новостей на страницах"
[available=раздел]текст[/available] | Смотрите раздел "Вывод новостей на страницах"
{AJAX} | Подключает все необходимы скрипты для работы DLE и AJAX, подключение обязательно, и рекомендуется размещение в начале страницы, сразу после тега <body>. Данный тег обязателен в шаблоне.
[group=X]текст[/group] | Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.
[category=X]текст[/category] | Предназначен для вывода текста если пользователь находится в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
{banner_имя} | Этот тег предназначен для вывода рекламной информации на сайте. Само имя для баннера задается в специальном модуле в админпанели.
{inform_имя} | Этот тег предназначен для вывода RSS информеров и новостей с других сайтов. Имя и все настройки для данного тега устанавливаются в админпанели скрипта.
[not-category=X]текст[/not-category] | Предназначен для вывода текста если пользователь находится везде, кроме как в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
[not-group=X]текст[/not-group] | Вывод текста любой группе пользователей, кроме указанной. Где X это список ID через запятую группы пользователей для которых непоказывать информацию.
[page-count=1,2,3] текст [/page-count] | Выводит текст заключенный в них, если пользователь находится на определенной по номеру страницы в навигации по новостям, независимо от раздела сайта, где 1,2,3 это номера страниц в навигации.
[not-page-count=1,2,3] текст [/not-page-count] | Выводит текст опубликованный в тегах на любых номерах страниц кроме указанных в теге.
[news=1,2,3] текст [/news] | Выводят заключенный в них текст, если посетитель просматривает полную новость указанных в параметре тега новостей, где 1,2,3 это ID новостей.
[not-news=1,2,3] текст [/not-news] | Выводит текст на любых других страницах кроме просмотра указанных в теге новостей.
[tags=тег1,тег2,тег3] текст [/tags] | Выводят заключенный в них текст если посетитель просматривает страницы с перечисленными ключевыми словами из облака тегов, где тег1,тег2,тег3 это ключевые слова из облака тегов.
[not-tags=тег1,тег2,тег3] текст [/not-tags] | Выводит текст на любых других страницах кроме указанных в теге.
[related-news] {related-news} [/related-news] | Выводят блок похожих новостей при просмотре полной новости.
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex
{catmenu} | Выводит меню из категорий сайта. Оформление меню осуществляется в шаблоне categorymenu.tpl
{catnewscount id="X"} | Выводит количество публикаций для указанной категории, где X это ID нужной вам категории.
{category-id} | Выводит ID просматриваемой посетителем сайта категории. Данный тег будет полезен при организации меню на сайте, а также когда нужно быстро переназначить какие-либо CSS классы или сами имена файлов шаблонов, при оформлении шаблонов вывода публикаций.
{category-title} | Выводит имя просматриваемой посетителем сайта категории. Данный тег будет полезен, когда на сайте нужно отдельно вывести имя просматриваемой категории.
{category-description} | Выводит заданное описание категории, когда пользователь просматривает данную категорию, также вывод доступен и при выводе полных публикаций.
{page-title} | Выводит указанный вами в разделе "Заголовки, описания, метатеги" заголовок для страницы
{page-description} | Выводит указанное вами в разделе "Заголовки, описания, метатеги" описание для страницы
[page-title] текст [/page-title] | Выводят текст, заключенный в них если в модуле "Заголовки, описания, метатеги" был задан заголовок для просматриваемой страницы.
[not-page-title] текст [/not-page-title] | Выводят текст, заключенный в них если заголовок для просматриваемой страницы не был задан.
[page-description] текст [/page-description] | Выводят текст, заключенный в них если в модуле "Заголовки, описания, метатеги" было задано описание для просматриваемой страницы
[not-page-description] текст [/not-page-description] | Выводят текст, заключенный в них если описание для просматриваемой страницы не было задано.
[navigation] текст [/navigation] | Выводит текст, заключённый в них если навигация по новостям имеется
[not-navigation] текст [/not-navigation] | Выводит текст, заключённый в них если навигация отсутствует
{navigation} | Выводит блок навигации по страницам
{cloudstag} | Выводит ключевое слово из облако тегов, при просмотре раздела сайта, который показывает публикации по определённому ключевому слову из облака тегов
[xfvalue_x] | Значение дополнительного поля "x", где "x" название дополнительного поля
[xfvalue_X limit="X2"] | Выводит только текст дополнительного поля без HTML форматирования, при этом сам текст сокращается до указанного X2 количества символов. При этом сокращение текста происходит до последнего логического слова. Например [xfvalue_test limit="50"] выведет только первые 50 символов значения дополнительного поля c именем test
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_X] [/xfnotgiven_X] | Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля
[ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue] | Выводят текст заключенный в них, если значение дополнительного поля совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую.
[ifxfvalue tagname!="tagvalue"] Текст [/ifxfvalue] | Выводят текст заключенный в них, если значение поля не совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую.
[xfvalue_thumb_url_X] | Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для уменьшенной копии загруженного изображения, где "х" это имя дополнительного поля
[xfvalue_image_url_X] | Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для полноразмерной картинки загруженного изображения, где "х" это имя дополнительного поля
[xfvalue_image_description_X] | Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только описание для загруженного изображения, где "х" это имя дополнительного поля.
[xfvalue_X image="Nr"] | Выводит загруженные для дополнительного поля с типом "Галерея" изображения, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи. Например, при использовании [xfvalue_test image="2"] будет выведено изображение номер два, загруженное в дополнительное поле с именем "test".
[xfvalue_X image-url="Nr"] | Выводит загруженные для дополнительного поля с типом "Галерея" URL полных изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.
[xfvalue_X image-thumb-url="Nr"] | Выводит загруженные для дополнительного поля с типом "Галерея" URL уменьшенных копий изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.
[xfvalue_X image-description="Nr"] | Выводит загруженные для дополнительного поля с типом "Галерея" описания изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.
[xfgiven_X image="NR"] текст [/xfgiven_X image="NR"] | Выводят текст заключённый в них если изображение с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения
[xfnotgiven_X image="NR"] Текст [/xfnotgiven_X image="NR"] | Выводят текст заключённый в них если изображение с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения
[xfvalue_X video="Nr"] | Выводит загруженные для дополнительного поля с типом "Видео плейлист" видео c выбранным номером по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста.
[xfvalue_X video-url="Nr"] | Выводит загруженные для дополнительного поля с типом "Видео плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста
[xfvalue_X video-description="Nr"] | Выводит загруженные для дополнительного поля с типом "Видео плейлист" описания видео, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста
[xfgiven_X video="Nr"] Текст [/xfgiven_X video="Nr"] | Выводят текст заключённый в них если видео с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер видео
[xfnotgiven_X video="Nr"] Текст [/xfnotgiven_X video="Nr"] | Выводят текст заключённый в них если видео с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер видео
[xfvalue_X audio="Nr"] | выводит загруженные для дополнительного поля с типом "Аудио плейлист" видео по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста
[xfvalue_X audio-url="Nr"] | Выводит загруженные для дополнительного поля с типом "Аудио плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста
[xfvalue_X audio-description="Nr"] | Выводит загруженные для дополнительного поля с типом "Аудио плейлист" описания аудио файла, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста
[xfgiven_X audio="Nr"] текст [/xfgiven_X audio="Nr"] | Выводят текст заключённый в них если аудио с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла
[xfnotgiven_X audio="Nr"] Текст [/xfnotgiven_X audio="Nr"] | Выводят текст заключённый в них если аудио с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла


Панель авторизации на сайте

Навигация: Шаблоны >

Панель авторизации на сайте

Вывод данного раздела настраивается в файле login.tpl В данном разделе настраивается вывод панели авторизации посетителя на сайте. Возможно использование следующих тегов:

{registration-link} | Ссылка на страницу регистрации посетителя
{lostpassword-link} | Ссылка на страницу восстановления пароля
{logout-link} | Ссылка на разлогинивание пользователя на сайте
{admin-link} | Ссылка на админпанель скрипта
{pm-link} | Ссылка на страницу персональных сообщений
{new-pm} | Количество новых персональных сообщений
{all-pm} | Общее количество персональных сообщений
{favorite-count} | Количество новостей, добавленных пользователем себе в закладки на сайте
{foto} | Ссылка на аватар пользователя.
[admin-link] и [/admin-link] | Выводит текст в тегах, если пользователь имеет доступ к админпанели скрипта
{profile-link} | Ссылка на профиль пользователя
{stats-link} | Ссылка на статистику на сайте
{addnews-link} | Ссылка на страницу добавления новости на сайте
{favorites-link} | Ссылка на просмотр закладок пользователя
{newposts-link} | Ссылка на просмотр непрочитанных новостей пользователем с последнего посещения им сайта
{group-icon} | Выводит иконку группы пользователя
{login-method} | В зависимости от установленного в настройках скрипта типа авторизации, вывод что необходимо вводить пользователю: логин или E-mail
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_x] текст [/xfnotgiven_x] | Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя
[xfvalue_x] | Выводится значение дополнительного поля "x", где "x" название дополнительного поля
{group} | Выводит название группы пользователя сайта в которой он находится в данный момент


Краткое содержание

Навигация: Шаблоны >

Краткое содержание

Вывод кратких новостей настраивается в файле shortstory.tpl и возможно использование следующих тегов:

{title}

Выводится заголовок статьи

{title limit="x"}

Выводится урезанный до X количества символов, заголовок новости.

{news-id}

ID номер новости, это номер под которым данная новость храниться в базе данных

{short-story}

Выводится краткая новость

{short-story limit="x"}

Выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов.

{author}

Автор статьи

{date}

Дата публикации, формат вывода даты настраивается в настройках системы

{rating}

Отображение рейтинга новости

[rating] текст [/rating]

Выводят заключенный в них текст, только если рейтинг для новости включен и убирают содержимое, если он был отключен при добавлении новости.

[rating-type-1] текст [/rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-3] текст [/rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[rating-type-4] текст [/rating-type-4]

Выводят текст, заключенный в теге, в случае если в настройках включено использование четвертого типа рейтинга 'Нравится' и 'Не нравится'.

[rating-minus] текст [/rating-minus]

Выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга публикации, выводится данная ссылка только если используется третий тип рейтинга.

[rating-plus] текст [/rating-plus]

Выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга публикации, выводится данная ссылка только если используется второй и третий тип рейтинга.

{likes}

Выводит количество лайков

{dislikes}

Выводит количество дизлайков

{vote-num}

Выводит количество пользователей, выставивших рейтинг для данной новости

{ratingscore}

Выводит число усредненного рейтинга от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д.

{comments-num}

Отображает количество комментариев , написанных к статье

{category}

Категория, к которой относится статья

{category-icon}

ссылка на иконку категории, внимание выводится именно путь к картинке, сам вывод вы должны предусмотреть самостоятельно например <img src="{category-icon}" />

{views}

Количество просмотров новости

{favorites}

Ссылка на добавление или удаление из Избранного

[add-favorites] текст [/add-favorites]

Выводят текст в них в виде ссылки на добавление новость в закладки на сайте

[del-favorites] текст [/del-favorites]

Выводят текст в них в виде ссылки удаление новости из закладок на сайте

[edit] текст [/edit]

Ссылка редактирование новости

{link-category}

Ссылка на все категории в которой присутствует новость

[full-link] и [/full-link]

Ссылка на полную версию, например [full-link]Подробнее…[/full-link]

[com-link] и [/com-link]

Ссылка на комментарии к статье, выводится только если они разрешены

[xfvalue_x]

Значение дополнительного поля "x", где "x" название дополнительного поля

[xfvalue_X limit="X2"]

Выводит только текст дополнительного поля без HTML форматирования, при этом сам текст сокращается до указанного X2 количества символов. При этом сокращение текста происходит до последнего логического слова. Например [xfvalue_test limit="50"] выведет только первые 50 символов значения дополнительного поля c именем test

[xfgiven_x] [xfvalue_x] [/xfgiven_x]

Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается

[xfnotgiven_X] [/xfnotgiven_X]

Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля

[ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue]

Выводят текст заключенный в них, если значение дополнительного поля совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую.

[ifxfvalue tagname!="tagvalue"] Текст [/ifxfvalue]

Выводят текст заключенный в них, если значение поля не совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую.

[xfvalue_thumb_url_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для уменьшенной копии загруженного изображения, где "х" это имя дополнительного поля

[xfvalue_image_url_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для полноразмерной картинки загруженного изображения, где "х" это имя дополнительного поля

[xfvalue_image_description_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только описание для загруженного изображения, где "х" это имя дополнительного поля.

[xfvalue_X image="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" изображения, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи. Например, при использовании [xfvalue_test image="2"] будет выведено изображение номер два, загруженное в дополнительное поле с именем "test".

[xfvalue_X image-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" URL полных изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfvalue_X image-thumb-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" URL уменьшенных копий изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfvalue_X image-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" описания изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfgiven_X image="NR"] текст [/xfgiven_X image="NR"]

Выводят текст заключённый в них если изображение с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения

[xfnotgiven_X image="NR"] Текст [/xfnotgiven_X image="NR"]

Выводят текст заключённый в них если изображение с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения

[xfvalue_X video="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" видео c выбранным номером по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста.

[xfvalue_X video-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста

[xfvalue_X video-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" описания видео, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста

[xfgiven_X video="Nr"] Текст [/xfgiven_X video="Nr"]

Выводят текст заключённый в них если видео с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер видео

[xfnotgiven_X video="Nr"] Текст [/xfnotgiven_X video="Nr"]

Выводят текст заключённый в них если видео с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер видео

[xfvalue_X audio="Nr"]

выводит загруженные для дополнительного поля с типом "Аудио плейлист" видео по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfvalue_X audio-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Аудио плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfvalue_X audio-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Аудио плейлист" описания аудио файла, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfgiven_X audio="Nr"] текст [/xfgiven_X audio="Nr"]

Выводят текст заключённый в них если аудио с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла

[xfnotgiven_X audio="Nr"] Текст [/xfnotgiven_X audio="Nr"]

Выводят текст заключённый в них если аудио с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла

[xfvalue_X format="Формат"]

Предназначено для вывода дополнительных полей с типом “Дата и время” где X это имя дополнительного поля, а “Формат” это формат вывода заданной в поле даты и времени. Вы можете выводить данное дополнительное поле в разных форматах даты и времени, а не только в том формате, которое указано для поля по умолчанию в настройках поля. Например тег [xfvalue_test format="j F Y H:i"] выведет дату и время указанное в поле в формате времени j F Y H:i.

[group=X]текст[/group]

Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.

[category=X]текст[/category]

Предназначен для вывода текста если пользователь находится в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую

[has-category] текст [/has-category]

Выводят текст, заключённых в них, если публикация находится в какой-либо категории

[not-has-category] текст [/not-has-category]

Выводят текст, заключённых в них, если у публикации нет никаких категорий.

[category-icon] текст [/category-icon]

Выводят текст, заключенный в них, если для категории, где находится публикация, была задана иконка в настройках категории

[not-category-icon] текст [/not-category-icon]

Выводят текст если для категории, где находится публикация, не задана иконка

[tags] текст [/tags]

Выводит текст если новость содержит ключевые слова, назначенные для облака тегов

{tags}

Выводит кликабельные ключевые слова новости

{full-link}

Для вывода полного постоянного адреса новости

[edit-date] текст [/edit-date]

Выводит текст если новость была отредактирована

{edit-date}

Выводит дату редактирования новости

{edit-date=формат даты}

Выводит дату редактирования публикации в заданном в теге формате. Тем самым вы можете задавать свой собственный формат для даты редактирования, или выводить не только дату целиком, но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {edit-date=d} выведет день месяца, а тег {edit-date=F} выведет название месяца, а тег {edit-date=d-m-Y H:i} выведет полную дату и время

{editor}

Выводит логин пользователя, отредактировавшего новость

[edit-reason] текст [/edit-reason]

Выводит текст если при редактировании была указана причина редактирования

{edit-reason}

Выводит причину редактирования новости

{date=формат даты}

Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{approve}

Выводится только при просмотре пользователем собственного профиля и показывает статус его новостей ожидающих модерации

[fixed] текст [/fixed]

Выводит текст в тегах если данная новость зафиксирована

[not-fixed] текст [/not-fixed]

Выводит текст в тегах если данная новость не была зафиксирована

[day-news] текст [/day-news]

Выводит ссылку на все новости, опубликованные в тот же день что и данная новость. Данный тег например можно использовать совместно с тегом {date}

[catlist=1,2....] текст [/catlist]

Выводит текст в теге, если новость принадлежит указанным категориям

[not-catlist=1,2....] текст [/not-catlist]

Выводит текст в теге, если новость не принадлежит указанным категориям.

{login}

Выводит логин пользователя добавившего новость в виде обычной текстовой информации без ссылок на профиль и карточку пользователя.

[poll] текст [/poll]

Выводят текст в данных тегах, если для данной публикации задан опрос.

{poll}

Выводит опрос, добавленный к новости

[not-poll] текст [/not-poll]

Выводят текст в данных тегах, если для данной публикации не был задан опрос.

[profile] текст [/profile]

Выводят прямую ссылку на профиль автора публикации, без использования всплывающего окна минипрофиля.

[complaint]

текст

[/complaint]

Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на новость.

{category-url}

Выводит полный URL на категорию, которой принадлежит данная новость. Данный тег выводит только URL в чистом виде без форматирования или готовой ссылки.

[comments]

текст

[/comments]

Выводят текст, заключенный в них, если у данной публикации присутствуют комментарии на сайте.

[not-comments]

текст

[/not-comments]

Выводят текст, заключенный в них, если у данной публикации отсутствуют комментарии на сайте.

{image-x}

Выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x]

Выводят текст указанный в них только в случае если картинка с номером X присутствует в новости

[not-image-x] текст [/not-image-x]

Выводят текст, указанный в них только в случае если картинка с номером X отсутствует в новости.

[tags=тег1,тег2,тег3] текст [/tags]

Выводят заключенный в них текст если посетитель просматривает страницы с перечисленными ключевыми словами из облака тегов, где тег1,тег2,тег3 это ключевые слова из облака тегов.

[not-tags=тег1,тег2,тег3] текст [/not-tags]

Выводит текст на любых других страницах кроме указанных в теге.

[declination=X] текст [/declination]

Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "комментарий", "комментария", "комментариев"

[newscount=x] текст [/newscount]

Выводит текст указанный в тегах если показывается X новость, где X это число показываемой на странице новости. Например [newscount=1] текст [/newscount] покажет текст при показе первой по счету на странице новости.

[not-newscount=X] текст [/not-newscount]

Выводят текст заключенный в данные теги при показе любых по счету новостей, кроме указанных X новостей. Данный тег будет полезен, если вы хотите выводить какие-либо элементы оформления во всех новостях при показе кратких новостей, кроме вышеуказанных. Например, что-либо не показывать в первой по списку новости.

{banner_x}

Выводит баннер добавленный в админпанели в разделе управления рекламными материалами. Где Х это имя баннера.

[not-news] текст [/not-news]

Выводят заключенный текст в них, в случае если публикации по данным критериям отсутствуют. Тем самым вы можете переназначить стандартное системное сообщение об отсутствии публикаций в каком-либо отдельном разделе сайта, сделав его уникальным, например, для каждого раздела сайта.

[if field = "значение"] текст [/if]

Выводят текст заключённых в них если значения поля равно указанному значению.

[if field = "значение"] текст [/if] - выведет текст если поле равно параметру 'значение'

[if field != "значение"]текст[/if] - выведет текст если поле не равно параметру 'значение'

[if field > "1"] текст [/if] - выведет текст если поле больше параметра 'значение'

[if field >= "2"] текст [/if] - выведет текст если поле больше либо равно параметру 'значение'

[if field < "3"] текст [/if] - выведет текст если поле меньше параметра 'значение'

[if field <= "4"] текст [/if] - выведет текст если поле меньше либо равно параметру 'значение'

[if field ~ "значение"] текст [/if] - выведет текст если в поле встречается текст 'значение'

[if field !~ "значение"] текст [/if] - выведет текст если в поле НЕ встречается текст 'значение'

Комбинированное использование:

[if field > "3" AND field2 < "5"] текст [/if] выведет текст если поле field больше трех, и при этом field2 меньше 5

[if field > "3" OR field2 < "5"] текст [/if] выведет текст если поле field больше трех или field2 меньше 5, то есть совпадение какого либо либого из условий

Имена полей, которое может принимать field:

id - Уникальный ID номер новости (число)

autor - Логин автора новости (текст)

date - Дата новости (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата новости округляется до минуты)

short_story - Текст короткой новости (текст)

full_story - В шаблоне короткой новости это количество символов в полном описании. В шаблоне полной новости непосредственно полный текст.

title - Текст заголовка новости (текст)

descr - Метатег описания новости (текст)

keywords - Метатег "ключевые слова" (текст)

category - Список категорий в которым принадлежит (массив, проверка по массиву ID категорий, которой принадлежит новость)

alt_name - Заголовок на латинице, для формирования адреса страницы при использовании ЧПУ. (текст)

comm_num - Количество комментариев (число)

allow_comm - Разрешены или нет комментарии (число, 1 или 0)

allow_main - Опубликована или нет новость на главной (число, 1 или 0)

approve - Новость опубликована на сайте или на модерации (число, 1 или 0)

fixed - Новость зафиксирована или нет (число, 1 или 0)

symbol - Символьный код (текст)

tags - Список тегов из списка тегов для облака тегов (массив, проверка по массиву слов из облака тегов)

news_read - Количество просмотров (число)

allow_rate - Разрешен рейтинг для новости или нет (число, 1 или 0)

rating - Рейтинг новости, общая сумма всех значений (число)

vote_num - Количество проголосовавших в рейтинге (число)

votes - Есть ли опрос в новости (число, 1 или 0)

view_edit - Отображать или нет причину редактирования (число, 1 или 0)

disable_index - Запрещена или нет индексация в поисковиках (число, 1 или 0)

editdate - Дата редактирования новости (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

editor - Логин последнего редактора публикации (текст)

reason - Причина редактирования новости (текст)

user_id - ID автора публикации (число)

xfield_x - Значение дополнительного поля публикации, где x это имя дополнительного поля. Например xfield_test значение дополнительного поля test

Список доступных тегов в случае включения вывода полной информации из профиля пользователя:

{profile-link}

Выводит ссылку на профиль автора публикации

{foto}

Выводит ссылку на аватар автора публикации

{fullname}

Выводит полное имя автора публикации

[fullname] текст [/fullname]

Выводит текст заключенный в теги в случае если полное имя указано в профиле автора

[not-fullname] текст [/not-fullname]

Выводит текст заключенный в теги в случае если полное имя не было указано в профиле автора

{land}

Выводит страну автора

[land] текст [/land]

Выводит текст заключенный в теги в случае если страна указана в профиле автора

[not-land] текст [/not-land]

Выводит текст заключенный в теги в случае если страна не была указана в профиле автора

{signature}

Выводит подпись автора

[signature] текст [/signature]

Выводит текст заключенный в теги в случае если подпись указана в профиле автора

[not-signature] текст [/not-signature]

Выводит текст заключенный в теги в случае если подпись не была указана в профиле автора

{user-info}

Выводит информацию о себе автора публикации

[user-info] текст [/user-info]

Выводит текст заключенный в теги в случае если информация о себе указана в профиле автора

[not-user-info] текст [/not-user-info]

Выводит текст заключенный в теги в случае если информация о себе не была указана в профиле автора

[online] текст [/online]

Выводит текст заключенный в теги в случае если автор публикации онлайн на сайте

[offline] текст [/offline]

Выводит текст заключенный в теги в случае если автор публикации оффлайн на сайте

{mail}

Выводит E-mail адрес пользователя

[pm] Текст [/pm]

Выводит ссылку с содержанием "Текст" на написание персонального сообшения автору публикации

{group}

Выводит группу пользователя

{registration}

Выводит дату регистрации пользователя

{lastdate}

Выводит дату последнего посещения пользователя

{group-icon}

Выводит иконку группы пользователя

{time_limit}

Выводит дату до которой пользователь находится в группе, если группа является временной

[time_limit] текст [/time_limit]

Выводит текст заключенный в теги в случае если пользователь находится во временной группе

{comm-num}

Выводит количество комментариев пользователя

{comments-url}

Выводит адрес ссылки на комментарии пользователя

[comm-num] текст [/comm-num]

Выводит текст заключенный в теги если пользователь имеет комментарии на сайте

[not-comm-num] текст [/not-comm-num]

Выводит текст заключенный в теги если пользователь не имеет комментариев на сайте

{news}

Выводит адрес ссылки на новости пользователя

{rss}

Выводит адрес ссылки на RSS новостей пользователя

{news-num}

Выводит количество новостей пользователя

[news-num] текст [/news-num]

Выводит текст заключенный в теги если пользователь имеет новости на сайте

[not-news-num] текст [/not-news-num]

Выводит текст заключенный в теги если пользователь не имеет новостей на сайте

{all-pm}

Выводит общее количество персональных сообщений пользователя

{favorite-count}

Выводит общее количество публикаций в закладках пользователя

[profile_xfvalue_X

Выводит значение дополнительного поля с именем "X" из его профиля

[profile_xfgiven_X] текст [/profile_xfgiven_X]

Выводит текст заключенный в теги если дополнительное поле с именем "X" указано в его профиле

[profile_xfnotgiven_X] текст [/profile_xfnotgiven_X]

Выводит текст заключенный в теги если дополнительное поле с именем "X" не указано в его профиле

[author-group=X] текст [/author-group]

Выводит текст заключенный в теги автор публикации находится в указанной группе "X" пользователей. Допускается перечесление групп через запятую, например: 1,2,3

[not-author-group=X] текст [/not-author-group]

Выводит текст заключенный в теги автор публикации не находится в указанной группе "X" пользователей. Допускается перечесление групп через запятую, например: 1,2,3


Статья целиком

Навигация: Шаблоны >

Статья целиком

Вывод статьи целиком настраивается в файле fullstory.tpl и возможно использование следующих тегов:

{title}

Заголовок статьи

{title limit="x"}

Выводится урезанный до X количества символов, заголовок новости.

{full-story}

Полная версия

{short-story}

Краткая версия новости

{full-story limit="x"}

Выводит только текст полной новости без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов

{author}

Автор статьи

{date}

Дата публикации

{pages}

Навигация по страницам новости

[pages] текст [/pages]

Выводят указанный текст в тегах, если новость разбита на несколько страниц при помощи тега {PАGEBREAK} и убирает текст в нем, если новость состоит из одной страницы.

{link-category}

Ссылка на все категрии в которой присутствует новость

{rating}

Выводится рейтинг публикации

[rating] текст [/rating]

Выводят заключенный в них текст, только если рейтинг для новости включен и убирают содержимое, если он был отключен при добавлении новости.

[rating-type-1] текст [/rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-3] текст [/rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[rating-type-4] текст [/rating-type-4]

Выводят текст, заключенный в теге, в случае если в настройках включено использование четвертого типа рейтинга 'Нравится' и 'Не нравится'.

[rating-minus] текст [/rating-minus]

Выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга публикации, выводится данная ссылка только если используется третий тип рейтинга.

[rating-plus] текст [/rating-plus]

Выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга публикации, выводится данная ссылка только если используется второй и третий тип рейтинга.

{likes}

Выводит количество лайков

{dislikes}

Выводит количество дизлайков

{vote-num}

Выводит количество пользователей, выставивших рейтинг для данной новости

{ratingscore}

Выводит число усредненного рейтинга от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д.

{comments-num}

Позволяет отображать количество комментариев к статье

{category}

Категория, к которой относится статья

{category-url}

Выводит полный URL на категорию, которой принадлежит данная новость. Данный тег выводит только URL в чистом виде без форматирования или готовой ссылки.

{category-icon}

Ссылка на иконку категории

[category-icon] текст [/category-icon]

Выводят текст, заключенный в них, если для категории, где находится публикация, была задана иконка в настройках категории

[not-category-icon] текст [/not-category-icon]

Выводят текст если для категории, где находится публикация, не задана иконка

[has-category] текст [/has-category]

Выводят текст, заключённых в них, если публикация находится в какой-либо категории

[not-has-category] текст [/not-has-category]

Выводят текст, заключённых в них, если у публикации нет никаких категорий.

{views}

Количество просмотров новости

{favorites}

Ссылка на добавление или удаление из Избранного

[add-favorites] текст [/add-favorites]

Выводят текст в них в виде ссылки на добавление новость в закладки на сайте

[del-favorites] текст [/del-favorites]

Выводят текст в них в виде ссылки удаление новости из закладок на сайте

[edit] текст [/edit]

Ссылка на редактирование новости

[print-link] и [/print-link]

Ссылка на версию для печати

[com-link] и [/com-link]

Ссылка на комментарии к статье только если они разрешены

[xfvalue_x]

Значение дополнительного поля "x", где "x" название дополнительного поля

[xfvalue_X limit="X2"]

Выводит только текст дополнительного поля без HTML форматирования, при этом сам текст сокращается до указанного X2 количества символов. При этом сокращение текста происходит до последнего логического слова. Например [xfvalue_test limit="50"] выведет только первые 50 символов значения дополнительного поля c именем test

[xfgiven_x] [xfvalue_x] [/xfgiven_x]

Выводится дополнительное поле "x", если поле не пустое

[xfnotgiven_X] [/xfnotgiven_X]

Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля

[ifxfvalue tagname="tagvalue"] Текст [/ifxfvalue]

Выводят текст заключенный в них, если значение дополнительного поля совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую.

[ifxfvalue tagname!="tagvalue"] Текст [/ifxfvalue]

Выводят текст заключенный в них, если значение поля не совпадает с указанным. Где tagname это имя дополнительного поля, а tagvalue это его значение. Значения tagvalue можно перечислять через запятую.

[xfvalue_thumb_url_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для уменьшенной копии загруженного изображения, где "х" это имя дополнительного поля

[xfvalue_image_url_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только URL для полноразмерной картинки загруженного изображения, где "х" это имя дополнительного поля

[xfvalue_image_description_X]

Данный тег может использоваться только если дополнительное поле имеет тип "Изображение". Тег выводит только описание для загруженного изображения, где "х" это имя дополнительного поля.

[xfvalue_X image="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" изображения, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи. Например, при использовании [xfvalue_test image="2"] будет выведено изображение номер два, загруженное в дополнительное поле с именем "test".

[xfvalue_X image-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" URL полных изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfvalue_X image-thumb-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" URL уменьшенных копий изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfvalue_X image-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Галерея" описания изображений, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер изображения из галереи.

[xfgiven_X image="NR"] текст [/xfgiven_X image="NR"]

Выводят текст заключённый в них если изображение с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения

[xfnotgiven_X image="NR"] Текст [/xfnotgiven_X image="NR"]

Выводят текст заключённый в них если изображение с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер изображения

[xfvalue_X video="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" видео c выбранным номером по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста.

[xfvalue_X video-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста

[xfvalue_X video-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Видео плейлист" описания видео, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер видео из плейлиста

[xfgiven_X video="Nr"] Текст [/xfgiven_X video="Nr"]

Выводят текст заключённый в них если видео с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер видео

[xfnotgiven_X video="Nr"] Текст [/xfnotgiven_X video="Nr"]

Выводят текст заключённый в них если видео с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а NR это номер видео

[xfvalue_X audio="Nr"]

выводит загруженные для дополнительного поля с типом "Аудио плейлист" видео по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfvalue_X audio-url="Nr"]

Выводит загруженные для дополнительного поля с типом "Аудио плейлист" URL загруженного, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfvalue_X audio-description="Nr"]

Выводит загруженные для дополнительного поля с типом "Аудио плейлист" описания аудио файла, по отдельности. Где "X" это имя дополнительного поля, а "Nr" это номер аудио файла из плейлиста

[xfgiven_X audio="Nr"] текст [/xfgiven_X audio="Nr"]

Выводят текст заключённый в них если аудио с указанным номером присутствует и загружено в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла

[xfnotgiven_X audio="Nr"] Текст [/xfnotgiven_X audio="Nr"]

Выводят текст заключённый в них если аудио с указанным номером отсутствует в дополнительном поле, где X это имя дополнительного поля, а Nr это номер аудио файла

[xfvalue_X format="Формат"]

Предназначено для вывода дополнительных полей с типом “Дата и время” где X это имя дополнительного поля, а “Формат” это формат вывода заданной в поле даты и времени. Вы можете выводить данное дополнительное поле в разных форматах даты и времени, а не только в том формате, которое указано для поля по умолчанию в настройках поля. Например тег [xfvalue_test format="j F Y H:i"] выведет дату и время указанное в поле в формате времени j F Y H:i.

[group=X]текст[/group]

Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.

{related-news}

Выводить ссылки на 5 наиболее подходящих по контексту новостей.

[catlist=1,2....] текст [/catlist]

Выводит текст в теге, если новость принадлежит указанным категориям

[not-catlist=1,2....] текст [/not-catlist]

Выводит текст в теге, если новость не принадлежит указанным категориям.

[tags] текст [/tags]

Выводит текст если новость содержит ключевые слова, назначенные для облака тегов

{tags}

Выводит кликабельные ключевые слова новости

{full-link}

Для вывода полного постоянного адреса новости

[edit-date] текст [/edit-date]

Выводит текст если новость была отредактирована

{edit-date}

Выводит дату редактирования новости

{edit-date=формат даты}

Выводит дату редактирования публикации в заданном в теге формате. Тем самым вы можете задавать свой собственный формат для даты редактирования, или выводить не только дату целиком, но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {edit-date=d} выведет день месяца, а тег {edit-date=F} выведет название месяца, а тег {edit-date=d-m-Y H:i} выведет полную дату и время

{editor}

Выводит логин пользователя, отредактировавшего новость

[edit-reason] текст [/edit-reason]

Выводит текст если при редактировании была указана причина редактирования

{edit-reason}

Выводит причину редактирования новости

{poll}

Подключает шаблон с опросом для новости, если опрос был добавлен к новости.

{date=формат даты}

выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

[fixed] текст [/fixed]

Выводит текст в тегах если данная новость зафиксирована

[not-fixed] текст [/not-fixed]

Выводит текст в тегах если данная новость не была зафиксирована

[day-news] текст [/day-news]

Выводит ссылку на все новости, опубликованные в тот же день что и данная новость. Данный тег например можно использовать совместно с тегом {date}

{comments}

Выводит комментарии, написанные к данной новости. Данный тег будет полезен тем, кому необходимо разместить комментарии, например общем дизайне полной новости. Данный тег не является обязательным, в случае его отсутствия комментарии будут автоматически расположены скриптом ниже полной новости

{addcomments}

Выводит форму добавления комментариев на сайт, совместно с новым тегом {comments} вы можете размещать форму добавления комментариев как выше, так и ниже самих комментариев. Данный тег также не является обязательным, в случае его отсутствия форма будет автоматически расположена скриптом ниже полной новости

{navigation}

Выводит навигацию по комментариям, если комментарии расположены на нескольких страницах, совместно с новым тегом {comments} вы можете располагать навигацию по комментариям как выше, так и ниже самих комментариев. Данный тег также не является обязательным, в случае его отсутствия навигация будет автоматически расположена скриптом ниже полной новости

{login}

Выводит логин пользователя добавившего новость в виде обычной текстовой информации без ссылок на профиль и карточку пользователя.

{related-ids}

Выводит список ID похожих публикаций для данной новости. Данный тег полезен при совместном использовании с тегом {custom ...}, например тег {custom id="{related-ids}"}

[related-news]

текст

[/related-news]

Выводят информацию, заключенную в тегах, только если для данной новости присутствуют похожие новости, в противном случае информация удаляется из шаблона.

[poll] текст [/poll]

Выводят текст в данных тегах, если для данной публикации задан опрос.

[not-poll] текст [/not-poll]

Выводят текст в данных тегах, если для данной публикации не был задан опрос.

[profile] текст [/profile]

Выводят прямую ссылку на профиль автора публикации, без использования всплывающего окна минипрофиля.

[complaint]

текст

[/complaint]

Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на новость.

{custom}

Смотрите раздел "Вывод новостей на страницах"

[comments]

текст

[/comments]

Выводят текст, заключенный в них, если у данной публикации присутствуют комментарии на сайте.

[not-comments]

текст

[/not-comments]

Выводят текст, заключенный в них, если у данной публикации отсутствуют комментарии на сайте

{image-x}

Выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x]

Выводят текст указанный в них только в случае если картинка с номером X присутствует в новости

[not-image-x] текст [/not-image-x]

Выводят текст, указанный в них только в случае если картинка с номером X отсутствует в новости.

{fullimage-x}

Выводит URL картинки, находящийся в тексте полной новости, где "x" это номер картинки в новости

[fullimage-x] текст [/fullimage-x]

Выводят указанный в них текст, только если картинка с номером "x" присутствует в полной новости.

[news=1,2,3] текст [/news]

Выводят заключенный в них текст, если посетитель просматривает полную новость указанных в параметре тега новостей, где 1,2,3 это ID новостей.

[not-news=1,2,3] текст [/not-news]

Выводит текст на любых других страницах кроме просмотра указанных в теге новостей.

[declination=X] текст [/declination]

Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "комментарий", "комментария", "комментариев"

{banner_x}

Выводит баннер добавленный в админпанели в разделе управления рекламными материалами. Где Х это имя баннера.

[vk] текст [/vk]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте

{vk_url}

Выводит ссылку URL на авторизацию в соц. сети Вконтакте

[odnoklassniki] текст [/odnoklassniki]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники

{odnoklassniki_url}

Выводит ссылку URL на авторизацию в соц. сети Одноклассники

[facebook] текст [/facebook]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook

{facebook_url}

Выводит ссылку URL на авторизацию в соц. сети Facebook

[google] текст [/google]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google

{google_url}

Выводит ссылку URL на авторизацию в соц. сети Google

[mailru] текст [/mailru]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru

{mailru_url}

Выводит ссылку URL на авторизацию в соц. сети Mail.ru

[yandex] текст [/yandex]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex

{yandex_url}

Выводит ссылку URL на авторизацию в соц. сети Yandex

[comments-subscribe]

текст

[/comments-subscribe]

Выводят текст, заключенный в них в виде ссылки на подписку на уведомления о новых комментариях.

[next-url] Текст [/next-url]

Выводят текст заключенных в них, если следующая новость присутствует на сайте

{next-url}

Выводит URL следующей публикации

{next-title}

Выводит заголовок следующей публикации

[prev-url] Текст [/prev-url]

Выводят текст заключенных в них, если предыдущая новость присутствует на сайте

{prev-url}

Выводит URL предыдущей публикации

{prev-title}

Выводит заголовок предыдущей новости

[if field = "значение"] текст [/if]

Выводят текст заключённых в них если значения поля равно указанному значению.

[if field = "значение"] текст [/if] - выведет текст если поле равно параметру 'значение'

[if field != "значение"]текст[/if] - выведет текст если поле не равно параметру 'значение'

[if field > "1"] текст [/if] - выведет текст если поле больше параметра 'значение'

[if field >= "2"] текст [/if] - выведет текст если поле больше либо равно параметру 'значение'

[if field < "3"] текст [/if] - выведет текст если поле меньше параметра 'значение'

[if field <= "4"] текст [/if] - выведет текст если поле меньше либо равно параметру 'значение'

[if field ~ "значение"] текст [/if] - выведет текст если в поле встречается текст 'значение'

[if field !~ "значение"] текст [/if] - выведет текст если в поле НЕ встречается текст 'значение'

Комбинированное использование:

[if field > "3" AND field2 < "5"] текст [/if] выведет текст если поле field больше трех, и при этом field2 меньше 5

[if field > "3" OR field2 < "5"] текст [/if] выведет текст если поле field больше трех или field2 меньше 5, то есть совпадение какого либо либого из условий

Имена полей, которое может принимать field:

id - Уникальный ID номер новости (число)

autor - Логин автора новости (текст)

date - Дата новости (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата новости округляется до минуты)

short_story - Текст короткой новости (текст)

full_story - В шаблоне короткой новости это количество символов в полном описании. В шаблоне полной новости непосредственно полный текст.

title - Текст заголовка новости (текст)

descr - Метатег описания новости (текст)

keywords - Метатег "ключевые слова" (текст)

category - Список категорий в которым принадлежит (массив, проверка по массиву ID категорий, которой принадлежит новость)

alt_name - Заголовок на латинице, для формирования адреса страницы при использовании ЧПУ. (текст)

comm_num - Количество комментариев (число)

allow_comm - Разрешены или нет комментарии (число, 1 или 0)

allow_main - Опубликована или нет новость на главной (число, 1 или 0)

approve - Новость опубликована на сайте или на модерации (число, 1 или 0)

fixed - Новость зафиксирована или нет (число, 1 или 0)

symbol - Символьный код (текст)

tags - Список тегов из списка тегов для облака тегов (массив, проверка по массиву слов из облака тегов)

news_read - Количество просмотров (число)

allow_rate - Разрешен рейтинг для новости или нет (число, 1 или 0)

rating - Рейтинг новости, общая сумма всех значений (число)

vote_num - Количество проголосовавших в рейтинге (число)

votes - Есть ли опрос в новости (число, 1 или 0)

view_edit - Отображать или нет причину редактирования (число, 1 или 0)

disable_index - Запрещена или нет индексация в поисковиках (число, 1 или 0)

editdate - Дата редактирования новости (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

editor - Логин последнего редактора публикации (текст)

reason - Причина редактирования новости (текст)

user_id - ID автора публикации (число)

xfield_x - Значение дополнительного поля публикации, где x это имя дополнительного поля. Например xfield_test значение дополнительного поля test

Список доступных тегов в случае включения вывода полной информации из профиля пользователя:

{profile-link}

Выводит ссылку на профиль автора публикации

{foto}

Выводит ссылку на аватар автора публикации

{fullname}

Выводит полное имя автора публикации

[fullname] текст [/fullname]

Выводит текст заключенный в теги в случае если полное имя указано в профиле автора

[not-fullname] текст [/not-fullname]

Выводит текст заключенный в теги в случае если полное имя не было указано в профиле автора

{land}

Выводит страну автора

[land] текст [/land]

Выводит текст заключенный в теги в случае если страна указана в профиле автора

[not-land] текст [/not-land]

Выводит текст заключенный в теги в случае если страна не была указана в профиле автора

{signature}

Выводит подпись автора

[signature] текст [/signature]

Выводит текст заключенный в теги в случае если подпись указана в профиле автора

[not-signature] текст [/not-signature]

Выводит текст заключенный в теги в случае если подпись не была указана в профиле автора

{user-info}

Выводит информацию о себе автора публикации

[user-info] текст [/user-info]

Выводит текст заключенный в теги в случае если информация о себе указана в профиле автора

[not-user-info] текст [/not-user-info]

Выводит текст заключенный в теги в случае если информация о себе не была указана в профиле автора

[online] текст [/online]

Выводит текст заключенный в теги в случае если автор публикации онлайн на сайте

[offline] текст [/offline]

Выводит текст заключенный в теги в случае если автор публикации оффлайн на сайте

{mail}

Выводит E-mail адрес пользователя

[pm] Текст [/pm]

Выводит ссылку с содержанием "Текст" на написание персонального сообшения автору публикации

{group}

Выводит группу пользователя

{registration}

Выводит дату регистрации пользователя

{lastdate}

Выводит дату последнего посещения пользователя

{group-icon}

Выводит иконку группы пользователя

{time_limit}

Выводит дату до которой пользователь находится в группе, если группа является временной

[time_limit] текст [/time_limit]

Выводит текст заключенный в теги в случае если пользователь находится во временной группе

{comm-num}

Выводит количество комментариев пользователя

{comments-url}

Выводит адрес ссылки на комментарии пользователя

[comm-num] текст [/comm-num]

Выводит текст заключенный в теги если пользователь имеет комментарии на сайте

[not-comm-num] текст [/not-comm-num]

Выводит текст заключенный в теги если пользователь не имеет комментариев на сайте

{news}

Выводит адрес ссылки на новости пользователя

{rss}

Выводит адрес ссылки на RSS новостей пользователя

{news-num}

Выводит количество новостей пользователя

[news-num] текст [/news-num]

Выводит текст заключенный в теги если пользователь имеет новости на сайте

[not-news-num] текст [/not-news-num]

Выводит текст заключенный в теги если пользователь не имеет новостей на сайте

{all-pm}

Выводит общее количество персональных сообщений пользователя

{favorite-count}

Выводит общее количество публикаций в закладках пользователя

[profile_xfvalue_X]

Выводит значение дополнительного поля с именем "X" из его профиля

[profile_xfgiven_X] текст [/profile_xfgiven_X]

Выводит текст заключенный в теги если дополнительное поле с именем "X" указано в его профиле

[profile_xfnotgiven_X] текст [/profile_xfnotgiven_X]

Выводит текст заключенный в теги если дополнительное поле с именем "X" не указано в его профиле

[author-group=X] текст [/author-group]

Выводит текст заключенный в теги если автор публикации находится в указанной группе "X" пользователей. Допускается перечисление групп через запятую, например: 1,2,3

[not-author-group=X] текст [/not-author-group]

Выводят текст заключенный в теги если автор публикации не находится в указанной группе "X" пользователей. Допускается перечисление групп через запятую, например: 1,2,3

[allow-comments-subscribe] текст [/allow-comments-subscribe]

Выводят текст заключённый в них, в случае если пользователю разрешено подписываться на комментарии. Тем самым вы можете сделать оформление ссылки на подписку на комментарии в нужном вам блоке и скрывать его если подписка запрещена.

[comments-unsubscribe] текст [/comments-unsubscribe]

Выводят текст заключенный в них в виде ссылки на отписку от комментариев к данной публикации. Тем самым пользователи могут отписаться только от одной конкретной новости на сайте, ранее для этого им нужно было отписываться от всех публикаций.


Комментарии

Навигация: Шаблоны >

Комментарии

Вывод данного раздела настраивается в файле comments.tpl В данном разделе настраивается вывод комментариев для статьи.

{author}

Имя человека, оставившего комментарий

{mail}

е-mail человека, оставившего комментарий

{date}

Дата публикации комментария, формат вывода даты настраивается в настройках системы

{comment}

Текст комментария

{comment limit="X"}

Выводит текст комментария без HTML форматирования, при этом сам текст комментария сокращается до указанного "x" количества символов.

{comment-id}

Идентификационный номер комментария

{ip}

IP адрес человека, оставившего комментарий, просмотр доступен только администраторам сайта

[com-edit] и [/com-edit]

Ссылка на редактирование комментария только если это разрешено

[com-del] и [/com-del]

Ссылка на удаление комментария только если это разрешено

{news_title}

Выводит ссылку на новость при просмотре последних комментариев, при выводе комментариев в новости тег вырезается

{news-title}

Выводит HTML безопасный заголовок новости, которой принадлежит данный комментарий, при просмотре последних комментариев. При выводе комментариев в новости тег вырезается. Данный тег будет полезен при использовании пользовательского вывода комментариев и при показе последних комментариев.

{news-link}

Выводит URL новости, которой принадлежит данный комментарий, при просмотре последних комментариев. При выводе комментариев в новости тег вырезается. Данный тег будет полезен при использовании пользовательского вывода комментариев и при показе последних комментариев.

[images] текст [/images]

Выводят заключенный в них текст, в случае если к комментарию были загружены изображения

{images}

Выводит все загруженные для комментария изображения в виде галереи изображений

{foto}

Выводит ссылку на фотографию

{fullname}

Выводит полное имя пользователя

{land}

Выводит место жительства

[signature] и [/signature]

Выводит текст заключенный в теги, если пользователь задал подпись в профиле

{signature}

Выводит подпись пользователя

{registration}

Выводит дату регистрации на сайте

{lastdate}

Выводит дату последнего посещения сайта пользователя.

{lastdate=формат даты}

Выводит последнего посещения сайта пользователем в заданном в теге формате. Например тег {lastdate=d} выведет день месяца, а тег {lastdate=F} выведет название месяца, а тег {lastdate=d-m-Y H:i} выведет полную дату и время.

{registration=формат даты}

Выводит дату регистрации пользователя в заданном в теге формате. Например тег {registration=d} выведет день месяца, а тег {registration=F} выведет название месяца, а тег {registration=d-m-Y H:i} выведет полную дату и время.

[fast] [/fast]

Быстрое цитирование комментариев

{group-icon}

Выводит иконку группы участника

{group-name}

Выводит имя группы участника

{news-num}

Выводит количество новостей участника

{comm-num}

Выводит количество комментариев участника

{date=формат даты}

Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{login}

Выводит логин автора комментария без каких либо ссылок и меню

[profile] текст [/profile]

Выводит текст заключенный в теге в виде ссылки на профиль пользователя оставившего комментарий

{mass-action}

Устанавливает возможность массовой отметки комментариев для выполнения массовых действий на сайте

[complaint]

текст

[/complaint]

Выводят текст, указанных в тегах в виде ссылки на написание жалобы, на комментарий.

[xfgiven_x]

[xfvalue_x]

[/xfgiven_x]

Выводится дополнительное поле "x", если поле не пустое

[xfnotgiven_x]

текст

[/xfnotgiven_x]

Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя

[xfvalue_x]

Значение дополнительного поля "x", где "x" название дополнительного поля

[fullname]

текст [/fullname]

Выводится текст заключенный в них только если полное имя пользователя задано

[not-fullname]

текст [/not-fullname]

Выводится текст, заданный в них только если полное имя пользователя не задано

[land] текст [/land]

Выводится текст заключенный в них только если местожительство пользователя было им задано

[not-land] текст [/not-land]

Выводится текст, заданный в них только если местожительство пользователя не было им указано

[news-num]

текст

[/news-num]

Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте

[not-news-num]

текст

[/not-news-num]

Выводится текст заключенных в них если у данного пользователя нет новостей на сайте

[comm-num]

текст [/comm-num]

Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте

[not-comm-num]

текст [/not-comm-num]

Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте

[online] текст [/online]

Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)

[offline] текст [/offline]

Выводят текст если пользователь оффлайн

[spam] Спамер [/spam]

Выводят текст, указанных в них, в виде ссылки, при нажатии на которую происходит отметка посетителя, оставившего комментарий, как "спамера"

[declination=X] текст [/declination]

Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "комментарий", "комментария", "комментариев"

[commentsgroup=1,2,3]

текст

[/commentsgroup]

Выводят заключенный в них текст указанных в них, если комментарий был написан пользователем принадлежащем перечисленным группам

[not-commentsgroup=1,2,3]

текст

[/not-commentsgroup]

Выводят заключенный в них текст если комментарий был написан пользователем не принадлежащем указанным группам

[commentscount=x]

текст

[/commentscount]

Выводят текст указанный в тегах если показывается X комментарий, где X это число показываемого на странице комментария. Например [commentscount=1] текст [/commentscount] покажет текст при показе первого по счету на странице комментария. Данный тег полезен для вебмастеров, которые хотят например регулировать где им показывать рекламу на сайте между комментариями. Например, добавленный в самый конец шаблона код [commentscount=1,10] рекламный код [/commentscount], будет показывать рекламу после первого и десятого комментария.

[not-commentscount=X]

текст

[/not-commentscount]

Выводят текст заключенный в данные теги при показе любых по счету комментариев, кроме указанных X комментариях. Данный тег будет полезен, если вы хотите выводить какие-либо элементы оформления во всех по счету комментариях, кроме вышеуказанных. Например, что-либо не показывать в первом по списку комментарии.

[rating-type-1] текст [/rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-3] текст [/rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[rating-type-4] текст [/rating-type-4]

Выводят текст, заключенный в теге, в случае если в настройках включено использование четвертого типа рейтинга 'Нравится' и 'Не нравится'.

[rating-minus] текст [/rating-minus]

Выводят текст, заключенных в них, в виде ссылки для уменьшения рейтинга комментария, выводится данная ссылка только если используется третий тип рейтинга.

[rating-plus] текст [/rating-plus]

Выводят текст, заключенных в них, в виде ссылки для увеличения рейтинга комментария, выводится данная ссылка только если используется второй и третий тип рейтинга.

{rating}

Выводит выставленный для комментария рейтинг.

{likes}

Выводит количество лайков

{dislikes}

Выводит количество дизлайков

{vote-num}

Выводит количество пользователей, которые выставили рейтинг для данного комментария.

{ratingscore}

Выводит число усредненного рейтинга от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д.

[reply] текст [/reply]

Выводят текст в них, в виде ссылки на открытие всплывающего окна для ответа на комментарий, в случае если включена поддержка древовидных комментариев, а в случае если она отключена вставляет логин выбранного комментатора в форму добавления комментариев

[treecomments]

текст

[/treecomments]

Выводят текст, заключенных в них, в случае если включены древовидные комментарии в настройках скрипта.

[not-treecomments]

текст

[/not-treecomments]

Выводят текст, заключенный в них, в случае если древовидные комментарии отключены.

[rootcomments] текст [/rootcomments]

Выводят текст, заключенных в них, в случае если комментарий является основным родительским к новости, а не является ответом на какой-либо другой комментарий.

[childrencomments] текст [/childrencomments]

Выводят текст, заключенных в них, в случае если комментарий является ответом на другой комментарий.

{replycount}

Выводит количество имеющихся ответов на данный комментарий

[comments-author]

текст

[/comments-author]

Выводят текст, заключенный в них, если пользователь, просматривающий страницу сайта, является автором данного комментария

[not-comments-author]

текст

[/not-comments-author]

Выводят текст, заключенный в них, если пользователь, просматривающий страницу сайта, не является автором данного комментария

[news-author] текст [/news-author]

Выводят текст, заключенный в них, если комментарий принадлежит автору данной новости

[not-news-author]

текст

[/not-news-author]

Выводят текст, заключенный в них, если комментарий не принадлежит автору данной новости

[positive-comment]

текст

[/positive-comment]

Выводят текст, заключенный в них, если комментарий имеет позитивный рейтинг

[negative-comment]

текст

[/negative-comment]

Выводят текст, заключенный в них, если комментарий имеет негативный рейтинг

[neutral-comment]

текст

[/neutral-comment]

Выводят текст, заключенный в них, если комментарий имеет нейтральный рейтинг

[catlist=1,2....] текст [/catlist]

Выводит текст в теге, если новость принадлежит указанным категориям

[not-catlist=1,2....] текст [/not-catlist]

Выводит текст в теге, если новость не принадлежит указанным категориям.

{banner_X}

Выводит рекламу из модуля рекламных материалов в админпанели. Где X это имя рекламного баннера

[if field = "значение"] текст [/if]

Выводят текст заключённых в них если значения поля равно указанному значению.

[if field = "значение"] текст [/if] - выведет текст если поле равно параметру 'значение'

[if field != "значение"]текст[/if] - выведет текст если поле не равно параметру 'значение'

[if field > "1"] текст [/if] - выведет текст если поле больше параметра 'значение'

[if field >= "2"] текст [/if] - выведет текст если поле больше либо равно параметру 'значение'

[if field < "3"] текст [/if] - выведет текст если поле меньше параметра 'значение'

[if field <= "4"] текст [/if] - выведет текст если поле меньше либо равно параметру 'значение'

[if field ~ "значение"] текст [/if] - выведет текст если в поле встречается текст 'значение'

[if field !~ "значение"] текст [/if] - выведет текст если в поле НЕ встречается текст 'значение'

Комбинированное использование:

[if field > "3" AND field2 < "5"] текст [/if] выведет текст если поле field больше трех, и при этом field2 меньше 5

[if field > "3" OR field2 < "5"] текст [/if] выведет текст если поле field больше трех или field2 меньше 5, то есть совпадение какого либо либого из условий

Имена полей, которое может принимать field:

id - Уникальный ID номер комментария (число)

post_id - Уникальный ID номер публикации (число)

user_id - Уникальный ID номер пользователя оставившего комментарий если он зарегистрирован (число)

date - Дата комментария (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата новости округляется до минуты)

gast_name - Логин автора комментария (текст)

gast_email - Е-mail автора комментария (текст)

ip - IP пользователя оставившего комментарий (текст)

is_register - Зарегистрирован автор комментария на сайте или нет (число 1 или 0)

rating - Общий рейтинг комментария (число)

vote_num - Количество голосов в рейтинге комментария (число)

name - Логин автора комментария если он зарегистрирован. (текст)

email - E-mail автора комментария если он зарегистрирован (текст)

news_num - Количество публикаций автора комментария если он зарегистрирован (число)

comm_num - Количество комментариев автора комментария если он зарегистрирован (число)

user_group - Группа автора комментария если он зарегистрирован (число)

lastdate - Дата последнего посещения автора комментария если он зарегистрирован (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата новости округляется до минуты)

reg_date - Дата регистрации автора комментария если он зарегистрирован (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата новости округляется до минуты)

signature - Подпись автора комментария если он зарегистрирован (текст)

foto - Ссылка на аватар автора комментария если он зарегистрирован (текст)

fullname - Полное имя автора комментария если он зарегистрирован (текст)

land - Местожительства автора комментария если он зарегистрирован (текст)

xfield_x - Значение дополнительного поля публикации, где x это имя дополнительного поля. Например xfield_test значение дополнительного поля test


Меню категорий

Навигация: Шаблоны >

Меню категорий

Вывод данного раздела настраивается в файле categorymenu.tpl В данном разделе настраивается вывод меню из категорий публикаций.

[root] текст [/root] | Выводят текст, заключенный в них при первоначальной генерации шаблона меню. Данные теги могут использоваться для создания внешнего оформления меню. Например, для добавления внешних HTML элементов или элементов меню не входящих в список категорий.
[item] текст [/item] | Выводят каждый элемент категории при построении списка меню категорий. В тексте заключенном в этом теге выводится HTML оформление каждого пункта меню
[sub-prefix] текст [/sub-prefix] | Выводят текст, заключенных в них в виде префикса для подкатегорий, если категория является родительской и у нее есть подкатегории.
[sub-suffix] текст [/sub-suffix] | Выводят текст заключенных, в них в виде суффикса для подкатегорий, если категория является родительской и у нее есть подкатегории.
{sub-item} | Указывает место для вывода подкатегорий в родительской категории, в случае если у нее есть подкатегории. Данный тег может использоваться только внутри тегов [item] [/item]
{id} | Выводит ID категории.
{name} | Выводит имя категории. Данный тег может использоваться только внутри тегов [item] [/item]
{url} | Выводит URL категории. Данный тег может использоваться только внутри тегов [item] [/item]
{icon} | Выводит иконку категории. Данный тег может использоваться только внутри тегов [item] [/item]
[category-icon] текст [/category-icon] | Выводят текст, заключенный в них, если для категории, где находится публикация, была задана иконка в настройках категории
[not-category-icon] текст [/not-category-icon] | Выводят текст если для категории, где находится публикация, не задана иконка
{news-count} | Выводит количество публикаций в категории. Данный тег может использоваться только внутри тегов [item] [/item]
[active] текст [/active] | Выводят текст заключенный в них, если просматривая на сайте категория или новость, принадлежит категории из меню. Данный тег может использоваться только внутри тегов [item] [/item] и используется например для подветки активных категорий из меню.
[not-active] текст [/not-active] | Выводят текст, заключенный в них, если просматриваемая на сайте категория, или новость, не принадлежит категории из меню.
[isparent] текст [/isparent] | Выводят текст заключенный в них, если категория является родительской и содержит в себе подкатегории Данный тег может использоваться только внутри тегов [item] [/item].
{description} | Выводит описание категории
[description] текст [/description] | Выводят текст заключённый в них если задано описание категории
[not-description] текст [/not-description] | Выводят текст заключённый в них если не было задано описание категории
[not-parent] текст [/not-parent] | Выводят текст, заключённый в них, если категория не является родительской и не содержит в себе подкатегории
[is-children] текст [/is-children] | Выводят текст, заключённый в них, если категория является подкатегорией другой категории
[not-children] текст [/not-children] | Выводят текст заключённый в них, если категория не является подкатегорией другой категории

Пример простейшего шаблона меню категорий на основе HTML тегов ul и li:

[root]<ul class="catmenu">[/root]

[item]

<li><a href="{url}">{name}</a>

[sub-prefix]<ul>[/sub-prefix]{sub-item}[sub-suffix]</ul>[/sub-suffix]

</li>

[/item]

[root]</ul>[/root]


Скачивание файлов

Навигация: Шаблоны >

Скачивание файлов

Настройка вывода файлов для скачивания, загруженных через скрипт. Файл шаблона attachment.tpl. Допускается использование следующих тегов:

[allow-download] текст [/allow-download] | Выводят текст заключенных в них, если для пользователя сайта разрешено скачивание загруженных файлов
[not-allow-download] текст [/not-allow-download] | Выводят текст заключенных в них, если для пользователя сайта запрещено скачивание загруженных файлов.
[count] текст [/count] | Выводят текст заключенных в них, если в настройках скрипта включена поддержка счетчика скачиваний файла с сервера
{id} | Выводит уникальный ID номер загруженного файла, информация о котором хранится в базе данных
{name} | Выводит имя загруженного файла, либо текст указанный для имени файла в теге [аttachment=...] в тексте новости
{extension} | Выводит расширение загруженного к новости файла
{link} | Выводит URL на скачивание загруженного файла
{size} | Выводит размер загруженного файла
{md5} | Выводит контрольную сумму MD5 загруженного файла
{date} | Выводит дату загрузки файла на сервер, в формате даты, указанной в настройках скрипта
{date=формат даты} | Выводит дату в заданном в теге формате. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца загрузки файла, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
{count} | Выводит количество скачиваний файла с сервера
{online-view-link} | Выводит ссылку URL на просмотр документа онлайн в браузере
[allow-online] текст [/allow-online] | Выводят заключенный в них текст, если загруженный документ имеет поддерживаемый для просмотра формат


Форма добавления комментария

Навигация: Шаблоны >

Форма добавления комментария

Вывод данного раздела настраивается в файле addcomments.tpl В этом разделе настраиваются шаблоны, которые используются при добавлении комментариев в базу данных со стороны посетителей сайта. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{title} | Выводит заголовок, для чего эта форма, для добавления или редактирования комментариев
[not-logged] и [/not-logged] | Выводится код заключенный в теги, если пользователь не зарегистрирован, например вы можете заключить в эти теги поля для ввода имени и e-mail адреса, если они не заполнены и пользователь авторизован на сайте, эти данные будут взяты автоматически из его профиля.
{editor} | Выводит в зависимости от настроек BBCODE или WYSIWYG редактор для добавления комментария
{image-upload} | Выводит специальное поле куда пользователь может переместить картинки для загрузки, либо выбрать их с компьютера.
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при добавлении комментариев
{sec_code} | Выводит код отображения CAPTCHA
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | выводит вопрос для посетителя из заданного ранее списка вопросов и ответов
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex
[comments-subscribe] текст [/comments-subscribe] | Выводят текст, заключенный в них в виде ссылки на подписку на уведомления о новых комментариях.
[catlist=1,2....] текст [/catlist] | Выводит текст в теге, если новость принадлежит указанным категориям
[not-catlist=1,2....] текст [/not-catlist] | Выводит текст в теге, если новость не принадлежит указанным категориям.
[allow-comments-subscribe] текст [/allow-comments-subscribe] | Выводят текст заключённый в них, в случае если пользователю разрешено подписываться на комментарии. Тем самым вы можете сделать оформление ссылки на подписку на комментарии в нужном вам блоке и скрывать его если подписка запрещена.
[comments-unsubscribe] текст [/comments-unsubscribe] | Выводят текст заключенный в них в виде ссылки на отписку от комментариев к данной публикации. Тем самым пользователи могут отписаться только от одной конкретной новости на сайте, ранее для этого им нужно было отписываться от всех публикаций.
{comments-subscribe} | Выводит чекбокс на подписку на комментарии в форме добавления комментария.


Опросы в новостях

Навигация: Шаблоны >

Опросы в новостях

Вывод данного раздела настраивается в файле poll.tpl В данном разделе настраивается вывод опроса для опубликованной новости

{title} | Заголовок опроса
{question} | Вопрос
{votes} | Общее количество голосов
{list} | Список вариантов ответа
[voted] текст [/voted] | Выводят текст в тегах если пользователь уже проголосовал в опросе, в противном случае его скрывают
[not-voted] текст [/not-voted] | Выводят текст в тегах если пользователь еще не проголосовал в опросе, в противном случае его скрывают


Добавление новости

Навигация: Шаблоны >

Добавление новости

Вывод данной формы настраивается в файле addnews.tpl В этом разделе настраиваются шаблоны, которые используются при добавлении новости в базу данных со стороны посетителей сайта. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{category} | Выводится поле для выбора категории к которой будет принадлежать категория
{xfields} | Вывод дополнительных полей при добавлении новости
[xfinput_X] | Выводит ваше выбранное дополнительное поле в форме добавления новости в нужном вам месте, где X это имя дополнительного поля для новостей
{bbcode} | Выводятся кнопки для вставки тегов в новости
{admintag} | Вывод дополнительных опций для администратора
[urltag] и [/urltag] | Выводится код заключенный в теги, для изменения ЧПУ URL статьи (доступно администратору)
[not-wysywyg] и [/not-wysywyg] | Выводится текст заключенный в теги если отключен WYSIWYG редактор, если включен, то содержимое тегов удаляется
{shortarea} | Выводит WYSIWYG редактор для добавления краткой новости
{title} | Выводит заголовок во время редактирования новости
{alt-name} | Значение ЧПУ при редактировании новости
{short-story} | Короткая новость при редактировании новости
{full-story} | Полная новость при редактировании новости
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при добавлении новостей
{sec_code} | Код отображения CAPTCHA
{fullarea} | Выводит WYSIWYG редактор для добавления полной новости
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | Выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | Выводит вопрос для посетителя из заданного ранее списка вопросов и ответов
{votetitle} | Выводит заголовок опроса при редактировании новости
{frage} | Выводит вопрос из опроса при редактировании новости
{votebody} | Выводит список вариантов ответа из опроса при редактировнии новости
[allow-shortstory] текст [/allow-shortstory] | Выводят текст заключённый в них в случае, если в настройках скрипта включена поддержка поля краткого описания, и скрывают текст в случае данное поле отключено.
[allow-fullstory] текст [/allow-fullstory] | Выводят текст заключённый в них в случае, если в настройках скрипта включена поддержка поля полного описания, и скрывают текст в случае данное поле отключено

Имеется также возможность передавать в URL браузера категории, которые необходимо сделать выбранными по умолчанию. Для этого используется URL http://вашсайт.ru/index.php?do=addnews&category=X где "X" это ID нужных вам категорий, перечисленные через запятую. Например, по адресу http://вашсайт.ru/index.php?do=addnews&category=3,4,5 в форме добавления новости на сайте будут выбраны по умолчанию категории с ID 1, 2 и 3. Данное нововведение будет полезно для сайтов, которые используют доп. поля для публикаций назначенные разным категориям, и хотят дать пользователям при добавлении публикаций несколько уже предустановленных форм добавления публикации, для различных категорий.


Предосмотр новостей

Навигация: Шаблоны >

Предосмотр новостей

Вывод данного раздела настраивается в файле preview.tpl В этом разделе настраиваются шаблоны, предназначенные для предосмотра добавляемых новостей. В данном шаблоне вы можете использовать все теги для краткой и полной новости, а также статических страниц, при этом для разделения просматриваемых частей используются дополнительно теги:

[short-preview] и [/short-preview] выводит в тегах текст шаблона предназначенного для просмотра краткой новости

[full-preview] и [/full-preview] выводит в тегах текст шаблона предназначенного для просмотра полной новости

[static-preview] и [/static-preview] выводит в тегах текст шаблона предназначенного для просмотра статической страницы


Предыдущая и следующая страницы для новостей

Навигация: Шаблоны >

Предыдущая и следующая страницы для новостей

Вывод данного раздела настраивается в файле navigation.tpl В данном разделе настраивается вывод навигации для новостей

[prev-link] and [/prev-link] | Создает ссылку на предыдущую страницу (если такая есть)
[next-link] and [/next-link] | Создает ссылку на следующую страницу (если такая есть)
{pages} | Создает ссылки на страницы; например: 1 2 3 4


Регистрация на сайте

Навигация: Шаблоны >

Регистрация на сайте

Вывод данного раздела настраивается в файле registration.tpl В этом разделе настраиваются шаблоны, которые используются при регистрации посетителей на сайте. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

[registration] и [/registration] | Выводит текст заключенный в тегах при регистрации
[validation] и [/validation] | Выводит текст заключенный в тегах при активации
[sec_code] и [/sec_code] | Выводит текст заключенный в тегах если разрешен показ кода безопасности
{reg_code} | Выводит код безопасности для посетителя
{xfields} | Выводит поля для ввода дополнительных полей профиля
[xfinput_X] | Выводит ваше выбранное дополнительное поле в виде заполения поля в нужном вам месте, где X это имя дополнительного поля
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[question] и [/question] | Выводят текст заключенный в данные теги если система вопрос-ответ включена
{question} | Выводит вопрос для посетителя из заданного ранее списка вопросов и ответов
[vk] текст [/vk] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте
{vk_url} | Выводит ссылку URL на авторизацию в соц. сети Вконтакте
[odnoklassniki] текст [/odnoklassniki] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники
{odnoklassniki_url} | Выводит ссылку URL на авторизацию в соц. сети Одноклассники
[facebook] текст [/facebook] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook
{facebook_url} | Выводит ссылку URL на авторизацию в соц. сети Facebook
[google] текст [/google] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google
{google_url} | Выводит ссылку URL на авторизацию в соц. сети Google
[mailru] текст [/mailru] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru
{mailru_url} | Выводит ссылку URL на авторизацию в соц. сети Mail.ru
[yandex] текст [/yandex] | Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex
{yandex_url} | Выводит ссылку URL на авторизацию в соц. сети Yandex


Профиль пользователя

Навигация: Шаблоны >

Профиль пользователя

Вывод данного раздела настраивается в файле userinfo.tpl В этом разделе настраиваются шаблоны, которые используются при выводе профиля пользователя. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{usertitle}

Вывод имени пользователя

{info}

Краткая информация о пользователе

{editmail}

Выводит Е-mail адрес пользователя

{comm-num}

Выводит количество комментариев

{news-num}

Выводит количество новостей пользователя

{status}

Статус пользователя (его группа на сайте)

{rate}

Текущий рейтинг новостей посетителя (складывается автоматически на основе рейтинга его статей)

[rating-type-1] текст [/rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование первого типа рейтинга 'Оценка'.

[rating-type-2] текст [/rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование второго типа рейтинга 'Только Нравится'.

[rating-type-3] текст [/rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.

[comments-rating-type-1]

текст [/comments-rating-type-1]

Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев первого типа рейтинга 'Оценка'.

[comments-rating-type-2]

текст [/comments-rating-type-2]

Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев второго типа рейтинга 'Только Нравится'.

[comments-rating-type-3]

текст [/comments-rating-type-3]

Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев третьего типа рейтинга 'Нравится' или 'Не нравится'.

{commentsrate}

Выводит суммарный рейтинг всех комментариев данного пользователя.

{ratingscore}

Выводит число усреднённого рейтинга всех публикаций пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д. Данный тег позволяет задать, например, собственное оформление звезд рейтинга с частичным заполнением, а не только 2 или 4 заполненных звезды.

{commentsratingscore}

Выводит число усредненного рейтинга всех комментариев пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д.

{registration}

Выводит его дату регистрации на сайте

{editinfo}

Вывод существующей краткой информации в поле при редактировании профиля

{hidemail}

Выводить чекбокс на скрытие e-mail адреса.

{foto}

Выводит ссылку на загруженную фотографию

{fullname}

Выводит полное имя пользователя

{land}

Выводит место жительства пользователя

[not-logged] и [/not-logged]

Выводится код заключенный в теги, если пользователь который просматривает профиль и есть этот самый пользователь, используется для того чтобы посетители могли редактировать свой собственный профиль.

[signature] и [/signature]

Выводит текст заключенный в теги, если пользователь задал подпись в профиле

{signature}

Выводит подпись пользователя

{editsignature}

Выводит отформатированную для редактирования подпись пользователя

{lastdate}

Выводит дату последнего посещения сайта пользователем

{comments}

Выводит ссылку на все комментарии этого пользователя

{allowed-ip}

Значение IP с которого разрешена авторизация

{xfields}

Выводится Список дополнительных полей профиля при их редактировании

[xfinput_X]

Выводит ваше выбранное дополнительное поле в виде заполения поля в нужном вам месте, где X это имя дополнительного поля

[xfvalue_x]

Выводится значение дополнительного поля "x", где "x" название дополнительного поля

[xfgiven_x] [xfvalue_x] [/xfgiven_x]

Выводится дополнительное поле "x", если поле не пустое

[xfnotgiven_x]

текст

[/xfnotgiven_x]

Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя

{group-icon}

Выводит иконку группы участника

[time_limit] [/time_limit]

Выводит текст между тегами если пользователь находится во временной группе

{time_limit}

Выводит дату, до которой пользователь находится во временной группе

{news}

Выводит ссылку на просмотр всех новостей данного пользователя

[rss] тект [/rss]

Выводит ссылку в профиле на RSS поток всех новостей пользователя.

{ignore-list}

Список пользователей, добавленных в игнорируемые.

[fullname]

текст [/fullname]

Выводится текст заключенный в них только если полное имя пользователя задано

[not-fullname]

текст [/not-fullname]

Выводится текст, заданный в них только если полное имя пользователя не задано

[land] текст [/land]

Выводится текст заключенный в них только если местожительство пользователя было им задано

[not-land] текст [/not-land]

Выводится текст, заданный в них только если местожительство пользователя не было им указано

[info] текст [/info]

Выводится текст заключенный в теги, если пользователь задал краткую информацию о себе в профиле

[not-info] текст [/not-info]

Выводится текст заключенный в теги, если пользователь не задавал краткую информацию о себе в профиле

[news-num]

текст

[/news-num]

Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте

[not-news-num]

текст

[/not-news-num]

Выводится текст заключенных в них если у данного пользователя нет новостей на сайте

[comm-num]

текст [/comm-num]

Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте

[not-comm-num]

текст [/not-comm-num]

Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте

[online] текст [/online]

Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)

[offline] текст [/offline]

Выводят текст если пользователь оффлайн

[profile-user-group=X] Текст [/profile-user-group]

Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, принадлежит указанной группе X. Где X это номер группы. Допускается также перечисление нужных групп через запятую.

[not-profile-user-group=X] Текст [/not-profile-user-group]

Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, не принадлежит указанной группе X. Где X это номер группы.

{timezones}

Выводит список доступных часовых поясов в системе, и позволяет пользователю выбрать свой часовой пояс для своего профиля на сайте.

{unsubscribe}

Выводит чекбокс на отписку от комментариев, и количество подписанных публикаций.

{news-subscribe}

Выводит чекбокс на подписку получения уведомлений о новых комментариях, которые добавляются к новостям, автором которых является пользователь.

{comments-reply-subscribe}

Выводит чекбокс на подписку получения уведомлений о новых комментариях, которые являются ответами на собственные комментарии пользователя.

{pm}

Ссылка на написание персонального сообщения пользователю

{email}

Ссылка на написание E-Mail сообщения пользователю

{twofactor-auth}

Выводит чекбокс для включения или отключения двухфакторной авторизации на сайте для пользователя

[banned] текст [/banned]

Выводят текст заключённый в них если пользователь в данный момент забанен на сайте

[not-banned] текст [not-banned]

Выводят текст заключённый в них если пользователь не забанен на сайте

{ban-description}

Выводит причину по которой пользователь забанен

{ban-date}

Выводит дату до которой пользователь был забанен на сайте

[vk] текст [/vk]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Вконтакте

{vk_url}

Выводит ссылку URL на авторизацию в соц. сети Вконтакте

[odnoklassniki] текст [/odnoklassniki]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Одноклассники

{odnoklassniki_url}

Выводит ссылку URL на авторизацию в соц. сети Одноклассники

[facebook] текст [/facebook]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Facebook

{facebook_url}

Выводит ссылку URL на авторизацию в соц. сети Facebook

[google] текст [/google]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Google

{google_url}

Выводит ссылку URL на авторизацию в соц. сети Google

[mailru] текст [/mailru]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Mail.ru

{mailru_url}

Выводит ссылку URL на авторизацию в соц. сети Mail.ru

[yandex] текст [/yandex]

Выводят текст заключенный в них, если включена поддержка авторизации при помощи социальной сети Yandex

{yandex_url}

Выводит ссылку URL на авторизацию в соц. сети Yandex

{social-list}

Выводит список привязанных социальных сетей и ссылки на их отключения от данного аккаунта

[attached-vk] текст [/attached-vk]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Вконтакте

[attached-odnoklassniki] текст [/attached-odnoklassniki]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Одноклассники

[attached-facebook] текст [/attached-facebook]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Facebook

[attached-google] текст [/attached-google]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Google

[attached-mailru] текст [/attached-mailru]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Mail.ru

[attached-yandex] текст [/attached-yandex]

Выводят текст заключенный в них в случае если аккаунт пользователя привязан к сети Яндекс

[detach-vk] текст [/detach-vk]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Вконтакте, случае если аккаунт пользователя привязан к ней.

[detach-odnoklassniki] текст [/detach-odnoklassniki]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Одноклассники, случае если аккаунт пользователя привязан к ней.

[detach-facebook] текст [/detach-facebook]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Facebook, случае если аккаунт пользователя привязан к ней.

[detach-google] текст [/detach-google]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Google, случае если аккаунт пользователя привязан к ней.

[detach-mailru] текст [/detach-mailru]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Mail.ru, случае если аккаунт пользователя привязан к ней.

[detach-yandex] текст [/detach-yandex]

Выводят текст заключённый в них в виде ссылки на отвязку аккаунта от социальной сети Яндекс, случае если аккаунт пользователя привязан к ней.

[ignore] текст [/ignore]

Выводят текст заключённый в них в виде ссылки на добавление пользователя в список игнорируемых

[delete] Текст [/delete]

Выводят текст заключённый в них в виде ссылки на удаление собственного профиля на сайте пользователем, в случае если это ему разрешено настройками групп пользователей

[if field = "значение"] текст [/if]

Выводят текст заключённых в них если значения поля равно указанному значению.

[if field = "значение"] текст [/if] - выведет текст если поле равно параметру 'значение'

[if field != "значение"]текст[/if] - выведет текст если поле не равно параметру 'значение'

[if field > "1"] текст [/if] - выведет текст если поле больше параметра 'значение'

[if field >= "2"] текст [/if] - выведет текст если поле больше либо равно параметру 'значение'

[if field < "3"] текст [/if] - выведет текст если поле меньше параметра 'значение'

[if field <= "4"] текст [/if] - выведет текст если поле меньше либо равно параметру 'значение'

[if field ~ "значение"] текст [/if] - выведет текст если в поле встречается текст 'значение'

[if field !~ "значение"] текст [/if] - выведет текст если в поле НЕ встречается текст 'значение'

Комбинированное использование:

[if field > "3" AND field2 < "5"] текст [/if] выведет текст если поле field больше трех, и при этом field2 меньше 5

[if field > "3" OR field2 < "5"] текст [/if] выведет текст если поле field больше трех или field2 меньше 5, то есть совпадение какого либо либого из условий

Имена полей, которое может принимать field:

name - Логин пользователя. (текст)

email - E-mail пользователя (текст)

user_id - Уникальный ID номер пользователя (число)

news_num - Количество публикаций пользователя (число)

comm_num - Количество комментариев пользователя (число)

user_group - Группа пользователя (число)

lastdate - Дата последнего посещения пользователя (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

reg_date - Дата регистрации пользователя (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

allow_mail - Разрешил ли пользователь получать письма с сайта (число 1 или 0)

info - Информация пользователя о себе (текст)

signature - Подпись пользователя (текст)

fullname - Полное имя пользователя (текст)

land - Местожительства пользователя (текст)

foto - Ссылка на аватар пользователя (текст)

pm_all - Количество персональных сообщений пользователя (число)

pm_unread - Количество непрочитанных персональных сообщений пользователя (число)

restricted - Наложены ли на пользователя ограничения (число 0 - ограничений нет, 1 - запрет на добавление публикаий 2 - запрет на добавление комментариев 3 - запрет на публикации и комментарии)

restricted_days - Количество дней на которое наложен запрет (число)

restricted_date - Дата до которой наложены запреты на пользователя (дата в английском формате, например "2020-09-01" или "10 September 2020" или "next Thursday" или "+1 day" или "next Thursday" или в unix формате, если же используется знак равенства то дата округляется до минуты)

logged_ip - IP c которым пользователь заходил на сайт (текст)

timezone - Часовой пояс пользователя в формате часовых поясов, например Europe/Moscow (текст)

news_subscribe - Подписан ли пользователь на уведомления о новых публициях (число 1 или 0)

comments_reply_subscribe - Подписан ли пользователь на уведомления об ответах на свои комментарии (число 1 или 0)

twofactor_auth - Включил ли пользователь двухфакторную авторизацию (число 1 или 0)

cat_allow_addnews - Категории в которые пользователю разрешено добавлять публикации (массив ID категорий)

cat_add - Категории которые являются доверительными для пользователя при добавлении публикаций (массив ID категорий)

xfield_x - Значение дополнительного поля пользователя, где x это имя дополнительного поля. Например xfield_test значение дополнительного поля test


Карточка профиля пользователя

Навигация: Шаблоны >

Карточка профиля пользователя

Вывод данного раздела настраивается в файле profile_popup.tpl В этом разделе настраиваются шаблоны, которые используются при выводе карточки профиля пользователя.

{usertitle} | Выводит логин пользователя
{fullname} | Выводит полное имя пользователя
{foto} | Выводит ссылку на загруженную фотографию
{status} | Статус пользователя
{registration} | Дата регистрации на сайте
{lastdate} | Выводит дату последнего посещения сайта пользователем
{lastdate=формат даты} | Выводит последнего посещения сайта пользователем в заданном в теге формате. Например тег {lastdate=d} выведет день месяца, а тег {lastdate=F} выведет название месяца, а тег {lastdate=d-m-Y H:i} выведет полную дату и время.
{registration=формат даты} | Выводит дату регистрации пользователя в заданном в теге формате. Например тег {registration=d} выведет день месяца, а тег {registration=F} выведет название месяца, а тег {registration=d-m-Y H:i} выведет полную дату и время.
{comm-num} | Количество комментариев
{news-num} | Количество новостей
{land} | Выводит место жительства
{info} | Краткая информация о пользователе
[info] текст [/info] | Выводится текст заключенный в теги, если пользователь задал краткую информацию о себе в профиле
{rate} | Текущий рейтинг новостей посетителя (складывается автоматически на основе рейтинга его статей)
[rating-type-1] текст [/rating-type-1] | Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование первого типа рейтинга 'Оценка'.
[rating-type-2] текст [/rating-type-2] | Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование второго типа рейтинга 'Только Нравится'.
[rating-type-3] текст [/rating-type-3] | Выводят текст, заключенный в них, если в настройках скрипта для новостей включено использование третьего типа рейтинга 'Нравится' или 'Не нравится'.
[comments-rating-type-1] текст [/comments-rating-type-1] | Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев второго типа рейтинга 'Только Нравится'.
[comments-rating-type-2] текст [/comments-rating-type-2] | Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев второго типа рейтинга 'Только Нравится'.
[comments-rating-type-3] текст [/comments-rating-type-3] | Выводят текст, заключенный в них, если в настройках скрипта включено использование для комментариев третьего типа рейтинга 'Нравится' или 'Не нравится'.
{commentsrate} | Выводит суммарный рейтинг всех комментариев данного пользователя.
{ratingscore} | Выводит число усреднённого рейтинга всех публикаций пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д. Данный тег позволяет задать, например, собственное оформление звезд рейтинга с частичным заполнением, а не только 2 или 4 заполненных звезды.
{commentsratingscore} | Выводит число усредненного рейтинга всех комментариев пользователя, от одного до пяти, с сохранением дробного значения. Например, в зависимости от выставленной оценки это может быть 1.6 или 4.2 и т.д.
[signature] и [/signature] | Выводит текст заключенный в теги, если пользователь задал подпись в профиле
{signature} | Выводит подпись пользователя
{group-icon} | Выводит иконку группы пользователя
{news} | Выводит ссылку на просмотр всех новостей данного пользователя
{comments} | Выводит ссылку на все комментарии этого пользователя
[rss] тект [/rss] | Выводит ссылку в профиле на RSS поток всех новостей пользователя
[fullname] текст [/fullname] | Выводится текст заключенный в них только если полное имя пользователя задано
[not-fullname] текст [/not-fullname] | Выводится текст, заданный в них только если полное имя пользователя не задано
[land] текст [/land] | Выводится текст заключенный в них только если местожительство пользователя было им задано
[not-land] текст [/not-land] | Выводится текст, заданный в них только если местожительство пользователя не было им указано
[news-num] текст [/news-num] | Выводится текст, заключенный в них если у данного пользователя есть опубликованные новости на сайте
[not-news-num] текст [/not-news-num] | Выводится текст заключенных в них если у данного пользователя нет новостей на сайте
[comm-num] текст [/comm-num] | Выводится текст, заключенный в них если у данного пользователя есть опубликованные комментарии на сайте
[not-comm-num] текст [/not-comm-num] | Выводится текст заключенных в них если у данного пользователя нет комментариев на сайте
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | Выводится дополнительное поле "x", если поле не пустое
[xfnotgiven_x] текст [/xfnotgiven_x] | Выводится текст, указанный в них, если дополнительное поле пользователя не было задано, где X это имя дополнительного поля профиля пользователя
[xfvalue_x] | Значение дополнительного поля "x", где "x" название дополнительного поля
[online] текст [/online] | Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)
[offline] текст [/offline] | Выводят текст если пользователь оффлайн
[profile-user-group=X] Текст [/profile-user-group] | Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, принадлежит указанной группе X. Где X это номер группы. Допускается также перечисление нужных групп через запятую.
[not-profile-user-group=X] Текст [/not-profile-user-group] | Выводят текст заключенных в них, если группа пользователя, профиль которого просматривается, не принадлежит указанной группе X. Где X это номер группы.
[ignore] текст [/ignore] | Выводят текст заключённый в них в виде ссылки на добавление пользователя в список игнорируемых
[banned] текст [/banned] | Выводят текст заключённый в них если пользователь в данный момент забанен на сайте
[not-banned] текст [not-banned] | Выводят текст заключённый в них если пользователь не забанен на сайте
{ban-description} | Выводит причину по которой пользователь забанен
{ban-date} | Выводит дату до которой пользователь был забанен на сайте


Форма поиска

Навигация: Шаблоны >

Форма поиска

Вывод данного раздела настраивается в файле search.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод формы поиска по сайту:

{searchtable} | Форма поиска в виде таблицы
{searchmsg} | Вывод сообщения о результатах поиска
[searchmsg] и [/searchmsg] | Вывод текста в случае если был произведен поиск
[simple-search] текст [/simple-search] | Выводит текст заключенный в теги если производится поиск по сокращенным
[extended-search] текст [/extended-search] | Выводит текст заключенный в теги если производится поиск по расширеным параметрам
{searchfield} | Выводит поле для заполнения текста который необходимо найти
{word-option} | Выводит чекбокс параметра поиска заданного текста (точное совпадение всех слов или нет)
{search-area} | Выводит выбор области поиска на сайте
{userfield} | Выводит поле для ввода автора публикаций
{user-option} | Выводит чекбокс параметра поиска автора (точное совпадение всех слов или нет)
{news-option} | Выводит выбор параметров комментариев у новостей
{comments-num} | Выводит поле для ввода количества комментариев у новостей
{date-option} | Выводит выбор параметров даты у новостей
{date-beforeafter} | Выводит выбор параметров новее или старее даты у новостей нужно найти
{sort-option} | Выводит выбор параметров сортировки найденных результатов
{order-option} | Выводит выбор порядка сортировки (возрастание или убывание)
{view-option} | Выводит выбор режима отображения найденных результатов
{category-option} | Выводит выбор категорий в которых необходимо произвести поиск


Результаты поиска

Навигация: Шаблоны >

Результаты поиска

Вывод данного раздела настраивается в файле searchresult.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод новостей найденных в результате поиска:

[searchposts] и [/searchposts] | Вывод найденных результатов для новостей
[searchcomments] и [/searchcomments] | Вывод найденных результатов для комментариев
[fullresult] и [/fullresult] | Вывод результатов в виде статей
[shortresult] и [/shortresult] | Вывод результатов в виде заголовков

Внимание, в данном шаблоне для непосредственного вывода статей и комментариев используются полностью аналогичные теги как и в шаблонах вывода кратких новостей и комментариев.


Результаты быстрого поиска

Навигация: Шаблоны >

Результаты быстрого поиска

Вывод данного раздела настраивается в файле fastsearchresult.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод новостей найденных в результате быстрого поиска на сайте. В данном шаблоне для непосредственного вывода статей используются полностью аналогичные теги как и в шаблонах вывода кратких новостей


Статистика сайта

Навигация: Шаблоны >

Статистика сайта

Вывод данного раздела настраивается в файле stats.tpl В данном разделе настраивается вывод общей статистики сайта

{datenbank} | Общий размер базы данных
{news_num} | Общее количество новостей
{news_allow} | Опубликовано новостей
{news_main} | Опубликовано на главной
{news_moder} | Ожидает модерации
{comm_num} | Количество комментариев
{user_num} | Зарегистрировано пользователей
{user_banned} | Забаненных пользователей
{topusers} | Список лучших авторов на сайте
{news_day} | Опубликовано новостей за сутки
{news_week} | Опубликовано новостей за неделю
{news_month} | Опубликовано новостей за месяц
{comm_day} | Опубликовано комментариев за сутки
{comm_week} | Опубликовано комментариев за неделю
{comm_month} | Опубликовано комментариев за месяц
{user_day} | Зарегистрировано пользователей за сутки
{user_week} | Зарегистрировано пользователей за неделю
{user_month} | Зарегистрировано пользователей за месяц


Вывод информации и ошибок

Навигация: Шаблоны >

Вывод информации и ошибок

Вывод данного раздела настраивается в файле info.tpl В данном разделе настраивается вывод формы в случае возникновения ошибок, либо наоборот в случае успешного выполнения действий.

{title} – заголовок сообщения

{error} – текст ошибки


Форма для отправки E-Mail

Навигация: Шаблоны >

Форма для отправки E-Mail

Вывод данного раздела настраивается в файле feedback.tpl В этом разделе настраиваются шаблоны, которые используются при выводе формы для отправки E-Mail. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{recipient} - Выводит список получателей

[not-logged] и [/not-logged] - Выводит текст между тегами если посетитель не зарегистрирован

{code} - Выводит код отображения CAPTCHA

[sec_code] и [/sec_code] Выводит текст если в настройках скрипта включена стандартная CAPTCHA

[recaptcha] и [/recaptcha] Выводит текст если в настройках скрипта включена reCAPTCHA

{recaptcha} Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи

[attachments] текст [/attachments] Выводят текст, заключённый в них, если разрешена отправка файлов в обратной связи для данной группы пользователей.

Также у вас есть возможность использования дополнительных полей в разделе обратной связи на сайте. Для того чтобы добавить дополнительное поле в форму обратной связи, вам необходимо только разместить необходимое поле с определенным именем в форме, после чего оно будет доступно для использования в шаблонах e-mail сообщений. Для добавления дополнительного поля в форму, для поля ввода необходимо использовать атрибут с именем: name="xfield[X]", где X это имя поля, написанное латинскими буквами. Например, вы хотите разместить в форме обратной связи поле для заполнения номера телефона, для этого в шаблоне feedback.tpl размещаете поле:

<input placeholder="Ваш номер телефона" type="text" name="xfield[tel]">

где tel это уникальное имя дополнительного поля, а в шаблоне e-mail сообщений в админпанели размещаете тег: {%tel%}, после чего заполненный пользователем номер телефона будет также присылаться вместе с сообщением. Допускается использование любого количества дополнительных полей.

Вы также можете в обратной связи прикреплённые к письмам файлы. Для этого в настройках групп можете задать для каждой группы пользователей разрешено ли им прикреплять к письмам файлы. Также можете указать сколько максимально файлов они могут приложить к письму, их максимальный суммарный размер, а также какие типы расширений файлов, которые они могут отправлять.

Непосредственно для прикрепления файлов к форме вы можете использовать тег:

<input name="attachments[]" type="file" multiple>

при этом имя тега и количество тегов может быть любым, главное это использование type="file" в атрибуте. DLE сам посчитает все прикреплённые к письму файлы и их соответствие настройкам групп.

Также имеется возможность использования нескольких форм обратной связи на сайте. Для этого используется специально сформированный URL в браузере. Для отправки стандартной формы обратной связи используется адрес http://вашсайт.ru/index.php?do=feedback Для того чтобы добавить ещё одну форму связи вы можете использовать адрес http://вашсайт.ru/index.php?do=feedback&template=X1&mailtemplate=X2, где X1 это имя шаблона для шаблона формы обратной связи, а X2 это имя шаблона письма, которое будет отправляться через эту форму. При этом если задан шаблон X1, то на сервере в папке шаблона у вас должен находится файл с именем feedback_X1.tpl, а если задан шаблон X2, то на сервере в папке шаблона у вас должен находится файл с именем email_X2.tpl. Например, при использовании URL http://вашсайт.ru/index.php?do=feedback&template=test&mailtemplate=test в папке вашего шаблона должен находится файл feedback_test.tpl для формы обратной связи и email_test.tpl для шаблона отправляемого сообщения. Эти файлы поддерживают все те же теги что и стандартная форма обратной связи, и стандартный шаблон e-mail сообщений в админпанели. Тем самым с учётом того что формы обратной связи поддерживают дополнительные поля разного типа, вы можете организовать на своём сайте, несколько различных форм обратной связи.


Восстановление пароля

Навигация: Шаблоны >

Восстановление пароля

Вывод данного раздела настраивается в файле lostpassword.tpl В этом разделе настраиваются шаблоны, которые используются при выводе формы для восстановления пароля на E-Mail. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{code} - Выводит код отображения CAPTCHA

[sec_code] и [/sec_code] Выводит текст если в настройках скрипта включена стандартная CAPTCHA

[recaptcha] и [/recaptcha] Выводит текст если в настройках скрипта включена reCAPTCHA

{recaptcha} Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи


Статические страницы

Навигация: Шаблоны >

Статические страницы

Вывод статических страниц настраивается в файле static.tpl или в файле который вы назначите при создании статической страницы в админпанели скрипта. В данном шаблоне вы можете использовать следующие теги:

{description} выводит описание статической страницы

{static} выводит текст статической страницы

{pages} Выводит навигацию по нескольким страницам одной статической страницы.

{views} Выводит количество просмотров статической страницы.

{custom} Смотрите раздел "Вывод новостей на страницах"

{text limit="x"} выводит только текст добавленных для статической страницы без HTML форматирования, при этом сам текст публикации сокращается до указанного X количества символов. При этом сокращение текста происходит до последнего логического слова.

{image-x} выводит URL картинки, находящейся в тексте статической страницы, где "x" это номер картинки в тексте страницы, например, {image-1} выведет URL первой картинки в тексте страницы.

[image-x] текст [/image-x] выводят указанный в них текст, только если картинка с номером "x" присутствует в тексте страницы.

[print-link] текст [/print-link] выводить ссылку на версию для печати

{date} выводит дату создания страницы в формате установленном в настройках скрипта

{date=формат даты} выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y, H:i} выведет полную дату и время. Также дополнительно как в тексте статических страниц, так и в их шаблонах вы можете указывать теги из модуля управления рекламой и теги информеров.

[edit] текст [/edit] выводит текст заключённый в них в виде ссылки на редактирование статической страницы, для групп пользователей, которым разрешено редактирование статических страниц.

[static=имя страницы] текст [/static] выводит текст заключенный в теги , если посетитель просматривает статическую страницу с указанным именем.

[not-static=имя страницы] текст [/not-static] выводит текст заключенный в теги, если посетитель не просматривает статическую страницу с указанным именем.

{full-link} выводит URL для данной статической страницы,

{print-link} выводит URL версии для печати для данной страницы.

Также в шаблоне имеется поддержка тегов рекламы и RSS информеров


Персональные сообщения

Навигация: Шаблоны >

Персональные сообщения

Вывод данного раздела настраивается в файле pm.tpl В этом разделе настраиваются шаблоны, которые используются для работы с персональными сообщениями. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

[inbox] и [/inbox] | Ссылка на входящие сообщения
[outbox] и [/outbox] | Ссылка на отправленные сообщения
[new_pm] и [/new_pm] | Ссылка на написание сообщения
[pmlist] и [/pmlist] | Выводится текст в тегах, если просматривается список сообщений
{pmlist} | Список сообщений
[newpm] и [/newpm] | Выводится текст в тегах, если написание сообщения
{pm-limit} | Выводит максимальное количество сообщений, который может хранить пользователь
{proc-pm-limit} | Выводит количество заполненного пространства ящика пользователя в процентах
{pm-progress-bar} | Выводит шкалу наполненности ящика персональных сообщений
{author} | Получатель сообщения
{subj} | Тема сообщения
{editor} | Выводит в зависимости от настроек BBCODE или WYSIWYG редактор для написания сообщения
{text} | Текст сообщения
[readpm] и [/readpm] | Выводится текст в тегах, если просматривается само сообщение
[reply] и [/reply] | Ссылка для ответа на сообщение
[del] и [/del] | Ссылка на удаление сообщения
{sec_code} | Код отображения CAPTCHA
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при написании персональных сообщений
{foto} | Выводит ссылку на фотографию
{group-icon} | Выводит иконку группы участника
{group-name} | Выводит имя группы участника
{news-num} | Выводит количество новостей участника
{comm-num} | Выводит количество комментариев участника
{login} | Выводит логин автора персонального сообщения, без какого-либо дополнительного оформления
{date=формат даты} | Выводит дату в заданном в теге формате. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время.
{lastdate=формат даты} | Выводит последнего посещения сайта пользователем в заданном в теге формате. Например тег {lastdate=d} выведет день месяца, а тег {lastdate=F} выведет название месяца, а тег {lastdate=d-m-Y H:i} выведет полную дату и время.
{registration=формат даты} | Выводит дату регистрации пользователя в заданном в теге формате. Например тег {registration=d} выведет день месяца, а тег {registration=F} выведет название месяца, а тег {registration=d-m-Y H:i} выведет полную дату и время.
[signature]{signature}[/signature] | Выводит текст заключенный в теги и подпись пользователя, если пользователь задал подпись в профиле
{date} | Дата публикации комментария, формат вывода даты настраивается в настройках системы
{registration} | Выводит дату регистрации на сайте
[recaptcha] тест [/recaptcha] | Выводят информацию, заключенную в тегах, в случае если в настройках скрипта включент тип каптчи reCAPTCHA
{recaptcha} | Выводит виджет reCAPTCHA если в настройках скрипта включен данный тип вывода каптчи.
[complaint] текст [/complaint] | Выводять текст, указанных в тегах в виде ссылки на написание жалобы, на персональное сообщение.
[ignore]текст[/ignore] | Выводит ссылки на добавление пользователя в список игнорируемых.
[online] текст [/online] | Выводят текст если пользователь онлайн (20 минут с момента последнего посещения пользователем сайта)
[offline] текст [/offline] | Выводят текст если пользователь оффлайн
[declination=X] текст [/declination] | Выводит склонения слов относительно чисел. В качестве параметров тега вместо X передается число, а вместо "текст" передается корень слова с окончаниями. Окончания слова перечисляются при помощи символа "|". Данный тег полезно использовать с другими тегами, выводящими например количество просмотров новости или количество комментариев. Например [declination={comments-num}]комментари|й|я|ев[/declination] в зависимости от количества комментариев будет выводить: "1 комментарий", "2 комментария", "10 комментариев"


Облако тегов

Навигация: Шаблоны >

Облако тегов

Вывод данного раздела настраивается в файле tagscloud.tpl В этом разделе настраиваются шаблоны, которые используются для работы с облаком тегов. В данном блоке показываются все ключевые теги добавленные к новостям.

Возможно использование следующих тегов:

{tags} - Используется для вывода всех ключевых тегов, находящихся в базе данных

{tags limit="100"} - Используется для вывода 100 самых популярных ключевых тегов, находящихся в базе данных


Голосование на сайте

Навигация: Шаблоны >

Голосование на сайте

Вывод данного раздела настраивается в файле vote.tpl В этом разделе настраиваются шаблоны, которые используются для работы с голосованием на сайте.

Возможно использование следующих тегов:

{title} - Заголовок опроса

{list} - Список вопросов

{vote_id} - ID опроса

{votes} - Количество голосов

[votelist] и [/votelist] - Выводит текст который нужно показывать для еще не голосовавших людей

[voteresult] и [/voteresult] - Выводит текст который нужно показывать для уже голосовавших людей


Топ новостей

Навигация: Шаблоны >

Топ новостей

Вывод данного раздела настраивается в файле topnews.tpl В этом разделе настраиваются шаблоны, которые используются для вывода блока популярных новостей.

Возможно использование следующих тегов:

{title} - выводит заголовок новости

{title limit="x"} - Выводится урезанный до X количества символов, заголовок новости.

{link} - выводит ссылку на новость

{date} - Выводится дата публикации, формат вывода даты настраивается в настройках системы

{date=формат даты} - Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости

{text} - выводит полностью краткое содержание новости

{text limit="x"} - выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации обрезает до указанных X количества символов. При этом обрезание текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым вы получаете возможность более расширенного оформления публикации популярных новостей на сайте.

{category} - выводит категорию, к которой относится статья

{link-category} - выводит ссылку на все категрии в которой присутствует новость

[xfvalue_x] - выводит значение дополнительного поля "x", где "x" название дополнительного поля

[xfgiven_x] [xfvalue_x] [/xfgiven_x] - Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается

[xfnotgiven_X] текст [/xfnotgiven_X] - Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля


Похожие новости

Навигация: Шаблоны >

Похожие новости

Вывод данного раздела настраивается в файле relatednews.tpl В этом разделе настраиваются шаблоны, которые используются для вывода списка похожих новостей при просмотре полной новости на сайте.

Возможно использование следующих тегов:

{title} - выводит заголовок новости

{title limit="x"} - выводит заголовок новости, сокращенный до указанного количества в теге X символов. При этом сокращение заголовка производится до завершения логического слова, а не обрывается посередине.

{link} - выводит ссылку на новость

{date} - Выводится дата публикации, формат вывода даты настраивается в настройках системы

{date=формат даты} - Выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости.

{text} - выводит полностью краткое содержание новости

{text limit="x"} - выводит только текст краткой новости без HTML форматирования, при этом сам текст публикации обрезает до указанных X количества символов. При этом обрезание текста происходит до последнего логического слова, а не обрывает текст на середине слова. Тем самым вы получаете возможность более расширенного оформления публикации популярных новостей на сайте.

{category} - выводит категорию, к которой относится статья

{link-category} - выводит ссылку на все категрии в которой присутствует новость

[xfvalue_x] - выводит значение дополнительного поля "x", где "x" название дополнительного поля

[xfgiven_x] [xfvalue_x] [/xfgiven_x] - Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается

[xfnotgiven_X] текст [/xfnotgiven_X] - Выводят текст указанный в них если дополнительное поле не было задано при публикации новости, где "х" это имя дополнительного поля


Временное отключение сайта

Навигация: Шаблоны >

Временное отключение сайта

В данном разделе вы можете настроить страницу, которая будет выводится при отключении сайта например на технические работы. Помните что администраторы всегда будут допущены к просмотру сайта как при включенном режиме. Все остальные будут видеть страницу из данного раздела.

Шаблон настраивается в файле offline.tpl и возможно использование следующих тегов:

{reason} - Используется для вывода причины отключения сайта, которое вы задаете в настройках скрипта


Модуль speedbar

Навигация: Шаблоны >

Модуль speedbar

В данном разделе вы можете настроить вывод текущего местоположения пользователя на вашем сайте. Данный шаблон использует только один тег {speedbar} который и выводит непосредственно местоположение.


RSS трансляция новостей

Навигация: Шаблоны >

RSS трансляция новостей

Данный шаблон находится в файле templates/rss.tpl и предназначен для настройки вывода RSS потока вашего сайта.

В данном шаблоне вы можете использовать следующие теги:

[rss] текст [/rss] - Выводят текст заключенный в них, при использовании блока стандартного RSS.

[turbo] текст [/turbo] - Выводят текст заключенный в них, при использовании блока турбо новостей для Яндекса.

[dzen] текст [/dzen] - Выводят текст заключенный в них, при использовании блока дзен новостей.

нн

{title} - Выводит заголовок новости

{rsslink} - Выводит полный URL новости

{rssauthor} - Выводят автора новости

{rssdate} - Выводят дату новости

{category} - Выводят категорию новости

{short-story} - Выводят текст краткой новости

{images} - Выводит набор картинок для Яндекс новостей

{full-story} - Выводит текст полной новости

Также вы можете использовать дополнительно любые теги которые поддерживаются шаблоном вывода краткиких новостей shortstory.tpl, однако вам необходимо быть внимательными чтобы не был нарушен стандарт вывода RSS 2.0 который используется для RSS трансляции публикаций.


RSS информер

Навигация: Шаблоны >

RSS информер

В данном шаблоне вы можете настроить вывод вашего RSS информера. Имя данного шаблона вы назначаете самостоятельно в админпанели при добавлении нового RSS информера. В данном шаблоне вы можете использовать следующие теги:

[link] текст [/link] - формирует ссылку на новость партнера

{link} - предназначен для вывода только URL ссылки на страницу источника публикации

{title} - заголовок новости

{news} - непосредственно сама новость

{category} - выводит категорию в которой опубликована новости в RSS потоке

{author} - выводит автора новости

{date} - выводит дату новости, при этом формат даты можно задать в настройках информера, для каждого информера.

{date=формат даты} - выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком, но и ее отдельные части. Формат даты задается задается согласно формату, принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время.

{image-x} - выводит URL картинок находящихся в краткой новости, где x это номер картинки в новости, например {image-1} выведет URL первой картинки в краткой новости

[image-x] текст [/image-x] - выводят текст указанный в них только в случае если картинка с номером X присутствует в новости


OpenSearch

Навигация: Шаблоны >

OpenSearch

Данный шаблон находится в файле templates/opensearch.tpl и предназначен для поддержки технологии OpenSearch в современных браузерах, данная технология позволяет интегрировать поиск по вашему сайту в строку поиска самого браузера. Будьте предельно внимательны при редактировании данного шаблона. Он должен соответствовать необходимым спецификациям.


Разработка и подключение модулей

Навигация: Разработчикам >

Разработка и подключение модулей

DataLife Engine предоставляет удобные механизмы для подключения разработанных вами модификаций скрипта. Данные механизмы позволяют обеспечить работоспособность и после обновления скрипта на новую версию, т.к. данные механизмы позволяют осуществлять подключение без правки файлов скрипта. Для подключения разработанных вами модулей вам необходимо в любом необходимом вам шаблоне добавить тег:

{include file="engine/modules/mymod.php"}

Где engine/modules/ это путь к файлу вашего модуля, а mymod.php имя подключаемого файла. Стандартные файлы модулей DataLife Engine находятся в этой папке и мы вам рекомендуем использовать данную папку, однако это не является обязательным требованием и файл может находится в любой другой папке на сервере. Единственное ограничение безопасности по подобному подключению модулей, это то что на папку в которой находится файл не должно быть прав на запись (CHMOD 777). Также мы рекомендуем вам использовать именно относительные пути при подключении модулей, DataLfe Engine автоматически распознает относительные пути и подключает ваши модули уже согласно настройкам скрипта и путям где установлен скрипт. Тем самым вы можете создавать универсальные инструкции по установке ваших модификаций.

Также вы можете подключать PHP файлы вашего модуля передав им различные параметры, например:

{include file="engine/modules/mymod.php?param=value1&variable2=value2"}

Благодаря подобному подключению, вы можете делать ваши модификации многофункциональными, которые будут выполнять различные роли и функции при различных подключениях. Переданные переменные будут доступны в вашем модуле как $param и $variable2 соответственно.

В качестве параметров к подключаемым модулям вы можете задавать шаблонные теги скрипта (за исключением использования тега в шаблоне main.tpl и тегов принадлежащих шаблону main.tpl). Например, при добавлении в шаблон полной новости конструкции {include file="engine/modules/mymod.php?param={news-id}"}, вы можете передавать вашему стороннему модулю в качестве параметра ID новости и т.д. Вниманию разработчиков: Передаваемые в скрипт параметры, это аналоги GET параметров URL браузера, соответственно при выборе передаваемых тегов вы должны учитывать ограничения GET строки, другими словами вы не можете передать в качестве параметра содержимое полной новости к примеру.

Также вы можете использовать подключение своих модулей и для замены основного блока, где выводятся новости и другая основная информация, для этого необходимо использовать данный тег совместно с тегами [aviable=раздел]текст[/aviable] и [not-aviable=раздел]текст[/not-aviable] Описание тегов смотрите в документации в разделе "Вывод новостей на страницах". Вы можете использовать как стандартный список разделов, так и использовать создание собственного раздела сайта, передав его в URL браузера. Рассмотрим простейший пример. Вы хотите добавить к стандартным разделам сайта, добавить свой раздел и выводить информацию в нем из вашего модуля. Допустим вы хотите создать раздел FAQ. Для этого в шаблоне main.tpl прописывается конструкция:

[aviable=faq]{include file="engine/modules/mymod.php"}[/aviable]

[not-aviable=faq]{content}[/not-aviable]

После подобного подключения помимо работы стандартных разделов сайта при обращении по адресу: http://site.ru/index.php?do=faq вместо новостей будет выводится ваш новый раздел из вашего модуля.

Для работы ваших модулей и вывода информации именно в том месте шаблона, где вставлен вышеуказанный тег, обязательно только одно важное условие. Вывод информации должен осуществляется только через функцию PHP echo. Рассмотрим пример простейшего модуля и вывода информации. Создадим файл mymod.php со следующим содержимым:

<?php

echo "Тестовый модуль";

?>

При подключении этого файла в шаблоне, в данном месте шаблона появится текст: Тестовый модуль

Список переменных и классов DLE которые вы можете использовать в вашем подключаемом модуле, без дополнительного объявления:

$is_logged - содержит информацию, является ли посетитель авторизованным пользователем или гостем, и содержит значения true или false.

$member_id - содержит массив с информацией о авторизованном пользователе, включая всю его информацию из профиля.

$db - класс DLE для работы с базой данных.

$tpl - класс DLE для работы с шаблонами.

$cat_info - массив содержащий информацию обо всех категориях на сайте.

$config - массив содержащий информацию обо всех настройках скрипта.

$user_group - массив содержащий информацию о всех группах пользователей и их настройках.

$category_id - содержит ID категории которую просматривает посетитель.

$_TIME - содержит текущее время в UNIX формате с учетом настроек смещения в настройках скрипта.

$lang - массив содержащий текст из языкового пакета.

$smartphone_detected - содержит информацию о том, просматривает ли пользователь сайт со смартфона или с обычного браузера, и содержит значения true или false.

$dle_module - содержит информацию о разделе сайта, который просматривает пользователь, либо информацию переменной do из URL браузера.

Внимание: Ваш модуль должен только читать данные из данных переменных, внесение изменений в значения переменных повлечет сбои в работе стандартных возможностей скрипта и дальнейшей его некорректной работе.


Подключение модулей в адмипанели

Навигация: Разработчикам >

Подключение модулей в адмипанели

DataLife Engine предоставляет удобные механизмы для подключения разработанных вами модификаций скрипта в админпанели. Данные механизмы позволяют подключать модули админпанели без внесения изменений в файлы скрипта и позволяют сохранять работоспособность после обновления скрипта на новую версию скрипта.

Для того чтобы подключить ваш сторонний модуль в админпанель, вы должны разместить файл вашего модуля в папке engine/inc/ это обязательное условие. Только файлы находящиеся в этой папке могут быть подключены. Например имя файла вашего модуля mymod.php вы разместили его в папке engine/inc/ После этого вы можете вызвать и обратится к вашему модулю из админпанели по адресу: http://site.ru/admin.php?mod=mymod где mymod это имя вашего модуля без расширения .php Подключение происходит автоматически, никаких изменений в файлах скрипта не требуется.

Для того чтобы пользователи не вводили адрес вашего модуля в браузере вручную и он отображался в списке всех разделов в административной панели, для этого предусмотрена специальная таблица в базе данных MySQL. Имя таблицы: ПРЕФИКС_admin_sections. ПРЕФИКС ваш скрипт установки может прочитать из файла engine/inc/dbconfig.php. Данная таблица содержит следующие имена полей:

name - содержит имя вашего модуля, а именно файла .php находящегося в папке engine/inc/, но без расширения файла. Например имя вашего файла mymod.php, то в данное поле должно быть записано значение mymod.

title - содержит заголовок вашего модуля.

descr - содержит описание вашего модуля.

icon - содержит имя иконки для вашего модуля, с указанием пути. Например, engine/skins/images/myicon.png. Рекомендуемые размеры иконок 70 на 70 пикселей.

allow_groups - содержит информацию о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанел.

Пример запроса для записи информации о модуле mymod:

INSERT INTO `префикс_admin_sections` (`name`, `title`, `descr`, `icon`, `allow_groups`) VALUES

('mymod', 'Тестовый модуль', 'Здесь находится описание тестового модуля', 'mymod.png', '1');

после выполнения данного запроса модуль в админпанели будет прописан в админпанели только для администраторов.

ВНИМАНИЕ: указание о группах в базе данных не запрещает и не предотвращяет запуск модуля пользователями из других групп. Для разграничения доступа ваши подключаемые модули обязаны сами производить проверку групп и разрешать выполнение только разрешенным группам.


API для разработки модулей

Навигация: Разработчикам >

API для разработки модулей

API предназначен для написания модификаций совместимых со старыми и будущими версиями скрипта. В случае использования API для получения данных из базы, вы можете быть уверенными, что данный код будет работать и в будущих версиях скрипта, тем самым облегчается проверка и адаптация кода при выходе новой версии. Также при использовании API вам нет необходимости писать собственные функции для выборки данных, нет необходимости подключать и объявлять необходимые для работы с БД классы. Достаточно просто подключить файл API, и начать использовать его функции, все остальное он берет на себя.

Для использования API в своем модуле вы должны его подключить строчкой:

include ('engine/api/api.class.php');

При этом вам нет необходимости задумываться есть ли подключение к БД или нет, подключены или нет необходимые классы. Данный код вы можете использовать как внутри файлов самого скрипта DLE, так и просто в других скриптах, не имеющих отношения к DLE. Тем самым вы можете организовывать стандартизированные интеграции скрипта DLE, с другими скриптами. Например форумами.

Список функций API:

$dle_api->take_user_by_id( int $id [, string $select_list] );

получение массива с информацией о пользователе по его ID. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией о пользователе либо false, если пользователь не найден.

$dle_api->take_user_by_name( string $name [, string $select_list]);

получение массива с информацией о пользователе по его логину. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией либо false, если пользователь не найден.

$dle_api->take_user_by_email( string $email [, string $select_list]);

получение массива с информацией о пользователе по его E-Mail. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией либо false, если пользователь не найден.

$dle_api->take_users_by_group( int $group_id [, string $select_list [, int $limit]]);

получение массива с информацией о пользователях по номеру группы. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить. Необязательный параметр $limit указывает на лимит количества возращаемых пользователей. Возвращает массив с информацией либо false, если пользователи не найдены.

$dle_api->take_users_by_ip( string $ip, [, bool $like [, string $select_list [, int $limit]]]);

Получение списка пользователей по IP, второй параметр $like указывает использовать точное совпадение при поиске, либо неточное. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить. Необязательный параметр $limit указывает на лимит количества возращаемых пользователей. Возвращает массив с информацией либо false, если пользователи не найдены.

$dle_api->change_user_name( int $user_id, string $new_name);

Изменение логина пользователя. user_id ID пользователя, логин которого необходимо заменить. new_name новый логин пользователя. Возвращаемые значения: true если успешно выполнено, false если новое имя уже занято другим пользователем.

$dle_api->change_user_pass( int $user_id, string $new_pass);

Изменение пароля пользователя. user_id ID пользователя, пароль которого необходимо заменить. new_pass новый пароль пользователя.

$dle_api->change_user_email( int $user_id, string $new_email);

Изменение E-Mail пользователя. user_id ID пользователя, E-Mail которого необходимо заменить. new_email новый E-Mail пользователя. Возвращаемые значения: 1 - успешно выполнено, -1 - новый E-Mail уже существует, -2 - некорректный E-mail.

$dle_api->change_user_group( int $user_id, int $new_group);

Изменение группы пользователя. user_id ID пользователя, группу которого необходимо заменить. new_group ID новой группы пользователя. Возвращаемые значения: true если успешно выполнено, false если указан ID несуществующей группы.

$dle_api->external_auth( string $login, string $password);

Авторизация по логину и паролю. Возвращаемые значения: true - авторизация успешна, false - логин или пароль не верны.

$dle_api->external_register( string $login, string $password, string $email, int $group);

Регистрация пользователя в базе данных. В функцию передаются: Логин, Пароль, E-mail и номер группы в которой зарегистрировать пользователя. Возвращаемые значения: 1 - успешно выполнено, -1 - новый логин уже существует, -2 - новый E-Mail уже существует, -3 - некорректный E-Mail, -4 - задана несуществующая группа.

$dle_api->send_pm_to_user ( int $user_id, string $subject, string $text, string $from);

Отправка персонального сообщения пользователю. $user_id ID получателя. $subject тема сообщения. $text текст сообщения. $from логин отправителя. Возвращаемые значения: 1 - успешно выполнено, -1 - получатель не найден, 0 - ошибка БД.

$dle_api->load_table ( string $table [, string $fields [, string $where [, bool $multirow [, int $start [, int $limit [, string $sort [, string $sort_order]]]]]]]);

Получение информации из таблицы БД.

$table - название таблицы

$fields - необходимые поля через запятую или * для всех

$where - условие выборки

$multirow - забирать ли один ряд или несколько

$start - начальное значение выборки

$limit - количество записей для выборки, 0 - выбрать все

$sort - поле, по которому осуществляется сортировка

$sort_order - направление сортировки

Возвращается массив с данными, либо false если в БД по указанным параметрам ничего не найдено.

$dle_api->save_to_cache ( string $fname, mixed $vars);

Запись данных в файл кеша. Параметр $fname указывает имя файла кеша без указания его расширения. $vars - данные для записи в кеш.

$dle_api->load_from_cache ( string $fname, [, int $timeout [, string $type]]);

Чтение данных из файла кеша. Параметр $fname указывает имя файла кеша без указания его расширения. Необязательный параметр $timeout указывает количество секунд, в течении которых информацию из кеша считать актуальной. Если файл кеша будет устаревшим, то функция возвращает false. Необязательный параметр $type указывает на тип данных который хранится в кеше, если не 'text' - считаем, что хранился массив и возвращается массив данных.

$dle_api->clean_cache ( [string $name] );

Удаление кеша. Необязательный параметр $name указывает на конкретное имя файла без расширения который нужно удалить

$dle_api->get_cached_files();

Получение массива содержащего названия файлов кеша.

$dle_api->edit_config ( mixed $key, [, string $new_value]);

Изменение и сохранение настроек скрипта.

Параметр $key string или array

string: Название параметра

array: ассоциативный массив параметров

Параметр $new_value - значение параметра. Не используется, если $key массив

$dle_api->take_news ( string $cat, [, string $fields [, int $start [, int $limit [, string $sort [, string $sort_order]]]]]);

Получение новостей

$cat - категории новостей, через запятую

$fields - перечень получаемых полей новостей или * для всех

$start - начальное значение выборки

$limit - количество новостей для выборки, 0 - выбрать все новости

$sort - поле, по которому осуществляется сортировка

$sort_order - направление сортировки

Возвращает ассоциативный 2-х мерный массив с новостями

$dle_api->checkGroup ( int $group );

Проверяет существует ли указанная группа или нет. Возвращаемые значения: true если группа существует, false если группа не существует.

$dle_api->install_admin_module ( string $name, string $title, string $descr, string $icon [, string $perm] );

Установка стороннего модуля в админпанель скрипта.

$name - название модуля, а именно файла .php находящегося в папке engine/inc/, но без расширения файла

$title - заголовок модуля

$descr - описание модуля

$icon - имя иконки для модуля, без указания пути. Иконка обязательно при этом должна находится в папке engine/skins/images/

$perm - информация о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанель

$dle_api->uninstall_admin_module ( string $name );

Удаление стороннего модуля из админпанели скрипта.

$name - название удаляемого модуля

$dle_api->change_admin_module_perms ( string $name, string $perm );

Изменение группы пользователей которым разрешен показ стороннего модуля в админпанели скрипта.

$name - название модуля

$perm - информация о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанель

Разработка полноценного API, только начата и на данный момент API имеет пока ограниченный набор функций. Поэтому мы просим всех заинтересованных в данном API разработчиков посетить специально созданную для этого тему на форуме и оставить свои пожелания о том какие новые функции вы хотите видеть в новых версиях. Потому что только опираясь на ваши потребности можно создать полноценный API, охватывающий все аспекты взаимодействия с скриптом.


Запуск функций по крону

Навигация: »Основной раздел«

Запуск функций по крону

В DataLife Engine присутствует возможность запускать некоторые функции по расписанию. Вы можете создавать автоматически бекап БД, оптимизировать БД, а также создавать карту сайта для поисковиков. Для этого необходима поддержка вашим хостингом функции запуска приложений по расписанию (CRON). Для запуска функций по крону предназначен файл cron.php расположенный в корне вашего сайта. По умолчанию в целях безопасности возможность запуска этого файла отключена, поэтому рассмотрим как можно включить данную функцию.

Во первых мы рекомендуем обязательно в целях безопасности изменить название файла cron.php на любое другое с расширением .php

Далее откройте этот файл в текстовом редакторе и в самом начале найдите строчку

$allow_cron = 0;

Измените ее на

$allow_cron = 1;

Тем самым вы разрешаете этому файлу выполнять функции в автоматическом режиме.

Далее вы можете изменить количество файлов резервных копий БД которые будут хранится на сервере. Для этого найдите чуть ниже строчку

$max_count_files = 5;

где 5 это количество копий БД. Вы можете поставить свое собственное количество файлов. При превышении данного лимита более старые резервные копии базы данных будут автоматически удалятся.

После того как вы произвели необходимые изменения, сохраните данный файл на сервере. Теперь вам нужно добавить данный файл на запуск по расписанию (CRON) время создания и периодичность вы устанавливаете самостоятельно. Подробную инструкцию по добавлению данного файла в функцию CRON вы можете получить у вашего хостинг провайдера.

Файл крона может выполнять следующие операции:

1. Создание резервной копии базы данный. Для запуска данного режима

просто запустите файл cron.php без указания ему параметров

2. Создание карты сайты сайта. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=sitemap

если используется консольный запуск скрипта, то используйте php -f cron.php sitemap

При создании карты сайта по крону, также будет выполняться автоматическое уведомление поисковых систем о наличии карты сайта.

3. Оптимизация базы данных. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=optimize

если используется консольный запуск скрипта, то используйте php -f cron.php optimize

4. Запуск антивируса. Для запуска данного режима

запустите файл с параметром cron.php?cronmode=antivirus

если используется консольный запуск скрипта, то используйте php -f cron.php antivirus

При этом конечно не следует забывать про указание правильных путей как к PHP интерпретатору, так и к самому скрипту от корня вашего сервера.


RSS Экспорт

Навигация: »Основной раздел«

RSS Экспорт

Движок DataLife Engine поддерживает также экспорт новостей в формате RSS для того чтобы посетители получили экспорт новостей с главной страницы вы должны использовать следующий путь.

С использованием ЧПУ:

http://website.com/rss.xml - трансляция основного потока RSS

http://website.com/rssturbo.xml - трансляция потока RSS Турбо для Яндекса

http://website.com/rssdzen.xml - трансляция потока RSS для сервиса Дзен

Без использования ЧПУ:

http://website.com/index.php?mod=rss - трансляция основного потока RSS

http://website.com/index.php?mod=rss&rssmode=turbo - трансляция потока RSS Турбо для Яндекса

http://website.com/index.php?mod=rss&rssmode=dzen - трансляция потока RSS для сервиса Дзен

Для экспорта новостей из определенной категории используйте следующие ссылки

С использованием ЧПУ:

http://website.com/альтернативное имя категории/rss.xml - трансляция основного потока RSS

http://website.com/альтернативное имя категории/rssturbo.xml - трансляция потока RSS Турбо для Яндекса

http://website.com/альтернативное имя категории/rssdzen.xml - трансляция потока RSS для сервиса Дзен

Без использования ЧПУ:

http://website.com/index.php?mod=rss&do=cat&category=альтернативное имя - трансляция основного потока RSS

http://website.com/index.php?mod=rss&do=cat&rssmode=turbo&category=альтернативное имя - трансляция потока RSS Турбо для Яндекса

http://website.com/index.php?mod=rss&do=cat&rssmode=dzen&category=альтернативное имя - трансляция потока RSS для сервиса Дзен

Для экспорта всех новостей определенного пользователя используйте следующие ссылки

С использованием ЧПУ:

http://website.com/user/имя пользователя/rss.xml - трансляция основного потока RSS

http://website.com/user/имя пользователя/rssturbo.xml - трансляция потока RSS Турбо для Яндекса

http://website.com/user/имя пользователя/rssdzen.xml - трансляция потока RSS для сервиса Дзен

Без использования ЧПУ:

http://website.com/index.php?mod=rss&subaction=allnews&user=имя пользователя - трансляция основного потока RSS

http://website.com/index.php?mod=rss&subaction=allnews&rssmode=turbo&user=имя пользователя - трансляция потока RSS Турбо для Яндекса

http://website.com/index.php?mod=rss&subaction=allnews&rssmode=dzen&user=имя пользователя - трансляция потока RSS для сервиса Дзен

Для экспорта новостей из определенного каталога используйте следующие ссылки

С использованием ЧПУ:

http://website.com/catalog/идентификатор/rss.xml - трансляция основного потока RSS

http://website.com/catalog/идентификатор/rssturbo.xml - трансляция потока RSS Турбо для Яндекса

http://website.com/catalog/идентификатор/rssdzen.xml - трансляция потока RSS для сервиса Дзен

Без использования ЧПУ:

http://website.com/index.php?mod=rss&catalog=идентификатор - трансляция основного потока RSS

http://website.com/index.php?mod=rss&rssmode=turbo&catalog=идентификатор - трансляция потока RSS Турбо для Яндекса

http://website.com/index.php?mod=rss&rssmode=dzen&catalog=идентификатор - трансляция потока RSS для сервиса Дзен